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1  Preface

1.1  Key Features

The R&S AREG100A Automotive Radar Echo Generator sets standards in RF perfor-
mance and usability. Outstanding key features are:
● Remote frontends supporting up to 4 GHz signal bandwidth and different frequen-

cies, like 24 GHz to 24.25 GHz, 76 GHz to 77 GHz and 76 GHz to 81 GHz
● Simultaneous simulation of up to four objects

– Up to three individually switchable paths for simulation of fixed object distances
from 5 m to 300 m

– One additional switchable path for fixed short object distance of 4m (including
0.8m air gap)

● Individually controllable amplitude for each path
● Frontend available with single antenna (best for testing MIMO radars) or two anten-

nas (best isolation between Rx/Tx path)
● Optional Doppler frequency offset for simulation of radial velocity
● Remote configuration and operation

For more information, see data sheet.

1.2  Documentation Overview

This section provides an overview of the R&S AREG100A user documentation. Unless
specified otherwise, you find the documents on the R&S AREG100A product page at:

www.rohde-schwarz.com/manual/areg100a

1.2.1  Getting Started Manual

Introduces the R&S AREG100A and describes how to set up and start working with the
product. Includes basic operations, typical measurement examples, and general infor-
mation, e.g. safety instructions, etc. A printed version is delivered with the instrument.

1.2.2  User Manuals and Help

Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control commands
with programming examples, and information on maintenance, instrument interfaces
and error messages. Includes the contents of the getting started manual .

Documentation Overview

http://www.rohde-schwarz.com/manual/areg100a
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1.2.3  Service Manual

Describes the performance test for checking the rated specifications, module replace-
ment and repair, firmware update, troubleshooting and fault elimination, and contains
mechanical drawings and spare part lists.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS):

https://gloris.rohde-schwarz.com

1.2.4  Instrument Security Procedures

Deals with security issues when working with the R&S AREG100A in secure areas. It
is available for download on the Internet.

1.2.5  Basic Safety Instructions

Contains safety instructions, operating conditions and further important information.
The printed document is delivered with the instrument.

1.2.6  Data Sheets and Brochures

The data sheet contains the technical specifications of the R&S AREG100A. It also
lists the firmware applications and their order numbers, and optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

See www.rohde-schwarz.com/brochure-datasheet/areg100a

1.2.7  Release Notes and Open Source Acknowledgment (OSA)

The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

The open-source acknowledgment document provides verbatim license texts of the
used open source software.

See www.rohde-schwarz.com/firmware/areg100a

1.2.8  Application Notes, Application Cards, White Papers, etc.

These documents deal with special applications or background information on particu-
lar topics.

See www.rohde-schwarz.com/application/areg100a

Documentation Overview

https://gloris.rohde-schwarz.com
https://www.rohde-schwarz.com/brochure-datasheet/areg100a/
https://www.rohde-schwarz.com/firmware/areg100a/
https://www.rohde-schwarz.com/application/areg100a/
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2  Safety and Regulatory Information
The product documentation helps you use the product safely and efficiently. Follow the
instructions provided here and in the Chapter 2.1, "Safety Instructions", on page 15.

Intended use

The product is intended for the development, production and verification of electronic
components and devices in industrial, administrative, and laboratory environments.
Use the product only for its designated purpose. Observe the operating conditions and
performance limits stated in the data sheet.

Where do I find safety information?

Safety information is part of the product documentation. It warns you of potential dan-
gers and gives instructions on how to prevent personal injury or damage caused by
dangerous situations. Safety information is provided as follows:
● In Chapter 2.1, "Safety Instructions", on page 15. The same information is provi-

ded in many languages as printed "Safety Instructions". The printed "Safety
Instructions" are delivered with the product.

● Throughout the documentation, safety instructions are provided when you need to
take care during setup or operation.

2.1  Safety Instructions

Products from the Rohde & Schwarz group of companies are manufactured according
to the highest technical standards. To use the products safely, follow the instructions
provided here and in the product documentation. Keep the product documentation
nearby and offer it to other users.

Use the product only for its intended use and within its performance limits. Intended
use and limits are described in the product documentation such as the data sheet,
manuals and the printed safety instructions. If you are unsure about the appropriate
use, contact Rohde & Schwarz customer service.

Using the product requires specialists or specially trained personnel. These users also
need sound knowledge of at least one of the languages in which the user interfaces
and the product documentation are available.

If any part of the product is damaged or broken, stop using the product. Never open
the casing of the product. Only service personnel authorized by Rohde & Schwarz are
allowed to repair the product. Contact Rohde & Schwarz customer service at http://
www.customersupport.rohde-schwarz.com.

Lifting and carrying the product

The maximum weight of the product is provided in the data sheet. To move the product
safely, you can use lifting or transporting equipment such as lift trucks and forklifts. Fol-
low the instructions provided by the equipment manufacturer.

Safety Instructions

http://www.customersupport.rohde-schwarz.com
http://www.customersupport.rohde-schwarz.com
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Choosing the operating site

Only use the product indoors. The product casing is not waterproof. Water that enters
can electrically connect the casing with live parts, which can lead to electric shock,
serious personal injury or death if you touch the casing. If Rohde & Schwarz provides a
carrying bag designed for your product, you can use the product outdoors.

Unless otherwise specified, you can operate the product up to an altitude of 2000 m
above sea level. The product is suitable for pollution degree 2 environments where
nonconductive contamination can occur. For more information on environmental condi-
tions such as ambient temperature and humidity, see the data sheet.

Setting up the product

Always place the product on a stable, flat and level surface with the bottom of the prod-
uct facing down. If the product is designed for different positions, secure the product so
that it cannot fall over.

If the product has foldable feet, always fold the feet completely in or out to ensure sta-
bility. The feet can collapse if they are not folded out completely or if the product is
moved without lifting it. The foldable feet are designed to carry the weight of the prod-
uct, but not an extra load.

If stacking is possible, keep in mind that a stack of products can fall over and cause
injury.

If you mount products in a rack, ensure that the rack has sufficient load capacity and
stability. Observe the specifications of the rack manufacturer. Always install the prod-
ucts from the bottom shelf to the top shelf so that the rack stands securely. Secure the
product so that it cannot fall off the rack.

Connecting to power

The product is an overvoltage category II product and has to be connected to a fixed
installation used to supply energy-consuming equipment such as household applian-
ces and similar loads. Be aware that electrically powered products have risks, such as
electric shock, fire, personal injury or even death.

Take the following measures for your safety:
● Before switching on the product, ensure that the voltage and frequency indicated

on the product match the available power source. If the power adapter does not
adjust automatically, set the correct value and check the rating of the fuse.

● If a product has an exchangeable fuse, its type and characteristics are indicated
next to the fuse holder. Before changing the fuse, switch off the instrument and dis-
connect it from the power source. How to change the fuse is described in the prod-
uct documentation.

● Only use the power cable delivered with the product. It complies with country-spe-
cific safety requirements. Only insert the plug into an outlet with protective conduc-
tor terminal.

● Only use intact cables and route them carefully so that they cannot be damaged.
Check the power cables regularly to ensure that they are undamaged. Also ensure
that nobody can trip over loose cables.

Safety Instructions
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● If the product needs an external power supply, use the power supply that is deliv-
ered with the product or that is recommended in the product documentation or a
power supply that conforms to the country-specific regulations.

● Only connect the product to a power source with a fuse protection of maximum
20 A.

● Ensure that you can disconnect the product from the power source at any time.
Pull the power plug to disconnect the product. The power plug must be easily
accessible. If the product is integrated into a system that does not meet these
requirements, provide an easily accessible circuit breaker at the system level.

Cleaning the product

Use a dry, lint-free cloth to clean the product. When cleaning, keep in mind that the
casing is not waterproof. Do not use liquid cleaning agents.

Meaning of safety labels

Safety labels on the product warn against potential hazards.

Potential hazard

Read the product documentation to avoid personal injury or product damage.

Electrical hazard

Indicates live parts. Risk of electric shock, fire, personal injury or even death.

Hot surface

Do not touch. Risk of skin burns. Risk of fire.

Protective conductor terminal

Connect this terminal to a grounded external conductor or to protective ground. This protects
you against electric shock should an electric problem occur.

2.2  Labels on R&S AREG100A

Labels on the casing inform about:
● Personal safety, see "Connecting to power" on page 16.
● Product and environment safety, see Table 2-1.
● Identification of the product, see the serial number on the rear panel.

Table 2-1: Labels regarding R&S AREG100A and environment safety

Labeling in line with EN 50419 for disposal of electrical and electronic equipment after the prod-
uct has come to the end of its service life. For more information, see Chapter 13.5, "Disposal",
on page 320.

Labels on R&S AREG100A
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2.3  Korea Certification Class A

이 기기는 업무용(A급) 전자파 적합기기로서 판매자 또는 사용자는 이 점을 주의하시기
바라며, 가정외의 지역에서 사용하는 것을 목적으로 합니다.

Korea Certification Class A
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3  Getting Started

3.1  Preparing for Use

Here, you can find basic information about setting up the instrument for the first time.

3.1.1  Lifting and Carrying

See also "Lifting and carrying the product" on page 15.

► Use the carrying handles at the side for lifting and carrying the R&S AREG100A.
The handles at the front are only for pushing and pulling the instrument when
mounting in a rack, see Chapter 3.1.4.2, "Mounting the R&S AREG100A in a
Rack", on page 21.

3.1.2  Unpacking and Checking

1. Unpack the R&S AREG100A carefully.

2. Retain the original packing material. Use it to protect the control elements and con-
nectors when transporting or shipping the R&S AREG100A later.
See also Chapter 12, "Transporting", on page 308.

3. Using the delivery notes, check the equipment for completeness.

4. Check the equipment for damage.

If the delivery is incomplete or equipment is damaged, contact Rohde & Schwarz.

3.1.3  Choosing the Operating Site

Specific operating conditions ensure proper operation and avoid damage to the prod-
uct and connected devices. For information on environmental conditions such as ambi-
ent temperature and humidity, see the data sheet.

See also "Choosing the operating site" on page 16.

Electromagnetic compatibility classes

The electromagnetic compatibility (EMC) class indicates where you can operate the
product. The EMC class of the product is given in the data sheet under "General data".
● Class B equipment is suitable for use in:

– Residential environments

Preparing for Use
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– Environments that are directly connected to a low-voltage supply network that
supplies residential buildings

● Class A equipment is intended for use in industrial environments. It can cause
radio disturbances in residential environments due to possible conducted and radi-
ated disturbances. It is therefore not suitable for class B environments.
If class A equipment causes radio disturbances, take appropriate measures to
eliminate them.

3.1.4  Setting Up the R&S AREG100A

See also:
● "Setting up the product" on page 16.
● "Intended use" on page 15.

3.1.4.1  Placing the R&S AREG100A on a Bench Top

To place the product on a bench top

1. Place the product on a stable, flat and level surface. Ensure that the surface can
support the weight of the product. For information on the weight, see the data
sheet.

2. CAUTION! Foldable feet can collapse. See "Setting up the product" on page 16.
Always fold the feet completely in or out. With folded-out feet, do not place any-
thing on top or underneath the product.

3. WARNING! A stack of products can fall over and cause injury. Never stack more
than three products on top of each other. Instead, mount them in a rack.
Stack as follows:

● It is best if all products have the same dimensions (width and length).
● The overall load on the lowest product must not exceed 500 N.
● With smaller products on top of the lowest product, the overall load on the low-

est product must not exceed 250 N.

Too many instruments

max. 500 N

Correct Different dimensions

max. 250 N

Preparing for Use
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4. NOTICE! Overheating can damage the product.
Prevent overheating as follows:

● Keep a minimum distance of 10 cm between the fan openings of the product
and any object in the vicinity.

● Do not place the product next to heat-generating equipment such as radiators
or other products.

3.1.4.2  Mounting the R&S AREG100A in a Rack

To prepare the rack

1. Observe the requirements and instructions in "Setting up the product" on page 16.

2. NOTICE! Insufficient airflow can cause overheating and damage the product.
Design and implement an efficient ventilation concept for the rack.

To mount the R&S AREG100A in a rack

1. Use an adapter kit that fits the dimensions of the R&S AREG100A to prepare the
instrument for rack mounting. For information on the dimensions, see data sheet.

a) Order the rack adapter kit designed for the R&S AREG100A. For the order
number, see data sheet.

b) Mount the adapter kit. Follow the assembly instructions provided with the
adapter kit.

2. Lift the R&S AREG100A to shelf height.

3. Push the R&S AREG100A onto the shelf until the rack brackets fit closely to the
rack.

4. Tighten all screws at the rack brackets with a tightening torque of 1.2 Nm to secure
the R&S AREG100A at the rack.

To unmount the R&S AREG100A from a rack

1. Loosen the screws at the rack brackets.

2. Bring the lifting equipment to shelf height.

3. Remove the R&S AREG100A from the rack.

4. If placing the R&S AREG100A on a bench top again, unmount the adapter kit from
the R&S AREG100A. Follow the instructions provided with the adapter kit.

Preparing for Use



Getting StartedR&S®AREG100A

22User Manual 1178.7417.02 ─ 06

3.1.5  Important Aspects for Test Setup

Cable selection and electromagnetic interference (EMI)

Electromagnetic interference (EMI) can affect the measurement results.

To suppress electromagnetic radiation during operation:
● Use high-quality shielded cables, especially for the following connector types:

– BNC
Double-shielded BNC cables.

– SMA
Double-shielded SMA cables.

– USB
Double-shielded USB cables.
How to: Chapter 3.1.8, "Connecting USB Devices", on page 23.
See also Chapter 11.6, "Measuring USB cable quality", on page 301.

– LAN
At least CAT6 STP cables.
How to: Chapter 3.1.7, "Connecting to LAN", on page 23

● Always terminate open cable ends.
● Ensure that connected external devices comply with EMC regulations.

Signal input and output levels

Information on signal levels is provided in the data sheet. Keep the signal levels within
the specified ranges to avoid damage to the R&S AREG100A and connected devices.

Preventing electrostatic discharge (ESD)

Electrostatic discharge is most likely to occur when you connect or disconnect a DUT.

► NOTICE! Risk of electrostatic discharge. Electrostatic discharge can damage the
electronic components of the product and the device under test (DUT).
Ground yourself to prevent electrostatic discharge damage:

a) Use a wrist strap and cord to connect yourself to ground.
b) Use a conductive floor mat and heel strap combination.

Over-the-air (OTA) tests

For over-the-air (OTA) tests, operate R&S AREG100A in shielded environment.

For more information, see data sheet.

3.1.6  Connecting to Power

For safety information, see "Connecting to power" on page 16.

Preparing for Use
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1. Plug the AC power cable into the AC power connector on the rear panel of the
instrument. Only use the AC power cable delivered with the R&S AREG100A.

2. Plug the AC power cable into a power outlet with ground contact.

The required ratings are listed next to the AC power connector and in the data
sheet.

3.1.7  Connecting to LAN

Network environment

Before connecting the product to a local area network (LAN), consider the following:
● Install the latest firmware to reduce security risks.
● For internet or remote access, use secured connections if applicable.
● Ensure that the network settings comply with the security policies of your company.

Contact your local system administrator or IT department before connecting your
product to your company LAN.

● When connected to the LAN, the product may potentially be accessed from the
internet, which may be a security risk. For example, attackers might misuse or
damage the product.

To connect to LAN

The connector is located on the rear panel.

► Connect the LAN socket via an RJ-45 cable to the LAN.

By default, the R&S AREG100A is configured to use DHCP (dynamic host configura-
tion protocol) and no static IP address is configured.

If switched on and connected to the LAN, the R&S AREG100A displays the address
information on the screen.

Figure 3-1: IP address indication on the screen (example)

See Chapter 9.6, "Connecting the Instrument to the Network (LAN)", on page 173

3.1.8  Connecting USB Devices

USB connectors are located on the front panel and rear panel. You can connect or dis-
connect all USB devices from the R&S AREG100A during operation.

Preparing for Use
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To connect USB storage devices

USB storage devices, such as memory sticks, allow easy data transfer from/to the
R&S AREG100A. You can also use them for firmware updates.

► Connect the USB storage device to any of the USB connectors.

To connect USB devices with external power supply

1. NOTICE! Connected devices with external power supply can feed back current into
the 5 V power supply of the USB interface and thus damage the R&S AREG100A.

Ensure that there is no connection between the positive pole of the power supply
and the +5 V power pin of the USB interface (VBUS).

2. Connect the USB storage device to any of the USB connectors.

To connect a keyboard

► Connect the keyboard to any of the USB connectors.

When connected, the R&S AREG100A detects the keyboard automatically. A detected
keyboard has the default layout English – US.

To connect a mouse

► Connect the mouse to any of the USB connectors.

When connected, the R&S AREG100A detects the mouse automatically.

To connect power sensors

You can connect power sensors of the R&S NRP families to any of the USB connec-
tors.

See Chapter 6, "Using Power Sensors", on page 74.

3.1.9  Connecting to Ref In/Ref Out

The connector is located on the rear panel.

To connect to "Ref In"/"Ref Out"

1. Use a high-quality BNC cable that matches the connector type.
See "Cable selection and electromagnetic interference (EMI)" on page 22.

2. To connect the cable with the "Ref In"/"Ref Out" connectors, proceed as follows:

a) Carefully align the connector of the cable and the "Ref In"/"Ref Out" connector
along a common axis.

b) Mate the connectors along the common axis until the male pin of the connector
of the cable engages with the female socket of the "Ref In"/"Ref Out" connec-
tor.

Preparing for Use



Getting StartedR&S®AREG100A

25User Manual 1178.7417.02 ─ 06

3.1.10  Connecting to Aux IF In/Aux IF Out

1. Use a high-quality cable that matches the SMA connector.
See "Cable selection and electromagnetic interference (EMI)" on page 22.

2. NOTICE! Risk of instrument damage and connector damage. Excessive tightening
can damage the cables and the connectors. However, if you do not tighten the con-
nectors enough, the measurement results can be inaccurate.
To connect the cable with the "Aux IF In"/"Aux IF Out" connectors, proceed as fol-
lows:

a) Carefully align the connector of the cable and the "Aux IF In"/"Aux IF Out" con-
nector along a common axis.

b) Mate the connectors along the common axis until the male pin of the inner con-
nector engages with the female socket of the outer connector.

c) Turn the nut of the outer connector until the connectors are firmly coupled.
d) Torque the nut to the specified limit using a calibrated torque wrench. Hold the

opposite connector part stationary with a spanner.

Also follow the instructions in chapter "Handling" of the application note 1MA99.

3.1.11  Connecting the Frontend

The frontend is delivered with two IF cables (IF TX CBL/IF RX CBL) and one control
cable (TRX CRTL Cable). These cables are calibrated and dedicated to the particular
frontend. Each cable has its own serial number, printed on it.

To connect the base unit and the frontend with the "IF TX CBL"/"IF RX CBL"
cables

1. Take the "IF TX CBL" cable delivered with the frontend.
See "To check the serial number of the cables" on page 27.

2. Connect the "Tx IF Out" connector of the base unit to "Tx IF In" connector of the
frontend.
Follow the instructions in Chapter 3.1.10, "Connecting to Aux IF In/Aux IF Out ",
on page 25.

This connection carries the IF signal for the transmitting antenna and the reference
signal for the frontend.

3. Take the "IF RX CBL" cable delivered with the frontend.

4. Connect the "Rx IF Out" connector of the frontend to "Rx IF In" connector of the
base unit.
Follow the instructions in Chapter 3.1.10, "Connecting to Aux IF In/Aux IF Out ",
on page 25.

This connection carries the IF signal of the receiving antenna for the base unit.

5. NOTICE! Excessive bending can damage the cables.

Preparing for Use
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Bend the "IF TX CBL"/"IF RX CBL" to a max. bending radius of 50 mm.

To connect the base unit and the frontend with the TRX CRTL Cable

1. NOTICE! If you connect or disconnect the control cable while the base unit is pow-
ered on, you can damage the R&S AREG100A.

Switch off the base unit.
See "To shut down the product" on page 28.

2. Take the TRX CRTL Cable cable delivered with the frontend.
See "To check the serial number of the cables" on page 27.

3. Hold the connector at the sleeve so that the red dot is upwards.

4. Align the connector of the cable along a common axis.

5. Plug the control cable at the "Control" connector at the base unit.

The sleeve locks.

6. Plug the control cable at the "Control" connector at the frontend.

The sleeve locks.

7. NOTICE! Excessive bending can damage the cables.
Bend the "TRX CRTL Cable" to a mix. bending radius of 50 mm.

Operating the frontend

1. Switch on the base unit.
See Chapter 3.1.12, "Switching On or Off", on page 27.

2. CAUTION! Hot surface, see "Meaning of safety labels" on page 17.
Hold the frontend by its sides.
Do not touch the waveguide surface. Depending on the ambient temperature, this
surface can become hot.

3. NOTICE! Overheating can damage the product.
Prevent overheating as follows:

● Do not cover the frontend module with thermally insulating material while the
R&S AREG100A is switched on.

● See also "To place the product on a bench top" on page 20.

See also: Chapter 4, "Generating Radar Echo Signals", on page 51.

To disconnect the frontend

1. NOTICE! If you connect or disconnect the control cable while the base unit is pow-
ered on, you can damage the R&S AREG100A.

Switch off the base unit.
See "To shut down the product" on page 28.

2. To disconnect the "IF TX CBL"/"IF RX CBL" cables, proceed as follows for each of
the four connections:

Preparing for Use
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a) Untorque the nut using a calibrated torque wrench. Hold the opposite connec-
tor part stationary with a spanner.

b) Turn the nut of the outer connector until the connectors are detached.

3. To disconnect the "TRX CRTL Cable":

a) Hold the connector at the sleeve.
b) To release the lock, pull the sleeve without turning.

Do not pull the cable.

To check the serial number of the cables

1. Switch on the base unit.
See Chapter 3.1.12, "Switching On or Off", on page 27.

2. On the front panel, press [Setup].

3. Select "Setup" > "Instrument Assembly" > "Hardware Config" > "RF Assembly".

4. For each cable, compare the displayed serial number with the serial number prin-
ted on the cable.

3.1.12  Switching On or Off

The following table provides an overview of power states, LEDs and power switch posi-
tions.

Table 3-1: Overview of power states

State LED Position of power switch

Off  gray [0]

Standby  orange [I]

Ready green [I]

To switch on the R&S AREG100A

The R&S AREG100A is off but connected to power. See Chapter 3.1.6, "Connecting to
Power", on page 22.

1. Set the switch on the power supply to position [I].
The switch is located on the rear panel.

The LED of the [On/Standby] key is orange.

2. Press the [On/Standby] key.
Key and LED are located on the front panel.

The LED changes to green. The R&S AREG100A boots.

When starting for the first time, the R&S AREG100A starts with the default settings.
When restarting the instrument, the settings depend on the instrument configura-
tion before shut-down.
See Chapter 7.4, "Saving and Recalling Instrument Settings", on page 93.
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When the instrument is switched on, it automatically monitors main functions. You can
query erroneous functions. In addition to automatic monitoring, you can perform main-
tenance tasks.

See:
● Chapter 11.4, "Querying Error Messages", on page 298

To shut down the product

The product is in the ready state.

► Press the [On/Standby] key.

The operating system shuts down. The LED changes to orange.

In the standby state, the power switch circuits are active. To deactivate them, discon-
nect the instrument from the power supply.

To disconnect from power

The R&S AREG100A is in the standby state.

1. NOTICE! Risk of data loss. If you disconnect the product from power when it is in
the ready state, you can lose settings and data. Shut it down first.
Set the toggle switch on the power supply to position [0].

The LED of the [On/Standby] key is switched off.

2. Disconnect the R&S AREG100A from the power source.

3.2  Instrument Tour

The following topics help you to get familiar with the instrument and perform the first
steps:
● Chapter 3.2.1, "Front Panel Tour", on page 28
● Chapter 3.2.2, "Rear Panel Tour", on page 33
● Chapter 3.2.3, "Frontend", on page 35

This section explains the control elements and the connectors of the R&S AREG100A
with the aid of the front and rear views. For specifications of the interfaces, refer to the
data sheet.

The meanings of the labels on the R&S AREG100A are described in Chapter 2.2,
"Labels on R&S AREG100A", on page 17.

3.2.1  Front Panel Tour

This section provides an overview of the control elements at the front panel of the
R&S AREG100A. Most of the connectors are at the rear panel and are described in
Chapter 3.2.2, "Rear Panel Tour", on page 33.

Instrument Tour
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Figure 3-2: Front panel view of the R&S AREG100A

1 = Utility keys
2 = Touchscreen
3 = Function keys and keypad
4 = Navigation controls
5 = Display keys
6 = USB
7 = Sensor
8 = [On/Standby]

3.2.1.1  Utility Keys

The utility keys set the R&S AREG100A to a defined state, and provide access to basic
settings and information on assistance.

Table 3-2: Utility keys

Utility key Assigned functions

[Preset] Sets the instrument to a defined state

[Local] Switches from remote control to local (manual) control

[Setup] Accesses the general instrument settings

[Help] Displays context-sensitive help text

3.2.1.2  Touchscreen

The screen at the front panel is the graphical user interface. It shows the settings dia-
logs and parameters, and the current configuration at a glance, see Chapter 3.4.3,
"Understanding the Display Information", on page 43.

Instrument Tour
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Figure 3-3: Touchscreen

The touch-sensitive panel provides an alternative means of user interaction for quick
and easy handling of the instrument, see Chapter 3.4.2, "Means of Manual Interaction",
on page 43.

See also:
● Chapter 3.4, "Instrument Control", on page 42, for operating the touchscreen.
● Chapter 13, "Maintenance, Storage and Disposal", on page 309, for instructions

on cleaning the screen.

3.2.1.3  Function Keys

Function keys provide access to the most common generator settings and functions.
You can find a detailed description of the corresponding functions in the user manual.

Table 3-3: Function keys

Function key Assigned functions

[Freq] Activates frequency entry.

[Level] Activates level entry.

[Mod on/off] Switches the modulation on and off.

[RF on/off] Switches the RF output on and off.

3.2.1.4  Keypad

The keypad enables you to enter alphanumeric parameters, including the correspond-
ing units. It contains the following keys:

Instrument Tour
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Table 3-4: Keys on the keypad

Type of key Description

Alphanumeric keys Enter numbers and (special) characters in edit dialog boxes.

Decimal point Inserts a decimal point "." at the cursor position.

Sign key Changes the sign of a numeric parameter. For an alphanumeric parame-
ter, inserts a "-" at the cursor position.

Unit keys

(G/n dBμV, M/μ μV, k/m mV and
x1 dB(m))

These keys add the selected unit to the entered numeric value and com-
plete the entry.

For level entries (e.g. in dB) or dimensionless values, all units have the
value "1" as multiplying factor. Thus, they have the same function as an
[Enter] key.

3.2.1.5  Navigation Controls

The navigation controls include a rotary knob, navigation keys, and the display keys.
They allow you to navigate within the display or within dialog boxes.

Rotary Knob

The rotary knob has several functions:

● For a numeric entry, increments (clockwise direction) or decrements (counterclock-
wise direction) the instrument parameter at a defined step width.

● Moves the selection, e.g. to a function block in the block diagram
● Shifts the selection bar within focused areas (e.g. lists).
● Acts like the [Enter] key, when it is pressed.

Editing Keys

Editing keys enable you to confirm an entry, delete individual characters, or exit the
current operation.

Instrument Tour
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Table 3-5: Editing keys

Type of key Description

[Esc] key Closes all kinds of dialog boxes, if the edit mode is not active. Quits the
edit mode, if the edit mode is active. In dialog boxes that contain a "Can-
cel" button it activates that button.

For "Edit" dialog boxes the following mechanism is used:
● If data entry has been started, it retains the original value and

closes the dialog box.
● If data entry has not been started or has been completed, it closes

the dialog box.

[Enter] key Has the same effect as pressing the rotary knob
● Concludes the entry of dimensionless entries. The new value is

accepted.
● With other entries, this key can be used instead of the default unit

key.
● In a dialog box, selects the default or focused element.
● Calls the next dialog level.
● Confirms and closes open input windows.

[Backspace] key Deletes the character to the left of the cursor in editing mode.

Navigation Keys

As an alternative to the rotary knob or the touchscreen, you can use the navigation
keys to navigate through dialog boxes, diagrams, or tables.

Table 3-6: Navigation keys

Type of key Description

[Up/Down] key The [Up] and the [Down] key does the following:
● In a numeric edit dialog box, increase or decrease the instrument

parameter.
● In a list, scroll forward and backward through the list entries.
● In a table, move the selection bar vertically.
● In windows or dialog boxes with vertical scrollbar, move the scroll-

bar.

[Left/Right] key The [Left] and the [Right] key does the following:
● In an alphanumeric edit dialog box, move the cursor.
● In a list, scroll forward and backward through the list entries.
● In a table, move the selection bar horizontally.
● In windows or dialog boxes with horizontal scrollbar, move the

scrollbar.

3.2.1.6  Display Keys

The display keys arrange different windows on the display.

Table 3-7: Display keys

Display key Assigned functions

[Home] Returns to the initial feature screen.

[Next window] Toggles between the entry fields in the taskbar.

[On/Off] ● Switches highlighted elements or a function block on and off.
● Switches between two or more settings, e.g. items of selection lists.

At the end of a list, the cursor is set on the first entry again.
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Display key Assigned functions

[Undo] Reverts the last operation.

[User] Adds a parameter to the user menu for quick access.

3.2.1.7  USB

Female USB type A connector, to connect devices like a keyboard, a mouse, a mem-
ory stick, or the R&S NRP-Z3/Z4 cable for the R&S NRP power sensors.

How to: Chapter 3.1.8, "Connecting USB Devices", on page 23

3.2.1.8  Sensor

Connector for R&S NRP sensors.

A power sensor is connected to the R&S AREG100A by inserting the male connector.
To disconnect, pull the connector by its sleeve. You cannot disconnect the sensor sim-
ply by pulling at the cable or the rear part of the connector.

The R&S AREG100A supports the use of R&S NRP power sensors in various ways
including the use as a power viewer.

See Chapter 6, "Using Power Sensors", on page 74.

3.2.1.9  On/Standby

The [On/Standby] key switches the instrument from the standby to the ready state or
vice versa.

The LED above the [On/Standby] key indicates the instrument state, see Chap-
ter 3.1.12, "Switching On or Off", on page 27.

3.2.2  Rear Panel Tour

This section provides an overview of the connectors at the rear panel of the instrument.
For technical data of the connectors, refer to the data sheet.

Instrument Tour
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Figure 3-4: Rear panel view of the R&S AREG100A

1 = Frontend Control, see "Control" on page 34
2 = Rx IF In and Tx IF Out connectors (SMA), see "Rx IF In/Tx IF Out " on page 34
3 = Aux IF In and Aux IF In connectors (SMA), see "Aux IF Out/Aux IF In " on page 34
4 = AC power supply connection and main power switch, see Chapter 3.2.2.1, "Connectors", on page 34
5 = Ref In and Ref Out connectors (BNC), see Chapter 3.2.2.1, "Connectors", on page 34
6 = USB connector (type A), see Chapter 3.2.2.1, "Connectors", on page 34
7 = LAN connector, see Chapter 3.2.2.1, "Connectors", on page 34
8 = USB In connector (type micro-B), see Chapter 3.2.2.1, "Connectors", on page 34
9 = IEEE 488 connector, see Chapter 3.2.2.1, "Connectors", on page 34

3.2.2.1  Connectors

Control
Connector for connecting the frontend with the supplied control cable.

How to: Chapter 3.1.11, "Connecting the Frontend", on page 25.

Rx IF In/Tx IF Out
SMA connector for connecting the frontend with the supplied IF cables.

How to: Chapter 3.1.11, "Connecting the Frontend", on page 25.

Aux IF Out/Aux IF In
Option: R&S AREG-B17

SMA connector for output of IF signals for signal analysis and input of an additional
interferer to the generated echo signal.

How to: Chapter 3.1.10, "Connecting to Aux IF In/Aux IF Out ", on page 25.

AC power supply connector and switch
Mains power switch for performing the following tasks:
● Connecting the internal power supply to the power source
● Disconnecting the internal power supply from the power source
How to: Chapter 3.1.6, "Connecting to Power", on page 22.

Instrument Tour
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Ref In/Ref Out
Input/output for external reference signal.

BNC connectors for 10 MHz reference signals.

How to: Chapter 3.1.9, "Connecting to Ref In/Ref Out", on page 24

USB/USB In
● Female USB type A connector, to connect devices like a keyboard, a mouse, a

memory stick, or the R&S NRP-Z3/Z4 cable for the R&S NRP power sensors
● Option: R&S AREG-B86

Female USB In connector (USB type B), for example for remote control.
How to: Chapter 3.1.8, "Connecting USB Devices", on page 23

LAN
RJ-45 connector to connect the R&S AREG100A to a LAN for remote control, remote
operation, and data transfer.

How to: Chapter 3.1.7, "Connecting to LAN", on page 23

IEEE 488
Option: R&S AREG-B86

General purpose interface bus (GPIB) interface for remote control of the instrument.
The interface is in compliance with the standards IEC 625, IEEE 488 and SCPI.

Use this interface to connect a computer for remote control of the R&S AREG100A. To
set up the connection, use high-quality shielded cables. See "Cable selection and elec-
tromagnetic interference (EMI)" on page 22.

See also Chapter D.1, "GPIB-Bus Interface", on page 350 and Chapter 9, "Network
Operation and Remote Control", on page 147.

3.2.3  Frontend

This section provides an overview of the connectors of the frontend of the instrument.
For technical data of the connectors, refer to the data sheet.

Instrument Tour
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4

2 31

Figure 3-5: Frontend of R&S AREG100A

1 = Control, see "Control" on page 36
2 = Rx IF Out and Tx IF In (SMA), see "Rx IF Out/Tx IF In" on page 36
3 = Rx Power (SMA), see "Rx Power" on page 36
4 = Waveguide ports, see "Waveguide port (2 x)" on page 36

3.2.3.1  Connectors

Control
Connector for connecting to the base unit with the supplied TRX CRTL Cable.

How to: Chapter 3.1.11, "Connecting the Frontend", on page 25.

Rx IF Out/Tx IF In
SMA connectors for connecting to the base unit with the supplied "IF TX CBL"/"IF RX
CBL" cables.

How to: Chapter 3.1.11, "Connecting the Frontend", on page 25.

Rx Power
SMA connector for connecting power sensors, for example for EIRP power measure-
ments.

How to: See Chapter 4, "Generating Radar Echo Signals", on page 51.

Waveguide port (2 x)
Ports for antenna connection.

Instrument Tour
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Supported are different frequency ranges: 24 GHz to 24.25 GHz, 76GHz to 77GHz or
76 GHz to 81 GHz.

The R&S AREG100A is delivered with one or two antennas mounted to the waveguide
ports. The antenna type, single or dual, depends on the options you have purchased.

You can detach the included antennas and connect your own antennas.

How to: Chapter 4.5, "Using Custom Antennas", on page 58.

3.2.3.2  Cables

The frontend is delivered with two IF cables (IF TX CBL/IF RX CBL) and one control
cable (TRX CRTL Cable). These cables are calibrated and dedicated to the particular
frontend. Each cable has its own serial number, printed on it.

The serial numbers of the supplied cables are saved in the frontend module. You can
check the serial numbers and compare them with the serial number printed on the
cables. See "To check the serial number of the cables" on page 27.

IF TX CBL/IF RX CBL
Two IF cables for connecting the base unit and the frontend, where:
● TX|RX - transmitting and receiving direction, in respect to the base unit
How to: Chapter 3.1.11, "Connecting the Frontend", on page 25.

TRX CRTL Cable
One control cable for connecting the base unit and the frontend via the "Control" con-
nector.

How to: Chapter 3.1.11, "Connecting the Frontend", on page 25.

3.3  Trying Out the Instrument

This chapter introduces the first steps with the R&S AREG100A. It shows how to oper-
ate and configure the instrument using simple examples. The complete description of
the functionality and its usage is given in the R&S AREG100A user manual.

Basic instrument operation is described in Chapter 3.4, "Instrument Control",
on page 42.

Prerequisites

The instrument is set up, connected to the power supply, and started up as described
in Chapter 3.1, "Preparing for Use", on page 19.

The instrument is manually operated via the touchscreen. Try out the following:

● Generating Radar Echo Signals..............................................................................38
● Saving and Recalling Settings................................................................................ 40

Trying Out the Instrument
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3.3.1  Generating Radar Echo Signals

The core element of a measurement setup is the R&S AREG100A base unit with con-
nected frontend.

To generate a radar echo signal

1. In the block diagram, select "Radar Objects".

2. Select a radar object. Use the object with the range that fulfills your test require-
ment.

3. Modify the attenuation until the display shows the appropriate value for the radar
cross section (RCS), which indicates the size of the simulated radar object.

Examples for RCS values at 79 GHz (can vary in reality):
● Truck: RCS =20 dBsm
● Car: RCS = 5 dBsm
● Pedestrian: RCS = −4 dBsm

4. If the attenuation range of the specific radar object is not enough to reach the
appropriate RCS value, modify the base attenuation.

Trying Out the Instrument
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5. Switch on your radar object.

6. Switch "RF On".

The RUT reports the range and the radar cross section of the target.
Compare these values with the pre-configured values in the R&S AREG100A.

Trying Out the Instrument
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3.3.2  Saving and Recalling Settings

To restore the results of our measurements later, we save the instrument settings in a
file.

To save the instrument settings in a file

We assume, a test configuration as described in Chapter 3.3.1, "Generating Radar
Echo Signals", on page 38.

1. Press the [Setup] key on the front panel.

2. In the "Setup" menu, select "Settings > Save/Recall".

3. In the "Save/Recall" dialog, select "Operation Mode > Save".

4. Tap the "Filename", use the on-screen keyboard, and enter MyTestSignal.

5. Tap the "Save" button.

The file MyTestSignal.savrcltxt is stored in the default direc-
tory /var/user/.

To load saved instrument settings

You can restore the settings to the instrument at any time using the settings file.

1. Press the [Preset] button to restore the default instrument settings so you can
check that the stored user settings are restored afterwards.

2. Press the [Setup] key on the front panel.

3. In the "Setup" menu, select "Settings > Save/Recall".

Trying Out the Instrument
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4. In the "Save/Recall" dialog, select "Operation Mode > Recall".
Navigate to the directory the file is saved in and select the MyTestSignal file.

5. Tap the "Recall" button.

All instrument settings are restored and the display resembles Chapter 3.3.1, "Gen-
erating Radar Echo Signals", on page 38, which shows the instrument display right
before the settings were saved.

How to display all parameters with values different to their preset values
When you load a file to your instrument, you do not have enough information on the
changed settings. In such case, it is useful to visualize all parameters that have been
changed from their default state.

Try out the following:
● Touch and hold a spot in the tile diagram for at least 1 second to access the con-

text-sensitive menu.
● Select "Mark All Parameters Changed from Preset".

Trying Out the Instrument
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● All changed parameters are highlighted.

See also Chapter 7, "File and Data Management", on page 86.

3.4  Instrument Control

This chapter provides an overview on how to work with the R&S AREG100A.

It covers the following topics:

● Possible Ways to Operate the Instrument...............................................................42
● Means of Manual Interaction...................................................................................43
● Understanding the Display Information...................................................................43
● Accessing the Functionality.....................................................................................45
● Entering Data.......................................................................................................... 46
● Getting Information and Help.................................................................................. 48
● Remote Control.......................................................................................................49
● Remote Operation over VNC.................................................................................. 50

3.4.1  Possible Ways to Operate the Instrument

There are three ways to operate the R&S AREG100A:
● Manual operation:

Use the touchscreen, hard keys and rotary knob, or an optional mouse and/or key-
board.
The description under Chapter 3.4, "Instrument Control", on page 42 shows how to
operate the instrument manually.

● Remote control:
Create programs to automatize repeating settings, tests and measurements. The
instrument is connected to a computer running the program.

Instrument Control
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This way of operation is described in Chapter 9, "Network Operation and Remote
Control", on page 147.

● Remote operation from a computer:
Remote monitoring and control of the instrument from a connected computer is
based on the common cross-platform technology VNC (Virtual Network Comput-
ing). On the remote computer, any standard web browser (supporting Java) or a
dedicated VNC client (like Ultr@VNC) can be used. See also Chapter 3.4.8,
"Remote Operation over VNC", on page 50.

3.4.2  Means of Manual Interaction

For the manual interaction with the R&S AREG100A, you have several methods that
you can use as an alternative to perform a task:
● Touchscreen:

Touchscreen operation is the most direct way to interact. Almost all control ele-
ments and actions on the screen are based on the standard operating system con-
cept. You can tap any user interface element to set parameters in dialog boxes,
enter data, scroll within a dialog etc., as if you work with a mouse pointer.
Tapping the screen works like clicking mouse buttons:
– Touch quickly = click: Selects a parameter or provokes an action.
– Touch and hold = right-click: Opens a context-sensitive menu.
– Touch and swipe = drag: Scrolls through the contents of a display element

larger than the screen, e.g. a list or a table.
● Function keys and rotary knob:

The front panel provides nearly all functions and controls to operate the instrument
in the classic way, without touchscreen.

● Optional mouse and/or keyboard:
These devices work like known from PCs. The navigation keys on the front panel
correspond to the keys on the keyboard.

This manual describes the manual interaction with the instrument via the touchscreen.
It mentions the alternative methods using the keys on the instrument or the on-screen
keypads if it deviates from the standard operating procedures. The usage of the touch-
screen and navigation keys is described in Chapter 3.4.4, "Accessing the Functional-
ity", on page 45.

Throughout the manual, the term "select" refers to any of the described methods, i.e.
using a finger on the touchscreen, a mouse pointer in the display, or a key on the
instrument or on a keyboard.

3.4.3  Understanding the Display Information

The home screen of the R&S AREG100A displays all main settings and generator
states, divided into three main operation areas.

● Additional Display Characteristics...........................................................................44

Instrument Control
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3.4.3.1  Additional Display Characteristics

The following section provides a short insight on the indication of the screen in general,
and significant elements that you see under specific operating modes, in dialogs or set-
tings.

● Appearance of active elements
– Active elements like On/Off switches, state buttons have a blue background.
– Selected elements are framed or highlighted orange.
– Inactive elements are gray.

● On-Screen keypads
As additional means of interacting with the instrument without having to connect an
external keyboard, either a numerical or alphanumerical on-screen keypad appears
when you activate an entry field (see Chapter 3.4.5, "Entering Data",
on page 46).

● Info line
The "Info line" shows brief status information and error messages. It appears when
an event generates a message.

● Key parameters indicated in tab labels
Most dialogs are divided into tabs with logically grouped parameters. The tab label
expresses the content and can also contain status indicators or the set value of a
key parameter.

● Scroll bar handle
An arrow icon that appears when you touch a scroll bar helps you to scroll in a dia-
log or list.

● Progress indicators
A busy icon indicates a currently running process. If a process takes some time, a
progress bar shows the current state.

● Context-sensitive menus
Within the entire screen display, including single parameters, you can access con-
text-sensitive menus that provide some additional functions.

Instrument Control
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3.4.4  Accessing the Functionality

All functionalities are provided in dialog boxes as known from computer programs. You
can control the instrument intuitively with the touchscreen. This section provides an
overview of the accessing methods.

The instrument's functions and settings can be accessed by selecting one of the follow-
ing elements:
● System and function keys on the front panel of the instrument
● Taskbar/softkeys on the touchscreen
● Context-sensitive menus for specific elements on the touchscreen, or with the

rotary knob (press and hold).
● Elements on the status bar in the touchscreen
● Displayed setting on the touchscreen, that means block diagram and all settings

available in dialogs.

To open a dialog box

► Perform one of the following actions:

● Tap the required tile, and then the menu entry.
● Tap the minimized view (button) on the taskbar.

Some of the utility keys access a dedicated dialog, too.

Instrument Control



Getting StartedR&S®AREG100A

46User Manual 1178.7417.02 ─ 06

To minimize a dialog box

► To return to the home screen, tap the "Home" button.

To close a dialog box

To close a dialog box, you have the same controls as you know from computers or
devices with touchscreen.

► Perform one of the following actions:

● Tap the "Close" icon in the upper right corner.
● Press the [Esc] key on the front panel.
● Drag and drop a minimized dialog from the taskbar to the tile diagram.

To select an option in a dialog box

► Tap the required option.

3.4.5  Entering Data

Some parameters have their own key on the front panel.

For data input in dialog boxes, the instrument provides on-screen keypads for entering
numeric and alphanumeric values. Thus, you can always set the parameters via the
touchscreen, the front panel, or an external keyboard.

To correct an entry

1. Using the arrow keys, move the cursor to the right of the entry you want to delete.

2. Press the [Backspace] key.

3. Deletes the entry to the left of the cursor.

4. Enter your correction.

To complete the entry

► Press the [Enter] key or the rotary knob.

To abort the entry

► Press the [Esc] key.
The dialog box closes without changing the settings.

Instrument Control
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3.4.5.1  Entering Numeric Parameters

To enter values with the on-screen keypad

For numeric settings, the instrument displays the numeric keypad. The units specified
correspond to the units of the parameter.

1. Enter the numeric value.

Tip: For quick entry, you can enter a value in exponential representation, e.g. 1e7
for 10000000.

2. Tap the unit button to complete the entry.

The unit is added to the entry.

Tip: For quick unit change, you can enter shortcuts, e.g. for a frequency value
1e8h for 100 MHz.
For an overview of shortcuts supported by the R&S AREG100A, see Chapter C,
"Unit Shortcuts", on page 348.

3. If the parameter does not require a unit, confirm the entered value by pressing
"Enter".

To enter values by using the front panel controls

1. Change the currently used parameter value by using the rotary knob or the [Up/
Down] keys.

2. If the parameter does not require a unit, confirm the entered value by pressing the
[Enter] key or any of the unit keys.
The instrument highlights the editing line to confirm the entry.

If you edit numeric data in tables, the entry field must be in edit mode: Press [Enter], or
the rotary knob to activate the edit mode.

3.4.5.2  Entering Alphanumeric Parameters

If a field requires alphanumeric input, you can use the on-screen keyboard to enter let-
ters and (special) characters.

3.4.5.3  Undo and Redo Actions

Accessed via the context-sensitive menus, "Undo" allows you to restore one or more
actions on the instrument. Depending on the available memory, the "Undo" steps can
restore all actions.

Instrument Control
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"Redo" restores a previously undone action.

3.4.6  Getting Information and Help

In some dialog boxes, graphics are included to explain the way a setting works.

For further information, you can use the following sources:
● Tooltips give the value range of the parameter.
● The context help provides functional description on a setting.
● The general help explains a dialog box, provides instructions, and general informa-

tion.

To display context help

► To access a help topic, perform one of the following:

a) Tap and hold the parameter for which you need information and tap "Help" in
the context menu.

b) Tap the parameter and press the [Help] key.

The "Help" dialog opens. You can browse the help for further information.

Contents of the help dialog box

The help dialog box covers two main areas:
● "Contents" - contains a table of help contents
● "Topic" - contains a specific help topic

The help system also provides an "Index" and a "Find" area, and "Zoom" functions that
are accessed via the corresponding buttons.

Instrument Control
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To open general help

► Press the yellow [Help] key on the front panel.

If a dialog box is opened, the help topic for the current tab is shown. Otherwise the
"Contents" page appears.

Navigating in the table of contents and in the help topics

1. To move through the displayed contents entries, tap on an entry and scroll or use a
connected mouse or the [Up/Down] keys.
Entries with a plus sign contain further entries.

2. To display a help topic, tap on the topic name or double-click the topic name or
press the [Enter] key.

3. To follow a cross-reference, tap on the link text.

4. To return to the previous page, select "Back".
This function scrolls back all steps you have performed before.

5. Use the "scroll bars" to shift the visible section of content shown.

6. To maximize the "Topics" area, tap the "Hide Contents Tree" button to hide the con-
tents tree.

Using the index

1. Select the "Index" button.

2. Enter the first characters of the topic you are interested in.

The entries starting with these characters are displayed.

3. Tap on the index entry.

The corresponding help topic is displayed.

3.4.7  Remote Control

In addition to working with the R&S AREG100A interactively, located directly at the
instrument, it is also possible to operate and control it from a remote PC.

The R&S AREG100A supports various methods for remote control:
● Connecting the instrument to a LAN (see Chapter 3.1.7, "Connecting to LAN",

on page 23)
● Using the LXI browser interface in a LAN
● Connecting a PC via the IEC-bus (IEEE 488) interface
● Remote control via the USB interface

For remote control over LAN or USB, you can use the R&S VISA (Virtual Instrument
Software Architecture) library provided for download at the Rohde & Schwarz website
http://www.rohde-schwarz.com/rsvisa.

Instrument Control
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How to configure the remote control interfaces is described in Chapter 9, "Network
Operation and Remote Control", on page 147.

3.4.8  Remote Operation over VNC

The VNC is an application which can be used to access and control the instrument
from a remote computer through a LAN connection. While the instrument is in opera-
tion, the instrument screen contents are displayed on the remote computer, and VNC
provides access to all applications, files, and network resources of the instrument.
Thus, remote operation of the instrument is possible.

Instrument control from a remote computer
To access the basic utility functions of the R&S AREG100A, perform a right mouse
click the block diagram and select "Key Emulation".
A key panel to the right of the block diagram gives access to the utility functions provi-
ded by the front panel keys.

The VNC is an add-on program, included in operating system Linux/Unix, and available
as a free-of-charge download on the internet.

For more information, refer to Chapter 9.9, "Operating the R&S AREG100A Remotely
via VNC", on page 198.

Instrument Control
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4  Generating Radar Echo Signals
The main application field of the R&S AREG100A is the generation of radar echo sig-
nals.

This section introduces the basic principle of the signal echo generation and lists some
typical measurement examples.

Measurement setup

A typical measurement setup consists of the R&S AREG100A base unit with connec-
ted frontend.

The R&S AREG100A receives a radar signal from the RUT (radar under test) in the
specified frequency band (e.g. 24 GHz or 77 GHz). It downconverts the signal to the
intermediate frequency (IF). Depending on the installed options and current configura-
tion, the signal is delayed and attenuated.

The modified IF signal is upconverted to the RF (radio frequency) and retransmitted to
the RUT. The RUT receives and processes this modified version of the signal it origi-
nally has transmitted. As a result, the RUT reports the range and the radar cross sec-
tion (RCS) of the target. For verification, you can compare the measured values with
values pre-configured in the R&S AREG100A.

The block diagram on Figure 4-1 illustrates how R&S AREG100A modifies the
received signal. Radar under test, required cabling and measured results are not
shown.

R&S AREG

LO
D

fD

Bypass

fIF,TX = fIF,RX+fD

On

Off

Doppler stage Delay stage

fRF,TX = 
fRF,RX + fD

fRF,RX

Frontend

LO

TX

RX  fIF,RX

Delay linesAttenuation

AttB

AttO

Figure 4-1: Block diagram: R&S AREG100A with connected frontend (simplified)

fRF,RX = RF frequency at the receiving antenna (RX) of the frontend
fIF,RX = Intermediate frequency (IF) at the frontend output, downconverted from the received RF
fIF,TX = Intermediate frequency (IF) at the frontend input, including Doppler frequency fD if Enable

Doppler Bypass = "Off"
fD = Doppler frequency
fRF,TX = RF frequency at the transmitting antenna (TX) of the frontend
Doppler stage = Option: R&S AREG-B60
Bypass = Representation of Enable Doppler Bypass parameter
LO = Local oscillator
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LOD = Local oscillator at the Doppler stage
Attenuation = Common base attenuation (AttB) and individual attenuation per object (AttO)
Delay lines = Up to four optical lines with constant delays

About radar echo generation

The R&S AREG100A generates up to four radar echo signals by delaying the received
radar signal through up to four optical fixed delay lines (see Figure 4-1). The delays are
fixed and defined during the purchasing process. The signal delay simulates echos
from static objects at different distance.

Additionally to delaying the signals, you can also apply an object attenuation and a
base attenuation. From the attenuation and the range, the R&S AREG100A calculates
the radar cross section (RCS) if the object, where the RCS indicates the size of the
simulated radar object.

Use the object attenuation to vary the RCS values of the individual objects separately.
Change the base attenuation value to apply an attenuation (or gain) to all objects at
once.

Radar equation

The radar equation describes how much reflected RF power is received by a radar
sensor from a reflecting object. In this implementation, the radar equation is the basis
for all attenuation and level calculations.

P_r = P_t * (G_t*G_r*λ2*RCS) / ((4*pi)3*R4), where:
● P_r: received power at the radar sensor
● P_t: transmitted radar signal power from the radar sensor
● G_t: gain of the radar transmit antenna
● G_r: gain of the radar receive antenna
● λ = c/f is the wavelength of the radar signal and

– c = 299700000m/s is the speed of light in the air
– f: frequency of the radar signal

● RCS: radar cross section
● R: distance between radar and a reflecting object

Radar cross section (RCS)

Radar cross section is a parameter which describes how much of the incoming radar
signal at the object gets reflected back to the radar sensor. The RCS does not repre-
sent the physical size of an object but is rather a virtual parameter. Multiply the RCS by
the power density of the radar signal at the location of the object to get the signal
power reflected back to the radar sensor.

The RCS value is often expressed in dBsm (dB square meters).

Many parameters affect the RCS of an object, for example:
● Geometrical shape of the object, like surfaces, edges or size
● Material of the object
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● Orientation of the object towards the radar sensor
● Polarization of the radar transmit antenna and the radar receive antenna
● Wavelength of the radar signal

RCS is sensitive to these parameters and is therefore difficult to list accurate RCS val-
ues for a given object.

Examples of typical RCS values at 76 GHz to 81 GHz:
● Truck: RCS = 20 dBsm
● Car: RCS = 5 dBsm
● Pedestrian: RCS = −4 dBsm

In R&S AREG100A, the following parameters influence the RCS value: frequency,
object distance, air gap, antenna gains, base attenuation and object attenuation.

The RCS is calculated as follows:

RCS = GTX * GRX * λ2 / (4*pi) * R4 / A4 * 1/AttO * 1/AttB, where:

● GTX: Gain of the R&S AREG100A transmit antenna, converted from dB to linear
scale

● GRX: Gain of the R&S AREG100A receive antenna, converted from dB to linear
scale

● λ = c/f is the wavelength of the radar signal and
– c = 299700000m/s is the speed of light in the air
– f: center frequency of the R&S AREG100A, as displayed with the parameter

Frequency
● R: object distance
● A: Air gap between radar sensor and R&S AREG100A antennas
● AttO: object attenuation, converted from dB to linear scale

● AttB: base attenuation, converted from dB to linear scale

Doppler speed and Doppler shift

If option R&S AREG-K799 installed, you can configure a common Doppler speed for all
objects and thus simulate the echo signals from objects moving with the same radial
velocity.

If option R&S AREG-B60 is installed, you can simulate moving objects with individual
radial velocities for each object. The radial velocity can be derivated from the defined
Doppler shift or Doppler speed.

The Doppler shift fD is calculated as follows:

fD = 2(ν/c)*fRF, where:

● v is the radial speed of the object
● fRF is the frequency of the RF output signal

● c = 299700000m/s is the speed of light in the air.

Either R&S AREG-K799 or R&S AREG-B60 can be installed.



Generating Radar Echo SignalsR&S®AREG100A

54User Manual 1178.7417.02 ─ 06

Bypassing Doppler stage

In R&S AREG100A and if R&S AREG-B60 is installed, Doppler effects are simulated
by mixing the local oscillator frequency fLO with the selected Doppler frequency fD (see
Figure 4-1). Naturally, mixers introduce intermodulation products.

To increase signal quality if the Doppler speed is zero, you can bypass the Doppler
stage. For details, see Enable Doppler Bypass.

4.1  How to Generate a Radar Echo Signal

Follow the steps described in Chapter 3.3.1, "Generating Radar Echo Signals",
on page 38.

4.2  Testing Radar Sensors against Interferers

The R&S AREG100A provides an input interface in the IF domain ("Aux IF In"). In com-
bination with any analog or vector signal generator, with this interface you can simulate
of a wide range of interferers together with the wanted echoes.

Figure 4-2: Example setup: Testing radar sensors against interferers

1. Connect an R&S SMW200A to the "Aux IF In" connector of the R&S AREG100A
base unit.

2. Set the frequency of the interfering signal to an IF frequency that results to the
required RF frequency.
Calculate the RF frequency as follows:
f_RF = f_IF + f_LO

Where f_LO depends on the installed options:
● f_LO = 23.3 GHz (R&S AREG-B124)

Testing Radar Sensors against Interferers
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● f_LO = 75.3 GHz (R&S AREG-B177)
● f_LO depends on selected "Frequency" (R&S AREG-B181)

– "Frequency" < 78.5 GHz, f_LO = 75.3 GHz.
– "Frequency" > 78.5 GHz, f_LO = 76.275 GHz.

The generated interfering signal is superimposed and upconverted into the E-band
together with the delayed echo signal from the simulated radar objects.

3. Observe and evaluate the influence of the interferer signals.

4.3  Measuring EIRP of Radar Sensor

Connect a power sensor to the "Rx Power" connector at the frontend to measure the
sensor's equivalent isotropic radiated power (EIRP). The receive path from the Rx
antenna port of the R&S AREG100A to the frontend's power measurement port is cali-
brated so that you can measure the EIRP at the frontend.

Figure 4-3: Example setup: Measuring EIRP of radar sensor

EIRP calculation

The EIRP value of the radar sensor is calculated from the measured output power, the
antenna gain, the air gap, instrument's internal gain and the temperature compensa-
tion.

The EIRP is calculated as follows:

EIRP [dB] = (PRX − G1) + 20 * log A − GRX − 20 * log λ

Where:
● A = air gap
● λ = wavelength of the radar transmission
● GRX = R&S AREG100A antenna gain

Measuring EIRP of Radar Sensor



Generating Radar Echo SignalsR&S®AREG100A

56User Manual 1178.7417.02 ─ 06

● G1 = internal gain from RX waveguide port to power sensor
● PRX = received power at the frontend

How to measure the EIRP with a power sensor

1. Connect the RF input of a power sensor to the "Rx Power" connector at the fron-
tend.

2. Connect the power sensor to the R&S AREG100A base unit.

The R&S AREG100A automatically detects a connected R&S NRP power sensor
and indicates it in the "NRP Power Viewer" and "NRP Sensor Mapping" dialogs.

3. Select "Power Sensors > NRP Power Viewer > NRP Sensor Mapping" and observe
the displayed information.

4. Select "AREG Config > EIRP > Sensor" and select the sensor you have connected
to the frontend.

Measuring EIRP of Radar Sensor
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The EIRP is calculated automatically, see "EIRP calculation" on page 55.

5. Observe the resulting EIRP value in "Power Sensors" > EIRP.

4.4  Analyzing the Radar Signal

If you want to analyze radar signals in the IF domain, connect a spectrum analyzer with
frequency and bandwidth settings matching the generated signal to the
R&S AREG100A.

Figure 4-4: Example setup: Analyzing radar signal

Analyzing the Radar Signal
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1. Connect an R&S FSW to the "Aux IF Out" connector of the R&S AREG100A base
unit.

2. Set the center frequency of the R&S FSW.

A radar signal at frequency f_RF is output at an intermediate frequency f_IF at the
"Aux IF Out" connector.
The f_RF frequency is calculated as follows:
f_IF = f_RF - f_LO

Where f_LO depends on the installed options:
● f_LO = 23.3 GHz (R&S AREG-B124)
● f_LO = 75.3 GHz (R&S AREG-B177)
● f_LO depends on selected "Frequency" (R&S AREG-B181)

– "Frequency" < 78.5 GHz, f_LO = 75.3 GHz.
– "Frequency" > 78.5 GHz, f_LO = 76.275 GHz.

You can observe and evaluate the radar signal of the RUT.

4.5  Using Custom Antennas

Depending on the installed options, the R&S AREG100A is delivered with one or two
antennas mounted to the waveguide ports. You can detach the included antennas and
connect your own antennas.

To mount your custom antenna

1. Switch off the base unit.
See Chapter 3.1.12, "Switching On or Off", on page 27.

2. For each antenna, unscrew the four screws holding the antenna to the waveguide
port with an 3/32 inch hex wrench.

3. Place the antennas carefully at the side.

4. Place your antenna at the waveguide.
Ensure that the antenna polarization matches the polarization of the frontend
waveguide.

5. Screw the four screws to hold the custom antenna.

To configure the antenna

The R&S AREG100A is pre-configured for the delivered antennas.

Change the setting to reflect the antenna characteristics of your custom antenna.

1. On the home screen, select .AREG Configuration.

2. Select "Use Custom Antenna > On".

3. In the field "AREG Antenna Gain TX", set the gain of the custom transmitting
antenna.

Using Custom Antennas
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4. In the field "AREG Antenna Gain RX", set the gain of the custom receiving
antenna.

5. Measure the distance between the base unit and the DUT.

6. Set the measured distance in the field "Air Gap from DUT to AREG".

To find out the default antenna delivered with your instrument

If you have multiple antennas and you want to check which antenna was delivered with
your R&S AREG100A, proceed as follows:

1. On the front panel, press [Setup].

2. Select "Setup" > "Instrument Assembly" > "Hardware Config" > "RF Assembly".

3. Compare the displayed serial number of the antenna with the serial number printed
on the physical antenna.

To remount the default antenna

1. Prepare the default antenna, delivered with your instrument.
See "To find out the default antenna delivered with your instrument" on page 59.

2. Unmount the custom antennas. Remount the default antennas.
Follow the steps described in "To mount your custom antenna" on page 58.

3. Switch on the R&S AREG100A, see "To switch on the R&S AREG100A"
on page 27.

4. Select "System Config > Setup > Settings > Factory Preset".

The antenna gain settings are preset to their default values.

4.6  Compensating Power Loss

An additional waveguide section between the R&S AREG100A waveguide and the
physical antenna introduces power loss and additional delay. The additional power loss
affects the RCS and EIRP values; the additional delay - the simulated object distance.

As R&S AREG100A uses fixed fiber delay lines to simulate delays, the additional dis-
tance cannot be compensated. You can, however, use the antenna gain setting to com-
pensate for the power loss and for adjusting the overall gain of the setup.

To compensate for the additional loss, reduce the default antenna gain value of the
respective antenna (AREG Antenna Gain TX) by the insertion loss of the additional
waveguide section.

After this correction, the displayed values of RCS and EIRP are correct.

Compensating Power Loss
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4.7  Temperature Compensation

The R&S AREG100A provides a built-in temperature compensation mechanism which
minimizes deviations of the signal attenuation due to temperature changes of the
R&S AREG100A base unit or frontend module. Based on the current instrument tem-
perature, this compensation mechanism adapts the internal step attenuator settings to
compensate for temperature effects in the signal chain.

To not disturb the measurement results, the temperature compensation mechanism
does not run automatically on its own but needs to be triggered. The compensation
process starts if you change one of the following settings: base or object attenuation,
radial velocity (Doppler shift or frequency) or object state.

When and how to start temperature compensation?

We recommend that you trigger temperature compensation before you start measure-
ment of a radar sensor.

Whenever you want to trigger temperature compensation, update any of the related
parameters. You can update a parameter manually, via the touchscreen, or remotely,
via a remote control command. Even setting a value that is identical with the current
one triggers the temperature compensation.

Temperature Compensation
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5  Radar Objects and Configuration Settings
You find the main configuration elements on the home screen.
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5.1  Radar Power Indicator

TheR&S AREG100A shows the "Radar Power" indicator in the display for quick
assessment of incoming radar signal power. The "Radar Power" indicator is updated
periodically. If the R&S AREG100A detects an incoming signal, the default gray indica-
tor turns colored.

The indication is color-coded:
● Blinking color

Pulsed radar signal.
● Green

RX power is in linear range.
● Yellow

RX power is strong, non-linear effects can occur.
Reduce input power, for example by enlarging the air gap.

● Red
RX power is in a range, where the receiver is in saturation.
Enlarge the air gap or reduce radar power.
Receiver saturation can also result from too much gain in the R&S AREG100A (i.e.
negative base attenuation setting) in conjunction with reduced R&S AREG100A
TX-to-RX isolation, leading to signal oscillation.
TX-to-RX isolation is lower for monostatic R&S AREG100A setups, and if metal
objects or signal reflectors are placed closely in front of the R&S AREG100A
antennas. Remove or tilt these objects or increase the Base Attenuation value to
reduce the risk of oscillation.

● Grey
No or weak RX power.
– Ensure that the radar under test (RUT) is working, located in a useful distance

(i.e. air gap) from the R&S AREG100A, and pointing at the R&S AREG100A
antennas.

– Check the correct polarization of the RUT.
The R&S AREG100A antennas are vertically polarized if the control and IF
connectors of the frontend module point upwards.

The "Radar Power" indicator is updated periodically. If the update period of the
"Radar Power" indicator coincides with the radar pulse repetition time, the indicator
update falls in the time between the pulses, when the radar in not transmitting.
In such cases, the "Radar Power" indicator can stay grey for a long period of time,
although the incoming radar signal is not weak.
Try out one of the following:
– Change the pulse repetition frequency of the RUT
– Restart your R&S AREG100A or the RUT

SCPI command:

[:SOURce<hw>]:AREGenerator:RADar:POWer:INDicator? on page 274

Radar Power Indicator
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5.2  Frequency

Displays the center frequency of the remote frontend.

● Option: R&S AREG-B124S / R&S AREG-B124D
Frequency range from 24 GHz to 24.25 GHz.
The field "Frequency" is read-only.

● Option: R&S AREG-B177S / R&S AREG-B177D
Frequency range from 76 GHz to 77 GHz.
The field "Frequency" is read-only.

● Option: R&S AREG-B181S / R&S AREG-B181D
Frequency range from 76 GHz to 81 GHz.
With a maximum bandwidth of 4 GHz, the following frequency values are suppor-
ted:
– Frequency range from 76 GHZ to 80 GHz: center frequency 78 GHz.
– Frequency range from 77 GHz to 81 GHz: center frequency 79 GHz.

If "Frequency" < 78.5 GHz, the local oscillator frequency is 75.3 GHz.
If "Frequency" > 78.5 GHz, the local oscillator frequency of 76.275 GHz.

SCPI command:

[:SOURce<hw>]:FREQuency[:CW|FIXed] on page 269

[:SOURce<hw>]:FREQuency[:CW|FIXed]:RCL on page 269

5.3  Radar Objects

Access:

1. In the home screen, observe the "Radar Objects" tile.

The "Radar Objects" tile displays the configuration settings of artificial radar objects
for reliable testing of radar sensors.

You can configure up to four radar objects. At least one radar object has to be con-
figured.

2. Tap the "Radar Objects" tile to configure one or more radar objects.

Radar Objects
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Dist:............................................................................................................................... 64
∑ Att:............................................................................................................................. 64
Vel:/D>>:....................................................................................................................... 65
RCS:..............................................................................................................................65

Dist:
The displayed distance is calculated as the sum of the following:
● The signal delay for the respective object signal path, multiplied with the speed of

light in air (c = 299700000 m/s)
● The air gap between the R&S AREG100A antenna and the radar under test (RUT),

as configured with "Air Gap from DUT to AREG" on page 71.
If you change the air gap in the measurement setup, the measured distance of the
RUT changes, as the signal delay in the R&S AREG100A stays constant.

Correct air gap value is a prerequisite for the calculation of the distance, EIRP and
RCS value. With correct air gap value, the "Radar Objects" tile shows the correct
resulting distance. The EIRP and RCS values are calculated automatically, too.

Example: 
● R&S AREG100A with default values:

– Object distance = 50 m
– "Air gap" = 0.8 m

● Test setup where the physical distance between the R&S AREG100A antenna and
the RUT = 1 m.

R&S AREG100A simulates object at a distance of 50.2 m. This behavior cannot be
changed.
To ensure that R&S AREG100A displays the simulated distance correctly, set "Air gap
= 1". The RCS and EIRP values are corrected, too.

∑ Att:
This attenuation is the sum of the following:
● The specific attenuation for each individual object, as configured in Attenuation
● The base attenuation affecting all radar targets, as configured in Base Attenuation

Settings.

Radar Objects
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Where the reference planes for the signal attenuation are:
● The RX waveguide input of the R&S AREG100A
● The TX waveguide output of the R&S AREG100A.

Vel:/D>>:
Displays the configured Doppler speed or Doppler shift values.

See:
● "Doppler Speed" on page 67.
● "Doppler Shift" on page 67.

RCS:
Displays the radar cross section.

For details, see "RCS" on page 67.

5.4  Objects Settings

Access:

► Select "Radar Objects" > "Configuration" > "Objects".

The "Objects" dialog displays all available radar objects and their configuration set-
tings.

Objects Settings
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Settings

Object 1 | 2 | 3 | 4.......................................................................................................... 66
State..............................................................................................................................66
Range............................................................................................................................66
Attenuation.................................................................................................................... 66
Doppler Speed.............................................................................................................. 67
Doppler Shift................................................................................................................. 67
RCS...............................................................................................................................67

Object 1 | 2 | 3 | 4
A maximum of four radar objects can be configured. The objects are defined by the
"Range" (see Range).

State
Activate the radar object.

Remote command: 
[:SOURce<hw>]:AREGenerator:OBJect:ALL[:STATe] on page 269
[:SOURce<hw>]:AREGenerator:OBJect<ch>[:STATe] on page 271

Range
Defines the range for a specific object.

The range can be displayed in different units, see "Range Unit" on page 69.
● Option: R&S AREG-B61

Fixed artificial object in a distance of 3.2 m + air gap.
● Option: R&S AREG-B62

Fixed customer defined artificial object in a distance between 4.2 m and 299.2 m +
air gap.
Specify the required distance (incl. air gap) during the ordering process along with
the desired air gap value.
You can change the air gap of the measurement setup at any time. The simulated
object range changes accordingly, as the internal signal delay of the
R&S AREG100A stays constant.
While changing the physical air gap, change also the air gap configuration in the
R&S AREG100A so that a correct calculation and display of distance, RCS and
EIRP values is assured.

Remote command: 
[:SOURce<hw>]:AREGenerator:OBJect<ch>:RANGe? on page 271

Attenuation
Defines the signal attenuation of a specific object, from the R&S AREG100A RX wave-
guide input to the TX waveguide output.

Change the attenuation to change the radar cross section (RCS) for a specific radar
object. Observe the resulting RCS.

Remote command: 
[:SOURce<hw>]:AREGenerator:OBJect<ch>:ATTenuation on page 270

Objects Settings
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Doppler Speed
Option: R&S AREG-K799 or R&S AREG-B60

If Doppler Format > "Doppler Speed", sets a frequency offset between the received
signals from the radar sensor and the retransmitted echo signal. Thus, it introduces a
radial velocity.
● Option: R&S AREG-K799

The common "Doppler Speed" applies to all radar objects.
● Option: R&S AREG-B60

You can define individual "Doppler Speed" values for each radar object.
For defining the units, see "Speed Unit" on page 69.

Remote command: 
[:SOURce<hw>]:AREGenerator:OBJect<ch>:DOPPler[:SPEed] on page 270

Doppler Shift
Option: R&S AREG-K799 or R&S AREG-B60

If Doppler Format > "Doppler Shift", add a doppler shift to the generated signal and
thus introduces a radial velocity.
● Option: R&S AREG-K799.

The common "Doppler Shift" applies to all radar objects.
● Option: R&S AREG-B60.

You can define individual "Doppler Shift" values for each radar object.
For defining the units, see "Speed Unit" on page 69.

Remote command: 
[:SOURce<hw>]:AREGenerator:OBJect<ch>:DOPPler:FREQuency
on page 270

RCS
Displays the calculated radar cross section (RCS) of an object.

The radar cross section depends on:
● the range
● the base attenuation
● the individual object attenuation
● the R&S AREG100A antenna gain
● the size of the air gap
The RCS does not represent the physical size of an object but is rather a virtual
parameter. Multiply it by the power density of the radar signal at the location of the
object, to get the signal power reflected back to the radar sensor. See "Radar cross
section (RCS)" on page 52.

The radio cross section can be displayed in different units.

See "RCS Unit" on page 69.

Remote command: 
[:SOURce<hw>]:AREGenerator:OBJect<ch>:RCS? on page 271

Objects Settings
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5.5  Base Attenuation Settings

Access:

► Select "Radar Objects" > "Configuration" > "Base Attenuation".

Settings

Base Attenuation...........................................................................................................68
Low Sensitivity.............................................................................................................. 68

Base Attenuation
Defines the attenuation affecting all radar targets.

The total attenuation per object is calculated as the sum of the base attenuation and
the individual attenuation for each radar object. This attenuation and the range are
used to calculate the radar cross section (RCS).

Positive values result in an attenuation; negative values - in a gain.

Remote command: 
[:SOURce<hw>]:AREGenerator:RADar:BASE:ATTenuation on page 272

Low Sensitivity
Defines if low sensitivity is used or not.

"On" If low sensitivity is enabled, the R&S AREG100A can process higher
signal power without signal saturation.
Signal linearity is increased, but signal noise can as well be
increased.

"Off" If disabled, signal noise is reduced but signal linearity decreases.
Disable the low sensitivity option, if the radar under test (RUT) has
low output power or is placed at large distance (air gap) from the
R&S AREG100A.

Remote command: 
[:SOURce<hw>]:AREGenerator:RADar:LSENsitivity on page 274

Base Attenuation Settings
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5.6  Units Settings

Access:

► Select "Radar Objects" > "Configuration" > "Units"

You can change the units for range, speed and RCS.

Settings

Range Unit.................................................................................................................... 69
Doppler Format............................................................................................................. 69
Speed Unit.................................................................................................................... 69
RCS Unit....................................................................................................................... 69

Range Unit
Defines the range unit.

Remote command: 
[:SOURce<hw>]:AREGenerator:UNITs:RANGe on page 275

Doppler Format
Sets whether the Doppler is defined as Doppler Speed or as Doppler Shift.

The parameter displayed in "Objects" dialog depend on this selection.

Remote command: 
[:SOURce<hw>]:AREGenerator:UNITs:DOPPler on page 275

Speed Unit
Defines the speed unit.

Remote command: 
[:SOURce<hw>]:AREGenerator:UNITs:SPEed on page 276

RCS Unit
Defines the unit of the radar cross section.

Possible units:

"sm" Defines the radar cross section in m2 (square meters).

"dBsm" Specifies the radar cross section in dB relative to 1 square meter.

Units Settings
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Remote command: 
[:SOURce<hw>]:AREGenerator:UNITs:RCS on page 275

5.7  AREG Configuration

Access:

► On the home screen, tap the "AREG Configuration" tile.

With the provided settings, you can configure a customer-specific antenna gain for
the transmitting and receiving antenna as well as the air gap between the DUT and
the R&S AREG100A.
In the "AREG Configuration" dialog, you can also define the source of the refer-
ence frequency.

Use Custom Antenna.................................................................................................... 71
AREG Antenna Gain TX............................................................................................... 71
AREG Antenna Gain RX............................................................................................... 71
Air Gap from DUT to AREG.......................................................................................... 71
Enable Doppler Bypass.................................................................................................72
Source...........................................................................................................................72
Show Connector............................................................................................................72
Sensor...........................................................................................................................73
EIRP..............................................................................................................................73

AREG Configuration
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Use Custom Antenna
By default, the R&S AREG100A is delivered with mounted antennas but you can
detach them and mount your own antennas.

You can, for example, use higher gain antennas or for mechanical reasons, use anten-
nas with a connected waveguide extension tube.

Set "Use Custom Antenna > On" to identify that a custom antenna or antenna assem-
bly is connected.

Whenever you use a custom antenna or antenna assemblies, set the total antenna
gain of the transmitting and receiving antennas so that R&S AREG100A calculates the
EIRP and RCS correctly.

Calculate the total antenna gain as follows:

Total_antenna_gain = Antenna_gain - Total_attenuation_waveguide

Remote command: 
[:SOURce<hw>]:AREGenerator:RADar:ANTenna:CUSTom[:STATe]
on page 272

AREG Antenna Gain TX
Displays the antenna gain of transmitting antenna.

If Use Custom Antenna > "On", the antenna gain can be set to a customer-specific
value.

Remote command: 
[:SOURce<hw>]:AREGenerator:RADar:ANTenna:REG:GAIN:TX on page 272

AREG Antenna Gain RX
Displays the antenna gain of receiving antenna.

If Use Custom Antenna > "On" is activated, the antenna gain can be set to a customer-
specific value.

Remote command: 
[:SOURce<hw>]:AREGenerator:RADar:ANTenna:REG:GAIN:RX on page 272

Air Gap from DUT to AREG
Specifies the air gap between DUT and R&S AREG100A.

Note: Changing the air gap does not change the distance of the simulated object. The
distance shown in the R&S AREG100A display is the sum of the internal distance in
the instrument, which is fixed and the air gap setting.
The air gap setting is pre-set to the value which was set during ordering the
R&S AREG100A.
If you want to change the air gap in your measurement setup, for example if a larger
anechoic chamber is used, adjust the "Air Gap from DUT to AREG" value. Select value
for that the R&S AREG100A can correctly calculate the measured EIRP values, effec-
tive distances, and RCS values of your simulated targets.
Presetting the instrument (e.g. [Preset]), does not change the air gap value.
Perform "Factory Preset" to reset the air gap value to it factory value, i.e. the value at
time of ordering.

AREG Configuration
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Remote command: 
[:SOURce<hw>]:AREGenerator:RADar:OTA:OFFSet on page 274

Enable Doppler Bypass
Option: R&S AREG-B60.

In R&S AREG100A, Doppler effects are simulated by mixing the local oscillator fre-
quency fLO with the selected Doppler frequency fD (see Figure 4-1). Naturally, mixers
introduce intermodulation products.

If the option R&S AREG-B60 is installed, but the simulation of Doppler effects is not
required in the current setup, set "Enable Doppler Bypass" = "On". Bypassing the Dop-
pler stage ensures higher signal quality.

If you need to deactivate the Doppler effects temporary in measurement setups with
"Doppler Speed ≠ 0", you can disable the simulation of Doppler effects in two ways:
● Use zero Doppler speed:

Set the "Doppler Speed/Doppler Shift = 0" and "Enable Doppler Bypass" = "Off".
This combination maintains the RCS values of the objects as they ware with "Dop-
pler Speed ≠ 0". The generation of intermodulation products and thus the simula-
tion of ghost targets is not suppressed.

● Bypass the Doppler path: "Enable Doppler Bypass" = "On".
The "Doppler Speed/Doppler Shift" values are ignored. The RCS values change
but the signal quality increases.

Remote command: 
[:SOURce<hw>]:AREGenerator:RADar:DBYPass[:STATe] on page 274

Source
The R&S AREG100A is equipped with an internal reference oscillator that generates a
reference frequency of 10 MHz. It is used as internal reference source for the synthe-
sizer.

Alternatively, you can apply an external reference signal.

Regardless of the used reference source (internal or external), the R&S AREG100A
always outputs the reference frequency at the output connector. You can use it, for
example to synchronize further connected instruments.

"Internal" Uses the internal reference oscillator

"External" Uses an external reference frequency signal.

If "Source = External" is selected, but no 10 MHz external reference
signal is provided at the "Ref In" connector:
● No reference signal is output at the "Ref Out" connector.
● The error message "Frontend 100 MHz PLL not locked" is dis-

played.
See also Chapter 11.3, "Device-Specific Error Messages",
on page 296.

Remote command: 
[:SOURce]:ROSCillator:SOURce on page 268

Show Connector
Show the connector location on the front/rear panel of the instrument.

AREG Configuration
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Sensor
Indicates if a power sensor is connected and which power sensor is used to measure
the EIRP value.

You can connect more than one power sensors to the R&S AREG100A, for example to
the Sensor or to the USB connectors. However, only the power sensor whose RF con-
nector is connected to the "Rx Power" output of the frontend can measure the EIRP
power.

See also: Chapter 4.3, "Measuring EIRP of Radar Sensor", on page 55.

Remote command: 
[:SOURce<hw>]:AREGenerator:RADar:EIRP:SENSor on page 273

EIRP
If power sensor is connectd to the frontend and selected for measuring the EIRP, this
parameter displays the measured EIRP value of the radar sensor.

See "How to measure the EIRP with a power sensor" on page 56.

Remote command: 
[:SOURce<hw>]:AREGenerator:RADar:EIRP? on page 273

5.8  Power Sensors

Access: On the home screen, observe the "Power Sensors" tile.

For details, see Chapter 6, "Using Power Sensors", on page 74.

Sensor...........................................................................................................................73
EIRP..............................................................................................................................73

Sensor
Indicates if a power sensor is connected and which power sensor is used to measure
the EIRP value.

You can connect more than one power sensors to the R&S AREG100A, for example to
the Sensor or to the USB connectors. However, only the power sensor whose RF con-
nector is connected to the "Rx Power" output of the frontend can measure the EIRP
power.

See also: Chapter 4.3, "Measuring EIRP of Radar Sensor", on page 55.

Remote command: 
[:SOURce<hw>]:AREGenerator:RADar:EIRP:SENSor on page 273

EIRP
If power sensor is connectd to the frontend and selected for measuring the EIRP, this
parameter displays the measured EIRP value of the radar sensor.

See "How to measure the EIRP with a power sensor" on page 56.

Remote command: 
[:SOURce<hw>]:AREGenerator:RADar:EIRP? on page 273

Power Sensors
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6  Using Power Sensors
The R&S AREG100A works with most of the R&S NRP power sensors and thus sup-
ports various application tasks. Using power sensors, you can for example determine
attenuation characteristics of downstream equipment or cables. You can use the mea-
sured values to compensate the losses with internal control functions or with an exter-
nal control circuit in real time.

R&S NRP sensors are highly accurate standalone measuring devices, suitable for a
wide range of applications. The devices communicate directly with the signal genera-
tor, calculate the average or peak power internally, include S-parameter correction and
return the measurement results to the generator.

The R&S AREG100A works with any sensor of the R&S NRP series and can perform
up to four power measurements simultaneously.

Check the firmware version of the R&S NRP sensors regularly. Update the firmware, if
necessary.
For updates, see the Rohde & Schwarz website http://www.rohde-schwarz.com in sec-
tion "Power Meters & Voltmeters".

When working with power sensors you can:
● Observe the supported connectors, connection options and the required accesso-

ries.
● Shows all R&S NRP sensors connected to the instrument, or in the LAN.
● measure and monior the RF output power or a user-defined signal source.

● Connecting R&S NRP Power Sensors to the R&S AREG100A..............................74
● NRP Sensor Mapping............................................................................................. 75
● NRP Power Viewer................................................................................................. 78

6.1  Connecting R&S NRP Power Sensors to the
R&S AREG100A

R&S NRP sensors are connected to the R&S AREG100A in the following ways:
● Connection to the Sensor connector

– R&S NRP-ZK6 (six-pole interface cable) for R&S NRPxx power sensors
– No additional cable for R&S NRP-Zxx power sensors (cable is fixed on the sen-

sor)
● Connection to the USB connector

Requires the following cables, depending on the used sensor type:
– R&S NRP-ZKU (USB interface cable) for R&S NRPxx power sensors
– R&S NRP-Z3 or R&S NRP-Z4 (USB adapter cables) for sensors of the R&S

NRP-Zxx family

Connecting R&S NRP Power Sensors to the R&S AREG100A
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● Connection via R&S NRP-Z5 sensor hub
The R&S NRP-Z5 USB sensor hub (high-speed USB 2.0) can host up to 4 R&S
NRP sensors. It provides simultaneous internal and external triggering of all con-
nected sensors.
Requires additional cables, depending on the used output connector of the hub.
Choose one of the following:
– Short extension cable R&S NRP-Z2 for connection to the sensor connector.

This six-pole connection provides the external trigger capability.
– Standard USB cable (USB type A to USB type B) to any USB type A connector

of the R&S AREG100A. This connection does not support external triggering.
● Connection via USB hub with external power supply unit

Requires the following cables, depending on the used sensor type:
– R&S NRP-ZKU (USB interface cable) for R&S NRPxx power sensors
– R&S NRP-Z3 or R&S NRP-Z4 (USB adapter cables) for sensors of the R&S

NRP-Zxx family
● Connection via LAN for R&S NRPxxxSN power sensors

Using the Ethernet interface requires PoE (Power over Ethernet) to provide the
electrical power.
To establish the connection, you can use:
– A PoE Ethernet switch, e.g. R&S NRP-ZAP1 and an RJ-45 Ethernet cable.
– A PoE injector and an RJ-45 Ethernet cable.

Detection and mapping

The R&S AREG100A automatically detects a connected R&S NRP power sensor and
indicates it in the "NRP Power Viewer" and "NRP Sensor Mapping" dialogs.

By default, detected sensors are indicated as follows:
● A sensor connected at the Sensor socket is assigned as "Sensor 1".

If no sensor is connected to this socket, channel 1 remains unassigned.
● Sensors 2 to 4 are assigned to the sensors at the USB connectors, according to

their sequence of connection.

On connection, the R&S AREG100A immediately starts the measurement of a detec-
ted R&S NRP power sensor. If you perform an instrument preset ([Preset] key or
*RST), the R&S AREG100A stops the measurements. The connection and the map-
ping of the power sensors remain, the measurements must be restarted.

6.2  NRP Sensor Mapping

The "NRP Sensor Mapping" lists all R&S NRP sensors detected by the instrument.

Any R&S NRP sensor that supports the USB legacy protocol and is connected to one
of the USB interfaces, is detected automatically and added to the list. Vice versa, the
R&S AREG100A removes a sensor from the list, when it is disconnected.

NRP Sensor Mapping
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R&S NRP sensors that are connected via LAN or use the USBTMC protocol are not
automatically detected. They are detected by the scan search function.

Access:

► Select "Power Sensors" > "NRP Sensor Mapping".

The dialog lists all detected R&S NRP sensors for selection and mapping. You can
also browse the network for sensors.
The detected sensors are characterized by the used protocol and the correspond-
ing connector icon. In the "Mapping" column, you can assign the sensor to one of
the available sensor channels. The list can contain several entries but the
R&S AREG100A can only use up to four sensors simultaneously.
The remote commands required to define these settings are described in Chap-
ter 10.15, "SENSe, READ, INITiate and SLISt Subsystems", on page 276.

Settings

Sensor Mapping List .................................................................................................... 76
Scan ............................................................................................................................. 77
Clear..............................................................................................................................77
Add Sensor/Hide 'Add Sensor'......................................................................................77
Add Sensor settings...................................................................................................... 77

└ Add LAN Sensor settings................................................................................77
└ Add USB Sensor settings .............................................................................. 77

Sensor Mapping List
Displays a list of all sensor entries with information on the sensor name, the used pro-
tocol, the connector and the assigned mapping.

If a sensor is connected via LAN or uses the USBTMC protocol, its protocol is indica-
ted as "Visa".

NRP Sensor Mapping
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Remote command: 
:SLISt[:LIST]? on page 279
:SLISt:ELEMent<ch>:MAPPing on page 281
:SLISt:SENSor:MAP on page 281

Scan
Scans the network and the USB connections for sensors connected using the VISA
communication protocol, i.e. sensors that are addressed over LAN or USBTMC.

The instrument detects sensors communicating over the USB legacy protocol automat-
ically.

Remote command: 
:SLISt:SCAN[:STATe] on page 279

Clear
Removes the selected sensor from the sensor mapping list.

Remote command: 
:SLISt:CLEar:LAN on page 280
:SLISt:CLEar:USB on page 280
:SLISt:CLEar[:ALL] on page 281

Add Sensor/Hide 'Add Sensor'
Shows or hides the "Add Sensor" settings.

Add Sensor settings
Configures settings to add sensors connected to the R&S AREG100A via USB or LAN.

Add LAN Sensor settings ← Add Sensor settings
Configures settings to add sensors connected to the R&S AREG100A via LAN.

"IP Address or Host Name"
Displays the host name or the IP address of a R&S NRP power sen-
sor.
If the R&S AREG100A does not detect a connected R&S NRP sen-
sor, you can assign the address information manually.

"Add LAN Sensor"
Adds a detected R&S NRP sensor connected in the LAN to the list of
sensors, including its device ID or name and its serial number.

Remote command: 
:SLISt:SCAN:LSENsor on page 279

Add USB Sensor settings ← Add Sensor settings
Configures settings to add sensors connected to the R&S AREG100A via USB.

"Device ID or Sensor Name"
Displays the device identifier or the name of the R&S NRP power
sensor.
If the R&S AREG100A does not detect a connected R&S NRP sen-
sor, you can assign the ID or name manually.

NRP Sensor Mapping
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"Serial Number"
Displays the serial number of the R&S NRP power sensor.
If the R&S AREG100A does not detect a connected R&S NRPsensor,
you can assign the serial number manually.

"Add USBTMC Sensor"
Adds a detected R&S NRP sensor connected at the USB interface to
the list of sensors, including its device ID or name and its serial num-
ber.

Remote command: 
:SLISt:SCAN:USENsor on page 280

6.3  NRP Power Viewer

The R&S AREG100A features the power viewer function for measuring or monitoring
signals with R&S NRP power sensors.

6.3.1  About

The R&S AREG100A can perform up to four power measurements simultaneously.

Depending on the signal characteristic (CW, AM, pulsed, etc.) or the parameter to be
measured (average, peak, etc...) a suitable R&S power sensor must be used.

About the measuring principle, averaging filter, filter length, and achieving stable
results

A sensor measures the average or peak RF power of the source continuously. The
measurement results are displayed in the "NRP Power Viewer" dialog.

The power viewer function uses averaging filters for getting a stable readout.

Measurement results could be interfered for instance by to much noise in your setup,
by a bad supression of harmonics or non harmonics or when you reach the sensitivity
level of your power sensor.

Measurements are continuously repeated in a predefined time window. The measure-
ment result is obtained by averaging the measured values for the last 2N time win-
dows. This approach is referred as a two-step averaging process.

The factor of 2 in the formula arises because the output signals from the microwave
detector are chopped at the same rate as the time windows to suppress low-frequency
noise. An independent measured value can only be obtained from two consecutive val-
ues.

The variable N in the formula indicates the filter length. The filter length then directly
influences the measurement time. The filter length can be selected automatically or it
can be manually set to a fixed value.

NRP Power Viewer
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Depending on the R&S NRP power sensor type, the manual setting of the filter length
varies in resolution:
● Resolution = 1 for the R&S NRPxx power sensor family
● Resolution = 2n for R&S NRP-Zxx power sensors, with n = 1 to 16

Follow the following general recommendation to find out the optimum filter length:
● Always start a measurement in auto mode ("Filter > Auto").

Check if the measurement results are sufficient.
● If the power is not constant, select the filter length manually ("Filter > User").

Trigger the "Auto Once" function to search for the optimum filter length for the cur-
rent measurement conditions.
The estimated value is indicated as filter length.

● If the target measurement accuracy value is known, select "Filter > Fixed Noise".
The averaging factor is selected automatically and so that the sensor's intrinsic
noise (two standard deviations) does not exceed the specified noise content.

● Different sensor types achieve the same filtering result with different filter and time
window lengths.
The time window length depends on the sensor type:
– For most sensors, it is fixed to 20 ms.
– For the R&S NRP-Z81 sensor, it is 10 μs.

The R&S NRP-Z81 uses filter length that is 1000 times larger than the filter
length for other sensors.

About zeroing

Activates the auto zero function.

Zeroing calibrates the external power sensor by adjusting its reading at zero signal
power. For this purpose, the RF power source must be switched off or disconnected
from the sensor. If a Rohde & Schwarz power sensor receives an input power during
the zeroing process, it aborts zeroing and generates an error message. Zeroing takes
a few seconds, depending on the sensor model. Refer to the documentation of your
power sensor for more information.

Tips for zeroing

When to perform zeroing:
● During warm up after switching on or connecting the instrument
● After a substantial change of the ambient temperature
● After fastening the power sensor module to an RF connector at high temperature
● After several hours of operation
● When low-power signals are to be measured, e.g. less than 10 dB above the lower

measurement limit.
● Switch off the RF power source for zeroing, but do not disconnect it from the power

sensor. This proceeding keeps the thermal equilibrium, and the zeroing process
also compensates the noise that superimposes the measured signal (e.g. from a
broadband amplifier).

NRP Power Viewer
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Related settings and functions

● Measurements-related settings, like results, filter, filter length:
● Software version of the connected power sensor:

:SENSe<ch>[:POWer]:TYPE? on page 289
● Acquisition of level correction data:

Additional information

See Rohde & Schwarz website http://www.rohde-schwarz.com in section "Power
Meters & Voltmeters" for:
● R&S NRP power sensor manual.
● Information on the R&S NRP-Z5 sensor hub and the available accessories.
● Sensor software updates.

6.3.2  NRP Power Viewer Settings

Access:

► Select "Power Sensors" > "NRP Power Viewer".

NRP Power Viewer
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The "Overview" tab shows the list of detected sensors, and provides a separate tab
per sensor.

A sensor tab contains all parameters for configuring the sensor settings, like aver-
age or peak display, reference source, filter and level offset.
The remote commands required to define these settings are described in Chap-
ter 10.15, "SENSe, READ, INITiate and SLISt Subsystems", on page 276, includ-
ing the triggering of the measurement and the retrieval of measurement results.

Settings:

Sensor type and serial number .................................................................................... 82
Level (Peak) / Level (Average) .....................................................................................82
Sensor Mapping............................................................................................................ 82
Sensor Settings.............................................................................................................82

└ State ...............................................................................................................82
└ Zero ................................................................................................................82
└ Use Frequency Of...........................................................................................83
└ Frequency ......................................................................................................83
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└ Level Offset State,Level Offset....................................................................... 83
└ Filter................................................................................................................83
└ Filter Length....................................................................................................84
└ Auto Once.......................................................................................................84
└ Noise/Signal Ratio.......................................................................................... 84
└ Timeout........................................................................................................... 84
└ Default Aperture Time.....................................................................................84
└ Aperture Time................................................................................................. 84
└ S-Parameter ...................................................................................................85
└ Enable Logging...............................................................................................85

Sensor type and serial number
Indicates the type and the serial number of the selected R&S NRP power sensor, and
the channel the sensor is assigned to.

The displayed Level (Peak) / Level (Average) values correspond to the particular sen-
sor.

Remote command: 
:SENSe<ch>[:POWer]:TYPE? on page 289
:SENSe<ch>[:POWer]:SNUMber? on page 288

Level (Peak) / Level (Average)
Indicates the measured peak or average level value.

You can also change the unit for the results display: Watt, dBm or dBμV.

Note: Peak level measurements are provided if the power sensor supports this feature.

Remote command: 
:READ<ch>[:POWer]? on page 282
:SENSe<ch>:UNIT[:POWer] on page 282

Sensor Mapping
Accesses the NRP Sensor Mapping dialog.

Sensor Settings
One tab per sensor provides the corresponding setting parameters.

State ← Sensor Settings
Activates level measurement.

Remote command: 
:INITiate<hw>[:POWer]:CONTinuous on page 281
To query the availability of a sensor at a given connector, use the command :
SENSe<ch>[:POWer]:STATus[:DEVice]? on page 289.

Zero ← Sensor Settings
Activates the auto zeroing.

For details, see "About zeroing" on page 79.

Remote command: 
:SENSe<ch>[:POWer]:ZERO on page 289

NRP Power Viewer
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Use Frequency Of ← Sensor Settings
Selects the source for measurement.

"RF" The R&S AREG100A transfers the RF frequency and level settings to
the R&S power sensor automatically. Thus you achieve power read-
ings of high accuracy, irrespective from the connected sensor type.

"User" Sets a user defined frequency.

Example: 
If you have a frequency converting device between the generator and
the DUT. If the frequency converter doubles the frequency, you can
set twice the frequency in the R&S AREG100A. The R&S power sen-
sor considers this RF frequency setting.

Set the parameter Frequency to the measurement's frequency.

Remote command: 
:SENSe<ch>[:POWer]:SOURce on page 288

Frequency ← Sensor Settings
Defines the frequency value if "Source > User" is used.

Remote command: 
:SENSe<ch>[:POWer]:FREQuency on page 287

Level Offset State,Level Offset ← Sensor Settings
Activates and defines a level offset which is considered in the power meassurement
result. The level offset value is always expressed in dB, irrespective of the display of
the measurement result.

This function allows you to consider, for example, an attenuator in the signal path.

Remote command: 
:SENSe<ch>[:POWer]:OFFSet on page 288
:SENSe<ch>[:POWer]:OFFSet:STATe on page 288

Filter ← Sensor Settings
Selects the way the length of the used filter is defined.

See also "About the measuring principle, averaging filter, filter length, and achieving
stable results" on page 78.

"Auto" Selects the filter length automatically and adjusts it to the measured
value. The value is indicated with the parameter Filter Length.
When high output power is applied, the filter length and therefore the
measurement time can be short.
When low output power is applied, the filter length and therefore the
measurement time is increased which reduces the considered noise
content in your measurement.

"User" The filter length is defined manually, with the parameter Filter Length.
As the filter length works as a multiplier for the time window, constant
filter length results in a constant measurement time.
Values 1 and 2N are allowed.

NRP Power Viewer
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"Fixed Noise" The averaging factor is taken automatically in accordance to the
value Noise/Signal Ratio. Thus, the sensor's intrinsic noise (2 stan-
dard deviations) does not exceed the specified noise content.
To avoid long measurement times when the power is too low, set a
Timeout.
Timeout is the maximum acceptable measurement time which limits
the averaging factor and therefore leads to a more unstable readout.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:TYPE on page 286

Filter Length ← Sensor Settings
Sets or indicates the filter length, depending on the selected filter mode.
● "Filter > Auto" indicates the automatically adjusted filter length.
● "Filter > User" enables you to set the filter length manually.
● "Filter > Fixed Noise" hides the setting parameter.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO? on page 284
:SENSe<ch>[:POWer]:FILTer:LENGth[:USER] on page 285

Auto Once ← Sensor Settings
Searches the optimum filter length for the current measurement conditions. The result
is indicated with the parameter Filter Length.

See also "About the measuring principle, averaging filter, filter length, and achieving
stable results" on page 78.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:SONCe on page 286

Noise/Signal Ratio ← Sensor Settings
For Filter > Fixed Noise, sets the noise content.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:NSRatio on page 285

Timeout ← Sensor Settings
For "Filter > Fixed Noise", sets a time limit for the averaging process.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe on page 285

Default Aperture Time ← Sensor Settings
The sensor default setting is sufficient. Disable this parameter to specify a user-defined
aperture time per sensor, if, for example, the readings vary.

To obtain stable readings, set the Aperture Time exactly to one modulation period.

Remote command: 
:SENSe<ch>[:POWer]:APERture:DEFault:STATe on page 283

Aperture Time ← Sensor Settings
If "Use Default Aperture Time > Off", defines the acquisition time per sensor.

NRP Power Viewer
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For example, to obtain a sufficient low average value, set the aperture time exactly to
one modulation period.

Remote command: 
:SENSe<ch>[:POWer]:APERture:TIMe on page 283

S-Parameter ← Sensor Settings
S-Parameter correction is used to mathematically shift the reference plane to the DUT
by considering the S-parameters for any components connected upstream of the sen-
sor.

The S-Parameter table can be changed with the S-Parameters tool, provided as part of
the free R&S NRP Toolkit software. For more information, refer to the manual of the
connected R&S NRP power sensor.

Remote command: 
:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe on page 284
:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST? on page 284
:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect on page 283

Enable Logging ← Sensor Settings
Activates recording of R&S NRP power sensor readings in a log file.

There is 1 log file per sensor. The log files are created automatically and filled in con-
tinuously. They are text files with predefined filename SensLog<n>.txt, where <n>
indicates the connected sensor. Log files are stored on the internal memory, in the
directory /var/user/SensorLogging.

Each log file contains the measured value (2 readings when you work with peak sen-
sors), the sensor type, and the measurement time (timestamp). Logged data is not
overwritten. When a new measurement is started, the collected logging data is appen-
ded in the log file.

Check the used disc space regularly and remove log files to maintain storage capacity.

Note: The logging function is intended for measurements with long time intervals. It is
suitable source for data reconstructions if the connection to the sensor was interrupted.

Remote command: 
:SENSe<ch>[:POWer]:LOGGing:STATe on page 287

NRP Power Viewer
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7  File and Data Management
The R&S AREG100A uses files to save all instrument data. The instrument allows you
to store and to load instrument settings, and to import and to export user data for pro-
cessing in another instrument or later. Finally, you can create a screenshot of the cur-
rent settings displayed on the screen and save it as a file.

This section focuses on the functions provided for managing of user data files and cov-
ers the topics listed below.

For information on the related remote control commands, refer to Chapter 10.11,
"MMEMory Subsystem", on page 233.

For information on how to save the displayed setting in a file, refer to Chapter 7.8,
"Creating Screenshots of Current Settings", on page 108.

● About the File System.............................................................................................86
● Restoring the (Default) Instrument Configuration....................................................88
● Protecting Data....................................................................................................... 92
● Saving and Recalling Instrument Settings.............................................................. 93
● Exporting and Importing Remote Command Lists.................................................. 97
● Using the File Manager...........................................................................................97
● How to Transfer Files from and to the Instrument.................................................102
● Creating Screenshots of Current Settings.............................................................108

7.1  About the File System

Depending on the contained information, two file groups can be distinguished: system
and user files.

Due to security reasons, system files and the system directory are protected and there-
fore not accessible.
The scope of this section is only the files with user data.

This section is an overview of the R&S AREG100A file system and covers the following
topics:
● "Types of user data" on page 87
● "File storage location" on page 87
● "File handling" on page 87
● "File naming conventions" on page 88
● "File contents" on page 88

About the File System



File and Data ManagementR&S®AREG100A

87User Manual 1178.7417.02 ─ 06

Types of user data

Depending on the content, the user data can be roughly divided into the following
data types:
● Settings, e.g. the current instrument settings, can be saved and loaded later or

used in other instrument of the same kind.
See Chapter 7.4, "Saving and Recalling Instrument Settings", on page 93

● SCPI scripts, a series of commands that can be run to perform a task.
See Chapter 7.5, "Exporting and Importing Remote Command Lists", on page 97

Depending on the data storage method, user data can be:
● Persistent, i.e. user files that are recorded on the data storage.

Data is preserved when instrument is powered off and can be accessed and modi-
fied subsequently.

● Temporary, i.e. volatile data that the instrument retains while it is powered on.
Volatile data is immediately lost when the R&S AREG100A is switched off.

File storage location

Without any additional measures, the R&S AREG100A stores user files on the internal
memory or if connected, on a memory stick.

Both, the user directory /var/user/ on the internal memory or the /usb/ directory
on the memory stick, can be used to preserve user-defined data. Any directory struc-
ture can be created.

The /var/volatile directory serves as a RAM drive and can be used to protect
sensitive information. The data is available temporarily.

Default storage location

The R&S AREG100A stores user data in the user directory.

In the file system, user directory is always indicated as /var/user/.

In manual control, you access this directory via the "File Manager", see Chapter 7.6,
"Using the File Manager", on page 97. In remote control, you can query it with the
command :SYSTem:MMEMory:PATH:USER?.

To query and change the default directory used for mass storage, use the command :
MMEMory:CDIRectory.

File handling

To access files and the file system of the instrument or to use the general file manage-
ment functions such as copying and moving data, use the standard "File Manager" dia-
log.

See Chapter 7.6, "Using the File Manager", on page 97.

To transfer files from and to the instruments or to exchange files, use one of the follow-
ing alternatives:
● Connect a memory stick to one of the USB interfaces.

About the File System
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The instrument recognizes automatically a connected memory stick and assigns
the /usb/ drive to it.

● Connect the instrument to a LAN.
An instrument connected to a LAN supports two standard file transfer methods
from a remote client:
– FTP (file transfer protocol)
– File sharing according to the SAMBA/SMB (server message block) protocol.

Both file transfer methods access the folder /user, that is the /var/user/ folder
on the instrument.
For step-by-step description, see Chapter 7.7, "How to Transfer Files from and to
the Instrument", on page 102.

● Map a network folder or a computer to an instrument connected to a LAN.
A mapped network folder is indicated as /shares/<"Local Folder">.
For step-by-step description, see Chapter 7.6.4, "How to Map a Network Folder",
on page 101.

File naming conventions

To enable files to be used in different file systems, consider the following file naming
conventions:
● The filename can be of any length and is case-sensitive, i.e it is distinguished

between uppercase and lowercase letters.
● All letters and numbers are permitted (numbers are, however, not permitted at the

beginning of the filename).
● Avoid using special characters.
● Do not use slashes "\" and "/". These symbols are used in file paths.
● Avoid using the following filenames: CLOCK$, CON, COM1 to COM4,

LPT1 to LPT3, NUL or PRN
They are reserved by the operating system.

File contents

To maintain the file size and to accelerate the loading and processing times, not all
instrument settings but rather the settings in state different than the preset one are
stored.

Network settings and remote settings cannot be saved and restored.

7.2  Restoring the (Default) Instrument Configuration

The R&S AREG100A has various options to set default settings. You can preset the
R&S AREG100A to an initial state at any time as a known starting point for configura-
tions. It is often useful as a first step in troubleshooting when unusual results arise.

Restoring the (Default) Instrument Configuration
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Overview of the characteristics of the preset functions

Select the preset option that most fits to your particular application:

● [Preset]
It is the most frequently used function.
A Preset executes a defined instrument setup to provide an initial instrument state
as a basis for a new configuration. It resets all parameters and switching states,
including also the states of inactive operating modes.
Network, remote access or system settings are retained.

► To execute a preset, press the [Preset] key at the front panel.

● "Set to Default"
Set To Default relates to individual dialogs or tabs and resets the associated set-
tings of the corresponding dialog. All other settings are retained.

► To reset the grouped settings, click "Set To Default".

● "Preset this parameter"
Sets a single parameter to its default value.

► To reset an individual parameter: Open its context-sensitive menu and select "Pre-
set this parameter...".

● "Factory Preset"
A factory preset is the most profound preset function that resets almost all instru-
ment settings, including reference oscillator, network and remote access settings.
Retained are the following settings:
– Security, password, and settings protected by these passwords
– User-defined data, like setups or data lists
– Settings that relate to an integration of the instrument in a measurement setup.

► To restore the factory defaults, select System Config > Setup > Settings > Factory
Preset.

Note: Perform a "Factory Preset" only if it is necessary. After a "Factory Preset",
the network connection to the instrument no longer exists.

Restoring the (Default) Instrument Configuration
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Presetting the instrument to a user-defined instrument state

The reset functions set the parameters and operating modes to default values prede-
fined by the factory. Alternatively to these default settings, you can:

● Define user-specific recall settings to be restored after a preset
(see Chapter 7.2.3, "How to Recall User Settings Automatically after Preset",
on page 91)

● Store and reload user-defined instrument states
(see Chapter 7.4.2, "How to Save and Recall Instrument Settings", on page 96)

Mark / Do not mark parameters changed from preset

To survey the current state of the settings concerning default values, the
R&S AREG100A offers a feature that visually identifies deviations from the default val-
ues.

For more information, see Chapter 7.2.2, "How to Identify Parameters Which Are Not in
a Preset State", on page 91.

7.2.1  Preset, Set to Default and Factory Preset Settings

Preset............................................................................................................................90
Set To Default................................................................................................................90
Preset this Parameter................................................................................................... 90
Execute Factory Preset.................................................................................................91

Preset
Resets all parameters and switching states, and closes all opened dialogs.

Note:
In contrast to the [Preset] key, the SCPI commands *RST and :SYSTem:PRESet do
not close open dialogs in the GUI.
Consider also the following possibilities:
● You can define the settings that are restored when you preset the instrument

(see Chapter 7.2.3, "How to Recall User Settings Automatically after Preset",
on page 91)

● You can reset the instrument to the factory state
(see "Execute Factory Preset" on page 91)

See also Table 7-1 that contains the key parameters that are reset by the correspond-
ing preset functions.

Remote command: 
*RST on page 213

Set To Default
Resets the associated settings of the corresponding dialog or tab.

Preset this Parameter
Restores the default value of a single parameter.

Restoring the (Default) Instrument Configuration
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Execute Factory Preset
Resets the instrument to its factory settings.

Note: "Factory Preset" retains all security settings and does not delete any user files
like setups or user data.
See also Table 7-1 that contains the key parameters that are reset by the correspond-
ing preset functions.

Remote command: 
:SYSTem:FPReset on page 216

7.2.2  How to Identify Parameters Which Are Not in a Preset State

To recognize the current state of the settings related to their default values at the first
glance, enable a function that visually identifies parameters in states different than pre-
set.

To activate this display:

1. Open the context-sensitive menu (touch and hold the screen anywhere in the GUI
of the R&S AREG100A).

2. Select "Mark all parameters changed from preset".

If enabled, the corresponding settings are marked.

7.2.3  How to Recall User Settings Automatically after Preset

You can define the settings that are restored when you preset the instrument.

1. Configure the settings as required. Save them as described in Chapter 7.4.2, "How
to Save and Recall Instrument Settings", on page 96.

2. Save the settings as a file with the predefined filename UserPreset.savrcltxt.
Save this file in the directory /var/user/.

The filename UserPreset.savrcltxt and the directory /var/user/ are man-
datory.

Now when you press the [Preset] key or send the *RST command to the instru-
ment, the defined settings are restored.
An "Info" message appears and confirms, that a file with user-defined preset set-
ting is loaded.

Restoring the (Default) Instrument Configuration
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7.2.4  Reference

See Table 7-1 for an overview of the main generator settings that are affected by the
corresponding preset functions. While the regular [Preset] key primarily resets the sig-
nal relevant parameters of the instrument, the "Factory Preset" affects almost all instru-
ment settings.

For information on the default values of further parameters, refer to the description of
the corresponding remote commands.

Table 7-1: Key parameters affected by preset and factory preset

Parameter Preset value Preset Factory
Preset

RF frequency x x x

RF level (RF output) off x x

Reference frequency settings (reference oscillator) - - x

Network settings - - x

Hostname - - x

GPIB address - - x

Start/Stop display update - - x

Display and keyboard settings - - x

Password and settings protected by passwords (e.g. dis-
abled LAN or USB)

- - -

Security settings - - -

User files (setups2), data lists, etc.) - - -

Air Gap 0.8 m - x

● 2) UserPreset.savrcltxt is renamed as UserPresetInactive.savrcltxt;
an existing file with the same name is overwritten.

If the default values in the "Remote Access" dialog had been changed, a factory preset
via remote control (:SYSTem:FPReset) terminates the connection to the instrument.

Security settings are never reset.

Resets all parameters and switching states, and closes all opened dialogs.

7.3  Protecting Data

During operation, the R&S AREG100A saves user data permanently in the user direc-
tory, see "File storage location" on page 87.

Protecting Data
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To protect any classified data and to avoid saving any sensitive data on the
R&S AREG100A permanently, you have the following options:
● Activate the volatile mode. This mode redirects user data to the volatile memory.

The internal memory is write-protected.
Instead, you can redirect the user data to an external storage medium, as, e.g., a
USB stick.
See also:
– "Default storage location" on page 87
– "Volatile Mode" on page 134
– Chapter 7.7.4, "Using a USB Storage Device for File Transfer", on page 107

● Save user files temporarily in the /var/volatile directory, which remains
available only until the instrument is turned off.
You can access data in the volatile memory just as data that is saved permanently
in the /var/user/.
See also Chapter 7.6.3, "How to Display All Saved Files", on page 100.

7.4  Saving and Recalling Instrument Settings

Save/Recall the complete instrument settings

Two different methods are available for managing complete instrument settings:
● Immediate (quick) Save/Recall

A defined set of instrument settings are saved or recalled quickly in just one step,
without defining a filename or storage location. This function enables a fast switch-
ing between different instrument settings.

● Save/Recall in files with user-defined names
The defined set of instrument settings are stored to a definable storage location.
The file extension is *.savrcltxt.
Settings files created in this way are visible in the file system and accessible with
the supported methods for file handling.

In the general case, a recall process replaces the instruments settings with the saved
values. An exception is the frequency and level settings. During recall of the instrument
settings, it is possible to retain the current settings or to overwrite them with the stored
values.

7.4.1  Save/Recall Settings

To access the dialog for storing and loading the complete instrument settings

1. Select "System Config > Save/Recall".

2. Select "Operation Mode > Save or Recall" to access the corresponding settings.

The provided settings for both operations are similar and closely related.

Saving and Recalling Instrument Settings
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Settings:

Operation Mode............................................................................................................ 94
Directory, File List and Filename...................................................................................94
Recent files................................................................................................................... 95
Show SCPI List............................................................................................................. 95
SCPI List....................................................................................................................... 95
Save.............................................................................................................................. 95
Save Immediate x......................................................................................................... 95
Exclude Frequency....................................................................................................... 95
Recall............................................................................................................................ 95
Recall Immediate x........................................................................................................96
File Manager................................................................................................................. 96

Operation Mode
Accesses the settings for storing ("Save") and loading ("Recall") of the instrument set-
tings. Also, you can import SCPI-Files ("SCPI-Import") or export SCPI files ("SCPI-
Export").

See Chapter 7.5, "Exporting and Importing Remote Command Lists", on page 97.

Directory, File List and Filename
Note:
You access this generic standard function each time you perform one of the following:
● Save or load (settings) files
● Define a folder in that these files are saved
● Navigate through the file system.
The dialog name changes depending on the context. The provided functions are self-
explanatory and similar.

Saving and Recalling Instrument Settings
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Use the settings for example as follows:
● To navigate through the file system, use the directory tree.
● To perform standard file management functions, like create directories, move, copy,

delete files and/or directories, use the standard "File Manager" function (see Chap-
ter 7.6, "Using the File Manager", on page 97).

Remote command: 
To list all files in a directory:
:MMEMory:CDIRectory on page 238
:MMEMory:CATalog? on page 237

Recent files
Displays the files last used.

Show SCPI List
Opens the "SCPI List", which lists the current settings of the R&S AREG100A as SCPI
commands.

The R&S AREG100A provides this function for Operation Mode > SCPI-Export.

SCPI List
Contains a list of all SCPI commands corresponding to the current instrument settings.

See also "How to create a SCPI list with the current instrument settings in one step"
on page 195

Save
Saves the current instrument settings under the defined filename.

Remote command: 
:MMEMory:STORe:STATe on page 242

Save Immediate x
Stores the current instrument setting in one of the intermediate memories.

These instrument settings are retained until a different instrument setting is stored in
the intermediate memory. When the instrument is switched off, the contents of the
intermediate memories are retained.

Remote command: 
*SAV on page 213

Exclude Frequency
The current frequency is retained when a stored instrument setting is loaded.

Remote command: 
[:SOURce<hw>]:FREQuency[:CW|FIXed]:RCL on page 269

Recall
Restores the selected configuration.

During recall, the instrument considers all related settings, for example sweeps in
active state or lists. An error message indicates the settings which cannot be imple-
mented.

Saving and Recalling Instrument Settings
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Remote command: 
:MMEMory:LOAD:STATe on page 240

Recall Immediate x
Loads the selected configuration from one of the intermediate memories. A message
appears if no instrument configuration is stored in this memory.

Remote command: 
*RCL on page 213

File Manager
Accesses the "File Manager" dialog, see Chapter 7.6, "Using the File Manager",
on page 97.

7.4.2  How to Save and Recall Instrument Settings

Instrument settings can be saved to a file and loaded again later, so that you can
repeat the tests with the same settings.

To access and recall instrument setups quickly

► Assign the appropriate action to the [User] key.
See Chapter 8.2.4, "How to Assign Actions to the [User] Key", on page 122.

To save and recall instrument settings

1. Select "System Config > Save/Recall" > "Operation Mode > Save".

2. Select "Save Immediate 1".

The instrument saves its settings in the intermediate memory 1. The filename and
the storage location cannot be changed.

3. Adapt the instrument settings as required. Select "Save Immediate 2"

4. To restore the settings, select the "Operation Mode > Recall"

5. Select "Recall Immediate 1"

The instrument is restored to the previous state.

6. Select "Recall Immediate 2" to switch to the settings stored in the second file.

To save complete instrument settings

1. Select "System Config > Save/Recall" > "Operation Mode > Save".

2. In the file selection dialog, select a filename and storage location for the settings
file.

3. Select "Save".

A file with the defined name and path and the extension *.savrcltxt is created.

Saving and Recalling Instrument Settings
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To restore instrument's configuration

Save the configuration as described in "To save complete instrument settings"
on page 96.

1. To restore settings, select "System Config > Save/Recall" > "Operation Mode >
Recall".

2. To retain the current frequency and level settings, enable "Save/Recall > Exclude
Frequency/Level"

3. In the file selection dialog, select the filename and storage location of the settings
file.

The settings are restored, but the frequency and level settings are retained; you
can repeat the signal generation with the same settings.
See also Chapter 7.2.3, "How to Recall User Settings Automatically after Preset",
on page 91.

7.5  Exporting and Importing Remote Command Lists

To set specific instrument settings or perform tasks automatically, you can create
scripts or import scripts that contain the settings in the form of remote control com-
mand sequences.

The R&S AREG100A also offers a SCPI macro recorder with code generator that is
used to record manual settings and create an executable script, see Chapter 9.8.4,
"How to Record / Create SCPI Lists", on page 193.

Completed scripts are stored in files and possibly converted to different formats,
depending on the used language of the source code.

The R&S AREG100A supports the following commonly used languages:
● Plain SCPI: *.txt
● MATLAB: *.m
● NICVI: *.c
● Python: *.py
It is also possible to convert the SCPI command list to a user-specific language, see
Chapter 9.8.5, "How to Convert and Save SCPI Lists", on page 196.

7.6  Using the File Manager

The "File Manager" is a tool similar to a standard Windows Explorer. It helps you man-
age mass storage media and files stored on the R&S AREG100A.

You can perform the following tasks:
● Copying multiple files from disk to other media

See Chapter 7.7, "How to Transfer Files from and to the Instrument", on page 102

Using the File Manager
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● Copying files into another directory
See Cut, Copy&Paste and Delete

● Renaming and deleting files
● Creating directories

See Create New Directory
● Mapping shared network folders

See Chapter 7.6.4, "How to Map a Network Folder", on page 101
● Displaying saved files

See Chapter 7.6.3, "How to Display All Saved Files", on page 100

Access:

► Select "System Config > Save/Recall" > "File Manager".

Tip: Each "Save/Recall" dialog and each "File Select" dialog provides a quick
access to the "File Manger", i.e. whenever you select data lists or files with user
data.

The "File Manager" dialog provides all standard functions required for file manage-
ment. It displays the contents of the selected folder on the R&S AREG100A and
provides functions to rename, delete, copy, or move individual files.

7.6.1  File Manager Settings

Access:

► Select "System Config > Save/Recall" > "File Manager".

Settings:

Map Network Share...................................................................................................... 98
File Type........................................................................................................................98
Directory and Filename................................................................................................. 99
Cut, Copy&Paste and Delete........................................................................................ 99
Rename ........................................................................................................................99
Create New Directory....................................................................................................99

Map Network Share
Accesses the Map Network Share Settings dialog where you can map one or more
network folders.

See also Chapter 7.6.4, "How to Map a Network Folder", on page 101.

File Type
Selects the file type to be listed. If a file type with a specific file extension is selected,
only files with this extension are listed.

Using the File Manager
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Directory and Filename
Selects the directory in which the file to be deleted or copied is located. The dialog lists
all files in this directory. Selected files are highlighted. The path is indicated above the
directory tree.

Unlike the "Save/Recall" and "File Select" dialogs, the "File Manager" displays the full
filenames including extensions.

Remote command: 
:MMEMory:CDIRectory on page 238

Cut, Copy&Paste and Delete
Standard file management functions.

Before a file is deleted, you have to confirm the delete operation.

Remote command: 
:MMEMory:DELete on page 240
:MMEMory:COPY on page 238

Rename
Renames the selected file or directory.

Remote command: 
:MMEMory:MOVE on page 241

Create New Directory
Creates a folder and opens an edit dialog box to enter name and path (absolute or rel-
ative to the current directory) of the new folder.

Remote command: 
:MMEMory:MDIRectory on page 241

7.6.2  Map Network Share Settings

Access:

► Select "System Config > Save/Recall" > "File Manager > Map Network Share".

The "Map Network Share" dialog provides settings that are similar to the standard Win-
dows Explorer function "Map network drive". These settings help you to create up to 10
"shortcuts" to shared folders or computers in the network.

The dialog displays a list of current mapped network folders. The directory tree of the
"File Manager", "Save/Recall", and "File Select" dialogs indicate a mapped network
folder as /shares/<"Local Folder">.

See also Chapter 7.6.4, "How to Map a Network Folder", on page 101.

Settings:

Network Folder............................................................................................................100
Local Folder................................................................................................................ 100
User Name.................................................................................................................. 100

Using the File Manager



File and Data ManagementR&S®AREG100A

100User Manual 1178.7417.02 ─ 06

Password.................................................................................................................... 100
Reconnect at Startup.................................................................................................. 100
Connect.......................................................................................................................100
Change........................................................................................................................100
Disconnect.................................................................................................................. 100

Network Folder
Enter the path of the folder or computer, e.g. //<IP Address>/user or //<server
name>/user.

Local Folder
Enter a letter or an alias name to describe the folder.

In the directory tree, a mapped network folder is indicated as /shares/
<"Local Folder">.

User Name
Enter a user name of a user that has the permission to access the selected network
folder.

Password
Enter the password of the selected user.

Reconnect at Startup
Enables reconnecting every time you start up the instrument.

Connect
Triggers the instrument to prove the credential and to map (i.e. connect) the selected
network folder or computer to the instrument.

You can map up to 10 network folders.

Change
Applies the changes.

Disconnect
Disconnects the network drive.

7.6.3  How to Display All Saved Files

To display all files on the internal memory

1. Select "System Config > Save/Recall" > "File Manager".

2. Navigate to /var/user/.

To display all files on a connected USB flash drive

1. Select "System Config > Save/Recall" > "File Manager".

2. Navigate to /usb/.

Using the File Manager
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To display all files in the volatile memory

1. Select "System Config > Save/Recall" > "File Manager".

2. Navigate to /var/volatile/.

7.6.4  How to Map a Network Folder

Possibly you would like to transfer instrument or user settings to another
R&S AREG100A, distribute waveform files to several instruments or you have to
access frequently the same network drive. In these cases, on a R&S AREG100A con-
nected to a LAN you can create a shortcut to this network folder or this computer.

How to: see Chapter 9.6.3, "How To Connect to LAN", on page 174.

To map a network folder, proceed as follows:

1. On the computer or the network folder you want to map, enable remote access.
You can specify a list of users allowed for remote access.
The remote access settings depend on the operating system the remote computer
is using. For step-by-step instructions, refer to the documentation of the particular
operating system.

2. On the R&S AREG100A, enable file transfer via SMB (samba).

3. Select "System Config > Setup > Remote Access > Network".
Select:

a) "Address Mode > Auto (DHCP)"
b) Check that the "DNS Suffix" and "DNS Server" are correct.

4. In the "Save/Recall" dialog, select "File Manager > Map Network Share".

5. In the "Map Network Share" dialog, select:

a) In the "Network Folder" field, enter //<IP Address>/user or //
<Server Name>/user.

b) In the "Local Folder" field, enter an alias name, e.g. setups.
c) Enter the "User Name" and "Password" of a user with a remote access permis-

sion to the selected network folder.
d) If necessary, enable "Reconnect at Startup".
e) Select "Connect".

The selected network folder is mapped to your instrument. The list of mapped net-
work folders is updated.

6. Close the "Map Network Share" dialog.

The navigation tree in the "File Manager" dialog displays the mapped network
folder as /shares/Setups.

Using the File Manager
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If the connection does not succeed, consider to check the following:
● Is the network folder or computer you try to map turned on?
● Is the network folder or computer enabled for remote access?
● Does the selected user name have the necessary permissions?

See also Chapter 7.7.5, "Using a File Server for Test Files Exchange", on page 107.

7.7  How to Transfer Files from and to the Instrument

As explained in "File handling" on page 87, you access the file system of the
R&S AREG100A via one of the following ways:
● Via the built-in "File Manager"

See Chapter 7.6, "Using the File Manager", on page 97.
● On an instrument connected to a LAN:

– Via one of the standard functions ftp or SMB (samba)
See Chapter 7.7.2, "Accessing the File System of the R&S AREG100A via ftp",
on page 104 and
Chapter 7.7.3, "Accessing the R&S AREG100A File System via SMB
(Samba)", on page 105

– Via mapped network drives
See Chapter 7.6.4, "How to Map a Network Folder", on page 101.

● Via a connected USB storage device
See Chapter 7.7.4, "Using a USB Storage Device for File Transfer", on page 107

Mainly because of security reasons, the access to the file system of your
R&S AREG100A can be denied, because one or all these access methods are deliber-
ately disabled. Access to the file system via LAN and/or USB requires that the corre-
sponding service is enabled and a write access to the file system is enabled. Refer to
Chapter 7.7.1, "Removing File System Protection", on page 102 for description of the
required steps.

This section provides an introduction to the topic. For comprehensive information, refer
to the application note 1GP72: Connectivity of Rohde&Schwarz Signal Generators.

● Removing File System Protection.........................................................................102
● Accessing the File System of the R&S AREG100A via ftp................................... 104
● Accessing the R&S AREG100A File System via SMB (Samba)...........................105
● Using a USB Storage Device for File Transfer......................................................107
● Using a File Server for Test Files Exchange......................................................... 107

7.7.1  Removing File System Protection

Before you try to access the file system via ftp, SMB (samba) or USB, fulfill the follow-
ing:
● Disable write protection on the file system

How to Transfer Files from and to the Instrument
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● Enable the corresponding service or interface

To enable write permission on the file system

1. Select "System Config > Setup > Security > Security > General"

2. Enable "Volatile Mode"

3. Enter the "Security Password".
The default password is 123456. For more information, see Chapter 8.4, "Using the
Security Settings", on page 129.

4. Select "System Config > Setup > Maintenance > Shut Down"

5. Select "Reboot".

The system reboots. The enabled settings are active.

To enable file transfer via ftp

1. Select "System Config > Setup > Security > Security > LAN Services".

2. Enable "LAN Interface"

3. Enable "FTP"

4. Enter the "Security Password".
The default password is 123456. For more information, refer to Chapter 8.4, "Using
the Security Settings", on page 129.

5. Select "Accept".

To enable file transfer via SMB (samba)

1. Select "System Config > Setup > Security > Security > LAN Services"

2. Enable "LAN Interface"

3. Enable "SMB (Samba)"

4. Enter the "Security Password".
The default password is 123456. For more information, refer to Chapter 8.4, "Using
the Security Settings", on page 129.

5. Select "Accept".

To enable file transfer via USB

1. Select "System Config > Setup > Security > Security > General"

2. Enable "USB Storage"

3. Enter the "Security Password".
The default password is 123456. For more information, refer to Chapter 8.4, "Using
the Security Settings", on page 129.

4. Select "Accept".

How to Transfer Files from and to the Instrument
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7.7.2  Accessing the File System of the R&S AREG100A via ftp

If the R&S AREG100A is connected to a LAN, you can use file transfer protocol (ftp) to
access the file system and to transfer files from and to the instrument.

How to: see Chapter 9.6.3, "How To Connect to LAN", on page 174.

To access the file system via ftp

We assume that the instrument and the remote PC are connected to a LAN.

1. Enable file transfer via ftp

2. Enable write permission on the file system

3. On the remote PC, start the Windows Explorer.

4. In the address field, enter ftp://<"IP Address" of the Instrument>, e.g.
ftp://10.124.0.166.
Tip: The R&S AREG100A indicates its IP address on the home screen.

A log-on dialog opens and requests a password.

The default user name and password is instrument.

Tip:
Default password
The FTP and SAMBA file access use the user "instrument" with default password
"instrument".
We recommend that you change this password in the "Setup > Security > Pass-
word Management > Change User Password" dialog before connecting the instru-
ment to the network.
See Chapter 8.4.4, "Password Management", on page 139.

5. Enter the password to access the user directory.
The user directory corresponds to the /var/user/ directory of the instrument.

There, you can perform standard functions like creating directory, or saving files.

6. In the user directory, create a directory, e.g. test ftp.

7. Select "System Config > Save/Recall".
Open the /var/user/ directory.

The dialog displays the /var/user/test ftp directory.

How to Transfer Files from and to the Instrument
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7.7.3  Accessing the R&S AREG100A File System via SMB (Samba)

The SMB (Samba) protocol is an alternative way to access the file system of the instru-
ment from a remote PC. This protocol works if both the instrument and the PC are con-
nected to a LAN.

How to: see Chapter 9.6.3, "How To Connect to LAN", on page 174.

To access the file system via SMB

We assume that the instrument and the remote PC are connected to a LAN.

1. Enable file transfer via ftp

2. Enable write permission on the file system

3. On the remote PC, start the Windows Explorer.

4. In the address field, enter //<"IP Address" of the Instrument>, e.g. ftp://
10.124.0.166.

How to Transfer Files from and to the Instrument
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Tip: The R&S AREG100A indicates its IP address on the home screen.

The user directory corresponds to the /var/user/ directory of the instrument;
the volatile directory - to the /var/volatile directory.

To map the R&S AREG100A as a network drive to the remote PC

We assume that the instrument and the remote PC are connected to a LAN.

1. Enable file transfer via SMB (Samba)

2. Enable write permission on the file system

3. On the remote PC, start the Windows Explorer.
Open the "Map Network Drive" dialog.

a) Select a valid "Drive", e.g. W.
b) In the "Folder" field, enter //<"IP Address" of the Instrument>/user

or //<"Hostname" of the Instrument>/user
For example: //10.124.0.166/user or //AREG100A-102030/user.
Tip: The R&S AREG100A indicates its IP address on the screen.

c) Select "Finish".

A log-on dialog opens and requests a user name and a password.

The default user name and password is instrument.

Tip:
Default password
The FTP and SAMBA file access use the user "instrument" with default password
"instrument".
We recommend that you change this password in the "Setup > Security > Pass-
word Management > Change User Password" dialog before connecting the instru-
ment to the network.
See Chapter 8.4.4, "Password Management", on page 139.

4. Enter the user name and the password of your instrument.

The /var/user/ directory of the instrument is mapped to and displayed as a net-
work drive of the remote PC.

How to Transfer Files from and to the Instrument
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You can access the files in the /var/user/ directory, perform standard function
like creating directory, or storing files.

7.7.4  Using a USB Storage Device for File Transfer

Alternatively to the file transfer possibility via LAN, you can use a USB storage device
for direct file transfer from and to the instrument.

We recommend that you transfer files with user data (like lists or instrument setup files)
to the instrument, rather than load and play them from a connected USB storage
device.

To transfer a file with user data to the instrument

1. Connect a USB storage device, for example a USB memory stick to one of the
USB interfaces of the instrument.

The R&S AREG100A recognizes the connected USB storage device automatically.

2. Enable file transfer via USB

3. Enable write permission on the file system

4. Select "System Config > Save/Recall".

The dialog displays the /var/user/ directory and the /usb/ drive.

5. In the "Save/Recall" dialog, select "File Manager".

6. In the directory tree, navigate to the /usb/ drive.
Select the required file with user data.

7. Select "Copy".

8. In the directory tree, navigate to the /var/user/ directory.
Select "Paste".

The file with user data is transferred to the instrument.

7.7.5  Using a File Server for Test Files Exchange

You can use a central file storage location like a file server in your company network to
store setup files, SCPI scripts, application programs, or waveform files on it. Usually,
you would like to distribute the files to several instruments. If the R&S AREG100As are
connected to a LAN, you can create a shortcut on the instruments to the file server.

To access the file server

1. On each R&S AREG100A, map the required directory of the file server to the
instrument.
Perform the steps described in Chapter 7.6.4, "How to Map a Network Folder",
on page 101.
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2. On each R&S AREG100A, use the same alias name for the directory of the file
server, i.e. enter the same "Local Folder" (in this example Setups).

On any of the R&S AREG100A, you access the file server directly from the "File
Manager" and under the same name, e.g. /shares/Setups.
An extra advantage in remote control is that the same application program would
control the instruments.
For example, use the remote control command MMEMory:CDIRectory
"/shares/Setups" to set the default directory for mass storage.

7.8  Creating Screenshots of Current Settings

The save/recall function enables you to save current settings in a file. To document the
most important settings for a performed signal generation, you can also save a hard-
copy of the current display.

● Hardcopy Settings.................................................................................................108
● How to Save a Hardcopy of the Display................................................................112

7.8.1  Hardcopy Settings

Access:

► Select "System Config > Setup > User Interface > Hardcopy".

Creating Screenshots of Current Settings
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The remote commands required to define these settings are described in Chapter 10.9,
"HCOPy Subsystem", on page 227.

Settings:

File.............................................................................................................................. 109
Format.........................................................................................................................109
Options........................................................................................................................109
Save............................................................................................................................ 109
Hardcopy Options > Common.....................................................................................109

└ Automatic Naming.........................................................................................110
└ Format...........................................................................................................110
└ Region...........................................................................................................110

Hardcopy Options > Automatic Naming...................................................................... 110
└ Path............................................................................................................... 111
└ Clear Path..................................................................................................... 111
└ Prefix, Year, Month, Day................................................................................111
└ Current Auto Number.................................................................................... 111

File...
In "Automatic Naming > Off" mode, accesses the standard file select dialog for select-
ing the filename and folder the hardcopy is stored in.

If you have enabled "Automatic Naming", the instrument displays the automatically
generated filename.

Remote command: 
:HCOPy:FILE[:NAME] on page 229

Format
Selects the output file format, for example *.bmp, *.jpg*.xpm and *.png.

Remote command: 
:HCOPy:IMAGe:FORMat on page 229
:HCOPy:DEVice:LANGuage on page 229

Options...
Accesses Hardcopy Options dialog.

Save
Saves a hardcopy of the current display as a file.

Remote command: 
:HCOPy[:EXECute] on page 230

Hardcopy Options > Common
Access: select "Hardcopy > Options... > Common".

With the provided settings, you can customize the file format and the syntax of the
automatically assigned filename.
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Automatic Naming ← Hardcopy Options > Common
If enabled, creates the output filenames automatically according to the rules set with
the Hardcopy Options > Automatic Naming settings.

Remote command: 
:HCOPy:FILE[:NAME]:AUTO:STATe on page 231

Format ← Hardcopy Options > Common
Selects the output file format, for example *.bmp, *.jpg*.xpm and *.png.

Remote command: 
:HCOPy:IMAGe:FORMat on page 229
:HCOPy:DEVice:LANGuage on page 229

Region ← Hardcopy Options > Common
Displays the snapshot area.

Remote command: 
:HCOPy:REGion on page 229

Hardcopy Options > Automatic Naming
Access: select "Hardcopy > Options... > Automatic Naming".
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Provided are the following settings:

Path... ← Hardcopy Options > Automatic Naming
Selects the directory.

Note: To select the destination path, specify also a filename. Otherwise an error mes-
sage is displayed and selection is canceled.

Remote command: 
:HCOPy:FILE[:NAME]:AUTO:DIRectory on page 230

Clear Path ← Hardcopy Options > Automatic Naming
Deletes all image files with extensions *.bmp, *.jpg, *.png and *.xmp in the direc-
tory set for automatic naming.

Before the command is executed, a warning message prompts you to confirm the dele-
tion of the files.

Remote command: 
:HCOPy:FILE[:NAME]:AUTO:DIRectory:CLEar on page 231

Prefix, Year, Month, Day ← Hardcopy Options > Automatic Naming
Determines the rules for "Automatic Naming".

Per default, the automatically generated filename is composed of:

<Path>/<Prefix><YYYY><MM><DD><Number>.<Format>, where Y, M and D mean
year, month, Day; Number is the Current Auto Number.

You can activate or deactivate each component separately.

The "Resulting filename" indicates the current filename syntax.

Remote command: 
:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix on page 232
:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix:STATe on page 232
:HCOPy:FILE[:NAME]:AUTO[:FILE]:YEAR:STATe on page 231
:HCOPy:FILE[:NAME]:AUTO[:FILE]:MONTh:STATe on page 231
:HCOPy:FILE[:NAME]:AUTO[:FILE]:DAY:STATe on page 231

Current Auto Number ← Hardcopy Options > Automatic Naming
Indicates the number which is used in the automatically generated filename.

Note: When initially switching on the instrument, the number is reset to the lowest pos-
sible value. Starting with number 0 the output directory is scanned for existing files. As
long as files with the same name are existing, the number is increased by 1. The num-
ber is automatically set so that the resulting filename is unique within the selected path.
The current number is not in the save/recall file but is temporarily stored within the
database. At the following save operation, the number is increased.

Remote command: 
:HCOPy:FILE[:NAME]:AUTO[:FILE]:NUMBer? on page 232
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7.8.2  How to Save a Hardcopy of the Display

1. Select "System Config > Setup > User Interface > Hardcopy".

2. To define the output format, select "Format > JPG".

3. To enable the instrument to create output filenames, select "Automatic Naming >
On".

4. Select "Options...".

5. In the "Hardcopy Options" dialog:

a) To change the default directory the file is saved in, select "Automatic Naming
Settings > Path" and define a path and a filename. For example, select the
default directory /var/user.

b) If necessary, disable or change some of the parameters in the "Automatic Nam-
ing Settings".

c) Close the "Hardcopy Options" dialog.

6. In the "Hardcopy" dialog, select "Save".

The instrument saves a hardcopy of the current instrument display as a *.jpg file.
The filename is automatically created.

7. To print the hardcopy, connect the instrument to a LAN and:

a) Transfer the file to a remote computer as described in Chapter 7.7, "How to
Transfer Files from and to the Instrument", on page 102.

b) On the remote computer, navigate through the file system.
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c) Print the selected file.
For more information, refer to the online help of the operating system.
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8  General Instrument Functions
The general instrument functions include basic instrument settings, regardless of the
selected operating mode and measurement. Some of these settings like screen display
and peripherals are initially configured at the setup of the instrument, according to per-
sonal preferences and requirements. However, you can individually adjust the settings
at any time, for example, if necessary for specific applications.

The following special functions help you in service and basic system configuration:
● Chapter 8.1, "Customizing the User Interface", on page 114

Allows you to adjust the display and keyboard language settings.
● Chapter 8.2, "Organizing Frequently Used Settings as Favorites", on page 118

Enables you to group user defined settings in a favorites list or to assign actions to
the [User] as quick access for later retrieval.

● Chapter 8.3, "Managing Licenses and License Keys", on page 123
If you have purchased an additional option for the R&S AREG100A, you can
enable it using a license key.

● Chapter 7.2, "Restoring the (Default) Instrument Configuration", on page 88
At any time, you can restore a default configuration to start a measurement at a
defined instrument state, or set the instrument to factory preset.

● Chapter 8.4, "Using the Security Settings", on page 129
Special security and protection functions protect your instrument from unauthorized
use or activate specific test routines.

8.1  Customizing the User Interface

The R&S AREG100A provides basic alignments of instrument settings regarding the
user interface, that means the touch panel (screen), the appearance of the displayed
dialogs and graphics, and an external keyboard.

Start / stop display update

The operating system of the R&S AREG100A refreshes the displayed settings by
default in almost real-time, to keep the display updated with the internally used values.
However, you can turn off this function to reduce settling times when the instrument is
remote controlled.

In detail described in the following paragraphs, you can:
● Set display and keyboard language, see Chapter 8.1.1, "Display and Keyboard

Settings", on page 115
● Set date and time for the system clock, see Chapter 13.4.2, "Date and Time",

on page 313
● Configure and activate a Screen Saver
● Deactivate display update to improve performance, see Chapter 8.1.2, "Display

Update Settings", on page 116

Customizing the User Interface
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8.1.1  Display and Keyboard Settings

Access:

1. Select "System Config > Setup > User Interface > Display/Keyboard > Display".

2. Select "Display/Keyboard > USB Keyboard".

In the "Display/Keyboard" dialog, you can change regional and language options
for the GUI and an external keyboard, and define the screen saver settings.

The remote commands required to configure the display and keyboard are described in
Chapter 10.7, "DISPlay Subsystem", on page 221 and Chapter 10.10, "KBOard Sub-
system", on page 232.

Screen Saver...............................................................................................................115
Wait Time.....................................................................................................................115
Display.........................................................................................................................116
RF Hardkey................................................................................................................. 116
USB Keyboard > Layout..............................................................................................116

Screen Saver
Activates the screensaver.

If activated, the display including backlight is switched off after the selected Wait Time
elapses and if no entries via touch panel, front panel, external mouse, or external key-
board are made

Remote command: 
:DISPlay:PSAVe[:STATe] on page 223

Wait Time
Enters the idle time that must elapse before the display lamp is shut off when no
entries are made.
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Remote command: 
:DISPlay:PSAVe:HOLDoff on page 222

Display
Adjusts the brightness of the display.

Increase the value to turn up the display brightness.

Remote command: 
:DISPlay:BRIGhtness on page 223

RF Hardkey
Adjusts the brightness of the [RF on/off] key.

Increase the value to change the contrast between the key and the front panel back-
ground color.

Remote command: 
:DISPlay:BUTTon:BRIGhtness on page 223

USB Keyboard > Layout
Selects the language of an externally connected keyboard via USB. The function
assigns the corresponding keys automatically.

Remote command: 
:KBOard:LAYout on page 233

8.1.2  Display Update Settings

Access:

► Select "System Config > Setup > User Interface > Start/Stop Display Update".

This dialog enables you, to deactivate updating the display.

The remote command to switch off the display update is described in Chapter 10.7,
"DISPlay Subsystem", on page 221.

Display Update is
Disables the automatic refreshing of the displayed values.

Remote command: 
:DISPlay:UPDate on page 223
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8.1.3  How to Set the Initial Instrument Settings

This section describes how to set up the R&S AREG100A initially.

8.1.3.1  Setting the Keyboard Language

You can select the language of the external keyboard connected to the instrument.

To adjust the keyboard settings

1. Press the [Setup] key.

2. Select "User Interface > Keyboard".

3. Select the "Layout".

The dialog closes and the changes take effect immediately.

8.1.3.2  Setting the Screen Saver

You can enable a screen saver that automatically turns off the display after a user-
defined period of time. The screen saver is activated if no settings are made on the
touch screen, or via keys or the rotary knob during the selected wait time.

To activate the screen saver

1. Press the [Setup] key.

2. Select "User Interface > Display"

3. Activate the "Screen Saver".

4. Define the "Wait Time" in minutes.

The instrument turns off the display after the defined period of time.

5. To reactivate the display, tap the screen or press any key on the front panel.

To deactivate the screen saver

1. Press the [Setup] key.

2. Select "User Interface > Display"

3. Disable the "Screen Saver" state.
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8.2  Organizing Frequently Used Settings as Favorites

The R&S AREG100A provides two possibilities to define frequently used settings and
procedures for later retrieval individually.

User menu and [User] key

These two functions work similar to the favorites function of a browser or other pro-
grams. They allow you to create a list of frequently used actions or to group frequently
used settings in one dialog.

You can collect the parameters of your configuration in a favorites list, i.e. in the "User
Menu", or define settings and actions with the [User] key:
● "User Menu" to group settings of specific tasks.

Similar to a favorites function, you can use this menu for:
– Grouping the settings required for a task in one dialog.
– Saving and recalling the settings of a task.
– Transferring the settings for use on multiple instruments.

● [User] key, with customizable function.
You can perform the following steps using this key:
– Open the "User Menu" (default functionality).
– Add or remove settings and functions.
– Execute actions and access functions.

Possible applications

The User key and the "User Menu" are useful for the following situations:
● There are functions or tasks you have to perform in a defined order but the setting

parameters are distributed across several dialogs.
● There are functions or tasks you have to perform frequently but they are not acces-

sible via the front panel keys.
● The required functions are grouped in a dialog that is not directly accessible from

the home screen.
● Your task involves the frequently loading and executing of certain SCPI scripts.

Refer to Chapter 9.8.4, "How to Record / Create SCPI Lists", on page 193 for
information on how to create an SCPI script.

● A quick access to saved setups is required.
● There are functions and tasks you have to perform on several instruments.

Dialog identification

To identify each dialog, the instrument uses a dedicated dialog ID. The dialog ID con-
tains the dialog position on the display and the current active tab. The action that trig-
gers the instrument to open a dialog uses this identification.
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Save/Recall vs. recall setup

If you need to restore a specific signal generation setup and perform further configura-
tions based on this particular instrument state, the R&S AREG100A provides two
options:
● "Save/Recall" function

For a detailed description, refer to Chapter 7.4, "Saving and Recalling Instrument
Settings", on page 93.

● "Recall Setup" function
If the "Recall Setup" is the only user action assigned to the [User] key, pressing this
key triggers the R&S AREG100A to load the user-defined preset file immediately.

8.2.1  User Menu Settings

The "User Menu" dialog contains function keys to organize, save and load a favorites
list. You can also modify, add or delete list entries directly in the dialog.

Clear User Menu
Removes all entries from the "User Menu" at once.

Save User Menu
Saves the current "User Menu" under the defined filename.

Recall User Menu
Loads the selected "User Menu" file.

This function enables you to use the user specific favorites file on another instrument.
However, if functions or parameters are not provided due to varying configuration of
the instrument, the settings of these particular parameters take no effect.

8.2.2  How To Use the User Menu for Fast Adjustments

Access:

1. Press the [User] key.

The "User Menu" dialog opens.
If you execute this action for the first time, the dialog displays instructions on how
to use the "User Menu".

2. If you already have a saved user menu file on the instrument, you can load with
"Recall User Menu".

Creating a "User Menu"

To create your own user dialog with settings:

1. Open a dialog with settings you frequently use.

2. Select a parameter.
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3. Open the context menu and select "Add to User Menu".

A favorites icon  indicates that the parameter is used in the "User Menu".
The "User Menu" button in the taskbar confirms that you have created a "User
Menu" with at least one entry.

4. Press the [User] key.

The "User Menu" dialog shows all parameters that you have added to the list.
You can modify the parameter settings directly in this dialog, e.g .change a state or
set values, as you do in the particular dialog the parameter originally belongs to.

5. To remove an entry, select the parameter either in the "User Menu" or in the dialog
where it originally belongs to.

a) Open the context menu and select "Remove from User Menu".

6. To remove all entries at once, select "Clear User Menu".

7. To save your individual favorites list, select "Save User Menu", and follow the file
managing instructions.
The file system automatically assigns the file extension *.user_menu.

8. To recall a previously saved user menu, select "Recall User Menu" and proceed
accordingly.

Providing a user menu favorites list for several instruments

To transfer files from or to an instrument:

1. Create the favorites list, as described in "Creating a "User Menu"" on page 119.

2. Save the favorites list.

3. To tansfer a file from or to an instrument, the R&S AREG100A provides several
options, see "File handling" on page 87.
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8.2.3  Define User Key Actions Settings

Access:

► Select "System Configuration > Setup > User Interface > Define User Key".

The dialog displays a list of the currently enabled actions and provides functions to
define new, edit or remove existing actions. If no actions have been defined, the list
is empty.
See Chapter 8.2.4, "How to Assign Actions to the [User] Key", on page 122.

The remote commands required to define these settings are described in Chapter 10.7,
"DISPlay Subsystem", on page 221.

Name
Enters a user-defined name for the action.

Wizard
Defines the action to be executed.

"Load SCPI Script"
Selecting the action load and executes the SCPI script.

"Recall Setup" Load a setup for quick access to the user-defined settings.

Select
Depending on the selected "Wizard", provides access to:
● The standard "File Select" function for loading of an SCPI script or setup file
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● A list of the dialog IDs of all currently opened dialogs. The dialog ID is used for dia-
log identification in the remote control.
See SCPI.

SCPI
For the currently selected action, displays the corresponding SCPI command with the
associated parameter for dialog identification (dialog ID). The automatically displayed
SCPIs are enabled for subsequent modification.

Remote command: 
:DISPlay:DIALog:OPEN on page 225
See also :DISPlay:DIALog:ID? on page 225

Add, Change, Remove
Standard functions for managing of the actions.

Back to Execute Mode
Opens the "Select Action to Execute" dialog. Select an Action form the list to execute
it.

To return to the "Define User Key Actions" dialogs, select Select Action to Execute >
Define Actions.

Select Action to Execute > Define Actions

Accesses the "Define User Key Actions" dialog.

8.2.4  How to Assign Actions to the [User] Key

The customizable [User] key has no predefined function assigned. You can individually
define actions to be executed or functions to be accessed when pressing this key.

To assign a frequently used dialog to the [User] key:

1. Open the dialog you want to quickly access.

2. Select "System Configuration > Setup > User Interface > Define User Key".

3. To create an action:

a) Specify the "Name".
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b) Select "Wizard > Open Dialog"
c) Select "Select" and select the dialog ID from the list

The corresponding SCPI command is automatically displayed and can be later
modified.

4. Select "Add" to store the new action in the list of user key actions.

5. To execute the created action, press User.
In the list of actions ("Select Action to Execute" dialog), navigate to the required
action.

The R&S AREG100A executes the action and opens the dialog.

8.3  Managing Licenses and License Keys

An option is ready to operate after it is enabled with a license keycode supplied with
the option. The license key is delivered as a file or on paper. Unregistered licenses
must be registered for a particular instrument before the corresponding option can be
enabled for operation.

For reliable operation, a software option usually requires the latest firmware version.
The required version is specified in the delivery. If your instrument works with a former
firmware version, update the firmware before enabling the software option.
The firmware update is described in the R&S AREG100A service manual.

8.3.1  Manage License Keys Settings

The "Manage Licnese Keys" dialog provides all information on the available licenses.
Instrument-related steps guide you through the process of registering or deactivating
licenses.

Access:

1. Select "System Config > Setup > Instrument Assembly > Manage License Keys >
Manage License Keys".
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In this tab, you can activate licenses for newly purchased or newly registered
options.

2. Select "System Config > Setup > Instrument Assembly > Manage License Keys >
Installed License Keys".

This tab lists all active options, with information on the available number of an
option, the license type and registration. You can query inactive or disabled options
also.

3. Select "Open License Server".
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See Chapter 8.3.2, "Using the License Server", on page 126.

The "Manage License Keys" dialog covers all required parameters for activating or
deactivating newly purchased or newly registered options, and provides access to
the onboard license server, see Chapter 8.3.2, "Using the License Server",
on page 126.

Settings

Device ID.....................................................................................................................125
Enter License Key....................................................................................................... 125
Import License Key from File...................................................................................... 125
Export Deactivation Response to File......................................................................... 125
License Installation Info...............................................................................................125
Installed License Keys................................................................................................ 125

└ Show Inactive................................................................................................126
└ Show Deactivated.........................................................................................126
└ Installed License Keys Table.........................................................................126

Open License Server.................................................................................................. 126

Device ID
Displays the instrument-specific identification number. The device ID is a unique string
with the following structure:
<stock number>-<serial number>-<checksum>

Enter License Key
Type here the license key provided with the option.

For license keys delivered as a file, use Import License Key from File....

Import License Key from File...
Opens a dialog for selecting the file with the license key.

Use this function also to import the deactivation key file generated by the R&S License
Manager online tool (see How to Move a Portable License).

Export Deactivation Response to File...
Exports the generated deactivation response key to a file and opens a file manage-
ment dialog to save the file.

This key is required during the unregistration process, e.g. when you want to deinstall
an option or have a portable option, which you want to register later on another instru-
ment (see How to Move a Portable License).

License Installation Info
Indicates status information on the performed actions.

Installed License Keys
Access: select "System Config > Setup > Instrument Assembly > Manage License
Keys > Installed License Keys".

Comprises information on the installed options.
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Show Inactive ← Installed License Keys
Enables the display of the inactive (expired) licenses in the Installed License Keys
Table.

Show Deactivated ← Installed License Keys
Enables the display of the deactivated licenses in the Installed License Keys Table.

See How to Move a Portable License for information on how to activate deactivated
licenses.

Installed License Keys Table ← Installed License Keys
Shows information on the currently installed options.

"Export License Key to File"
Opens a dialog to save the generated license key file. This file is
required during the unregistration process.
If you have a portable unregistered option, you can register it later on
another instrument (see How to Move a Portable License).

"Option" Displays the option short designation.

"License Count"
Displays the number of the licenses for the selected option key.

"License Type" Displays the type of license.
A license type determines the common qualification application dura-
tion and the portability of a license. The following license types are
provided: evaluation, permanent, portable, quantified, time-controlled
with a duration of 1, 3, 6 or 12 months. A license can also be deacti-
vated or expired.
For time limited licenses, the left time of applicability is displayed too.

"Registrations" (reserved for future use)

Open License Server
Opens the R&S License Server of the R&S AREG100A, see Chapter 8.3.2, "Using the
License Server", on page 126.

8.3.2  Using the License Server

The R&S AREG100A now supports handling of software licenses using the license
server from Rohde & Schwarz.

The R&S License Server is a browser application you can access directly in the
R&S AREG100A. The onboard license server is integrated in the instrument firmware
with connection to a local smartcard memory. The local smartcard holds local licenses,
i.e. licenses used on this specific instrument.

To open the license server

Access:

1. Select "System Config > Setup > Instrument Assembly > Manage License Keys >
Installed License Keys".
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2. Select "Open License Server".

The license server browser opens. The application shows the internal license
server of the R&S AREG100A in the "License providers" tile. The "License", "Ana-
lytics" and "Configuration" views enable you to activate licenses, or, e.g., deacti-
vate and release licenses again.
In the "License Info" tile on the right, the application shows the characteristics of
the selected license provider.

To expand the license key list window, fold in  the "License Provider" and the
"License Info " tiles .

Short glance at the "Analytics" and "Configuration" views

To get a brief introduction on these views:

1. Select "Analytics".

Shows information on configured client applications, license providers and license
types. It provides access to the client applications and enables you to export statis-
tics data for evaluation in external applications.

2. Select "Configuration".

Shows configured license servers, access lists and installed product definitions. It
provides access to add and to remove license server configurations and to manage
local licenses.

For details on handling and functionality, see the manual R&S®License Server -
Managing Licenses - User Manual

To manage licenses on the R&S AREG100A

To request or return a license, proceed as follows:

1. Access: see "To open the license server" on page 126.

Managing Licenses and License Keys
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The browser application opens.

2. Select the "Licenses" view.

3. In the "Licenses providers" tile, select the license provider, e.g. R&S AREG.

The license server shows the license key list with the options available for the
selected provider. In this example, the licenses of the R&S AREG100A.

4. Select the option license summary view .

This view lists the options, the number of available licenses, and the state of their
use. In the last column, you can see the maintenance expiration date of each
license.

5. To request enabling a license, select  (activate) in the toolbar.

6. To return the license, select  (discontinue).

7. Follow the instructions on the screen.

8.3.3  How to Move a Portable License

This example is intended to explain how to perform the required steps at the instru-
ment.

Use a USB flash drive to transfer the license key files between the instruments and the
browser.

We assume knowledge about the handling of the R&S License Manager online tool
and the description of the whole process.

1. Open your browser. Enter https://extranet.rohde-schwarz.com/service.
Select "Manage Licenses > Move Portable License".

The first step requires the Device IDs of the source and target instruments.

2. To find out the Device IDs, proceed as follows:

a) On the source instrument, select "System Config > Setup > Instrument Assem-
bly > Manage License Keys > Manage License Keys > Device ID".

b) On the target instrument, select "System Config > Setup > Instrument Assem-
bly > Manage License Keys > New License > Device ID".

c) In the browser, select "Manage Licenses > Move Portable License > Select
Devices" and enter the Device IDs.

3. On the source instrument, select "System Config > Setup > Instrument Assembly >
Manage License Keys > Installed License Keys > License Keys Table".

Managing Licenses and License Keys
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Navigate to the portable license you want to move.
Select the "Export License to File" column.

A standard file manager dialog opens.

4. Enter a filename. Save the exported license key, e.g.
k123_portable_key_to_move.xml.

5. In the browser, select "Manage Licenses > Move Portable License > Select
License (from file)" and select the exported license key.
Check the selection. Create the deactivation key. Save it to file.

6. On the source instrument, select "System Config > Setup > Instrument Assembly >
Manage License Keys > Manage License Keys > Import License Keys from File".
Select the transferred deactivation key.

7. On the source instrument, select "System Config > Setup > Instrument Assembly >
Manage License Keys > Manage License Keys > Export Deactivation Response to
File".

8. In the browser, go to "Manage Licenses > Move Portable License > Install Deacti-
vation Key (from file)".
Enter the deactivation response of the instrument.

The license is deactivated for the source instrument.

9. In the "Manage Licenses > Move Portable License", go to step "Create License" to
generate a license key for this portable option and the selected target instrument.
Download the license key as a file. Transfer it to the target instrument.

10. In the target instrument, select "System Config > Setup > Instrument Assembly >
Manage License Keys > New License > Import License Keys from File".
Select the created license key file.

The portable option is installed on the target instrument.

8.4  Using the Security Settings

The protection function of the R&S AREG100A offers several levels to activate particu-
lar functions like self-test or tests for service purposes specifically.

Protection

The five protection levels are automatically active on startup, the protection levels, that
means all protected functions are locked.

To unlock a protection level:

► In the "System Config > Setup > Security > Protection", enter the correct password.

To lock a protection level:

► Clear the corresponding checkbox.

Using the Security Settings
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Protection levels

The following functions are protected in the respective levels:
● Protection level 1

Protects against accidental changes, like, for example, the clock and date, several
internal adjustments functions and the self-test, as well as network settings or the
instrument hostname.
You can access this level with the password 123456.

● Protection level 2
Unlocks protected service functions. It is accessible to authorized personnel of
Rohde & Schwarz service department only.

● Protection level 3 to 5
Are reserved for internal use.

Security

The security concept of the R&S AREG100A helps you to protect your instrument
against uncontrolled access and changes. All provided security services require that
you enter the security password.

Provided security services are:
● General security parameters, such as:

– USB storage that secures controlled access to the mass memory of the instru-
ment

– Volatile mode that prevents information to be written to the internal memory
permanently.

– Sanitizing that prevents the instrument from leaving a secure environment with
stored user information.

– Annotation frequency and amplitude prevent reading the display.
– Secure Update Policy check that verifies the integrity and origin of the firm-

ware package to be installed.
To access the settings of these topics, see Setting Security Parameters >
"Secure Update Policy" on page 132.

● Password management secures controlled user access to the instrument
With the two-step password concept, you can assign a user-defined password for
the operating system, and a security password for accessing the mass storage of
the instrument.
See also Chapter 8.4.4, "Password Management", on page 139.

● LAN services secure controlled network access
You can individually lock and unlock supported LAN interface services. Also you
can activate and deactivate SMB client and SMB server, that use versions 1.0 and
2.0 of the SMB protocol. See Chapter 8.4.3, "Configuring LAN Services",
on page 137.
Remote control via LAN interface requires that the interface is activated, but you
can enable the required services specifically.

● User interface prevents front panel operation and/or reading the display.
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For more information, see the document R&S AREG100A Instrument Security Proce-
dures.

8.4.1  Protection Level Settings

Access:

► Select "System Config > Setup > Security > Protection".

The "Protection" dialog provides access to the unlocking of different protection lev-
els.
Several functions in the instrument are password-protected to prevent for example
accidental changes, "Protection" on page 129.

The remote commands required to unlock a protected stage are described in Chap-
ter 10.12, "SYSTem Subsystem", on page 243.

Protection Level/Password
Unlocks the selected level of protection, if you enter the correct password.

The default protection level 1 password is 123456.

To lock the protection level again, clear the checkbox.

Remote command: 
:SYSTem:PROTect<ch>[:STATe] on page 251

8.4.2  Setting Security Parameters

Access:

► Select "System Config > Setup > Security > Security > General".
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In the "General" tab, you can determine the security level for firmware updates, and
configure the security settings for the mass memory and manual operation.

All modified settings in this dialog are not applied until you enter the Security Password
and confirm with Accept.

8.4.2.1  Update Policy Security Settings

Access:

► Select "System Config > Setup > Security > Security > General > SW Update".

The SW Update tab enables you to select the security mode for firmware updates.

The remote commands available to control security settings are described in Chap-
ter 10.12, "SYSTem Subsystem", on page 243.

Secure Update Policy
Allows you to configure the automatic signature verification for firmware installation.

To apply the change: enter the security password and confirm with "Accept". Otherwise
the change has no effect.

Using the Security Settings
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See also:
● Chapter 8.4, "Using the Security Settings", on page 129 for more information on

the security concept.
● The release notes for details on signature verification when installing new or former

firmware versions, available at www.rohde-schwarz.com/firmware/areg100a.

"Confirm Unsigned"
Performs the signature verification.
If the check detects any discrepancies, the instrument issues a warn-
ing message. You can still update the firmware or reject updating.
This setting also enables you to downgrade the firmware version.

"All Packages" Accepts all packages without signature verification.

"R&S Signed Packages"
Performs the signature check.
If the check detects any discrepancies, the instrument issues a warn-
ing message and locks the update to this firmware.

Remote command: 
:SYSTem:SECurity:SUPolicy on page 260

8.4.2.2  Disk & Memory Security Settings

Access:

► Select "System Config > Setup > Security > Security > General > Disk & Memory".

The "Disk & Memory" tab secures controlled access to the mass memory and pre-
vents information from leaving a secure environment.

The remote commands available to control security settings are described in Chap-
ter 10.12, "SYSTem Subsystem", on page 243.

USB Storage
Activates the access to external USB storage media.

To apply the change: enter the security password and confirm with "Accept". Otherwise
the change has no effect.

See also Chapter 7.7.4, "Using a USB Storage Device for File Transfer", on page 107.

Using the Security Settings



General Instrument FunctionsR&S®AREG100A

134User Manual 1178.7417.02 ─ 06

Note: Remove all USB memory devices before disabling the USB storage. If any USB
memory device remains connected, disabling is blocked, and the instrument returns a
warning message.

Volatile Mode
Activates volatile mode, so that no user data can be written on the internal memory
permanently.

In volatile mode:
● Data that the instrument normally stores on the internal memory is redirected to

volatile memory.
● The user directory is mapped to the volatile memory. You access the temporary

data just as data stored in the /var/user/, see Chapter 7.3, "Protecting Data",
on page 92.

● Data on the internal memory cannot be changed. It is protected against modifica-
tion or erasure.

● You can only save data:
– Temporarily in the volatile memory
– On a connected external storage device, such as a memory stick

To activate volatile mode: enter the security password, confirm with "Accept" and
reboot the instrument. Otherwise the change has no effect.

Activated volatile mode is indicated by the icon .

Remote command: 
:SYSTem:SECurity:VOLMode[:STATe] on page 252

Sanitize
Executes the erase procedure that sanitizes the internal memory.

If the instrument is subject to high security, and you have not enabled the volatile
mode, the internal flash memory holds user-data, i.e. it poses a security risk. The sani-
tizing function makes sure that no user information is stored on the instrument when it
leaves the secure environment.

To apply the change: enter the security password and confirm with "Accept". Otherwise
the change has no effect.

See also Chapter 8.4, "Using the Security Settings", on page 129 for more information
on the security concept.

Remote command: 
:SYSTem:SECurity:SANitize[:STATe] on page 260

8.4.2.3  Manual Operation Security Settings

Access:

► Select "System Config > Setup > Security > Security > General > Manual Opera-
tion".
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The "SW Update" tab enables you to lock front panel operation and/or reading the
display.

The remote commands available to control security settings are described in:
● Chapter 10.7, "DISPlay Subsystem", on page 221
● Chapter 10.12, "SYSTem Subsystem", on page 243.

Annotation Frequency
Enables the display of the currently used frequency in the status bar.

How to: see "Disabling the frequency and level indication in the status bar"
on page 144.

Remote command: 
:DISPlay:ANNotation:FREQuency on page 224

Annotation Amplitude
Enables the display of the currently selected level in the status bar.

How to: see "Disabling the frequency and level indication in the status bar"
on page 144.

Remote command: 
:DISPlay:ANNotation:AMPLitude on page 224

User Interface
Allows you to lock the controls for manual operation and the display individually.

How to: see "Deactivating the user interface" on page 144.

See also Chapter 8.4, "Using the Security Settings", on page 129.

"Enabled" Enables the display and all controls for the manual operation of the
instrument.
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"Touchscreen Off"
Locks the touch sensitivity of the screen.
This security feature protects the instrument against unintentional
change of settings by accidentally touching of the screen.

Still available controls for manual operation are:
● The keys at the front panel, including the rotary knob
● The external mouse and keyboard
● Remote operation over VNC
The instrument indicates the locked touchscreen by an icon .
Unlocking is possible via VNC, external controls or remote control.

"VNC Only" Locks the keys at the front panel, the touchscreen and externally con-
nected keyboard and mouse.
The display on the screen remains and shows the current settings
and changes.
The instrument indicates the activated "VNC only" feature by the icon

.
Unlocking is possible via VNC or turning off and on again.

"Display Only" Locks the manual operation of the instrument. The display on the
screen remains and shows the current settings and changes.
This security feature protects the instrument against unauthorized
access, but still shows the current settings and processes, for exam-
ple when you operate the instrument via remote control.

The function disables:
● The touchscreen functionality of the display
● The keys at the front panel of the instrument
● The external mouse and keyboard
The instrument indicates the locked controls by a padlock  softkey.
How to unlock: see "Unlocking (reactivating) the user interface for
manual operation" on page 144.

"Disabled" Locks the display and all controls for the manual operation of the
instrument.
This security feature protects the instrument against unauthorized
reading and access, for example when you operate the instrument via
remote control.

The function disables:
● The display
● The touchscreen
● The keys at the front panel of the instrument
● The external mouse and keyboard
The screen shuts off and displays a padlock symbol  instead.
How to unlock: see "Unlocking (reactivating) the user interface for
manual operation" on page 144.

Remote command: 
:SYSTem:ULOCk on page 249
:SYSTem:DLOCk on page 248
:SYSTem:KLOCk on page 249
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Enabling a locked user interface for manual operation
Follow the instructions listed in "Unlocking (reactivating) the user interface for manual
operation" on page 144.

Remote command: 
:SYSTem:ULOCk on page 249
:SYSTem:DLOCk on page 248
:SYSTem:KLOCk on page 249

8.4.3  Configuring LAN Services

Access:

1. Select "System Config > Setup > Security > Security > LAN Services > Main Ser-
vices".

In the "Main Services" side tab, you can individually enable or disable the suppor-
ted LAN interface services.

2. Select "System Config > Setup > Security > Security > LAN Services > Samba Ser-
vices".
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In the "Samba Services" side tab, you can activate older versions of the SMB client
and SMB server.

How to:
● "Disabling the LAN interface" on page 143
● "Disabling LAN services" on page 143
● "Activating SMB version 1.0/2.0 client and server" on page 143

Common Services
Enable or disable the LAN interface and supported LAN interface services.

LAN ← Common Services
Enables the LAN interface in general, and thus provides remote access via all
unlocked services.

Enable LAN Services individually ← Common Services
Enables or disables the following interface services individually.

"SCPI over LAN"
Activates access over LAN to control the instrument remotely, by
using SCPI (Standard Commands for Programmable Instruments)
commands.
See also "Starting a remote control session over LAN with R&S VISA"
on page 182.

"VNC" Activates access over VNC (Virtual Network Computing) interface, a
graphical desktop sharing system that uses RFB protocol to control
the instrument remotely.
See also Chapter 9.9, "Operating the R&S AREG100A Remotely via
VNC", on page 198.

"SSH (SCP)" Activates access over SSH (Secure Shell), a network protocol for
secure data communication.

"Remote Support"
Activates remote support over SSH.

"HTTP" Activates access via HTTP (Hyper Text Transfer Protocol), the appli-
cation protocol for hypermedia information systems.

"FTP" Activates access over FTP (File Transfer Protocol), used to transfer
files from a host to the instrument and vice versa.
See also Chapter 7.7.2, "Accessing the File System of the
R&S AREG100A via ftp", on page 104.

"SMB (Samba)"
Activates access to SMB (Server Message Block), used for providing
shared access to files, printers and serial ports of a network.
See also Chapter 7.7.3, "Accessing the R&S AREG100A File System
via SMB (Samba)", on page 105.

"Avahi (Zeroconf)"
Activates Avahi, a service for automatic configuration of the instru-
ment in a network environment.
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"Software Update"
Allows updating the software.

Samba Services
Activate or deactivate support of SMB client and SMB server version 1.0 and 2.0 of the
SMB protocol.

Support of version 1.0 and 2.0 is additional to the current SMB protocol version sup-
ported in the firmware. This firmware supports SMB protocol versions up to version 4.

SMB 1.0/2.0 Client ← Samba Services
Activates support of the SMB client compatible with SMB protocol versions 1.0 and 2.0.

SMB 1.0/2.0 Server ← Samba Services
Activates support of the SMB server compatible with SMB protocol versions 1.0 and
2.0.

Security Password
Enters the password that is required to enable or to disable the settings protected by a
security password. Default is 123456.

How to:
● "Disabling the LAN interface" on page 143
● "Disabling LAN services" on page 143
● "Changing the default security password" on page 143.

Accept
Applies the modified settings, provided the security password is entered and correct.

8.4.4  Password Management

Access:

1. Select "System Config > Setup > Security > Security > Password Management >
User Password".
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In this tab, you can assign the security and a user-defined password.

2. Select "System Config > Setup > Security > Security > Password Management >
Security Password".

How to:
● "Changing the default user password of the instrument" on page 142.
● "Changing the default security password" on page 143.

User Name
Indicates the user name used for access to the Linux operating system and valid for
VNC, FTP and SMB (Samba) access.
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User Password
Access: select "System Config > Setup > Security > Security > Password Management
> User Password".

Allows you to change and confirm the user password.

Old Password ← User Password
Enters the current user password. The default password is "instrument".

Note: We recommend that you change the default password before connecting the
instrument to a network.

How to:
● "Changing the default user password of the instrument" on page 142.
● "Changing the default security password" on page 143.

New Password ← User Password
Enters the new user password.

The security password can contain decimal characters only.

Confirm Password ← User Password
Confirms the new user password by repeating.

How to:
● "Changing the default user password of the instrument" on page 142.
● "Changing the default security password" on page 143.

Change Password ← User Password
Changes the user password accordingly.

Security Password
Access: select "System Config > Setup > Security > Security > Password Management
> Security Password".

Enables you to change and confirm the security password.

Old Password ← Security Password
Enters the currently used security password. The default password is '123456'.

Note: We recommend that you change the default password before connecting the
instrument to a network.

How to:
● "Changing the default user password of the instrument" on page 142.
● "Changing the default security password" on page 143.
The security password is required when changing the status of the USB and LAN inter-
face.

New Password ← Security Password
Enters the new security password.

The security password can contain decimal characters only.

Confirm Password ← Security Password
Confirms the new security password by repeating.
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How to:
● "Changing the default user password of the instrument" on page 142.
● "Changing the default security password" on page 143.

Change Password ← Security Password
Changes the password accordingly.

8.4.5  How to Prevent Unauthorized Access

The default computer name and user password are instrument. The user password is
the password required for VNC, FTP and SMB (samba) connections. If, for example,
the VNC service or FTP are enabled, anyone in the network who knows the computer
name and user password of the instrument can access it.

The default security password is 123456. The security password is required when
changing the status of the USB and LAN interface.

To prevent unauthorized access, use the following configurations exclusively or com-
plementary:
● "Changing the default user password of the instrument" on page 142
● "Changing the default security password" on page 143
● "Disabling the LAN interface" on page 143
● "Disabling LAN services" on page 143
● "Activating SMB version 1.0/2.0 client and server" on page 143
● "Disabling the frequency and level indication in the status bar" on page 144
● "Deactivating the user interface" on page 144

If security is a concern, see the document instrument security procedures for compre-
hensive description.

Changing the default user password of the instrument

► Note: We recommend that you change the default password before connecting the
instrument to a network.

How to:
● "Changing the default user password of the instrument" on page 142.
● "Changing the default security password" on page 143.

a) Select "System Config > Setup > Security > Security > Password Management
> User Password".

b) Enter the current password in the "Old Password" field.
c) Enter the new password in the "New Password" and "Confirm Password" fields.
d) Select "Change Password".

The user password is changed; the user name is displayed ("Security > Password
Management > User Password > User Name").
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Changing the default security password

► Note: We recommend that you change the default password before connecting the
instrument to a network.

How to:
● "Changing the default user password of the instrument" on page 142.
● "Changing the default security password" on page 143.

a) Select "System Config > Setup > Security > Security > Password Management
> Security Password".

b) Enter the current password in the "Old Password" field.
The default password is 123456.

c) Enter the new password in the "New Password" and "Confirm Password" fields.
d) Select "Change Password".

Disabling the LAN interface

1. Select "System Config > Setup > Security > Security > LAN Services > Main Ser-
vices".

2. Select "LAN > Off".

All LAN connections and hence all LAN services are disabled.

Disabling LAN services

1. Select "System Config > Setup > Security > Security > LAN Services > Main Ser-
vices".

2. Select, for example, "FTP > Off" or "VNC > Off".

3. Enter the Security Password.

4. Select "Accept".

Activating SMB version 1.0/2.0 client and server

By default, support of SMB client and SMB server of the SMB protocol versions 1.0
and 2.0 is deactivated.

Activate support only, if needed:

1. Select "System Config > Setup > Security > Security > LAN Services > Samba Ser-
vices".

2. Select "SMB 1.0/2.0 Client > On" and "SMB 1.0/2.0 Server > On".

3. Enter the Security Password.

4. Select "Accept".
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Disabling the frequency and level indication in the status bar

These settings are useful to prevent unauthorized personnel from reading the display,
when you remotely control the instrument from a different location.

1. Select "System Config > Setup > Security > General > Manual Operation".

2. Select "Annotation Frequency > Off" or "Annotation Amplitude > Off".

3. Enter the Security Password.

4. Select "Accept".

Deactivating the user interface

1. Select "System Config > Setup > Security > General > Manual Operation".

2. Select "User Interface > Disabled".

3. Enter the Security Password.

4. Select "Accept".

The screen shuts off and displays a padlock symbol  instead.
There are further possible configurations. For details, see "User Interface"
on page 135.

Unlocking (reactivating) the user interface for manual operation

1. In manual operation:

a) On the instrument's keypad or external keyboard, press any key.
The instrument prompts you to enter the security password for unlocking.

If you press the character of the first key, the input field accepts the character
immediately.

b) Delete the entry before inserting the password.
Enter the security password 123456.

2. In remote control mode:

a) Send the command SYST:ULOC ENABled to release all locks at once.
b) Send the command SYST:KLOC OFF to unlock the keyboard and touchscreen.
c) Send the command SYST:DLOC OFF to release all locks.

Via remote control, there is no password required.
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8.5  Undoing or Restoring Actions

"Undo" is a function that removes the effect of the last action on the instrument and
reverts it to an older state. Conversely, "Redo" restores a previously undone action.

You can "Undo/Redo" actions according to two criteria:
● Step by step

Gradually undo/redo the actions in reverse order as previously performed.
Depending on the available memory the "Undo/Redo" steps may restore all
actions.

● Multiple steps at once
Select any specific action in the history list to "Undo/Redo" multiple actions in a sin-
gle step.
Note: This mode requires a system restoration file on the instrument.

Access:

► Select "Setup > Settings > Undo/Redo".

The dialog contains all functions for enabling the "Undo/Redo" functionality.

Settings:

State............................................................................................................................145
History List.................................................................................................................. 145
Clear History............................................................................................................... 146
Apply........................................................................................................................... 146

State
Enables the recording of the performed actions.

History List
Lists the performed actions, provided "Undo/Redo" state is "On".

Undoing or Restoring Actions
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Clear History
Deletes the recorded list of the performed steps.

Apply
Performs the "Undo/Redo".

If you select a previously performed action of the list, all subsequent actions are
undone. The list entries remain.

If you select a subsequently executed action, you can restore all the actions undone up
to this state.

8.6  Shutting Down and Rebooting the Instrument

The [Power On/Standby] front panel key switches the instrument from the standby to
the ready state or vice versa. In remote operation from a remote computer or in manual
control, there is another possibility to shut down the instrument or to reboot the system.

Access:

► Select "System Config > Setup > Maintenance > Shut Down".

Remote command:
● :SYSTem:REBoot on page 266
● :SYSTem:SHUTdown on page 267

Shutting Down and Rebooting the Instrument
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9  Network Operation and Remote Control

The description in this section requires basic knowledge of the remote control opera-
tion. Definitions specified in the SCPI standard are not provided.
You find some basic information to the SCPI syntax, command lists, and general pro-
gramming recommendations in Chapter A.1, "Additional Basics on Remote Control",
on page 321.
See also Chapter A.1.5, "Status Reporting System", on page 333.

As an alternative to the interactive operation directly at the instrument, you can operate
the R&S AREG100A also from a remote location.

The Figure 9-1 shows the possibilities of the physical connection (interfaces) for the
remote access.

Figure 9-1: Supported remote connections

The various interfaces provide flexible access to the instrument, such as remote con-
trol, remote operation or remote file access. These remote access modes are funda-
mentally different, although they are often considered interchangeable.

See:
● Overview of Remote Access Modes
● 1GP72: Connectivity of Rohde&Schwarz Signal Generators
● Chapter 3.1.7, "Connecting to LAN", on page 23

9.1  Overview of Remote Access Modes

This section outlines the possible access modes and their major characteristics.

Overview of Remote Access Modes
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Network Operation and Remote ControlR&S®AREG100A

148User Manual 1178.7417.02 ─ 06

Remote control (SCPI)

● A remote PC controls the instrument, usually via VISA (Virtual Instrument Software
Architecture) interfaces.

● Remote control disables the manual operation of the instrument; you can set differ-
ent lock states.

● The GUI is not visible.
● Remote control commands (SCPI) perform the settings, either individually or in

sequences (SCPI programs).
● Using SCPI programs is faster than the manual operation, since they automate

repeating applications.

Remote operation (VNC)

● A remote device accesses the instrument via the common platform technology
VNC (Virtual Network Computing).

● The protocol allows simultaneous operation from several remote devices and the
instrument nevertheless remains locally operable.

● The GUI is visible.
● To perform the settings, you can operate the instrument as with the manual control.
● During remote operation via VNC, the direct control of the instrument is not dis-

abled.
You can control the instrument from the front panel and via the remote computer
alternately.

● Clients supporting remote operation depend on the used remote device, see
Table 9-1.

● How to: see Chapter 9.9, "Operating the R&S AREG100A Remotely via VNC",
on page 198.

Table 9-1: Supported VNC operation modes

Remote device VNC client Requirements Characteristics

Desktop

(Windows, Linux,
MacTMOS)

● Ultr@VNC
● Other dedicated client soft-

ware

Ultr@VNC or Client Software
must be installed.

Fast, supports several options like
full screen mode or auto-login.

 ● Any web browser Java Runtime must be installed
and activated in the browser set-
tings.

Fast and convenient - only the
instrument address required.

Java runtime is sometimes con-
sidered as security concern.

 ● Web browser with HTML5 Web sockets must be supported. Slower than the other modes.

No additional installation or acti-
vation required.

No security concern.

Smart device

(Tablet/ smartphone)

● Dedicated client App App must be installed. Fast, supports several options like
full screen mode or auto-login.

 ● Web browser with HTML5 Web sockets must be supported. Support of QR code scanning

Slower than a dedicated App.

Overview of Remote Access Modes
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Remote file access (FTP, SAMBA/SMB)

● A remote client accesses the instrument's file system, using the protocols FTP (file
transfer protocol) and SAMBA/SMB (server message block).

● The protocols enable you to transfer files from or to the instrument and to get direct
access to its file sharing directory share.

How to:

Chapter 7.7, "How to Transfer Files from and to the Instrument", on page 102.

"Activating SMB version 1.0/2.0 client and server" on page 143

9.2  Remote Control Interfaces and Protocols

The instrument supports various interfaces for remote control. The table gives an over-
view on the connectivity:

Table 9-2: Remote control interfaces and protocols

Interface Protocols, VISA*) address string and library Remarks

Local area network
(LAN)

● HiSLIP High-Speed LAN Instrument Protocol
(IVI-6.1)
TCPIP::host address::hislip0[::INSTR]
VISA

● VXI-11
TCPIP::host address[::
LAN device name][::INSTR]
VISA

● Socket communication (Raw Ethernet, simple
Telnet)
TCPIP::host address[::
LAN device name]::<port>::SOCKET
VISA or socket controller

The interface is based on TCP/IP and supports
various protocols.

For a description of the protocols, refer to:
● Chapter 9.2.1.2, "HiSLIP Protocol",

on page 152
● Chapter 9.2.1.3, "VXI-11 Protocol",

on page 152
● Chapter 9.2.1.4, "Socket Communication",

on page 152

USB ● USBTMC
USB::<vendor ID>::<product ID>::
<serial number>[::INSTR]
VISA

The USB In connector is at the rear panel of the
instrument.

For a description of the interface, refer to Chap-
ter 9.2.2, "USB Interface", on page 153

GPIB (IEC/IEEE Bus
Interface)

● –
GPIB::<address>[::INSTR] (no secondary
address)
VISA

Optional GPIB bus interfaces according to stan-
dard IEC 625.1/IEEE 488.1 are on the rear
panel of the instrument.

For a description of the interface, refer to Chap-
ter 9.2.3, "GPIB Interface (IEC/IEEE Bus Inter-
face)", on page 153.

*) VISA (Virtual Instrument Software Architecture) is a standardized software interface library providing input and output functions to
communicate with instruments. A VISA installation on the controller is a prerequisite for remote control over LAN (when using
VXI-11 or HiSLIP protocol), USB and serial interface. For remote control via socket communication VISA installation is optional. For
more information, see Chapter 9.3.1, "VISA Library", on page 155.
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Rohde & Schwarz provides the standardized I/O software library R&S VISA for com-
munication with the instruments via TCP/IP (LAN: HiSLIP, VXI-11 and raw socket) or
USB (USBTMC) interfaces.
R&S VISA is available for download at the Rohde & Schwarz website http://
www.rohde-schwarz.com/rsvisa.

How to configure the remote control interfaces is described in Chapter 9.7, "Controlling
the R&S AREG100A Remotely", on page 176.

SCPI (Standard Commands for Programmable Instruments)

SCPI commands - messages - are used for remote control. Commands that are not
taken from the SCPI standard follow the SCPI syntax rules. The instrument supports
the SCPI version 1999. The SCPI standard is based on standard IEEE 488.2 and aims
at the standardization of device-specific commands, error handling and the status reg-
isters. The tutorial "Automatic Measurement Control - A tutorial on SCPI and IEEE
488.2" from John M. Pieper (Rohde & Schwarz order number 0002.3536.00) offers
detailed information on concepts and definitions of SCPI.

Tables provide a fast overview of the bit assignment in the status registers. The tables
are supplemented by a comprehensive description of the status registers.

For more information, see also Chapter A.1, "Additional Basics on Remote Control",
on page 321.

9.2.1  LAN Interface

To be integrated in a LAN, the instrument is equipped with a LAN interface, consisting
of a connector, a network interface card and protocols.

For remote control via a network, the PC and the instrument must be connected via the
LAN interface to a common network with TCP/IP network protocol. The TCP/IP net-
work protocol and the associated network services are preconfigured on the instru-
ment. Software for instrument control and (for specified protocols only) the VISA pro-
gram library must be installed on the controller.

If several instruments are connected to the network, each instrument has its own IP
address and associated resource string. The controller identifies these instruments by
the resource string.

9.2.1.1  VISA Resource Strings

The VISA resource string is required to establish a communication session between
the controller and the instrument in a LAN. The resource string is a unique identifier,
composed of the specific IP address of the instrument and some network and VISA-
specific keywords.

Remote Control Interfaces and Protocols
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TCPIP = designates the network protocol
host address = designates the IP address or hostname of the instrument
[::LAN device name] = defines the protocol and the instance number of a subinstrument
[::INSTR] = indicates the instrument resource class (optional)

The IP address (host address/computer name) is used by the programs to identify and
control the instrument. It is automatically assigned by the DHCP server the first time
the device is registered on the network. Alternatively, you can also assign its LAN
device name.

If assigned, the IP address is displayed on home screen. You can adjust it manually
with the parameter the "System Config > Remote Access > Network" > IP AddressEna-
bling a locked user interface for manual operation.

The following section lists the characteristics of the VISA resource strings for the corre-
sponding interface protocols. The highlighted characters are crucial.

HiSLIP

hislip0 = HiSLIP device name, designates that the interface protocol HiSLIP is used (mandatory)

hislip0 is composed of [::HiSLIP device name[,HiSLIP port]] and must be
assigned.

For details of the HiSLIP protocol, refer to Chapter 9.2.1.2, "HiSLIP Protocol",
on page 152.

VXI-11

[::inst0] = LAN device name, indicates that the VXI-11 protocol is used (optional)

inst0 currently selects the VXI-11 protocol by default and can be omitted.

For details of the VXI-11 protocol, refer to Chapter 9.2.1.2, "HiSLIP Protocol",
on page 152.

Socket communication

port = determines the used port number
SOCKET = indicates the raw network socket resource class

Socket communication requires the specification of the port (commonly referred to as
port number) and of "SOCKET" to complete the VISA resource string with the associ-
ated protocol used.

The registered port for socket communication is port 5025.

See also Chapter 9.2.1.4, "Socket Communication", on page 152.

Remote Control Interfaces and Protocols
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9.2.1.2  HiSLIP Protocol

The HiSLIP (High Speed LAN Instrument Protocol) is the successor protocol for
VXI-11 for TCP-based instruments specified by the IVI foundation. The protocol uses
two TCP sockets for a single connection - one for fast data transfer, the other for non-
sequential control commands (e.g. Device Clear or SRQ).

HiSLIP has the following characteristics:

● High performance as with raw socket network connections
● Compatible IEEE 488.2 support for Message Exchange Protocol, Device Clear,

Serial Poll, Remote/Local, Trigger, and Service Request
● Uses a single IANA registered port (4880), which simplifies the configuration of fire-

walls
● Supports simultaneous access of multiple users by providing versatile locking

mechanisms
● Usable for IPv6 or IPv4 networks

Using VXI-11, each operation is blocked until a VXI-11 device handshake returns. How-
ever, using HiSLIP, data is sent to the device using the "fire and forget" method with
immediate return. Thus, a successful return of a VISA operation such as viWrite()
does not guarantee that the instrument has finished or started the requested com-
mand, but is delivered to the TCP/IP buffers.

For more information see also the application note:

1MA208: Fast Remote Instrument Control with HiSLIP

9.2.1.3  VXI-11 Protocol

The VXI-11 standard is based on the ONC RPC (Open Network Computing Remote
Procedure Call) protocol which in turn relies on TCP/IP as the network/transport layer.
The TCP/IP network protocol and the associated network services are preconfigured.
TCP/IP ensures connection-oriented communication, where the order of the
exchanged messages is adhered to and interrupted links are identified. With this proto-
col, messages cannot be lost.

9.2.1.4  Socket Communication

An alternative way for remote control of the software is to establish a simple network
communication using sockets. The socket communication, also referred to as "Raw
Ethernet communication", does not necessarily require a VISA installation on the
remote controller side. It is available by default on all operating systems.

The simplest way to establish socket communication is to use the built-in telnet pro-
gram. The telnet program is part of every operating system and supports a communi-
cation with the software on a command-by-command basis. For more convenience and
to enable automation by means of programs, user-defined sockets can be program-
med.
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Socket connections are established on a specially defined port. The socket address is
a combination of the IP address or the host name of the instrument and the number of
the port configured for remote-control. All R&S AREG100A use port number 5025 for
this purpose. The port is configured for communication on a command-to-command
basis and for remote control from a program.

9.2.2  USB Interface

For remote control via the USB connection, the PC and the instrument must be con-
nected via the USB type B interface. A USB connection requires the VISA library to be
installed. VISA detects and configures the R&S instrument automatically when the
USB connection is established. You do not have to install a separate driver.

USBTMC (USB Test & Measurement Class Specification) is a protocol that is built on
top of USB for communication with USB devices. It defines class code information of
the instrument, that identifies its functionality to load the respective device driver. Using
VISA library, it supports service request, triggers, and other specific operations.

9.2.2.1  USB Resource String

The resource string represents an addressing scheme that is used to establish a com-
munication session with the instrument. It is based on the instrument address and
some instrument- and vendor-specific information.

The USB resource string syntax is as follows:

USB = denotes the used interface
<vendor ID> = is the manufacturer ID for Rohde & Schwarz
<product ID> = is the product identification of the instrument
<serial number> = is the individual serial number on the rear of the instrument
[::INSTR] = indicates the instrument resource class (optional)

To set the USB resource string, see Remote Access Settings.

Example: 
USB::0x0AAD::0x01e1::100001
0x0AAD is the vendor ID for Rohde & Schwarz.
0x01e1 is the product ID for the R&S AREG100A
100001 is the serial number of the particular instrument.

9.2.3  GPIB Interface (IEC/IEEE Bus Interface)

To be able to control the instrument via the GPIB bus, the instrument and the controller
must be linked by a GPIB bus cable. A GPIB bus card, the card drivers and the pro-
gram libraries for the programming language used must be provided in the controller.

Remote Control Interfaces and Protocols
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GPIB address

The controller must address the instrument with the GPIB bus channel (see Chap-
ter 9.4.3, "GPIB Address Settings", on page 162). GPIB provides channel addresses
from 0 to 30.

The GPIB resource string syntax is as follows:

GPIB = denotes the used interface
<channel address> = the used channel
[::INSTR] = indicates the instrument resource class (optional)

Note: If the VISA implementation supports the GPIB interface, you can optionally
define the VISA Instrument Control Resource (INSTR). It is used to define the basic
operations and attributes for a device, such as reading, writing, or triggering.

Notes and characteristics

In connection with the GPIB interface, note the following:
● Up to 15 instruments can be connected.
● The total cable length is restricted to a maximum of 15 m, or 2 m times the number

of devices, whichever is less. The maximum recommended cable length between
two instruments is 2 m.

● A wired "OR"-connection is used if several instruments are connected in parallel,
since the slowest instrument determines the speed.

● Any connected IEC bus cable must be terminated by an instrument or controller.

9.2.4  LXI Browser Interface

The LXI browser interface allows easy configuration of the LAN and remote control of
the R&S AREG100A without additional installation requirements. The instrument's LXI
browser interface works correctly with all W3C compliant browsers.

See Chapter 9.10.1, "LXI Functionality", on page 204 for more about LXI.

The LAN settings are configured using the instrument's LXI browser interface descri-
bed in Chapter 9.5.2.1, "LAN Configuration", on page 169. The LXI status settings in
the R&S AREG100A are described in Chapter 9.5.1, "LXI Status Settings",
on page 167.

9.3  Remote Control Programs and Libraries

This section shows how the remote-control programs access the instrument, and the
libraries they require for the appropriate interface protocols.

Remote Control Programs and Libraries
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Figure 9-2: Overview of remote control interfaces, protocols and libraries

9.3.1  VISA Library

VISA is a standardized software interface library providing input and output functions to
communicate with instruments. Thus, you can configure the interface without having to
adjust the application program to the used interface.

The I/O channel (LAN or TCP/IP, USB, GPIB, etc.) is selected at initialization time with
the channel–specific address string ("VISA resource string"), or by an appropriately
defined VISA alias (short name). See also Table 9-2 for an overview.

Instrument access via VXI-11 or HiSLIP protocols is achieved from high level program-
ming platforms using VISA as an intermediate abstraction layer. VISA encapsulates the
low-level VXI or GPIB function calls and thus makes the transport interface transparent
for the user.

A VISA installation is a prerequisite for remote control using the following interfaces:
● LAN interface using HiSLIP Protocol
● LAN interface using VXI-11 Protocol
● USB Interface

Instrument access via the LAN socket protocol or GPIB connections can be operated
both, with or without the VISA library. See also Chapter 9.2.1.4, "Socket Communica-
tion", on page 152 and Chapter 9.2.3, "GPIB Interface (IEC/IEEE Bus Interface)",
on page 153.

For more information about VISA library, refer to the user documentation.

9.3.2  Possible Setups and Access Functions

The following examples give an overview of dependencies between the available libra-
ries, the possible interfaces and protocols, and whether an instrument driver is provi-
ded. The involved parts are highlighted. For more information, see the application
note 1GP72: Connectivity of Rohde&Schwarz Signal Generators.
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● Remote control (application) program using VISA

Figure 9-3: Application program using VISA

Protocol Remote control program

Socket viOpen (..., "TCPIP:AREG100A-102030::5025::SOCKET", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

VXI-11 viOpen (..., "TCPIP:AREG100A-102030::inst0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

HiSLIP viOpen (..., "TCPIP:AREG100A-102030::hislip0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

USBTMC viOpen (..., "USB::0x0AAD::0x01e1::100001::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

GPIB viOpen (..., "GPIB::28::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

● Remote control program using instrument driver (VISA available)

Figure 9-4: Application using instrument driver (VISA available)
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Protocol Remote control program

Socket rsareg_init ("TCPIP:AREG100A-102030::5025::SOCKET", ...)
rsareg_SetFrequency (..., 2e9)

VXI-11 rsareg_init ("TCPIP:AREG100A-102030::inst0::INSTR", ...)
rsareg_SetFrequency (..., 2e9)

HiSLIP rsareg_init ("TCPIP:AREG100A-102030::hislip0::INSTR", ...)
rsareg_SetFrequency (..., 2e9)

USBTMC rsareg_init ("USB::0x0AAD::0x01e1::100001::INSTR", ...)
rsareg_SetFrequency (..., 2e9)

GPIB rsareg_init ("GPIB::28::INSTR", ...)
rsareg_SetFrequency (..., 2e9)

● Remote control program using instrument driver (VISA not available)

Figure 9-5: Remote control program using instrument driver (VISA not available)

Protocol Remote control program

Socket rsareg_init ("TCPIP:AREG100A-102030::5025::SOCKET", ...)
rsareg_SetFrequency (..., 2e9)

GPIB rsareg_init ("GPIB::28::INSTR", ...)
rsareg_SetFrequency (..., 2e9)

9.4  Remote Access Settings

This section outlines the settings required for accessing and configuring the provided
remote control interfaces. It includes network settings, access addresses, emulation
settings for using the command sets of other generators, and the access via smart
devices.

Remote Access Settings
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About instrument emulations

You can also remotely control the R&S AREG100A via the command set of another
signal generator. With this function you can, for example, replace a signal generator
with an R&S AREG100A in an automated test setup, without adjusting the command
scripts used.

You find all the remote control command sets supported by the R&S AREG100A in a
selection list.

The selected instrument also defines the identification string that is retrieved with query
*IDN?. If necessary, use the parameter Mode and IDN String to change this string.

As any other parameter, the remote control command set can also be changed
remotely by the command :SYSTem:LANGuage.

While working in an emulation mode, the R&S AREG100A specific command set is
disabled and the SCPI command :SYSTem:LANGuage is discarded.

To return to the SCPI command set of the R&S AREG100A, use the appropriate com-
mand of the selected command set.

9.4.1  Network Settings

Access:

► Select "System Config > Remote Access > Network".

In the "Network" dialog, you can configure the settings of the general network envi-
ronment and specific identification parameters of the instrument in the network.

Remote Access Settings
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The remote commands required to configure the network remotely are described in
Chapter 10.12, "SYSTem Subsystem", on page 243.

How to: see Chapter 9.6.3, "How To Connect to LAN", on page 174.

Network Status
Indicates that the instrument is connected to the network.

Remote command: 
:SYSTem:COMMunicate:NETWork:STATus? on page 255

Restart Network
Terminates the network connection of the instrument and subsequently sets it up
again. You can use this function to fix network problems.

Note: This function restarts only the connection of the instrument to the network. It
does not impact the network itself.

Remote command: 
:SYSTem:COMMunicate:NETWork:RESTart on page 254

Hostname
Displays the hostname.

Each instrument is delivered with an assigned hostname, a logical name which can be
used instead of the IP address. With the default network settings, the IP address is
allocated by the DHCP server. This address can change each time the instrument is
reconnected. Unlike the IP address, the hostname name does not change.

Note:
This function is password-protected. Unlock the protection level 1 to access it.
● We recommend that you do not change the default network settings or the host-

name to avoid problems with the network connection.
If you change the hostname, be sure to use a unique name.

Remote command: 
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname on page 255

Workgroup
Sets the individual windows workgroup name of the R&S AREG100A. This parameter
is required in case the instrument is integrated in a windows network.

This function is password-protected. Unlock the protection level 1 to access it.

Remote command: 
:SYSTem:COMMunicate:NETWork[:COMMon]:WORKgroup on page 255

Address Mode
Selects the mode for assigning the IP address.

How to: see Chapter 9.6.4, "How to Assign the IP Address", on page 175.

"Auto (DCHP)"
Assigns the IP address automatically, provided the network supports
DHCP (Dynamic Host Configuration Protocol).

"Static" Enables you to assign the IP address manually.
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Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress:MODE on page 254

IP Address
Displays the IP address of the instrument in the network.

By default, the R&S AREG100A is configured to use dynamic TCP/IP configuration
and to obtain the whole address information automatically.

If the network does not support DHCP or the attempt does not succeed, the instrument
tries to obtain the IP address via Zeroconf (APIPA) protocol. IP addresses assigned via
Zeroconf start with the number blocks 169.254.*.*.

Note: An IP address that is assigned via the Zeroconf protocol although the network
requires an IP address assigned via the DHCP server can cause network connection
failures.
How to:
● "To assign the IP address manually on the instrument" on page 175.
● Chapter 9.6.2, "How To Activate LAN Services", on page 174.

Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress on page 253

Subnet Mask
Displays the bit group of the subnet in the host identifier.

To assign the subnet mask manually, select Address Mode > "Static".

Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK on page 256

Default Gateway
Displays the gateway address.

This address identifies the router on the same network as the instrument that is used to
forward traffic to destinations beyond the local network.

To assign the gateway address manually, select Address Mode > "Static".

Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway on page 256

DNS Suffix
Displays the primary DNS (Domain Name System) suffix, that means the DNS name
without the hostname part.

The DNS system uses the suffix for registration and name resolution for unique identifi-
cation of the instrument in the entire network.

To assign the DNS suffix manually, select Address Mode > "Static".

Remote command: 
:SYSTem:COMMunicate:NETWork[:COMMon]:DOMain on page 255

DNS Server
Determines the preferred server for name resolution. The DNS server contains the
underlying numerical values that are required for name resolution of the hostname as
part of the IP address.

Remote Access Settings



Network Operation and Remote ControlR&S®AREG100A

161User Manual 1178.7417.02 ─ 06

To select the DNS server manually, select Address Mode > "Static".

Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:DNS on page 256

MAC Address
Indicates the MAC (Media Access Control) address, a unique identifier of the network
adapter in the R&S AREG100A.

Remote command: 
:SYSTem:COMMunicate:NETWork:MACaddress on page 254

9.4.2  VISA Resource Strings

Access:

► Select "System Config > Remote Access > Visa Resource Strings".

The "Visa Resource String" dialog displays the VISA resource strings provided for
remote control via the different interfaces.

Remote command:

:SYSTem:COMMunicate:HISLip:RESource? on page 253

:SYSTem:COMMunicate:NETWork:RESource? on page 254

:SYSTem:COMMunicate:SOCKet:RESource? on page 257

:SYSTem:COMMunicate:GPIB:RESource? on page 253
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:SYSTem:COMMunicate:USB:RESource? on page 257

:SYSTem:COMMunicate:SERial:RESource? on page 257

9.4.3  GPIB Address Settings

Access:

1. Select "System Config > Remote Access > GPIB Address".

2. Set the GPIB channel address of the connected instrument.

Remote command:

:SYSTem:COMMunicate:GPIB[:SELF]:ADDRess on page 253

9.4.4  RS232 Settings

Access:

► Select "System Config > Remote Access > RS232".

The "RS232" dialog enables you to control the instrument over a serial interface
using a USB adapter. The controller and the instrument must be connected with
the external USB/serial-adapter R&S TS1-USB (see recommended extras in the
data sheet) and a serial crossover (null modem) cable. The USB connection
requires the Visa library to be installed on the controller. Visa detects and config-
ures the R&S AREG100A automatically when the USB connection is established.

The remote commands required to configure the emulation settings remotely are
described in Chapter 10.12, "SYSTem Subsystem", on page 243.
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Baud Rate
Sets the baudrate for the serial remote control interface.

Remote command: 
:SYSTem:COMMunicate:SERial:BAUD on page 256

Parity
Sets the parity for the serial remote control interface.

Remote command: 
:SYSTem:COMMunicate:SERial:PARity on page 256

Stop Bits
Sets the number of stop bits for the serial remote control interface.

Remote command: 
:SYSTem:COMMunicate:SERial:SBITs on page 257

9.4.5  Instrument Emulations Settings

Access:

► Select "System Config > Remote Access > Instrument Emulations".

The "Instrument Emulations" dialog enables you to emulate a remote control com-
mand set of another signal generator.

The remote commands required to configure the emulation settings remotely are
described in Chapter 10.12, "SYSTem Subsystem", on page 243.
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Language
Selects the instrument whose remote command set is emulated by the
R&S AREG100A.

Remote command: 
:SYSTem:LANGuage on page 259

Mode
Selects the way the instrument identification is performed.

"Automatic" Sets the "IDN String" and the "OPT String" automatically for the
instrument selected with the parameter Language.

"User Defined" Enables you to define the "IDN String" and the "OPT String".

Remote command: 
:SYSTem:IDENtification on page 258

Set to Default
In "Mode > User Defined", resets the *IDN and *OPT strings.

Remote command: 
:SYSTem:IDENtification:PRESet on page 258

IDN String
Indicates the identification string of the instrument when queried with the common
command *IDN?.

In addition to the preset values, you can define your own identification string so that
each generator uses an individual identification, like My_SigGen for instance, see
Mode .

Remote command: 
*IDN? on page 211
:SYSTem:IRESponse on page 259

OPT String
Indicates the option string of the instrument as queried with common command *OPT?.

In Mode > "User Defined", you can define your own option string, additionally to the
automatically created one.

Remote command: 
*OPT? on page 212
:SYSTem:ORESponse on page 259

9.4.6  Remote Connections Settings

The "Remote Connections" dialog covers the active SCPI and TCP/IP connections,
and a history list of the connections that have accessed the instrument before.

Remote Access Settings
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9.4.6.1  Active Connections

Access:

► Select "System Config > Remote Access > Remote Connections > Active".

The "Active " tab shows the currently active remote connections, and you can
enable the display of the active connections in the task bar.

Show Remote Connections in Taskbar
Displays the currently active connections in the taskbar.

SCPI Connections
Displays the VISA resources strings of the remote connections currently controlling the
instrument via the LAN interface.

Remote command: 
n.a.

TCP/IP Connections
Displays the types and client addresses of the remote connections curently controlling
the instrument via the LAN interface.

Remote command: 
n.a.

Remote Access Settings
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9.4.6.2  Closed Connections

Access:

► Select "System Config > Remote Access > Remote Connections > Closed".

The "Closed" tab shows the currently active remote connections, and you can
enable the display of the active connections in the task bar.

SCPI Connections
Lists the VISA resource strings of the last remote connections that have accessed the
instrument via the LAN interface before.

Remote command: 
n.a.

TCP/IP Connections
Lists the types and client addresses of the last remote connections that had accessed
the instrument via the LAN interface before.

Remote command: 
n.a.

9.4.7  QR Code

Access:

► Select "System Config > Remote Access > QR Code".
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The "QR Code" dialog shows the current instrument address (IP address) in quick
response (QR) format.

This functionality provides fast access to the instrument via VNC with, for example, a
smartphone or a tablet.

See Chapter 9.9.3, "How To Set Up a Remote Operation from a Smart Device",
on page 201.

9.5  LXI Settings

On the R&S AREG100A the LXI functionality is already installed and enabled, see LXI
Status Settings. Thus, the instrument can be accessed via any web browser (like the
Microsoft Internet Explorer) to perform the following tasks:
● Modifying network configurations
● Remote control the instrument
● Performing SCPI remote diagnostics

The LAN settings are configured using the instrument's LXI browser interface descri-
bed in Chapter 9.5.2.1, "LAN Configuration", on page 169.

9.5.1  LXI Status Settings

Access:

► Select "System Config > Setup > Remote Access > LXI Status...".

LXI Settings
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The "LXI - Status" dialog shows the parameters of the LAN connection.

Alternatively, you can change the LAN settings using the LXI web browser interface,
see Chapter 9.5.2.1, "LAN Configuration", on page 169.

LAN Status
The LED indicates the LXI status.

"green" Normal operation

"green (flashing)"
Device identification

"red" LAN fault

Hostname / MAC Address / IP Address
See "Hostname" on page 159.

LAN Reset
Initiates the network configuration reset mechanism for the instrument and resets the
hostname, MAC address, and IP address.

According to the LXI standard, a LAN reset must place the following network settings
to a default state:

Parameter Value

TCP/IP mode DHCP + Auto IP address

Dynamic DNS Enabled

ICMP ping Enabled

Password for LAN configuration LxiWebIfc

The LAN reset also resets the following parameters for the Automotive Radar Echo
Generator:

LXI Settings
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Parameter  

Hostname Instrument-specific hostname

Description Automotive radar echo generator

Negotiation Auto detect

VXI-11 discovery Enabled

9.5.2  LXI Browser Settings

To access the instrument via the web browser:

► In the address field of the browser on your PC, type the instrument's host name or
IP address, for example http://10.113.1.151.
Note: Do not add the missing zeros in the IP address, while opening the instru-
ment homepage.

The instrument homepage (welcome page) opens.

The navigation pane of the browser interface contains the following elements:
● "LXI"

– "Home" opens the instrument homepage.
The homepage displays the device information required by the LXI stan-
dard, including the VISA resource string in read-only format.

– "Device Indicator" activates or deactivates the LXI status indication.
When activated, the LXI LEDs flash, both in the browser dialog and in the
LXI dialog of the connected instrument, see LAN Status. A green LXI status
symbol indicates that a LAN connection has been established; a red sym-
bol indicates that no LAN cable is connected.

– "Lan Configuration" allows you to configure LAN parameters and to initiate
a ping, see "Ping Client" on page 171.

– "Status" displays information about the LXI status of the instrument.
– "Utilities" provides access to the LXI event log functionality required by the

LXI standard.
● "Instrument Control"

– "Web Control" provides remote access to the instrument, see "Starting a
remote control via the LXI web browser" on page 178.

● "Diagnostics"
– "SCPI Remote Trace" records messages exchanged via the remote control

interface, see "SCPI Remote Trace" on page 172.
● "Help"

– "Glossary" explains terms related to the LXI standard.
– www.rohde-schwarz.com opens the Rohde & Schwarz homepage.

9.5.2.1  LAN Configuration

The "LAN Configuration" web page displays all mandatory LAN parameters and allows
their modification.

LXI Settings
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It comprises the following navigation entries.

● IP Configuration.................................................................................................... 170
● Advanced Config...................................................................................................170
● Ping Client.............................................................................................................171
● SCPI Remote Trace.............................................................................................. 172

IP Configuration

The "IP configuration" web page displays all mandatory LAN parameters and allows
their modification.

The "IP Address Mode" selects a configuration mode for the IP address of the instru-
ment. With static configuration, the entered IP address, subnet mask, and default gate-
way are used. With dynamic configuration, DHCP or dynamic link local addressing
(automatic IP) is used to obtain the instrument IP address.

Changing the LAN configuration
This function is password-protected. Unlock the protection level 1 to access it.
Note: We recommend that you change the default password before connecting the
instrument to a network.
How to:
● "Changing the default user password of the instrument" on page 142.
● "Changing the default security password" on page 143.

See Chapter 8.4.4, "Password Management", on page 139.

Advanced Config

The "Advanced Config" web page provides LAN settings that are not declared manda-
tory by the LXI standard.

LXI Settings
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The following advanced parameters are available:
● "mDNS and DNS-SD": The additional protocols "multicast DNS" and "DNS service

discovery" are used for device communication in zero configuration networks,
working without DNS and DHCP.

● "ICMP Ping": Must be enabled to use the ping utility.
If you disable this setting, the instrument does not answer ping requests. The set-
ting does not affect the LXI ping client. You can ping other hosts from the instru-
ment, even if the setting is disabled.

● "VXI-11 Discovery": Must be enabled to detect the instrument in the LAN.
If you disable this setting, the instrument cannot be detected by the VXI-11 discov-
ery protocol mechanism. The setting does not affect other detection mechanisms.
Setting up a VXI-11 connection via the IP address or the host name is independent
of this setting.

Changing the LAN configuration
This function is password-protected. Unlock the protection level 1 to access it.
Note: We recommend that you change the default password before connecting the
instrument to a network.
How to:
● "Changing the default user password of the instrument" on page 142.
● "Changing the default security password" on page 143.

See Chapter 8.4.4, "Password Management", on page 139.

Ping Client

The "Ping Client" page provides the ping utility to verify the connection between the
LXI-compliant instrument and another device.

LXI Settings
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The ping is initiated from the instrument. Using the ICMP echo request and echo reply
packets, this function checks whether the communication with a device via LAN is
working. Ping is useful for the diagnosis of IP network or router failures.

To initiate a ping at the instrument:

1. On the "Ping Client" page, enter the IP address of the host in the "Destination
Address" field (for example 10.113.1.151).

2. Select "Submit".

SCPI Remote Trace

The remote trace functionality allows you to trace input and output strings at the
remote control interface of the R&S AREG100A, see Chapter 9.7.8, "How to Trace
Messages with the LXI Web Browser Interface", on page 186.

A recorded trace (message log) can be evaluated directly in the dialog. Use the high-
lighting and navigation functions provided by the lower toolbar to locate error mes-
sages and messages containing arbitrary search strings. You can also export the mes-
sage log to a *.csv file and evaluate the file using a suitable program.

To trace and display messages, switch on "logging" and "live mode" in the toolbar.

Toolbars

The toolbar at the top of the dialog provides basic settings and functions.

● "Live mode" / "logging": If logging is switched on, messages are traced. They are
stored in an internal database and can be displayed upon request, using the
refresh button (live mode off) or they can be displayed automatically (live mode
on).
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● "Filter": applies a filter to columns and/or rows when working (live mode off)
● "Refresh": reads the message log from the internal database and displays it
● "Download": stores the SCPI trace log to a *.csv file
● "Clear": deletes all message log entries in the database and at the screen
● "Details": displays details of the selected message, for example an SCPI command

in hex format (also possible by double\-clicking a message)

Columns

The following columns are available if no column filter is applied:

● "Rec": record number of the message within the message log
● I: number of the subinstrument
● "MT": indicates the type of the message. Possible values and related message

contents are:
– > = incoming command
– < = outgoing response to a query
– E = error message, highlighted by red color
– T = execution time, i.e. time required by the instrument to process the com-

mand internally.
● "message": indicates the type of the message. Possible values and related mes-

sage contents are:
– > = incoming command
– < = outgoing response to a query
– E = error message, denoted in red
– T = execution time, i.e. time required by the instrument to process the com-

mand internally

9.6  Connecting the Instrument to the Network (LAN)

The R&S AREG100A is equipped with a network interface and can be connected to an
Ethernet LAN (local area network).

There are two methods to establish a LAN connection to the instrument:
● A non-dedicated network (Ethernet) connection from the instrument to an existing

network
● A dedicated network connection (Point-to-point connection) between the instru-

ment and a single computer

For addressing, both the instrument and the computer require an IP address. The
address information is usually assigned to the devices automatically, see Chap-
ter 9.6.4, "How to Assign the IP Address", on page 175.
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● How To Enable Access via LAN............................................................................174
● How To Activate LAN Services..............................................................................174
● How To Connect to LAN........................................................................................174
● How to Assign the IP Address...............................................................................175
● How to Use Computer Names (Hostnames).........................................................175

9.6.1  How To Enable Access via LAN

Per default, the LAN interfaces on the instrument are enabled.

If they have been disabled because of security reasons, enable them as follows:

1. Select "Setup > Security > LAN Services > LAN Interface = On".

2. Enter the Security Password.

3. Select "Accept".

9.6.2  How To Activate LAN Services

Per default, the LAN interfaces and all LAN services are enabled.

If they have been disabled because of security reasons, enable them as follows:

1. Select "Setup > Security > LAN Services".

2. Enable the required service, e.g. "LAN Services > FTP > On".

3. Enter the Security Password.

4. Select "Accept".

See Chapter 8.4.5, "How to Prevent Unauthorized Access", on page 142.

9.6.3  How To Connect to LAN

1. NOTICE! Connecting to the network can cause network failure. Errors can affect
the entire network.
Consult your network administrator before performing the following tasks:
● Connecting the instrument to the network
● Configuring the network
● Changing IP addresses

2. Connect the LAN socket on the rear panel via an RJ-45 cable to the LAN.

The R&S AREG100A displays its IP address on the screen.
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9.6.4  How to Assign the IP Address

Depending on the network capacities, the TCP/IP address information for the instru-
ment can be obtained in different ways.
● If the network supports DHCP (dynamic host configuration protocol), the address

information is assigned automatically.
● If the network does not support DHCP, the instrument tries to obtain the IP address

via Zeroconf (APIPA) protocol. If this attempt does not succeed or if the instrument
is set to use alternate TCP/IP configuration, the addresses must be set manually.

Since the dynamic TCP/IP configuration assigns the address information automatically,
it is safe to establish a physical connection to the LAN without any previous instrument
configuration.

To assign the IP address manually on the instrument

1. NOTICE! Connecting to the network can cause network failure. Errors can affect
the entire network.
Consult your network administrator before performing the following tasks:
● Connecting the instrument to the network
● Configuring the network
● Changing IP addresses

2. Select "System Config > Remote Access > Network".

3. Select "Address Mode > Static".

4. Select the "IP Address".

5. Enter the IP address, for example 192.168.0.1.

The IP address consists of four number blocks separated by dots. Every block con-
tains 3 numbers in maximum.

6. Select the "Subnet Mask" and enter the subnet mask, for example 255.255.255.0.

The subnet mask consists of four number blocks separated by dots. Every block
contains 3 numbers in maximum.

To assign the IP address manually on the computer

► Obtain the necessary information from your network administrator. If you use more
than one LAN connector, you need separate address information for each connec-
tor.
For information on how to perform the configurations, refer to the documentation of
the operating system the computer uses.

9.6.5  How to Use Computer Names (Hostnames)

In a LAN that uses a DNS server, each PC or instrument connected in the LAN can be
accessed via an unambiguous computer name (hostname) instead of the IP address.
The DNS server translates the hostname to the IP address. It is especially useful when
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a DHCP server is used, as a new IP address can be assigned each time the instru-
ment is restarted.

Each instrument is delivered with an assigned computer name, that remains perma-
nent as long as it is not explicitly changed.

The default computer name follows the syntax <INST>-<Serial Number>, where:
● <INST> is the short name of your instrument, as stated on the front panel.
● <Serial Number> is the individual serial number of the instrument.

You can find the serial number at the rear panel of instrument. It is the third part of
the device ID printed on the barcode sticker .

Example: 
The default hostname of an R&S AREG100A with a serial number 102030 is
AREG100A-102030.

To query and change a computer name

1. Select "System Config > Remote Access > Network".

The computer name is displayed under "Hostname".

2. Select "System Config > Setup > Security > Protection".

3. Enable the "Protection Level 1".
The default password is 123456.

The parameter "Hostname" in the "Network" tab is now enabled for configuration.

4. Change the "Hostname".

9.7  Controlling the R&S AREG100A Remotely

This section shows you how to set up remote control connections over the available
interfaces.

The following general prerequisites must be fulfilled:
● The instrument and the controller have to be connected with the suitable cable and

switched on.
See Chapter 9.6, "Connecting the Instrument to the Network (LAN)", on page 173.

● To operate the instrument via remote control, it must be addressed using the
defined interface address.
See:
– Chapter 9.2.1, "LAN Interface", on page 150
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– Chapter 9.2.2, "USB Interface", on page 153
– Chapter 9.2.3, "GPIB Interface (IEC/IEEE Bus Interface)", on page 153
– Chapter 9.7.1, "How to Find the VISA Resource String", on page 177

● A remote control program must open a connection to the instrument, before it can
send commands to and receive device responses from the instrument.

If security is a concern, see:
● Document instrument security procedures.
● Chapter 8.4.5, "How to Prevent Unauthorized Access", on page 142.

● How to Find the VISA Resource String.................................................................177
● How to Change the GPIB Instrument Address......................................................178
● Establishing a Remote Control Connection over the LXI Browser Interface.........178
● Establishing a Remote Control Connection over LAN Using VXI-11 Protocol...... 179
● Establishing a Remote Control Connection over LAN Using Socket Communication

.............................................................................................................................. 184
● Setting Up a Remote Control Connection over GPIB........................................... 185
● Setting Up a Remote Control Connection over USB.............................................186
● How to Trace Messages with the LXI Web Browser Interface.............................. 186
● How to Return to Manual Operation......................................................................187

9.7.1  How to Find the VISA Resource String

► Select "System Config > Remote Access > VISA Resource Strings".

The dialog shows all specified resource strings of the supported remote control
interfaces.
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Note: Using the RS232 serial interface via USB requires the USB serial adapter
R&S TS-USB1.

9.7.2  How to Change the GPIB Instrument Address

To control the instrument remotely via the GPIB bus, it must be addressed using the
GPIB address. The remote control address is factory-set to 28, but it can be changed if
it does not fit in the network environment. For remote control, addresses 0 through 30
are allowed. The GPIB address is maintained after a reset of the instrument settings.

To set the GPIB address:

1. Select "System Config > Remote Access > GPIB Address".

2. Select "GPIB Channel Address" and enter a value between 0 and 30.

Risk of losing remote connection
If the remote access and network settings had been configured to values different to
the default, executing a factory preset via remote control terminates the connection to
the instrument.

9.7.3  Establishing a Remote Control Connection over the LXI Browser
Interface

Via the LXI browser interface to the R&S AREG100A one or more users can control
the instrument remotely from another PC without additional installation. Most instru-
ment controls are available via the front panel simulation. File upload and download
between the instrument and the remote PC is also available.

Starting a remote control via the LXI web browser

1. On the instrument, enable the LAN interface.
See Chapter 9.6.1, "How To Enable Access via LAN", on page 174.

2. Connect the remote PC and the instrument in the same network.
See Chapter 9.6.3, "How To Connect to LAN", on page 174.

3. On the remote PC, start a web browser that supports HTML5 (W3C compliant).

4. Enter the IP address of the R&S AREG100A in the browser's address bar.

The R&S AREG100A's welcome page is displayed.

5. In the navigation pane, select "Instrument Control" > "Web Control".

Remote access to the instrument requires the password. The default password is
instrument.

6. Enter the password and confirm with the [Enter] key.

After the connection is established, the current screen of the R&S AREG100A is
displayed in the browser window.
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7. Use the mouse cursor and keyboard to access the functionality of the instrument
as you would directly perform on the instruments touchscreen and front panel.

9.7.4  Establishing a Remote Control Connection over LAN Using VXI-11
Protocol

In this example, the I/O software library R&S VISA from Rohde & Schwarz is used to
set up a LAN remote control link and remotely control the R&S AREG100A. R&S VISA
is running on a controller PC with Windows operating system. When the connection is
set up, you can send commands to the instrument and receive the responses.

The remote control connection requires a VISA installation but no additional hardware
on the controller PC. The LAN I/O channel is selected at initialization time using the
VISA resource string (also referred to as "address string"). A VISA alias (short name) is
used to replace the complete resource string. The host address is the
R&S AREG100A's hostname or its IP address.

See also Chapter 9.2.1, "LAN Interface", on page 150.

Setting up the controller with R&S VISA

To remote control the R&S AREG100A, we use the R&S VISA Tester application. The
application communicates via TCP/IP protocol.

The instrument is preconfigured for networks using DHCP (dynamic host configuration
protocol). If this configuration is used, enter the computer name in the position of the IP
address.

1. On the instrument:

a) Enable the LAN interface.
See Chapter 9.6.1, "How To Enable Access via LAN", on page 174.

b) Enable "SCPI over LAN".
See Chapter 9.6.2, "How To Activate LAN Services", on page 174.

2. On the controller (remote PC), install the R&S VISA program.
See http://www.rohde-schwarz.com/rsvisa > "RS VISA Release Notes".

3. Connect the controller and the instrument in the same network (network cable).
Switch them on.
See also Chapter 9.6.3, "How To Connect to LAN", on page 174.

4. On the controller, start "R&S VISA > Tester 32bit" or "R&S VISA > Tester 64bit".

Controlling the R&S AREG100A Remotely
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5. In the menu bar, select "Choose VISA Implementation > Rohde & Schwarz Visa"
and confirm with "OK".

6. In the menu bar, select "Find Resource" to search for the instrument in the LAN.

7. Select "VXI-11" and "Find Resources".

R&S VISA scans the network for connected instruments and lists all detected
instruments in the "Resource" list.
Note: The search may take some time, particularly in large networks.

8. Select the required instrument and confirm with "Select".
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The "Find and select resource" dialog closes and R&S VISA indicates the IP
address in the "Resource" field of the main application window.

9. As an alternative to the IP address, you can assign an alias name to the
R&S AREG100A:

a) In the menu bar, select "RsVisaConfig".

b) In the toolbar, select "+" to access the "VISA Resource String Composer".

Controlling the R&S AREG100A Remotely



Network Operation and Remote ControlR&S®AREG100A

182User Manual 1178.7417.02 ─ 06

c) Fill in the "Alias" name, the "VISA Resource String" and the "Device IP Address
or host name" as shown in the figure, and confirm with "OK".

The "Alias" name is assigned.

d) Close the dialog.
The R&S AREG100A is registered in the program. It can be addressed via the
resource string or alias name.

10. In the main window, select "Connect".

R&S VISA establishes the connection to the R&S AREG100A.

You can send settings to configure the instrument and receive its responses.

Note: If the connection cannot be set up, R&S VISA displays an error in the log
view.
See also Chapter 11.5, "Resolving Network Connection Failures", on page 300.

For further information on the functions to read and write to an open session, and
the utility applications the software provides, see the R&S VISA user manual.

Starting a remote control session over LAN with R&S VISA

To set the instrument to remote control, you can use the addressed command &GTR or
send any command from the controller.

1. Start the R&S VISA Tester.
Establish the connection to the R&S AREG100A.
See "Setting up the controller with R&S VISA" on page 179.
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2. In the R&S VISA "Basics" tab, enter an SCPI command, e.g. "*IDN?". Confirm with
"Query".

The instrument is switched to remote control when it receives a command from the
controller.

3. Select "Read" to obtain the instrument response.

Tip: If the "Show Log" checkbox is checked, R&S VISA displays each VISA func-
tion call in the log-view on the left. If you check the "Write Log" checkbox, the log-
view entry is written to the log file as well. You can operate the log-view in two
modes: the "Live Mode" shows only the most recent messages whereas the "View
Mode" allows you to scroll the history.

4. To check the performed setting, SOUR1:FREQ? and select "Query".

While remote control is active, the "Remote" icon in the status bar indicates that the
instrument is in remote control mode. Currently ongoing communication (data
transfer) is indicated by green colored arrows in the icon.
Operating via the front and touch panel or via mouse and keyboard are locked,
allowing a remote control program to be performed without interruption. On the dis-
play, keys and entry fields are grayed out and cannot be activated or modified, but
you can still open dialogs, for example to verify settings.

5. To disable the access to the dialogs, use the command SYST:KLOC ON.

6. To prevent unintentional return to manual operation, use the command &LLO.
See also Chapter A.1.2, "LAN Interface Messages", on page 322.

The instrument switches to "Remote LLO" state. The [Setup] key is disabled.

7. To enable the [Setup] key, use the command &GTR.
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8. To return to manual operation, see Chapter 9.7.9, "How to Return to Manual Oper-
ation", on page 187.

Tip: Switching from manual operation to remote control and vice versa does not
affect the other instrument settings.

9.7.5  Establishing a Remote Control Connection over LAN Using Socket
Communication

This section provides an example on how to establish a remote control connection over
Telnet client and a simple sockets-based program example that can be further devel-
oped.

See also Chapter B, "Telnet program examples", on page 343.

The telnet client transmits information unencrypted. Therefore, for sensitive information
we recommend that you use a client which supports secure protocols, like SSH.

In the following example, we assume basic knowledge of programming and operation
of the controller. You can find information on the interface commands in the corre-
sponding manuals.

Setting up a Telnet connection

To control the software, only a Telnet program is required. The Telnet program is part of
every operating system.

1. On the instrument:

a) Enable the LAN interface.
See Chapter 9.6.1, "How To Enable Access via LAN", on page 174.

b) Enable "SCPI over LAN".
See Chapter 9.6.2, "How To Activate LAN Services", on page 174.

2. Connect the remote PC and the instrument in the same network.
See also Chapter 9.6.3, "How To Connect to LAN", on page 174.

3. On the remote PC, start the Telnet program.
Enter the socket address.
The socket address is a combination of the IP address or the hostname of the
R&S AREG100A and the number of the port configured for remote-control via Tel-
net.
Tip: The R&S AREG100A uses the port number 5025 for remote connection via
Telnet.
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The connection to the instrument is set up and you can send remote-control com-
mands.

4. Telnet does not reflect your first entry.
Insert a command, e.g. *IDN and confirm with "Enter".

5. Observe the screen.

A response on the query confirms that the connection is working. The client dis-
plays all subsequent inputs and responses.

6. Even if the cursor is not visible on the screen, blindly enter a remote-control com-
mand. Confirm with Enter.

9.7.6  Setting Up a Remote Control Connection over GPIB

The program example in this section is written in VISUAL BASIC. A condition for pro-
gramming in VISUAL BASIC is that the modules NIGLOBAL (Niglobal.bas) and
VBIB32 (Vbib_32.bas) are added to the projects.

Drivers for instrument, for example IVI-COM and LabVIEW drivers, are available for
download area on the product page at:
https://www.rohde-schwarz.com/driver/areg200a/

Starting a remote control session over GPIB

1. Connect instrument and controller using a GPIB cable.
Switch them on.

Controlling the R&S AREG100A Remotely
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2. Select "System Config > Remote Access > GPIB Address " > "GPIB Channel
Address = 28".
The GPIB address of the instrument must be the default value of 28.

3. Execute the following commands on the controller:

a) Open the port to the instrument.
CALL IBFIND("DEV1", generator%)

b) Inform the controller about instrument address.
CALL IBPAD(generator%, 28)

c) Reset the instrument.
CALL IBWRT(generator%, "*RST;*CLS")

d) Set the instrument to new address.
CALL IBWRT(generator%, "SYST:COMM:GPIB:ADDR 18")

e) Inform the controller about new address.
CALL IBPAD(generator%, 18)

The GPIB address of the instrument is changed.

4. To return to manual operation, press the Local key at the front panel.

9.7.7  Setting Up a Remote Control Connection over USB

For remote control via the USB connection, the PC and the instrument must be con-
nected via the USB type B interface. A USB connection requires the VISA library to be
installed. VISA detects and configures the R&S instrument automatically when the
USB connection is established. You do not have to enter an address string or install a
separate driver.

Starting a remote control session over USB

1. Connect instrument and controller using USB cable. Switch them on.

2. Execute the following commands on the controller:

a) Open the port to the instrument.
viOpen (..., "USB::0x0AAD::0x01e1::100001::INSTR", ...)

b) Reset the instrument.
viRST (generator%, "*RST;*CLS")

c) Set 20 dB base attenuation
viPrintf (..., "SOUR:AREG:RAD:BASE:ATT 20dB\n")

The RF frequency and signal level of the instrument are changed.

3. To return to manual operation, press the [Local] key.

9.7.8  How to Trace Messages with the LXI Web Browser Interface

The remote trace functionality allows you to trace commands and messages
exchanged via a remote control interface of the R&S AREG100A.
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Activating the SCPI remote trace

1. On the instrument:

a) Enable the LAN interface.
See Chapter 9.6.1, "How To Enable Access via LAN", on page 174.

b) Enable "SCPI over LAN".
See Chapter 9.6.2, "How To Activate LAN Services", on page 174.

2. Connect the remote PC and the instrument in the same network.
See also Chapter 9.6.3, "How To Connect to LAN", on page 174.

3. Start a web browser that supports HTML5 (W3C compliant).

4. Enter the IP address of the R&S AREG100A in the browser's address bar.

The welcome page is displayed.

5. In the navigation pane, select "Diagnostics > SCPI Remote Trace".

6. In the toolbar bar of the "SCPI Remote Trace" page, select "live mode > on" and
"logging > on".

"live mode > on" displays all commands and responses, and "logging > on" also
traces messages.

If you now control the R&S AREG100A with SCPI commands, using an appropriate
tool, the LXI function records the information sent and received.
The function records all sent commands, received responses and messages, and
saves them in an internal database. If "live mode" is disabled, you can display the
recent traces upon request, using the "refresh" button. You can also save the log in
a file.
Note: The diagnostics functionality will be extended in later releases, e.g. to down-
load or upload SCPI command files from / to the instrument.

9.7.9  How to Return to Manual Operation

Before returning to manual control, command processing must be completed. Other-
wise, the instrument switches back to remote control immediately.

1. To return from "Remote" state to manual state, perform one of the following:

● On the controller, use the command &GTL
Note: If &NREN has been set before &GTL is locked. Use &GTR instead.

● In the status bar, select the "Remote" icon.
● On the front panel, press the [Local] key.
● In the block diagram, select "Context sensitive menu > Key Emulation > Local"

2. To return from "Remote LLO" state to manual or to "Remote" state, perform one of
the following:
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Note: In the local lockout state, the command &GTL and the [Local] key are locked.
You can unlock this state only via remote control.
● On the controller, use the command &LOCS.

This command switches directly to manual operation.
● Send the command &REMS.

This command changes the remote control state from "Remote LLO" to
"Remote".

● Use the Visual Basic command CALL IBLOC (generator%).
The command switches directly to manual operation.

● VISA function viGpibControlREN()
This function switches directly to manual operation.

9.8  Automating Tasks with Remote Command Scripts

To achieve fast configuration, make complex test setups or repeating measurements
reproducible, you can automate the required settings with scripts. A script contains a
series of SCPI commands corresponding to the settings. When completed, it is conver-
ted to an executable format, saved in a file and can be run whenever needed.

If you frequently need to load and run a script, assign the script to the [User], and you
can quickly and easily perform the task.
See Chapter 8.2.4, "How to Assign Actions to the [User] Key", on page 122.
In contrast to "Recall Setup" via the [User] key, an assigned script execution does not
close active dialogs and windows. On the contrary, even active window control (open /
close) is possible.

Figure 9-6: Steps for performing SCPI Scripts

In the graph, you can see the main steps required to work with an SCPI script.

Creating a SCPI list

With the SCPI record functions, you can create a SCPI command list directly in the
instrument and then export the list to the controller. If you want to edit or write a script
manually, use a suitable editor on the controller. Even for manually creating, the instru-
ment supports you by showing the corresponding command syntax and the current
settings value.
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Directly in the instrument, you can create a SCPI list at any time of operation, in the
following ways:
● Recording steps

Both, automatic and manual SCPI recording of settings is possible. You can start,
stop and resume automatic recording, and also record individual commands man-
ually.
– Manually record the steps selectively

In manual recording mode, you can deliberately record a SCPI command with
the "Add CPI Command to Recording List" function, see How to record SCPI
lists manually.

– Automatically record all performed steps
The instrument records the SCPI command and settings value of each step
you perform, and then writes the commands to the file system, see How to
record SCPI lists automatically.
You can also add a SCPI command manually to the recording list during auto-
matic SCPI recording.

Note: The Automotive Radar Echo Generator clears the SCPI list after booting
automatically.

● Generating all settings at once
Generates the SCPI commands of the current instrument settings in one step, and
writes the command list in a temporary list, see How to create a SCPI list with the
current instrument settings in one step.
Note: This function lists all commands in alphabetical order, in contrast to the
recording or manual creation, which consider the order the settings are configured.
Using this function can slow down the runtime or cause errors during execution.
Therefore, always check and revise a script if necessary, see "How to check an
SCPI list" on page 196.

● Manually create a command script with "Copy" and paste
Enables you to copy the SCPI command and the current setting, see Chap-
ter 9.8.1, "Show SCPI Command", on page 190.

Some parameters cannot be set by an SCPI command.
If so, no SCPI command found is entered instead of a command when you record or
generate all settings at once.

The difference between Show SCPI Command and the provided cross-reference

If you want to enter your settings in a script, or use a remote control program, you must
know the corresponding SCPI command and the exact syntax.

If you need to look up the SCPI command, the instrument offers two ways to figure it
out quickly.
● "Show SCPI command" (context-sensitive menu)

Displays the SCPI command syntax of a selected parameter including the current
setting value, see "Findig out the SCPI command using "Show SCPI Command""
on page 197.
The "Copy" function enables you to write an SCPI script conveniently by hand.

● Instrument help ([Help] key)
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Opens a help topic that describes the selected parameter or instrument function,
including a cross-reference to the corresponding SCPI command. The reference
leads you to the description of the SCPI command comprising the complete SCPI
syntax, all available setting values, value ranges, etc.
See "Findig out the SCPI command using the online help" on page 197.

Creating and exporting a script file

When the script list is completed, a code generator translates the SCPI commands into
the source code of a proprietary programming language, using a code template. There-
fore, each language requires an appropriate code template. When converted, you can
save the script in a file with an extension corresponding to the programming language.

The R&S AREG100A provides the following predefined code templates by default:
● Plain SCPI

Represents SCPI base format, that is ASCII format, saved as text file (*.txt).
● MATLAB

A programming environment, frequently used in signal processing and test and
measurement applications (*.m).
You can directly use this format with MATLAB(c) Toolkit. For comprehensive infor-
mation on this topic, refer to the application note 1GP60: MATLAB Toolkit for R&S
Signal Generators.

● NICVI
An ANSI C programming environment designed for measurements and tests (*.c).
You can directly use this format with National Instruments LabWindows CVI.

● Python3
A general purpose and high level programming language (*.py).

You can also convert a script to a user-specific format. In this case, you need a code
template with the extension *.expcodetmpl.

For information on how to select the code template and save the script in a file, see
Chapter 9.8.3, "SCPI Recording Export Settings", on page 192.

Executing an SCPI script

An SCPI script primarily runs on the controller PC. In addition, you can execute a script
directly on the instrument, by assigning the script to the [User] key.

See Chapter 8.2.4, "How to Assign Actions to the [User] Key", on page 122.

9.8.1  Show SCPI Command

Access:

1. Select the parameter.

2. Open the context-sensitive menu (tap and hold).

3. Select "Show SCPI Command".
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This function provides the syntax of the remote command with the current setting.

Copy
Copies the command and the current setting.

Close
Exits the "SCPI Command" dialog.

9.8.2  Displaying an SCPI List

The instrument displays a recorded SCPI list and thus provides viewing the recorded
results before exporting.

► Depending on the starting point, you can access the "SCPI Recording List" dialog
as follows:

● During recording
Select "Show SCPI Recording List" in the context-sensitive menu.

● At any time outside recording
Select "Show SCPI Recording List" in the context-sensitive menu.
This function assumes that at least one recording has been executed after
power-on.

● At the end of the recording
Select "Stop automatic SCPI recording". The dialog opens automatically.

● After you have exported the script to a file.
Select "SCPI Recording Export > Show file content"
See Chapter 9.8.3, "SCPI Recording Export Settings", on page 192.
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The "SCPI Recording List" shows the last recorded and exported commands.

SCPI Recording List
Lists the automatically or manually recorded recorded SCPI commands.

Export
Opens the SCPI Recording Export dialog for configuring the file parameters for export.

Remove All, Remove First, Remove Last
Deletes either the first, the last or all recorded SCPI commands.

To remove several recorded commands, repeat the removing.

For post processing, export the SCPI command list in a file, see Chapter 9.8.5, "How to
Convert and Save SCPI Lists", on page 196.

9.8.3  SCPI Recording Export Settings

Scripts are configured and saved in the "SCPI Recording Export" dialog. This dialog
opens automatically, when you stop recording.

Access:

1. Select "Show SCPI Recording List" in the context-sensitive menu.

The "SCPI Recording List" dialog opens.

2. Select "Export".
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The "SCPI Recording Export" dialog contains all functions required for export of
command lists to a file. It enables you to select the source code format, assign an
individual filename and display the file content.

Format
Selects the source code format for the command list.

"Plain SCPI" Uses SCPI syntax.

"Predefined Code Generator"
Accesses the predefined templates for common source code genera-
tors that convert the recorded settings in the programming languages
MATLAB or NICVI or Python.

"User Code Generator"
Use this setting to convert a script by a user-specific code generator.

Select Code Template
Opens the standard "File Select" dialog and lists the predefined or user-defined code
templates.

File
Opens the standard file select dialog "Select Output File".

Export
Executes data export.

The SCPI list is saved in as file with the selected filename and in the selected directory,
see File.

Reload
Reloads a SCPI list from a file.

You can export recorded SCPI lists to files (see File and Export), that can be modified.

File content
Displays the content of the script in the selected format and code template.

9.8.4  How to Record / Create SCPI Lists

How to record SCPI lists automatically

The following example briefly explains how to proceed when you want to record SCPI
lists.

For comprehensive description, see 1GP98: SCPI Recorder Test Automation on a Fin-
gertip.

1. On the screen, open the context-sensitive menu (touch and hold, or right mouse
click) and select "Start SCPI recording".
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Starting from now, all steps you perform are recorded.

2. To stop SCPI recording, select "context-sensitive menu > Stop SCPI recording".

The "SCPI Recording List" dialog opens automatically.

3. Proceed with How to check an SCPI list.

How to record SCPI lists manually

1. To retrace your settings, open the context-sensitive menu and select "Mark all
Parameters Changed from Preset".

This function identifies and highlights all settings you have changed, both in the
block diagram, and in the dialogs.

2. For selectively recording your steps:

a) Set the parameter.
b) Open the context-sensitive menu.
c) Select "Add SCPI Command to Recording List"

Tip: You cannot see "Add SCPI ..." in the menu?
A possible reason is opening the menu outside of a dialog or input field, for
example in a block diagram. Open the context-sensitive menu within the corre-
sponding dialog or input field, and the feature is available.

d) Continue with the next setting, and repeat steps a to b whenever needed.

Each time you select "Add SCPI ...", the SCPI command is appended to a tempo-
rary list.

3. To check the progress of the recording, select "Context-Sensitive > Show SCPI
Recording List".

The "SCPI Recording List" dialog opens, displaying all recorded settings so far.

4. Proceed with How to check an SCPI list.
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How to create a SCPI list with the current instrument settings in one step

You can also generate a SCPI list from a manually created instrument state at any
time, in only one step.

To generate an SCPI list with commands for all settings performed:

1. Select "Save/Recall > SCPI Export".

The instrument opens the standard file select dialog, see Chapter 7.4.1, "Save/
Recall Settings", on page 93.

2. In the "Format" entry field, select the source code.

3. Depending on the selected format, convert the script as described in Chapter 9.8.5,
"How to Convert and Save SCPI Lists", on page 196

4. Enter a filename.

5. Select "Export".
The instrument writes all SCPI commands of the key parameters and the modified
settings in the file. Also assigns the file extension automatically according to the
source code format.

6. To preview the content of the SCPI list:

a) Select "System Config > Save/Recall".
b) Select "Operation Mode > SCPI-Export".
c) In the /var/user/ directory, select a previously saved file.
d) Select "Show SCPI List".

The list of all SCPI commands is displayed, for example, for a final check.

Exporting the SCPI list of the instrument state in one step is a fast and convenient
method. Nevertheless, it usually requires postprocessing on an external PC.
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How to check an SCPI list

The easiest way to check a list, is to execute it. The generator returns a warning if a
setting could not be performed.

However, we recommend that you check the list and possibly rework. It can be that ...
● A parameter has not assigned an SCPI command or an element of the user inter-

face has not an assigned parameter. In these cases, :SYST:INF:SCPI 'SCPI
command not available' is entered in the list instead.
Such entries are also detected during execution. The instrument recognizes these
incomplete commands and displays an error message.

● A preset has been executed, but several standards subsequently perform some
internal settings that are also assigned to the list with "SCPI Export".

● After a preset still some settings are defined, which are then written to the list gen-
erated with "SCPI Export."

Some suggestions on how you can check and revise a list:

1. Search and remove missing command entries.

2. Remove unnecessary content written after a preset.

3. Rearrange the commands to a reasonable order. If you, for example, set a STATe
command to the last position of a list, you can avoid intermediate calculations of
the signal.

4. Preview the list for completeness by comparing it with the modified settings in the
manual mode.

a) To retrace your settings in manual operation, open the context-sensitive menu
and select "Mark all parameters changed from preset".
The function identifies all settings you have changed, both in the block dia-
gram, and in the dialogs. They appear orange.

b) Check whether there is a command in the list for all modified settings.

5. To perform modifications, export the list to a PC, using for example a USB flash
drive.

9.8.5  How to Convert and Save SCPI Lists

After completing the recording, the "SCPI Recording Export" dialog opens.

1. Select the "Format" for the command syntax in which you want to save the list.

2. "Select Code Template"
Depending on the selected format, proceed accordingly:
Note: Select the code template before exporting.

a) Plain SCPI
Continue with the next step.
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b) Predefined code generator
The "SCPI Recording Export - Select Predefined Code Template" dialog opens.
Select one of the predefined code templates.

c) User code generator
A file system ("SCPI Recording Export - Select User Code Template") dialog
opens.
Select your user-defined code template. The code template must have file
extension *.expcodetmpl.

3. Select "File..."
The "SCPI Recording Export - Select Output File" dialog opens.

4. Select "New" and assign a filename for saving the recorded list.

5. In the "SCPI Recording Export" dialog, select "Export".
Saves the recorded data either in ASCII format (plain SCPI), or in the correspond-
ing format of the used code template, and shows the SCPI list in the "File Content"
section.

9.8.6  How to Find Out the SCPI Commands for GUI Functions

Findig out the SCPI command using "Show SCPI Command"

1. To find out the SCPI command of a parameter in manual operation, select the
respective parameter.

2. Open the context-sensitive menu and select "Show SCPI command"

You get the detailed command syntax, including the currently set value.

With the "Copy" function, you can conveniently paste the command including the
current setting, e.g., in a command script.

Findig out the SCPI command using the online help

If you are looking for the remote command to a function in manual operation, you find it
in the description of the online help.

1. To find out the SCPI command of a parameter in manual operation, select the
respective parameter.
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2. To open the corresponding help topic, select one of the following:

● In the display, select "context-sensitive menu > Help".

● On the front panel, press the [Help] key.

The help topic opens. Apart from the function description, it contains the SCPI
command in detailed syntax.

How to find the corresponding GUI function to a command
Conversely, if you are looking for a function in the GUI, which belongs to a SCPI, you
find it via a cross-reference in the online help and in the user manual.

9.9  Operating the R&S AREG100A Remotely via VNC

This section shows you some examples of the various possibilities to set up remote
operation.

● Using a desktop system
– Chapter 9.9.2.1, "Using a Web Browser", on page 199
– Chapter 9.9.2.2, "Using a VNC Client Software", on page 199

● Using a smart device
– Chapter 9.9.3.1, "Using a VNC App", on page 202
– Chapter 9.9.3.2, "Using a Web Browser with HTML5", on page 202
– Chapter 9.9.3.3, "Special Mode QR Code ", on page 203

9.9.1  How To Enable the VNC Service

1. NOTICE! Enabled VNC service can lead to unauthorized access.
Change the computer name and password of the instrument.
See Chapter 8.4.5, "How to Prevent Unauthorized Access", on page 142.

2. Select "System Config > Setup > Security > Security > LAN Services".

3. Select "VNC > On".

4. Enter the Security Password.

5. Select "Accept".
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9.9.2  How To Set Up a Remote Operation from a Desktop System

9.9.2.1  Using a Web Browser

The R&S AREG100A supports remote operation via VNC with any web browser, like
Windows Internet Explorer or Mozilla Firefox for instance, or alternatively, an HTML5
web browser.

To operate the instrument via a web browser remotely:

1. Install the JRE (Java Runtime Environment) on the remote computer.
Note: Skip this step if you are working with an HTML5 web browser.

2. Type the instruments' IP address in the address field of the web browser on your
PC, e.g. http://10.113.1.151

The VNC authentication screen appears.

3. Enter the password and confirm with "OK".
The default password is instrument.

After the connection is established, the current screen of the signal generator is
displayed and the instrument can be remotely operated from the remote computer.

9.9.2.2  Using a VNC Client Software

A VNC client software is an application which can be used to access and control the
instrument from a remote computer through a LAN connection.

The VNC client software for setting up the connection is included in the operating sys-
tem Linux/Unix per default. For Windows operating systems, a VNC client software
must be installed manually.

Various free-of charge programs such as Ultr@VNC or similar VNC client programs
are available for download on the Internet.

Setting up the VNC connection on a Linux/Unix desktop client

1. Start a web browser on the remote computer. Enter the IP address of the instru-
ment.

2. Enter the following address:
vnc://<IP-address of the instrument>, for example vnc://10.113.1.151.

A dialog opens requesting the password for the remote VNC connection.

3. Enter the password and confirm with "OK".
The default password is instrument.

After the connection is established, the current screen of the signal generator is
displayed and the instrument can be remotely operated from the remote computer.
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Setting up the VNC connection on a Windows desktop client

1. Install the VNC viewer program component on the remote computer.

a) On the Internet, select a VNC client program and download it onto your PC.
For example the free of charge software Ultr@VNC (vncviewer.exe is avail-
able, see http://www.uvnc.com/download/index.html.

b) Execute the VNC client installation.
c) Select the VNC viewer program component and follow the installation instruc-

tions.

2. Start VNC viewer program component on the PC.

3. Select "VNC Server" and enter the IP address of the instrument.

4. To initialize the connection, select "Connect".

A dialog opens requesting the password.

5. Enter the password and confirm with "OK".
The default password is instrument.

After the connection is established, the current screen of the signal generator is
displayed and the instrument can be remotely operated from the remote computer.

Terminating VNC connection

► Perform one of the following:

a) On an external Unix/Linux PC, close the Internet browser or the signal genera-
tor window.
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b) On an external Windows PC, close the VNC viewer program.

The connection is terminated but not disabled. It can be established again any
time.
In the "Active Connections" tab, the displayed TCP/IP connection disappears.
See Chapter 8.4.5, "How to Prevent Unauthorized Access", on page 142.

9.9.3  How To Set Up a Remote Operation from a Smart Device

The R&S AREG100A supports remote operation via VNC from a smart device (remote
client), like a tablet (tablet computer) or a smartphone. The smart device accesses the
instrument via WLAN, either by a suitable App, or an HTML5 web browser, that means
with embedded javascript.

There are several possibilities to establish a WLAN connection between the smart
device and the R&S AREG100A. This section gives an example of how a network envi-
ronment can be built up, and some essential configuration steps.

For more information, see:
● 1MA216: Remote Operation of Windows Based Instruments with Apple iPad
● 7BM82: Apple iPad Remote Control of Broadcasting T&M Instruments

Example: 

Figure 9-7: Example of a network configuration for remote operation with a smart device

As shown in the figure, the R&S AREG100A and the WLAN router are connected to
the LAN router. The smart device accesses the Rohde & Schwarz instrument via the
WLAN router.

Prerequisites

For this network configuration, the following prerequisites must be met:
● The required equipment is:
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– A LAN router
– A WLAN router (hot spot)

Required for accessing the R&S AREG100A
● The smart device must be known and accepted in the network of the

R&S AREG100A.
● The App or web browser implements the VNC functionality on the smart device for

remote operation.

It is recommended that all components in the network use DHCP, which automatically
assigns the relevant address information.

With the configuration in the example, you can reach the instrument from a great dis-
tance, since the WLAN router acts as an additional access point.

9.9.3.1  Using a VNC App

Using a VNC App enables the smart device to access the R&S AREG100A via WLAN.

The VNC Apps are available from various manufacturers of the smart devices.

The list of supported devices is different according to the smart device.

1. Refer to the manufacturer's website to find out whether a VNC App is available for
your device, and how it is installed.

2. In the network, establish the connection of the WLAN router to the LAN router.
We assume the connection of the LAN router and the R&S AREG100A and their
configuration in the LAN.

3. Configure the WLAN router according to the manufacturer's instructions.

4. Install the required VNC App on your smart device.

5. On the smart device, start the VNC App.

6. In the address field, enter the IP address of the instrument.

A log-on dialog opens and requests the password for the VNC connection.

7. Enter the password to establish the remote access.
The default user name and password is instrument.
See Chapter 8.4.5, "How to Prevent Unauthorized Access", on page 142.

After the connection is established, the current screen of the signal generator is
displayed and the instrument can be remotely operated.

9.9.3.2  Using a Web Browser with HTML5

The R&S AREG100A supports remote operation from a smart device via VNC with any
HTML5 compliant web browser, like Internet Explorer, Firefox, Google Chrome, or
Safari for instance.

Operating the R&S AREG100A Remotely via VNC
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To operate the instrument remotely via a web browser, proceed as follows:

1. In the web browser enter the IP address of the instrument, e.g. http://10.113.1.151.

2. Type the instrument IP address in the address field of the web browser on your PC,
e.g. http://10.113.1.151

The VNC authentication screen appears.

3. Enter the password and confirm with "OK".
The default password is instrument.
See Chapter 8.4.5, "How to Prevent Unauthorized Access", on page 142.

After the connection is established, the current screen of the signal generator is
displayed and the instrument can be remotely operated.

9.9.3.3  Special Mode QR Code

If your smart device is equipped with a camera and a QR code reader, you can scan
the instrument's IP address or access the instrument with the Safari web browser.

QR code readers are available from various manufacturers of the smart devices.

The list of supported devices is different according to the smart device.

1. Refer to the manufacturer's website of your smart device to find out whether a
reader is available for your device, and how it is installed.

2. Install the required QR code reader software on your device.

3. Start the reader.

4. On the R&S AREG100A, select "System Config > Remote Access".

5. In the "Remote Access" dialog, select the "QR-Code" tab.

6. Scan the QR code of the instrument with your smart device.

7. On the device, decode the scanned QR code and pass it to the web browser.

A dialog opens requesting the password for the VNC connection.

8. Enter the password and confirm with "OK".
The default password is instrument.

After the connection is established, the current screen of the signal generator is
displayed and the instrument can be remotely operated.

Operating the R&S AREG100A Remotely via VNC
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9.10  References

9.10.1  LXI Functionality

LAN Extensions for Instrumentation (LXI) is an instrumentation platform for measuring
instruments and test systems that is based on standard Ethernet technology.

LXI is intended to be the LAN-based successor to GPIB, combining the advantages of
Ethernet with the simplicity and familiarity of GPIB. Like GPIB, LXI determines and
standardizes the way the instrument behaves in a LAN.

The LXI implementation in the R&S AREG100A allows you to change certain LAN set-
tings, to reset the LAN connection, and to identify the instrument.

For information about the LXI standard, refer to the LXI website at http://www.lxistan-
dard.org.
See also "News from Rohde & Schwarz, article 2006/II - 190".

The LXI functionality in the R&S AREG100A is characterized by a common LAN imple-
mentation, including an ICMP ping responder for diagnostics. The instrument can be
configured via a web browser. A LAN Configuration Initialize (LCI) mechanism resets
the LAN configuration. The instrument also supports automatic detection in a LAN via
the VXI-11 discovery protocol and programming by IVI drivers.

In addition the R&S AREG100A provides the following LXI-related functionality:
● Integrated "LXI Status" dialog for LXI status indication and reset of the LAN config-

uration, see Chapter 9.5.1, "LXI Status Settings", on page 167.
● "LXI Browser Interface", as described in Chapter 9.5.2.1, "LAN Configuration",

on page 169.
● "SCPI Remote Trace" utility, see "SCPI Remote Trace" on page 172.

Firmware update
To enable the full LXI functionality after a firmware update, shut down and restart the
instrument.

9.10.2  Code Generator Templates

This section describes the main structure of the code generator templates, and shows
the method by means of the NICVI template.

The code generation is controlled by templates with the following blocks:

References
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Command Function

#EXTENSION_START
#EXTENSION_END

Defines the output file extension.

#INIT_CODE_START
#INIT_CODE_END

Contains initial entries, such as included files and
libraries, buffer size, commands for synchronization,
or creating a VISA session.

All entries between start and end are written once at
the beginning of the output file.

#COMMAND_CODE_START
#COMMAND_CODE_END

Frame for an SCPI command. A command is
accessed with %COMMAND.

#NO_COMMAND_CODE_START
#NO_COMMAND_CODE_END

Frame for a parameter with no SCPI command
available. A parameter is accessed with
%PARAMETER.

#EXIT_CODE_START
#EXIT_CODE_END

Closes the visa session.

All entries between start and end are written once at
the end of the output file.

Templates are created in ASCII format with file extension *.expcodetempl.

Example: 
Example to the code generator template NICVI.expcodetmpl:

#EXTENSION_START
.c
#EXTENSION_END

#INIT_CODE_START
#include <ansi_c.h>
#include <visa.h>
#include <cvirte.h>

#define MAX_BUFFER_SIZE 200
static ViStatus status;
static ViSession defaultRM, handle;

static void write_command(char *command)
{
  char writeBuffer[MAX_BUFFER_SIZE];
        char readBuffer[MAX_BUFFER_SIZE];
        int length;
        int readCount;
        
        strcpy(writeBuffer, command);
        //append "*OPC?" to sync
        strcat(writeBuffer, ";*OPC?");
        length = strlen (writeBuffer);
        writeBuffer[length]='\n';

References
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        length = length+1;
        viWrite (handle, writeBuffer, length, VI_NULL);
        //read result
        viRead(handle, readBuffer, 100, &readCount);
}     
int main (int argc, char *argv[])
{
  if (InitCVIRTE (0, argv, 0) == 0)
     return -1;    /* out of memory */
        //create a VISA session and return a handle to it
     viOpenDefaultRM (&defaultRM);
        //create a VISA session to the serial port and return a handle to it
        viOpen (defaultRM, (ViRsrc)"TCPIP::localhost::INSTR", VI_NULL, VI_NULL, 
&handle);
#INIT_CODE_END

#COMMAND_CODE_START
  write_command("%COMMAND");
#COMMAND_CODE_END

#NO_COMMAND_CODE_START
  //no SCPI command available for parameter %PARAMETER !
#NO_COMMAND_CODE_END

#EXIT_CODE_START
  viClose (handle);
        viClose (defaultRM);
        return 0;
}
#EXIT_CODE_END

9.10.3  Remote Control States

How to recognize if there is an active remote connection to the instrument

► Observe the indication on the taskbar.

A softkey in the taskbar indicates if and what kind of remote connections are cur-
rently set up.
See also Chapter 9.4.6, "Remote Connections Settings", on page 164.

The following table shows the different remote control states and the associated com-
mands or actions to return to manual control.

References
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10  Remote Control Commands
In the following, all remote-control commands are presented in detail with their param-
eters and the ranges of numerical values.

Common suffixes

The following common suffixes are used in remote commands:

Suffix Value range Description

SOURce<hw> [1] SOURce[1] = RF output

(optional keyword)

OBJect<ch> [1] to 4 Available objects

● Conventions Used in SCPI Command Descriptions............................................. 207
● Programming Examples........................................................................................208
● Common Commands............................................................................................ 210
● Preset Commands................................................................................................ 214
● CALibration Subsystem.........................................................................................216
● DIAGnostic Subsystem......................................................................................... 219
● DISPlay Subsystem.............................................................................................. 221
● FORMat.................................................................................................................226
● HCOPy Subsystem............................................................................................... 227
● KBOard Subsystem...............................................................................................232
● MMEMory Subsystem...........................................................................................233
● SYSTem Subsystem............................................................................................. 243
● TEST.....................................................................................................................267
● SOURce Subsystem............................................................................................. 268
● SENSe, READ, INITiate and SLISt Subsystems.................................................. 276
● STATus Subsystem...............................................................................................290

10.1  Conventions Used in SCPI Command Descriptions

Note the following conventions used in the remote command descriptions:
● Command usage

If not specified otherwise, commands can be used both for setting and for querying
parameters.
If a command can be used for setting or querying only, or if it initiates an event, the
usage is stated explicitly.

● Parameter usage
If not specified otherwise, a parameter can be used to set a value and it is the
result of a query.
Parameters required only for setting are indicated as Setting parameters.
Parameters required only to refine a query are indicated as Query parameters.
Parameters that are only returned as the result of a query are indicated as Return
values.

Conventions Used in SCPI Command Descriptions



Remote Control CommandsR&S®AREG100A

208User Manual 1178.7417.02 ─ 06

● Conformity
Commands that are taken from the SCPI standard are indicated as SCPI con-
firmed. All commands used by the R&S AREG100A follow the SCPI syntax rules.

● Asynchronous commands
A command which does not automatically finish executing before the next com-
mand starts executing (overlapping command) is indicated as an Asynchronous
command.

● Reset values (*RST)
Default parameter values that are used directly after resetting the instrument (*RST
command) are indicated as *RST values, if available.

● Factory preset values
Default parameter values that are reset only by factory preset.

● Default unit
The default unit is used for numeric values if no other unit is provided with the
parameter.

● Manual operation
If the result of a remote command can also be achieved in manual operation, a link
to the description is inserted.

10.2  Programming Examples

The corresponding sections of the same title provide simple programming examples for
the R&S AREG100A. The purpose of the examples is to present all commands for a
given task. In real applications, one would rather reduce the examples to an appropri-
ate subset of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the examples
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (for example comments) start with two // characters.

At the beginning of the most remote control program, an instrument (p)reset is recom-
mended to set the R&S AREG100A to a definite state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

In all the examples we assume that:
● A remote PC is connected to the instrument
● The remote PC and the instrument are switched on
● A connection between them is established
● The security setting "System Config > Setup > Security > SCPI over LAN" is

enabled.

Programming Examples
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Example: Configuring radar objects
SOURce:FREQuency:CW 79000000000
SOURce:ROSCillator:SOURce INT

SOURce:AREGeneratior:RADar:BASE:ATTenuation 0
SOURce:AREGeneratior:RADar:LSENsitivity 1

SOURce:AREGeneratior:UNIT:DOPPler SPE

SOURce:AREGeneratior:OBJect1:STATe 1
SOURce:AREGeneratior:OBJect1:ATTenuation 50
SOURce:AREGeneratior:OBJect1:DOPPler:SPEed 100
SOURce:AREGeneratior:OBJect1:RANGe?
// 3.7
SOURce:AREGeneratior:OBJect1:RCS?
// -39.6
SOURce:AREGeneratior:RADar:BASE:ATTenuation 10
SOURce:AREGeneratior:OBJect1:RCS?
// -49.6

SOURce:AREGeneratior:UNIT:DOPPler FREQ
SOURce:AREGeneratior:OBJect1:DOPPler:FREQuency?
// 14644.8612213135

SOURce:AREGenerator:OBJect:ALL:STATe 1
SOURce:AREGeneratior:OBJect2:STATe?
// 1

SOURce:AREGeneratior:RADar:ANTenna:CUSTom:STATe 1
SOURce:AREGeneratior:RADar:ANTenna:REG:GAIN:TX 20
SOURce:AREGeneratior:RADar:ANTenna:REG:GAIN:RX 15
SOURce:AREGeneratior:RADar:OTA:OFFSet 0.5

SOURce:AREGeneratior:RADar:DBYPass:STATe 0

SOURce:AREGenerator:RADar:POWer:INDicator?
// GOOD

Programming Examples
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Example: Measuring EIRP
*RST
SOURce:AREGenerator:RADar:EIRP:SENSor?
// UDEF
// no sensor is selected for the calculation of EIRP

// query if there is a sensor connected to the instrument
:SLISt:LIST?
// "NRP-Z21-900007-USB Legacy"
// there is one sensor connected
:SLISt:ELEMent1:MAPPing SENS1
// maps the sensor from the list to the first sensor channel

// selesct the sensor for measuring the EIRP
SOURce:AREGenerator:RADar:EIRP:SENSor SEN1

// query the EIRP value
SOURce:AREGenerator:RADar:EIRP?
// -33.980

10.3  Common Commands

Common commands are described in the IEEE 488.2 (IEC 625-2) standard. These
commands have the same effect and are employed in the same way on different devi-
ces. The headers of these commands consist of "*" followed by three letters. Many
common commands are related to the Status Reporting System.

Available common commands:

*CLS.............................................................................................................................211
*ESE.............................................................................................................................211
*ESR?...........................................................................................................................211
*IDN?............................................................................................................................211
*IST?............................................................................................................................ 211
*OPC............................................................................................................................212
*OPT?...........................................................................................................................212
*PRE............................................................................................................................ 212
*PSC............................................................................................................................ 212
*RCL.............................................................................................................................213
*RST.............................................................................................................................213
*SAV.............................................................................................................................213
*SRE............................................................................................................................ 213
*STB?...........................................................................................................................214
*TRG............................................................................................................................ 214
*TST?........................................................................................................................... 214
*WAI.............................................................................................................................214

Common Commands
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*CLS

Clear status

Sets the status byte (STB), the standard event register (ESR) and the EVENt part of
the QUEStionable and the OPERation registers to zero. The command does not
alter the mask and transition parts of the registers. It clears the output buffer.

Usage: Setting only

*ESE <Value>

Event status enable

Sets the event status enable register to the specified value. The query returns the con-
tents of the event status enable register in decimal form.

Parameters:
<Value> Range: 0 to 255

*ESR?

Event status read

Returns the contents of the event status register in decimal form and then sets the reg-
ister to zero.

Return values: 
<Contents> Range: 0  to  255

Usage: Query only

*IDN?

Identification

Returns the instrument identification.

Return values: 
<ID> "Rohde&Schwarz,<device type>,<part number>/<serial num-

ber>,<firmware version>"

Usage: Query only

Manual operation: See "IDN String" on page 164

*IST?

Individual status query

Returns the contents of the IST flag in decimal form. The IST flag is the status bit
which is sent during a parallel poll.

Common Commands
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Return values: 
<ISTflag> 0 | 1

Usage: Query only

*OPC

Operation complete

Sets bit 0 in the event status register when all preceding commands have been execu-
ted. This bit can be used to initiate a service request. The query writes a "1" into the
output buffer when all preceding commands have been executed, which is useful for
command synchronization.

*OPT?

Option identification query

Queries the options included in the instrument. For a list of all available options and
their description, refer to the data sheet.

Return values: 
<Options> The query returns a list of options. The options are returned at

fixed positions in a comma-separated string. A zero is returned
for options that are not installed.

Usage: Query only

Manual operation: See "OPT String" on page 164

*PRE <Value>

Parallel poll register enable

Sets parallel poll enable register to the indicated value. The query returns the contents
of the parallel poll enable register in decimal form.

Parameters:
<Value> Range: 0  to  255

*PSC <Action>

Power on status clear

Determines whether the contents of the ENABle registers are preserved or reset when
the instrument is switched on. Thus a service request can be triggered when the instru-
ment is switched on, if the status registers ESE and SRE are suitably configured. The
query reads out the contents of the "power-on-status-clear" flag.

Parameters:
<Action> 0 | 1

0
The contents of the status registers are preserved.

Common Commands
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1
Resets the status registers.

*RCL <Number>

Recall

Loads the instrument settings from an intermediate memory identified by the specified
number. The instrument settings can be stored to this memory using the command
*SAV with the associated number.

It also activates the instrument settings which are stored in a file and loaded using the
MMEMory:LOAD <number>, <file_name.extension> command.

Manual operation: See "Recall Immediate x" on page 96

*RST

Reset

Sets the instrument to a defined default status. The default settings are indicated in the
description of commands.

The command is equivalent to SYSTem:PRESet.

Usage: Setting only

Manual operation: See "Preset" on page 90

*SAV <Number>

Save

Stores the current instrument settings under the specified number in an intermediate
memory. The settings can be recalled using the command *RCL with the associated
number.

To transfer the stored instrument settings in a file, use the command :MMEMory:
STORe:STATe.

Manual operation: See "Save Immediate x" on page 95

*SRE <Contents>

Service request enable

Sets the service request enable register to the indicated value. This command deter-
mines under which conditions a service request is triggered.

Parameters:
<Contents> Contents of the service request enable register in decimal form.

Bit 6 (MSS mask bit) is always 0.
Range: 0  to  255

Common Commands
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*STB?

Status byte query

Reads the contents of the status byte in decimal form.

Usage: Query only

*TRG

Trigger

Triggers all actions waiting for a trigger event. In particular, *TRG generates a manual
trigger signal. This common command complements the commands of the TRIGger
subsystem.

Usage: Event

*TST?

Self-test query

Initiates self-tests of the instrument and returns an error code.

Return values: 
<ErrorCode> integer > 0 (in decimal format)

An error occurred.
(For details, see the Service Manual supplied with the instru-
ment).
0
No errors occurred.

Usage: Query only

*WAI

Wait to continue

Prevents servicing of the subsequent commands until all preceding commands have
been executed and all signals have settled (see also command synchronization and
*OPC).

Usage: Event

10.4  Preset Commands

The preset commands are not bundled in one subsystem. Therefore, they are listed
separately in this section.

Preset Commands
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Four presetting actions are available:
● Activating the default state of all internal instrument functions (*RST on page 213).

Functions that concern the integration of the instrument into a measurement setup
are not changed, e.g. reference oscillator source settings.

● Activating the preset state of the parameters related to the selected signal path (:
SOURce<hw>:PRESet on page 215)

● Activating the preset state of all parameters that are not related to the signal path
(:DEVice:PRESet on page 215)

● Activating the original state of delivery (factory reset, :SYSTem:FPReset
on page 216). Only functions that are protected by a password remain unchanged
as well as the passwords themselves.

When resetting, the following deviation between remote and manual control exists:
In contrast to the [Preset] key, the SCPI commands *RST and :SYSTem:PRESet do
not close open dialogs in the GUI.

:DEVice:PRESet............................................................................................................ 215
:SOURce<hw>:PRESet.................................................................................................. 215
:SYSTem:PRESet.......................................................................................................... 215
:SYSTem:FPReset......................................................................................................... 216

:DEVice:PRESet

Presets all parameters which are not related to the signal path, including the LF gener-
ator.

Example: DEV:PRES
Presets all instruments settings that are not related to the signal
path.

Usage: Event

:SOURce<hw>:PRESet

Presets all parameters which are related to the selected signal path.

Example: SOUR:PRES
Presets all settings that are related to signal path

Usage: Event

:SYSTem:PRESet

Triggers an instrument reset. It has the same effect as:
● The *RST command

Example: SYST:PRES
All instrument settings (also the settings that are not currently
active) are reset to their default values.

Preset Commands
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Usage: Setting only

Manual operation: See "Preset" on page 90

:SYSTem:FPReset

Triggers an instrument reset to the original state of delivery.

Example: SYST:FPR
All instrument settings (also the settings that are not currently
active) are reset to the factory values.

Usage: Event

Manual operation: See "Execute Factory Preset" on page 91

10.5  CALibration Subsystem

The CALibration subsystem contains the commands needed for performing internal
adjustments. This procedure is triggered by the query commands.

Suffix <hw>

Suffix Value range Description

CALibration<hw> [1] Optional suffix

Understanding the query response

● 0: error-free execution of the adjustments
● 1: indicates that an error occurred; the process has been canceled

:CALibration:ALL[:MEASure]?......................................................................................... 216
:CALibration<hw>:ALL:DATE?.........................................................................................217
:CALibration<hw>:ALL:INFormation?............................................................................... 217
:CALibration<hw>:ALL:TEMP?........................................................................................ 217
:CALibration<hw>:ALL:TIME?......................................................................................... 218
:CALibration:DATA:FACTory:DATE?.................................................................................218
:CALibration<hw>:CONTinueonerror................................................................................218

:CALibration:ALL[:MEASure]? [<Force>]

Starts all internal adjustments that do not need external measuring equipment.

Query parameters: 
<Force> string

Return values: 
<Measure> 0 | 1 | OFF | ON

CALibration Subsystem
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Example: CAL:ALL:MEAS?
// 0
// Executes the adjustments of all instrument functions. 
// When completed, it indicates that the adjustment 
// has been performed successfully.

Usage: Query only

Manual operation: See "Adjust All" on page 311

:CALibration<hw>:ALL:DATE?

Queries the date of the most recently executed full adjustment.

Suffix: 
<hw>

.
[1]
Optional suffix

Return values: 
<Date> string

Example: CAL:ALL:DATE?
// "2016-01-01"

Usage: Query only

Manual operation: See "Last Full Adjustment" on page 311

:CALibration<hw>:ALL:INFormation?

Queries the current state of the internal adjustment.

Return values: 
<CalInfoText> string

Example: CAL:ALL:INF?
"Instrument is calibrated, no adjustment required."
"UNCAL, instrument is warming up."
"UNCAL, Please perform full adjustment after warming up."
"UNCAL, Please perform full adjustment."

Usage: Query only

Manual operation: See "Information" on page 312

:CALibration<hw>:ALL:TEMP?

Queries the temperature deviation compared to the calibration temperature.

Suffix: 
<hw>

.
[1]
Optional suffix

Return values: 
<Temperature> string

CALibration Subsystem



Remote Control CommandsR&S®AREG100A

218User Manual 1178.7417.02 ─ 06

Example: CALibration:ALL:TEMP?
// "+12.00 K"

Usage: Query only

Manual operation: See "Temperature Offset" on page 312

:CALibration<hw>:ALL:TIME?

Queries the time elapsed since the last full adjustment.

Return values: 
<Time> string

Example: CAL:ALL:TIME?
// "22 days"

Usage: Query only

Manual operation: See "Time" on page 311

:CALibration:DATA:FACTory:DATE?

Queries the date of the last factory calibration.

Return values: 
<Date> string

Example: CAL:DATA:FACT:DATE? 
// "2016-01-01"

Usage: Query only

Manual operation: See "Last Factory Calibration" on page 303

:CALibration<hw>:CONTinueonerror <State>

Continues the calibration even though an error was detected. By default adjustments
are aborted on error.

Suffix: 
<hw>

.
[1]
Optional suffix

Parameters:
<State> 0 | 1 | OFF | ON

*RST: n.a. (factory preset: 0)

Example: CAL:CONT ON
// Continues calibration after an error

Manual operation: See "Continue Adjustment on Error" on page 312

CALibration Subsystem
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10.6  DIAGnostic Subsystem

The DIAGnostic subsystem contains the commands used for instrument diagnosis
and servicing. SCPI does not define any DIAGnostic commands; the commands lis-
ted here are all device-specific. All DIAGnostic commands are query commands
which are not affected by *RST.

The test functions are intended for services purposes.
They are thus password-protected functions. Unlock the corresponding protection level
to access them, see :SYSTem:PROTect<ch>[:STATe]
For more information, see R&S AREG100A Service Manual.

Common suffixes

The following common suffixes are used in remote commands:

Suffix Value range Description

DIAGnostic<hw> [1] Optional suffix

Example: Programming example
The example lists the commands required to query assemblies and test points for diag-
nosis purposes.
// Query the operating hours and number of power-on so far.
:DIAGnostic:INFO:OTIMe?
// 112 h
:DIAGnostic:INFO:POCount? 
// 14

Commands

:DIAGnostic<hw>:BGINfo:CATalog?.................................................................................219
:DIAGnostic<hw>:BGINfo?..............................................................................................220
:DIAGnostic:INFO:OTIMe?..............................................................................................220
:DIAGnostic:INFO:POCount?.......................................................................................... 220
:DIAGnostic<hw>:POINt:CATalog?...................................................................................221
:DIAGnostic<hw>[:MEASure]:POINt?...............................................................................221

:DIAGnostic<hw>:BGINfo:CATalog?

Queries the names of the assemblies available in the instrument.

Return values: 
<Catalog> string

List of all assemblies; the values are separated by commas
The length of the list is variable and depends on the instrument
equipment configuration.

Example: See Example "Programming example" on page 219.

DIAGnostic Subsystem
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Usage: Query only

:DIAGnostic<hw>:BGINfo? [<Board>]

Queries information on the modules available in the instrument, using the variant and
revision state.

Query parameters: 
<Board> string

Module name, as queried with the command :
DIAGnostic<hw>:BGINfo:CATalog?.
To retrieve a complete list of all modules, omit the parameter.
The length of the list is variable and depends on the instrument
equipment configuration.

Return values: 
<BgInfo> <Module name> <Module stock number incl. variant> <Module

revision> <Module serial number>
List of comma-separated entries, one entry per module.
Each entry for one module consists of four parts that are separa-
ted by space characters.

Example: See Example "Programming example" on page 219.

Usage: Query only

Manual operation: See "Assembly" on page 302

:DIAGnostic:INFO:OTIMe?

Queries the operating hours of the instrument so far.

Return values: 
<OperationTime> integer

Range: 0  to  INT_MAX
*RST: 0

Example: See Example "Programming example" on page 219.

Usage: Query only

Manual operation: See "Operation Time / h" on page 303

:DIAGnostic:INFO:POCount?

Queris how often the instrument has been turned on so far.

Return values: 
<PowerOnCount> integer

Range: 0  to  INT_MAX
*RST: 0

Example: See Example "Programming example" on page 219.
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Usage: Query only

Manual operation: See "Power On Count" on page 303

:DIAGnostic<hw>:POINt:CATalog?

Queries the test points available in the instrument.

For more information, see R&S AREG100A Service Manual.

Return values: 
<Catalog> string

List of comma-separated values, each representing a test point

Example: See Example "Programming example" on page 219.

Usage: Query only

:DIAGnostic<hw>[:MEASure]:POINt? <Name>

Triggers the voltage measurement at the specified test point and returns the measured
voltage.

For more information, see R&S AREG100A Service Manual.

Query parameters: 
<Name> <test point identifier>

Test point name, as queried with the command :
DIAGnostic<hw>:POINt:CATalog?

Return values: 
<Value> <value><unit>

Example: See Example "Programming example" on page 219.

Usage: Query only

10.7  DISPlay Subsystem

The DISPlay system contains the commands to set the power-save mode of the
instrument.

Programming Examples

Example: Activating screen saver mode and display update
Use the following commands to switch on the screen saver of your instrument or to
automatic display. These settings are particularly useful when you control the instru-
ment remotely.

// Set the wait time interval and activate the screen saver
:DISPlay:PSAVe:HOLDoff 10
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:DISPlay:PSAVe:STATe ON

// Disable the display of the current frequency and level values in remote control
:DISPlay:ANNotation:ALL ON
// :DISPlay:ANNotation:FREQuency ON
// :DISPlay:ANNotation:AMPLitude ON

// Enable automatic update of the display at defined time intervals
:DISPlay:UPDate ON

Example: Querying the dialog IDs, opening and closing dialogs
Use the following commands to query the dialog IDs of all currently open dialogs. The
dialog ID is a prerequisite for opening and closing dialogs via the remote control.

The dialog ID is also required to define user key actions.
See Chapter 8.2.4, "How to Assign Actions to the [User] Key", on page 122.

// Query the dialog IDs of all open dialogs
:DISPlay:DIALog:ID?
// CEUtraDLGenSetDlg,_,$A DlgKeyRf_Rosc

// Open and close dialogs via remote control
:DISPlay:DIALog:OPEN "CEUtraDLGenSetDlg,_,$A"
:DISPlay:DIALog:OPEN "DlgKeyRf_Rosc"
:DISPlay:DIALog:CLOSe "DlgKeyRf_Rosc"
:DISPlay:DIALog:CLOSe:ALL 

:DISPlay:PSAVe:HOLDoff............................................................................................... 222
:DISPlay:PSAVe[:STATe].................................................................................................223
:DISPlay:BRIGhtness..................................................................................................... 223
:DISPlay:BUTTon:BRIGhtness.........................................................................................223
:DISPlay:UPDate........................................................................................................... 223
:DISPlay:ANNotation:AMPLitude..................................................................................... 224
:DISPlay:ANNotation:FREQuency....................................................................................224
:DISPlay:ANNotation[:ALL]..............................................................................................224
:DISPlay:DIALog:ID?......................................................................................................225
:DISPlay:DIALog:OPEN..................................................................................................225
:DISPlay:DIALog:CLOSe................................................................................................ 226
:DISPlay:DIALog:CLOSe:ALL..........................................................................................226

:DISPlay:PSAVe:HOLDoff <HoldoffTimeMin>

Sets the wait time for the screen saver mode of the display.

Parameters:
<HoldoffTimeMin> integer

Range: 1  to  60
*RST: n.a. (factory preset: 10)
Default unit: minute
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Example: see Example "Activating screen saver mode and display update"
on page 221

Manual operation: See "Wait Time" on page 115

:DISPlay:PSAVe[:STATe] <State>

Activates the screen saver mode of the display.

We recommend that you use this mode to protect the display, if you operate the instru-
ment in remote control.

To define the wait time, use the command :DISPlay:PSAVe:HOLDoff.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: n.a. (factory preset: 0)

Example: See Example "Activating screen saver mode and display
update" on page 221

Manual operation: See "Screen Saver" on page 115

:DISPlay:BRIGhtness <BRIGhtness>

Sets the brightness of the dispaly.

Parameters:
<BRIGhtness> float

Range: 1.0  to  20.0
Increment: 1.0
*RST: 14.0

Example: DISPlay:BRIGhtness 14

Manual operation: See "Display" on page 116

:DISPlay:BUTTon:BRIGhtness <ButtonBrightnes>

Sets the brightness of the [RF on/off] key.

Parameters:
<ButtonBrightnes> integer

Range: 1  to  20
*RST: n.a. (no preset. default: 14)

Example: DISPlay:BUTTon:BRIGhtness 15

Manual operation: See "RF Hardkey" on page 116

:DISPlay:UPDate <Update>

Activates the refresh mode of the display.
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Parameters:
<Update> 0 | 1 | OFF | ON

*RST: n.a. (factory preset: 1)

Example: See Example "Activating screen saver mode and display
update" on page 221

Manual operation: See "Display Update is" on page 116

:DISPlay:ANNotation:AMPLitude <State>

Indicates asterisks instead of the level values in the status bar.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: n.a. (factory preset: 1)

Example: See Example "Activating screen saver mode and display
update" on page 221

Manual operation: See "Annotation Amplitude" on page 135

:DISPlay:ANNotation:FREQuency <State>

Indicates asterisks instead of the frequency values in the status bar.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: n.a. (factory preset: 1)

Example: See Example "Activating screen saver mode and display
update" on page 221

Manual operation: See "Annotation Frequency" on page 135

:DISPlay:ANNotation[:ALL] <State>

Displays asterisks instead of the level and frequency values in the status bar of the
instrument.

We recommend that you use this mode if you operate the instrument in remote control.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 1

Example: See Example "Activating screen saver mode and display
update" on page 221
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:DISPlay:DIALog:ID?

Returns the dialog identifiers of the open dialogs in a string separated by blanks.

Return values: 
<DialogIdList> <DialogID#1>< ><DialogID#2>< > ... < ><DialogID#n>

Dialog identifiers are string without blanks. Blanks are represen-
ted as $$.
Dialog identifiers <DialogID> are composed of two main parts:
<DialogName>[<OptionalParts>]
<DialogName>
Meaningful information, mandatory input parameter for the com-
mands:
:DISPlay:DIALog:OPEN on page 225
:DISPlay:DIALog:CLOSe on page 226

<Optional parts>
String of $<X> values, where <X> is a character, interpreted as
follows:
$q<DialogQualifier>: optional dialog qualifier, usually the
letter A or B, as displayed in the dialog title.
$i<Instances>: comma-separated list of instance indexes,
given in the order h,c,s,d,g,u,0. Default is zero; the termi-
nating ",0" can be omitted.
$t<TabIds>: comma-separated indexes or tab names;
required, if a dialog is composed of several tabs.
$x<Left>$y<Top>$h<Left>$w<Top>: position and size;
superfluous information.

Example: See Example "Querying the dialog IDs, opening and closing dia-
logs" on page 222

Usage: Query only

Manual operation: See "SCPI" on page 122

:DISPlay:DIALog:OPEN <DialogId>

Opens the specified dialog.

Setting parameters: 
<DialogId> string

To find out the dialog identifier, use the query :DISPlay:
DIALog:ID?.
The <DialogName> part of the query result is mandatory.

Example: See Example "Querying the dialog IDs, opening and closing dia-
logs" on page 222

Usage: Setting only

Manual operation: See "SCPI" on page 122

DISPlay Subsystem



Remote Control CommandsR&S®AREG100A

226User Manual 1178.7417.02 ─ 06

:DISPlay:DIALog:CLOSe <DialogId>

Closes the specified dialog.

Setting parameters: 
<DialogId> string

To find out the dialog identifier, use the query :DISPlay:
DIALog:ID?.
The <DialogName> part of the query result is sufficient.

Example: See Example "Querying the dialog IDs, opening and closing dia-
logs" on page 222

Usage: Setting only

:DISPlay:DIALog:CLOSe:ALL

Closes all open dialogs.

Example: See Example "Querying the dialog IDs, opening and closing dia-
logs" on page 222

Usage: Event

10.8  FORMat

:FORMat:BORDer..........................................................................................................226
:FORMat:SREGister.......................................................................................................227
:FORMat[:DATA]............................................................................................................ 227

:FORMat:BORDer <Border>

Determines the sequence of bytes within a binary block. This only affects blocks which
use the IEEE754 format internally.

Parameters:
<Border> NORMal | SWAPped

NORMal
Expects/sends the least significant byte of each IEEE754 float-
ing-point number first and the most significant byte last.
SWAPped
Expects/sends the most significant byte of each IEEE754 float-
ing-point number first and the least significant byte last.
*RST: NORMal

Example: :FORM:BORD SWAP
transfers the data with the most significant bit first.
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:FORMat:SREGister <Format>

Determines the numeric format for responses of the status register.

Parameters:
<Format> ASCii | BINary | HEXadecimal | OCTal

ASCii
Returns the register content as a decimal number.
BINary|HEXadecimal|OCTal
Returns the register content either as a binary, hexadecimal or
octal number. According to the selected format, the number
starts with #B (binary), #H (hexadecimal) or #O (octal).
*RST: ASCii

Example: :FORM:SREG HEX
returns the register content as a hexadecimal number.

:FORMat[:DATA] <Data>

Determines the data format the instrument uses to return data via the IEC/IEEE bus.

The instrument automatically detects the data format used by the controller, and
assigns it accordingly. Data format determined by this SCPI command is in this case
irrelevant.

Parameters:
<Data> ASCii | PACKed

ASCii
Transfers numerical data as plain text separated by commas.
PACKed
Transfers numerical data as binary block data.
The format within the binary data depends on the command.
The various binary data formats are explained in the description
of the parameter types.
*RST: ASCii

Example: :FORM ASC
transfers the data as ASCII data.

10.9  HCOPy Subsystem

The HCOPy subsystem contains the commands to generate and save a hard copy of
the display.

To access a stored hard copy file, use the commands of the MEMM subsystem.
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Example: Store a hard copy of the display
The following example lists commands to configure and execute a hard copy to an
automatic named file.

:HCOPy:DEVice:LANGuage PNG
:HCOPy:FILE:NAME:AUTO:STATe 1
// defines the output format
// sets the instrument to automatically create output file names

// ******************************************************************
// Configure hard copy options, set automatic naming rules
// An automatically generated file name consists of:
// <Prefix><YYYY><MM><DD><Number>.<Format>
// ******************************************************************
:HCOPy:DEVice:LANGuage BMP
// defines output format *.bmp
:HCOPy:REGion DIALog    
// selects the region to be copied
:HCOPy:FILE:AUTO:DIR "/usb/HCopy" 
// sets destination directory of automatic named file
:HCOPy:FILE:NAME:AUTO:FILE:PREFix:STATe 1
:HCOPy:FILE:NAME:AUTO:FILE:PREFix:"hardcopy"
:HCOPy:FILE:NAME:AUTO:FILE:YEAR:STATe 1
:HCOPy:FILE:NAME:AUTO:FILE:MONTh:STATe 1
// uses automatic naming prefix
// sets automatic naming prefix to "hardcopy"
// uses automatic naming date parameters year and month

// ******************************************************************
// Execute and transfer the hard copy
// ******************************************************************
:HCOPy:EXECute
:HCOPy:DATA 
// generates a hard copy
// transfers the hard copy to the remote client
:HCOPy:FILE:AUTO:FILE? 
// queries the automatic file name
// "hardcopy1607001.bmp"  
:HCOPy:FILE:AUTO:NUMBer? 
// queries the number in the automatic file name
// "001"  
:HCOPy:FILE:AUTO? 
// queries the path and file name of the automatically generated file
// "/usb/HCopy/hardcopy1607001.bmp"  

10.9.1  Hard Copy Settings

With the following commands, you can configure the settings of a hard copy.
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:HCOPy:DATA?..............................................................................................................229
:HCOPy:IMAGe:FORMat................................................................................................ 229
:HCOPy:DEVice:LANGuage............................................................................................229
:HCOPy:REGion............................................................................................................ 229
:HCOPy:FILE[:NAME].....................................................................................................229
:HCOPy[:EXECute]........................................................................................................ 230

:HCOPy:DATA?

Transfers the hard copy data directly as a NByte stream to the remote client.

Return values: 
<Data> block data

Example: See Example "Store a hard copy of the display" on page 228

Usage: Query only

:HCOPy:IMAGe:FORMat <Format>
:HCOPy:DEVice:LANGuage <Language>

Selects the graphic format for the hard copy. You can use both commands alterna-
tively.

Parameters:
<Language> BMP | JPG | XPM | PNG

*RST: PNG

Example: See Example "Store a hard copy of the display" on page 228

Manual operation: See "Format" on page 109

:HCOPy:REGion <Region>

Selects the area to be copied.

You can create a snapshot of the screen or an active dialog.

Parameters:
<Region> ALL | DIALog

*RST: ALL

Example: See Example "Store a hard copy of the display" on page 228

Manual operation: See "Region" on page 110

:HCOPy:FILE[:NAME] <Name>

Determines the file name and path to save the hard copy, provided automatic naming
is disabled.

Note: If you have enabled automatic naming, the instrument automatically generates
the file name and directory, see Chapter 10.9.2, "Automatic Naming", on page 230.
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Parameters:
<Name> string

Example: See Example "Store a hard copy of the display" on page 228

Manual operation: See "File..." on page 109

:HCOPy[:EXECute]

Generates a hard copy of the current display. The output destination is a file.

Example: See Example "Store a hard copy of the display" on page 228

Usage: Event

Manual operation: See "Save" on page 109

10.9.2  Automatic Naming

Use the following commands to automatically assign a file name.

:HCOPy:FILE[:NAME]:AUTO?.........................................................................................230
:HCOPy:FILE[:NAME]:AUTO:DIRectory........................................................................... 230
:HCOPy:FILE[:NAME]:AUTO:DIRectory:CLEar................................................................. 231
:HCOPy:FILE[:NAME]:AUTO:FILE?................................................................................. 231
:HCOPy:FILE[:NAME]:AUTO:STATe.................................................................................231
:HCOPy:FILE[:NAME]:AUTO[:FILE]:DAY:STATe................................................................231
:HCOPy:FILE[:NAME]:AUTO[:FILE]:MONTh:STATe...........................................................231
:HCOPy:FILE[:NAME]:AUTO[:FILE]:YEAR:STATe............................................................. 231
:HCOPy:FILE[:NAME]:AUTO[:FILE]:NUMBer?.................................................................. 232
:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix..................................................................... 232
:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix:STATe........................................................... 232

:HCOPy:FILE[:NAME]:AUTO?

Queries path and file name of the hardcopy file, if you have enabled Automatic Nam-
ing.

Return values: 
<Auto> string

Example: See Example "Store a hard copy of the display" on page 228

Usage: Query only

:HCOPy:FILE[:NAME]:AUTO:DIRectory <Directory>

Determines the path to save the hard copy, if you have enabled Automatic Naming.

If the directory does not yet exist, the instrument automatically creates a new directory,
using the instrument name and /var/user/ by default.
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Parameters:
<Directory> string

*RST: /var/user/

Example: See Example "Store a hard copy of the display" on page 228

Manual operation: See "Path..." on page 111

:HCOPy:FILE[:NAME]:AUTO:DIRectory:CLEar

Deletes all files with extensions *.bmp, *.jpg, *.png and *.xpm in the directory set
for automatic naming.

Example: See Example "Store a hard copy of the display" on page 228

Usage: Event

Manual operation: See "Clear Path" on page 111

:HCOPy:FILE[:NAME]:AUTO:FILE?

Queries the name of the automatically named hard copy file.

An automatically generated file name consists of:

<Prefix><YYYY><MM><DD><Number>.<Format>.

You can activate each component separately, to individually design the file name.

Return values: 
<File> string

Example: See Example "Store a hard copy of the display" on page 228.

Usage: Query only

:HCOPy:FILE[:NAME]:AUTO:STATe <State>

Activates automatic naming of the hard copy files.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 1

Example: See Example "Store a hard copy of the display" on page 228

Manual operation: See "Automatic Naming" on page 110

:HCOPy:FILE[:NAME]:AUTO[:FILE]:DAY:STATe <State>
:HCOPy:FILE[:NAME]:AUTO[:FILE]:MONTh:STATe <State>
:HCOPy:FILE[:NAME]:AUTO[:FILE]:YEAR:STATe <State>

Uses the date parameters (year, month or day) for the automatic naming. You can acti-
vate each of the date parameters separately.
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Parameters:
<State> 0 | 1 | OFF | ON

*RST: 1

Example: See Example "Store a hard copy of the display" on page 228

Manual operation: See "Prefix, Year, Month, Day" on page 111

:HCOPy:FILE[:NAME]:AUTO[:FILE]:NUMBer?

Queries the number that is used as part of the file name for the next hard copy in auto-
matic mode.

At the beginning, the count starts at 0. The R&S AREG100A searches the specified
output directory for the highest number in the stored files. It increases this number by
one to achieve a unique name for the new file.

The resulting auto number is appended to the resulting file name with at least three
digits.

Return values: 
<Number> integer

Range: 0  to  999999
*RST: 0

Example: See Example "Store a hard copy of the display" on page 228

Usage: Query only

Manual operation: See "Current Auto Number" on page 111

:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix <Prefix>
:HCOPy:FILE[:NAME]:AUTO[:FILE]:PREFix:STATe <State>

Uses the prefix for the automatic generation of the file name, provided PREF:STAT is
activated.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 1

Example: See Example "Store a hard copy of the display" on page 228

Manual operation: See "Prefix, Year, Month, Day" on page 111

10.10  KBOard Subsystem

The KBOard subsystem contains the commands to set a connected keyboard.

:KBOard:LAYout.............................................................................................................233
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:KBOard:LAYout <Layout>

Selects the language for an external keyboard and assigns the keys acccordingly.

Parameters:
<Layout> CHINese | DANish | DUTCh | DUTBe | ENGLish | ENGUK |

FINNish | FRENch | FREBe | FRECa | GERMan | ITALian |
JAPanese | KORean | NORWegian | PORTuguese | RUSSian |
SPANish | SWEDish | ENGUS
*RST: n.a. (factory preset: ENGLish)

Example: :KBOard:LAYout US
// activates American keyboard

Manual operation: See "USB Keyboard > Layout" on page 116

10.11  MMEMory Subsystem

The MMEMory subsystem (Mass MEMory) contains the commands for managing files
and directories as well as for loading and saving complete instrument settings in files.

Mass storage location

Without any additional measures, the R&S AREG100A stores user files on the internal
memory or if connected, on a memory stick.

Both, the user directory /var/user/ on the internal memory or the /usb/ directory
on the memory stick, can be used to preserve user-defined data. Any directory struc-
ture can be created.

The /var/volatile directory serves as a RAM drive and can be used to protect
sensitive information. The data is available temporarily.

Default storage location

The R&S AREG100A stores user data in the user directory.

In the file system, user directory is always indicated as /var/user/.

In manual control, you access this directory via the "File Manager", see Chapter 7.6,
"Using the File Manager", on page 97. In remote control, you can query it with the com-
mand :SYSTem:MMEMory:PATH:USER?.

To query and change the default directory used for mass storage, use the command :
MMEMory:CDIRectory.
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10.11.1  File Naming Conventions

To enable files to be used in different file systems, consider the following file naming
conventions:
● The filename can be of any length and is case-sensitive, i.e it is distinguished

between uppercase and lowercase letters.
● All letters and numbers are permitted (numbers are, however, not permitted at the

beginning of the filename).
● Avoid using special characters.
● Do not use slashes "\" and "/". These symbols are used in file paths.
● Avoid using the following filenames: CLOCK$, CON, COM1 to COM4,

LPT1 to LPT3, NUL or PRN
They are reserved by the operating system.

Wildcards

The two characters "*" and "?" function as "wildcards", i.e. they are used for selecting
several files. The "?" character represents exactly one character, while the "*" charac-
ter represents all characters up to the end of the filename. "*.*" therefore represents all
files in a directory.

Filename and file path

When used in remote control commands, the parameter <filename> is specified as a
string parameter with quotation marks. It can contain either the complete path including
the root user directory /var/user and filename, or only the filename. The filename
must include the file extension. The same applies for the directory /var/volatile
and for the parameters <directory_name> and <path>.

Depending on how much information is provided, the values specified in the parameter
or with the command MMEM:CDIR are used for the path and drive setting in the com-
mands.

10.11.2  Accessing Files in the Default or in a Specified Directory

For better overview and easy file handling, you may not save all user files in the user
directory /var/user but rater organize them into subdirectories.

The command syntax defines two general ways to access files with user data in a spe-
cific directory:
● Change the current default directory for mass memory storage and then directly

access the files in this default directory, like saved list files, files with user data or
save/recall files.
The subsequent commands for file handling (select, delete, read out files in the
directory, etc.) require only specification of the filename. File extension can be
omitted; after syntax evaluation of the used command, the R&S AREG100A filters
out the relevant files.
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● Define the absolute file path, including the user directory /var/user, created
subdirectories and filename (see Example "Load file with user data from a specific
directory" on page 235).
As a rule, whenever an absolute file path is determined, it overwrites a previously
specified default directory.

The following example explains this rule as a principle. Exceptions of this general rule
are stated in the description of the corresponding command. The Chapter 10.11.3,
"Programming Examples", on page 235 explains the general working principle with the
commands for mass memory storage.

The same rule applies to the /var/volatile directory, see Example "Working with
files in the volatile memory" on page 237.

Example: Load file with user data from a specific directory
This example shows the principle of file handling in remote environment by using list
commands. Working with the files of other subsystems is analogical. We assume that
the directory /var/user/my_files is existing and contains the files
list_test.lsw and list_2.lsw.

10.11.3  Programming Examples

Example: Saving and loading current settings
This example shows two ways of how to save the current instrument setting in the file
settings.savrcltxt in the directory /var/user/savrcl.

Before the instrument settings can be saved in a file, they have to be saved in an inter-
mediate memory using common command *SAV <number>. The specified number is
then used in the :MMEMory:STORe:STATe command.

Also, after loading a file with instrument settings with command :MMEMory:LOAD:
STATe, these settings have to be activated with the common command *RCL
<number>.

// Save the current settings in an intermediate memory with number 4
*SAV 4

// save the settings in a file in a specific directory;
// the complete path has to be specyfied
:MMEMory:STORe:STATe 4,"/var/user/savrcl/settings.savrcltxt"

// save the settings in a file in the default directory;
// set the default directory; specify only the file name
:MMEMory:CDIRectory  "/var/user/savrcl"
*SAV 4
:MMEMory:STORe:STATe 4,"settings.savrcltxt"

// Load the saved settings in the intermediate memory 4 and activate them
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:MMEMory:LOAD:STATe 4,"/var/user/settings.savrcltxt"
*RCL 4

Example: Working with files and directories
This example shows how to list files in a directory, list the subdirectories, query the
number of files in a directory, create directory, rename and delete files.

// Query the current default directory for mass storage,
// change the directory to the default user directory "/var/user"
// and read out the files in it
:MMEMory:CDIRectory?
// "/var/user/temp"
:MMEMory:CDIRectory
:MMEMory:CDIRectory?
// "/var/user/"
:MMEMory:CATalog?
// 1282630,8102817792,".,DIR,4096","..,DIR,4096","Log,DIR,4096",
// "settings.savrcltxt,BIN,16949","temp,DIR,4096","test,DIR,4096",
// "list.lsw,BIN,1245201"
// the directory "/var/user" contains the predefined directory "Log",
// the subdirectories "test" and "temp"
// as well as the files "settings.savrcltxt" and "list.lsw"

// query only the subdirectories of the current or specified directory
:MMEMory:DCATalog? "/var/user"
// ".","..","Log","temp","test"

// query only number of subdirectories in the current or specified directory
:MMEMory:DCATalog:LENGth? "/var/user"
// 5

// query number of files in the current or specified directory
:MMEMory:CATalog:LENGth? "/var/user"
// 7

// Create a new directory for mass memory storage in the specified directory
:MMEMory:MDIRectory "/var/user/new"

// Copy the file "settings.savrcltxt" into the new directory
:MMEMory:COPY "/var/user/settings.savrcltxt","/var/user/new/settings.savrcltxt"

// Rename the file "settings.savrcltxt" into the new directory
// and read out the files in this specific directory
:MMEMory:CDIRectory  "/var/user/new"
:MMEMory:MOVE "settings.savrcltxt","settings_new.savrcltxt"
:MMEMory:CATalog? "/var/user/new"
// 25141,8102789120,".,DIR,4096","..,DIR,4096","settings_new.savrcltxt,BIN,16949"

// Delete the "test" directory
:MMEMory:RDIRectory "/var/user/test"
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Example: Working with files in the volatile memory
This example shows how to work with files in the /var/volatile directory.

// Change the default directory for mass storage,
// read out the files, load and play a file with the ARB 
:MMEMory:CDIRectory "/var/volatile"
:MMEMory:CDIRectory?
// "/var/volatile"
:MMEMory:CATalog?
//13928,525352960,".,DIR,60","..,DIR,4096","list.lst,BIN,9772"

:SOURce1:LIST:SELect "/var/volatile/list"
:SOURce1:FREQuency:MODE LIST
:OUTPut1:STATe 1

10.11.4  Remote Control Commands
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:MMEMory:CATalog:LENGth?......................................................................................... 238
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:MMEMory:CATalog? <path>

Returns the content of a particular directory.

Query parameters: 
<path> string

String parameter to specify the directory.
If you leave out the path, the command returns the contents of
the directory selected with :MMEMory:CDIRectory.
The path may be relative or absolute.

Return values: 
<UsedDiskSpace> Byte size of all files in the directory.

<FreeDiskSpace> Remaining disk space in bytes.

<FileInfo> <NameFileN>,<SuffixFileN>,<SizeFileN>
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List of files, separated by commas
<NameFileN>
Name of the file.
<SuffixFileN>
Type of the file. Possible suffixes are: ASCii, BINary, DIRectory
<SizeFileN>
Size of the file in bytes.

Usage: Query only

Manual operation: See "Directory, File List and Filename" on page 94

:MMEMory:CATalog:LENGth? <Path>

Returns the number of files in the current or in the specified directory.

Query parameters: 
<Path> string

String parameter to specify the directory. If the directory is omit-
ted, the command queries the content of the current directory,
queried with :MMEMory:CDIRectory command.

Return values: 
<FileCount> integer

Number of files.

Usage: Query only

:MMEMory:CDIRectory <Directory>

Changes the default directory for mass memory storage. The directory is used for all
subsequent MMEM commands if no path is specified with them.

Parameters:
<Directory> <directory_name>

String containing the path to another directory. The path can be
relative or absolute.
To change to a higher directory, use two dots '..' .

Usage: SCPI confirmed

Manual operation: See "Directory, File List and Filename" on page 94

:MMEMory:COPY <SourceFile>[,<DestinationFile>]

Copies an existing file to a new file. Instead of just a file, this command can also be
used to copy a complete directory together with all its files.

Setting parameters: 
<SourceFile> string

String containing the path and file name of the source file
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<DestinationFile> string
String containing the path and name of the target file. The path
can be relative or absolute.
If <DestinationFile> is not specified, the <SourceFile> is
copied to the current directory, queried with the :MMEMory:
CDIRectory command.
Note: Existing files with the same name in the destination direc-
tory are overwritten without an error message.

Usage: Setting only
SCPI confirmed

Manual operation: See "Cut, Copy&Paste and Delete" on page 99

:MMEMory:DATA <Filename>, <BinaryBlock>
:MMEMory:DATA? <Filename>

The setting command writes the block data <BinaryBlock> to the file identified by
<Filename>.

Tip: Use this command to read/transfer stored instrument settings or waveforms
directly from/to the instrument.

Parameters:
<BinaryBlock> #<number><length_entry><data>

#: Hash sign; always comes first in the binary block
<number>: the first digit indicates how many digits the subse-
quent length entry has
<length_entry>: indicates the number of subsequent bytes
<data>: binary block data for the specified length.
For files with a size with more than nine digits (gigabytes), the
instrument allows the syntax #(<Length>), where <Length>
is the file size in decimal format.

Parameters for setting and query: 
<Filename> string

String parameter to specify the name of the file.

Example: MMEMory:DATA '/var/user/test.txt',#15hallo
Writes the block data to the file test.txt.
The digit 1 indicates a length entry of one digit; the digit 5 indi-
cate a length of the binary data (hallo) in bytes.
MMEMory:DATA? '/var/user/test.txt'
Sends the data of the file test.txt from the instrument to the
controller in the form of a binary block.
Response: #15hallo

Usage: SCPI confirmed
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:MMEMory:DCATalog? <path>

Returns the subdirectories of a particular directory.

Query parameters: 
<path> String parameter to specify the directory. If the directory is omit-

ted, the command queries the content of the current directory,
queried with :MMEMory:CDIRectory command.

Return values: 
<Catalog> <file_entry>

Names of the subdirectories separated by colons. The first two
strings are related to the parent directory.

Usage: Query only

:MMEMory:DCATalog:LENGth? [<Path>]

Returns the number of subdirectories in the current or specified directory.

Query parameters: 
<Path> String parameter to specify the directory. If the directory is omit-

ted, the command queries the contents of the current directory,
to be queried with :MMEMory:CDIRectory command.

Return values: 
<DirectoryCount> integer

Number of parent and subdirectories.

Usage: Query only

:MMEMory:DELete <Filename>

Removes a file from the specified directory.

Setting parameters: 
<Filename> string

String parameter to specify the name and directory of the file to
be removed.

Usage: Event
SCPI confirmed

Manual operation: See "Cut, Copy&Paste and Delete" on page 99

:MMEMory:LOAD:STATe <SavRclStateNumb>, <file_name>

Loads the specified file stored under the specified name in an internal memory.

After the file has been loaded, the instrument setting must be activated using an *RCL
command.
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Setting parameters: 
<SavRclStateNumb> Determines to the specific <number> to be used with the *RCL

command, e.g. *RCL 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Usage: Setting only

Manual operation: See "Recall" on page 95

:MMEMory:MDIRectory <Directory>

Creates a subdirectory for mass memory storage in the specified directory. If no direc-
tory is specified, a subdirectory is created in the default directory. This command can
also be used to create a directory tree.

Setting parameters: 
<Directory> string

String parameter to specify the new directory.

Usage: Event

Manual operation: See "Create New Directory" on page 99

:MMEMory:MOVE <SourceFile>, <DestinationFile>

Moves an existing file to a new location or, if no path is specified, renames an existing
file.

Setting parameters: 
<SourceFile> string

String parameter to specify the name of the file to be moved.

<DestinationFile> string
String parameters to specify the name of the new file.

Usage: Event
SCPI confirmed

Manual operation: See "Rename " on page 99

:MMEMory:MSIS <Msis>

Defines the drive or network resource (in the case of networks) for instruments with
windows operating system, using msis (MSIS = Mass Storage Identification String).

Note: Instruments with Linux operating system ignore this command, since Linux does
not use drive letter assignment.

Usage: SCPI confirmed
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:MMEMory:RDIRectory <Directory>

Removes an existing directory from the mass memory storage system. If no directory
is specified, the subdirectory with the specified name is deleted in the default directory.

Setting parameters: 
<Directory> string

String parameter to specify the directory to be deleted.

Usage: Event

:MMEMory:STORe:STATe <savrcl_state_nr>, <file_name>

Stores the current instrument setting in the specified file.

The instrument setting must first be stored in an internal memory with the same num-
ber using the common command *SAV.

Setting parameters: 
<savrcl_state_nr> Corresponds to the specific <number> defined with the *SAV

command, e.g. *SAV 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Usage: Event

Manual operation: See "Save" on page 95

:MEMory:HFRee?

Returns the used and available memory in Kb.

Return values: 
<TotalPhysMemKb> integer

Total physical memory.

<ApplicMemKb> integer
Application memory.

<HeapUsedKb> integer
Used heap memory.

<HeapAvailableKb> integer
Available heap memory.

Usage: Query only
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10.12  SYSTem Subsystem

The SYSTem subsystem contains a series of commands for general functions which do
not directly affect signal generation.

Example: Retrieving information on network-related settings
SYSTem:COMMunicate:NETWork:STATus?
// 1
SYSTem:PROTection1:STATe 0,123456

SYSTem:COMMunicate:NETWork:IPADdress:MODE STAT
SYSTem:COMMunicate:NETWork:IPADdress "10.113.0.104"
SYSTem:COMMunicate:NETWork:IPADdress:DNS "10.0.2.166"
SYSTem:COMMunicate:NETWork:COMMon:HOSTname?
// "AREG100A-102030"
SYSTem:COMMunicate:NETWork:COMMon:WORKgroup "instrument"
SYSTem:COMMunicate:NETWork:COMMon:DOMain "rsint.net"
SYSTem:COMMunicate:NETWork:IPADdress:GATeway "10.113.0.1"
SYSTem:COMMunicate:NETWork:IPADdress:SUBNet:MASK "255.255.252.0"
SYSTem:COMMunicate:NETWork:MACaddress "08 00 27 a3 a1 70"
SYSTem:PROTection1:STATe 1

Example: Finding out the used VISA ressource strings
SYSTem:COMMunicate:NETWork:RESource?
// "TCPIP::10.113.0.104::inst0::INSTR"

SYSTem:COMMunicate:HISLip:RESource?
// "TCPIP::10.113.0.104::hislip0::INSTR"

SYSTem:COMMunicate:SOCKet:RESource?
// "TCPIP::10.113.0.104::5025::SOCKET"
SYSTem:COMMunicate:USB:RESource?
// "USB::0x0AAD::0x01e1::100001::INSTR"

SYSTem:COMMunicate:GPIB:RESource?
// "GPIB::28::INSTR"
SYSTem:COMMunicate:GPIB:SELF:ADDRess?
// 28
SYSTem:COMMunicate:GPIB:LTERminator?
// STAN

SYSTem:COMMunicate:SERial:RESource?
// "ASRL1::INSTR"
SYSTem:COMMunicate:SERial:SBITs?
// 1
SYSTem:COMMunicate:SERial:BAUD?
// 115200
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SYSTem:COMMunicate:SERial:PARity?
// NONE

Example: Querying the error queue
SYSTem:ERRor:STATic?
// -221,"Settings conflict", 153,"Input voltage out of range", ...
// returns all static errors that are collected in the error queue

SYSTem:ERRor:HISTory:ClEar
// deletes the history entries

:SYSTem:ERRor:ALL?....................................................................................................245
:SYSTem:ERRor:CODE:ALL?......................................................................................... 246
:SYSTem:ERRor:CODE[:NEXT]?.....................................................................................246
:SYSTem:ERRor:COUNt?...............................................................................................247
:SYSTem:ERRor[:NEXT]?...............................................................................................247
:SYSTem:ERRor:GNEXt?............................................................................................... 248
:SYSTem:ERRor:HISTory:CLEar......................................................................................248
:SYSTem:ERRor:STATic?............................................................................................... 248
:SYSTem:DLOCk........................................................................................................... 248
:SYSTem:KLOCk........................................................................................................... 249
:SYSTem:NINFormation?................................................................................................249
:SYSTem:ULOCk........................................................................................................... 249
:SYSTem:LOCK:OWNer?................................................................................................250
:SYSTem:LOCK:RELease:ALL........................................................................................ 250
:SYSTem:LOCK:REQuest[:EXCLusive]?.......................................................................... 250
:SYSTem:SAV................................................................................................................251
:SYSTem:RCL............................................................................................................... 251
:SYSTem:PROTect<ch>[:STATe]......................................................................................251
:SYSTem:SECurity:VOLMode[:STATe]..............................................................................252
:SYSTem:COMMunicate:GPIB:LTERminator.....................................................................252
:SYSTem:COMMunicate:GPIB:RESource?....................................................................... 253
:SYSTem:COMMunicate:GPIB[:SELF]:ADDRess...............................................................253
:SYSTem:COMMunicate:HISLip:RESource?..................................................................... 253
:SYSTem:COMMunicate:NETWork:IPADdress.................................................................. 253
:SYSTem:COMMunicate:NETWork:IPADdress:MODE........................................................254
:SYSTem:COMMunicate:NETWork:MACaddress...............................................................254
:SYSTem:COMMunicate:NETWork:RESource?.................................................................254
:SYSTem:COMMunicate:NETWork:RESTart..................................................................... 254
:SYSTem:COMMunicate:NETWork:STATus?.................................................................... 255
:SYSTem:COMMunicate:NETWork[:COMMon]:DOMain.....................................................255
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname................................................255
:SYSTem:COMMunicate:NETWork[:COMMon]:WORKgroup.............................................. 255
:SYSTem:COMMunicate:NETWork[:IPADdress]:DNS.........................................................256
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway..................................................256
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK..........................................256
:SYSTem:COMMunicate:SERial:BAUD............................................................................ 256
:SYSTem:COMMunicate:SERial:PARity............................................................................256
:SYSTem:COMMunicate:SERial:RESource?.....................................................................257
:SYSTem:COMMunicate:SERial:SBITs.............................................................................257
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:SYSTem:COMMunicate:SOCKet:RESource?...................................................................257
:SYSTem:COMMunicate:USB:RESource?........................................................................ 257
:SYSTem:HELP:EXPort.................................................................................................. 258
:SYSTem:IDENtification.................................................................................................. 258
:SYSTem:IDENtification:PRESet......................................................................................258
:SYSTem:IRESponse..................................................................................................... 259
:SYSTem:ORESponse....................................................................................................259
:SYSTem:LANGuage......................................................................................................259
:SYSTem:INFormation:SCPI............................................................................................260
:SYSTem:SECurity:SANitize[:STATe]................................................................................260
:SYSTem:SECurity:SUPolicy........................................................................................... 260
:SYSTem:SPECification?................................................................................................ 260
:SYSTem:SPECification:VERSion....................................................................................261
:SYSTem:SPECification:IDENtification:CATalog?...............................................................261
:SYSTem:SPECification:PARameter?...............................................................................262
:SYSTem:SPECification:VERSion:CATalog?..................................................................... 262
:SYSTem:SPECification:VERSion:FACTory?.....................................................................262
:SYSTem:SRData?.........................................................................................................263
:SYSTem:STARtup:COMPlete?....................................................................................... 263
:SYSTem:DATE............................................................................................................. 263
:SYSTem:NTP:HOSTname............................................................................................. 264
:SYSTem:NTP:STATe..................................................................................................... 264
:SYSTem:TIME.............................................................................................................. 264
:SYSTem:TIME:ZONE.................................................................................................... 264
:SYSTem:TIME:ZONE:CATalog?......................................................................................265
:SYSTem:UPTime?........................................................................................................ 265
:SYSTem:BIOS:VERSion?.............................................................................................. 265
:SYSTem:VERSion?.......................................................................................................265
:SYSTem:OSYStem?......................................................................................................266
:SYSTem:MMEMory:PATH:USER?.................................................................................. 266
:SYSTem:DFPR?........................................................................................................... 266
:SYSTem:REBoot...........................................................................................................266
:SYSTem:RESTart..........................................................................................................266
:SYSTem:SHUTdown..................................................................................................... 267
:SYSTem:WAIT..............................................................................................................267

:SYSTem:ERRor:ALL?

Queries the error/event queue for all unread items and removes them from the queue.

Return values: 
<All> string

Error/event_number,"Error/event_description>[;Device-depend-
ent info]"
A comma separated list of error number and a short description
of the error in FIFO order.
If the queue is empty, the response is 0,"No error"
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.
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Volatile errors are reported once, at the time they appear. Identi-
cal errors are reported repeatedly only if the original error has
already been retrieved from (and hence not any more present in)
the error queue.

Example: SYST:ERR:ALL?
Queries all entries in the error queue.
Response: 0, 'no error'
No errors have occurred since the error queue was last read out.

Usage: Query only

Manual operation: See "Clear History" on page 300

:SYSTem:ERRor:CODE:ALL?

Queries the error numbers of all entries in the error queue and then deletes them.

Return values: 
<All> string

Returns the error numbers. To retrieve the entire error text, send
the command :SYSTem:ERRor:ALL?.

0
"No error", i.e. the error queue is empty
Positive value
Positive error numbers denote device-specific errors
Negative value
Negative error numbers denote error messages defined by
SCPI.

Example: SYST:ERR:CODE:ALL
Queries all entries in the error queue.
Response: 0
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:CODE[:NEXT]?

Queries the error number of the oldest entry in the error queue and then deletes it.

Return values: 
<Next> string

Returns the error number. To retrieve the entire error text, send
the command :SYSTem:ERRor:ALL?.

0
"No error", i.e. the error queue is empty
Positive value
Positive error numbers denote device-specific errors
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Negative value
Negative error numbers denote error messages defined by
SCPI.

Example: SYST:ERR:CODE
Queries the oldest entry in the error queue.
Response: 0
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:COUNt?

Queries the number of entries in the error queue.

Return values: 
<Count> integer

0
The error queue is empty.

Example: SYST:ERR:COUN
Queries the number of entries in the error queue.
Response: 1
One error has occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor[:NEXT]?

Queries the error/event queue for the oldest item and removes it from the queue.

Return values: 
<Next> string

Error/event_number,"Error/event_description>[;Device-depend-
ent info]"
Error number and a short description of the error.
If the queue is empty, the response is 0,"No error"
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.
Volatile errors are reported once, at the time they appear. Identi-
cal errors are reported repeatedly only if the original error has
already been retrieved from (and hence not any more present in)
the error queue.

Example: SYST:ERR?
Queries the oldest entry in the error queue.
Response: 0, 'no error'
No errors have occurred since the error queue was last read out.

Usage: Query only

Manual operation: See "Static Errors/Error History" on page 299
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:SYSTem:ERRor:GNEXt?

Similar to :SYSTem:ERRor[:NEXT]?, but queries the next entry from the global per-
sistant error/event queue.

Return values: 
<NextGlobalError> string

Error/event number, "Error/event description> [;Device depend-
ent info]"
An error number and a short description of the error.
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.

Example: SYST:ERR:GNEX?
Returns the next error message from the global error queue.

Usage: Query only

:SYSTem:ERRor:HISTory:CLEar

Clears the error history.

Example: See Example "Querying the error queue" on page 244

Usage: Event

Manual operation: See "Clear History" on page 300

:SYSTem:ERRor:STATic?

Returns a list of all errors existing at the time when the query is started. This list corre-
sponds to the display on the info page under manual control.

Return values: 
<StaticErrors> string

Example: See Example "Querying the error queue" on page 244

Usage: Query only

Manual operation: See "Static Errors/Error History" on page 299

:SYSTem:DLOCk <DispLockStat>

Disables the manual operation via the display, including the front panel keyboard of the
instrument and the Local key.

Parameters:
<DispLockStat> 0 | 1 | OFF | ON

*RST: n.a. (factory preset: 0)

Example: SYST:DLOC ON
Activates the display lock. The instrument cannot be operated
via the display until it has been enabled with SYST:DLOC OFF.
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Manual operation: See "User Interface" on page 135

:SYSTem:KLOCk <State>

Disables the front panel keyboard of the instrument including the Local key.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: n.a. (factory preset: 0)

Example: SYST:KLOC ON
Locks the front panel and external controls.
To enable the controls, send SYST:KLOC OFF.

Manual operation: See "User Interface" on page 135

:SYSTem:NINFormation?

Queries the oldest information message ("Error History > Level > Info") in the error/
event queue.

Return values: 
<NextInfo> string

Example: :SYSTem:NINFormation?
Queries the oldest entry in the info message queue.
Response: 90,"Info;=== Instrument startup...
==="
Information message containing error number 90, that states,
that the instrument startup is complete.

Usage: Query only

:SYSTem:ULOCk <Mode>

Locks or unlocks the user interface of the instrument.

Parameters:
<Mode> ENABled | DONLy | DISabled | TOFF | VNConly

ENABled
Unlocks the display, the touchscreen and all controls for the
manual operation.
DONLy
Locks the touchscreen and controls for the manual operation of
the instrument. The display shows the current settings.
VNConly
Locks the touchscreen and controls for the manual operation,
and enables remote operation over VNC. The display shows the
current settings.
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TOFF
Locks the touchscreen for the manual operation of the instru-
ment. The display shows the current settings.
DISabled
Locks the display, the touchscreen and all controls for the man-
ual operation.
*RST: n.a. (factory preset: ENABled)

Example: :SYST:ULOC DIS
Activates the user interface lock, including display and controls.

Manual operation: See "User Interface" on page 135

:SYSTem:LOCK:OWNer?

Queries the sessions that have locked the instrument currently.

If an exclusive lock is set, the query returns the owner of this exclusive lock, otherwise
it returns NONE.

Return values: 
<Owner> string

Example: SYST:LOCK:OWN?
Returns the owner of locking.
Response: NONE
The instrument is not locked.

Usage: Query only

:SYSTem:LOCK:RELease:ALL

Revokes the exclusive access to the instrument.

Usage: Setting only

:SYSTem:LOCK:REQuest[:EXCLusive]?

Queries whether a lock for exclusive access to the instrument via ethernet exists. If
successful, the query returns a 1, otherwise 0.

Return values: 
<Success> integer

Example: SYST:LOCK:REQ?
Queries the state of exclusive locking.
Response: 1
The exclusive locking is active.

Usage: Query only
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:SYSTem:SAV <Pathname>

Saves the current R&S AREG100A settings into a file with defined filename and into a
specified directory. The file extension (*.savrcltxt) is assigned automatically.

Setting parameters: 
<Pathname> string

Example: SYSTem:SAV "/var/user/temp/Test"
Saves the file Test.savrcltxt into the direc-
tory /var/user/temp/.

Usage: Setting only

:SYSTem:RCL <Pathname>

Loads a file with previously saved R&S AREG100A settings.

Loads the selected file with previously saved R&S AREG100A settings from the default
or the specified directory. Loaded are files with extension *.savrcltxt.

Setting parameters: 
<Pathname> string

Example: SYSTem:RCL "/var/user/temp/Test"
Loads the file Test.savrcltxt from the direc-
tory /var/user/temp/.

Usage: Setting only

:SYSTem:PROTect<ch>[:STATe] <State>[, <Key>]

Activates and deactivates the specified protection level.

Suffix: 
<ch>

.
Indicates the protection level.
See also "Protection" on page 129

Parameters:
<State> 0 | 1 | OFF | ON

*RST: n.a. (factory preset: 1)

Setting parameters: 
<Key> integer

The respective functions are disabled when the protection level
is activated. No password is required for activation of a level.
A password must be entered to deactivate the protection level.
The default password for the first level is 123456.
This protection level is required to unlock internal adjustments
for example.
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Example: To activate protection level:
SYSTem:PROTect1:STATe 1
Internal adjustments or hostname cannot be changed.
To unlock protection level 1:
SYSTem:PROTect1:STATe 0,123456
Internal adjustments are accessible.

Manual operation: See "Protection Level/Password" on page 131

:SYSTem:SECurity:VOLMode[:STATe] <SecPassWord>, <MmemProtState>

Activates volatile mode, so that no user data can be written to the internal memory per-
manently.

To enable volatile mode, reboot the instrument. Otherwise the change has no effect.

Parameters:
<MmemProtState> 0 | 1 | OFF | ON

*RST: 0

Setting parameters: 
<SecPassWord> string

Current security password
The default password is 123456.

Example: SYSTem:SECurity:VOLMode:STATe "123456", 1
SYSTem:REBoot

Manual operation: See "Volatile Mode" on page 134

:SYSTem:COMMunicate:GPIB:LTERminator <LTerminator>

Sets the terminator recognition for remote control via GPIB interface.

Parameters:
<LTerminator> STANdard | EOI

EOI
Recognizes an LF (Line Feed) as the terminator only when it is
sent with the line message EOI (End of Line). This setting is rec-
ommended particularly for binary block transmissions, as binary
blocks may coincidentally contain a characater with value LF
(Line Feed), although it is not determined as a terminator.
STANdard
Recognizes an LF (Line Feed) as the terminator regardless of
whether it is sent with or without EOI.
*RST: n.a. (factory preset: STANdard)

Example: See Example "Finding out the used VISA ressource strings"
on page 243.
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:SYSTem:COMMunicate:GPIB:RESource?

Queries the visa resource string for remote control via the GPIB interface.

To change the GPIB address, use the command :SYSTem:COMMunicate:GPIB[:
SELF]:ADDRess.

Return values: 
<Resource> string

Example: See Example "Finding out the used VISA ressource strings"
on page 243.

Usage: Query only

:SYSTem:COMMunicate:GPIB[:SELF]:ADDRess <Address>

Sets the GPIB address.

Parameters:
<Address> integer

Range: 0  to  30
*RST: 28

Example: See Example "Finding out the used VISA ressource strings"
on page 243.

:SYSTem:COMMunicate:HISLip:RESource?

Queries the VISA resource string. This string is used for remote control of the instru-
ment with HiSLIP protocol.

Return values: 
<Resource> string

Example: See Example "Finding out the used VISA ressource strings"
on page 243.

Usage: Query only

:SYSTem:COMMunicate:NETWork:IPADdress <IpAddress>

Sets the IP address.

Parameters:
<IpAddress> string

Range: 0.0.0.0.  to  ff.ff.ff.ff

Example: See Example "Retrieving information on network-related set-
tings" on page 243.

Manual operation: See "IP Address" on page 160
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:SYSTem:COMMunicate:NETWork:IPADdress:MODE <Mode>

Selects manual or automatic setting of the IP address.

Parameters:
<Mode> AUTO | STATic

*RST: n.a. (factory preset: AUTO)

Example: See Example "Retrieving information on network-related set-
tings" on page 243.

Example: SYSTem:COMMunicate:NETWork:IPADdress:MODE
STATic
SYSTem:COMMunicate:NETWork:IPADdress
"10.113.0.105"

Manual operation: See "Address Mode" on page 159

:SYSTem:COMMunicate:NETWork:MACaddress <MacAddress>

Queries the MAC address of the network adapter.

This is a password-protected function. Unlock the protection level 1 to access it.

Parameters:
<MacAddress> string

Example: See Example "Retrieving information on network-related set-
tings" on page 243.

Manual operation: See "MAC Address" on page 161

:SYSTem:COMMunicate:NETWork:RESource?

Queries the visa resource string for Ethernet instruments.

Return values: 
<Resource> string

Example: See Example "Finding out the used VISA ressource strings"
on page 243.

Usage: Query only

:SYSTem:COMMunicate:NETWork:RESTart

Restarts the network.

Example: SYSTem:COMMunicate:NETWork:RESTart
// Terminates the network connection and sets it up again

Usage: Event

Manual operation: See "Restart Network" on page 159
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:SYSTem:COMMunicate:NETWork:STATus?

Queries the network configuration state.

Return values: 
<State> 0 | 1 | OFF | ON

Example: See Example "Retrieving information on network-related set-
tings" on page 243.

Usage: Query only

Manual operation: See "Network Status" on page 159

:SYSTem:COMMunicate:NETWork[:COMMon]:DOMain <Domain>

Determines the primary suffix of the network domain.

Parameters:
<Domain> string

Example: See Example "Retrieving information on network-related set-
tings" on page 243.

Manual operation: See "DNS Suffix" on page 160

:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname <Hostname>

Sets an individual hostname for the Automotive Radar Echo Generator.

Note:We recommend that you do not change the hostname to avoid problems with the
network connection. If you change the hostname, be sure to use a unique name.

This is a password-protected function. Unlock the protection level 1 to access it.

Parameters:
<Hostname> string

Example: See Example "Retrieving information on network-related set-
tings" on page 243.

Manual operation: See "Hostname" on page 159

:SYSTem:COMMunicate:NETWork[:COMMon]:WORKgroup <Workgroup>

Sets an individual workgroup name for the instrument.

Parameters:
<Workgroup> string

Example: See Example "Retrieving information on network-related set-
tings" on page 243.

Manual operation: See "Workgroup" on page 159
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:SYSTem:COMMunicate:NETWork[:IPADdress]:DNS <DNS>

Determines or queries the network DNS server to resolve the name.

Parameters:
<DNS> string

Example: See Example "Retrieving information on network-related set-
tings" on page 243.

Manual operation: See "DNS Server" on page 160

:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway <Gateway>

Sets the IP address of the default gateway.

Parameters:
<Gateway> string

Range: 0.0.0.0  to  ff.ff.ff.ff

Example: See Example "Retrieving information on network-related set-
tings" on page 243.

Manual operation: See "Default Gateway" on page 160

:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK <Mask>

Sets the subnet mask.

Parameters:
<Mask> string

Example: See Example "Retrieving information on network-related set-
tings" on page 243.

Manual operation: See "Subnet Mask" on page 160

:SYSTem:COMMunicate:SERial:BAUD <Baud>

Defines the baudrate for the serial remote control interface.

Parameters:
<Baud> 2400 | 4800 | 9600 | 19200 | 38400 | 57600 | 115200

*RST: n.a. (factory preset: 115200)

Example: See Example "Finding out the used VISA ressource strings"
on page 243.

Manual operation: See "Baud Rate" on page 163

:SYSTem:COMMunicate:SERial:PARity <Parity>

Enters the parity for the serial remote control interface.
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Parameters:
<Parity> NONE | ODD | EVEN

*RST: n.a. (factory preset: NONE)

Example: See Example "Finding out the used VISA ressource strings"
on page 243.

Manual operation: See "Parity" on page 163

:SYSTem:COMMunicate:SERial:RESource?

Queries the visa resource string for the serial remote control interface. This string is
used for remote control of the instrument.

Return values: 
<Resource> string

Example: See Example "Finding out the used VISA ressource strings"
on page 243.

Usage: Query only

:SYSTem:COMMunicate:SERial:SBITs <SBits>

Defines the number of stop bits for the serial remote control interface.

Parameters:
<SBits> 1 | 2

*RST: n.a. (factory preset: 1)

Example: See Example "Finding out the used VISA ressource strings"
on page 243.

Manual operation: See "Stop Bits" on page 163

:SYSTem:COMMunicate:SOCKet:RESource?

Queries the visa resource string for remote control via LAN interface, using TCP/IP
socket protocol.

Return values: 
<Resource> string

Example: See Example "Finding out the used VISA ressource strings"
on page 243.

Usage: Query only

:SYSTem:COMMunicate:USB:RESource?

Queries the visa resource string for remote control via the USB interface.
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Return values: 
<Resource> string

Example: See Example "Finding out the used VISA ressource strings"
on page 243.

Usage: Query only

:SYSTem:HELP:EXPort

Saves the online help as zip archive in the user directory.

Example: :SYSTem:HELP:EXPort
MMEM:CDIR?
// "/var/user"
MMEM:CAT?
// ..,"Log,DIR,4096","help.tgz,BIN,69836600"
// confirms that help zip archive is saved.

Usage: Event

Manual operation:: "Setup > Help > Export Help to User Path"

:SYSTem:IDENtification <Identification>

Selects the mode to determine the "IDN String" and the "OPT String" for the instru-
ment, selected with command :SYSTem:LANGuage.

Note: While working in an emulation mode, the R&S AREG100A specific command set
is disabled, that is, the SCPI command SYST:IDEN is discarded.

Parameters:
<Identification> AUTO | USER

AUTO
Automatically determines the strings.
USER
User-defined strings can be selected.
*RST: n.a. (factory preset: AUTO)

Example: SYST:IDEN AUTO
Automatically assigns the OPT and IDN strings according to the
selected instrument language.

Manual operation: See "Mode" on page 164

:SYSTem:IDENtification:PRESet

Sets the *IDN and *OPT strings in user defined mode to default values.

Example: SYST:IDEN USER
SYST:IDEN:PRES

Usage: Event
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Manual operation: See "Set to Default" on page 164

:SYSTem:IRESponse <IdnResponse>

Defines the user defined identification string for *IDN.

Note: While working in an emulation mode, the instrument's specific command set is
disabled, i.e. the SCPI command SYST:IRES is discarded.

Parameters:
<IdnResponse> string

Example: SYST:IDEN USER
// Selects a user-defined identification
SYST:IRES "Test Device"
// Defines identification string 'test device'
*IDN?
// Response: 'test device'

Manual operation: See "IDN String" on page 164

:SYSTem:ORESponse <OResponse>

Defines the user defined response string for *OPT.

Note: While working in an emulation mode, the instrument's specific command set is
disabled, i.e. the SCPI command SYST:ORES is discarded.

Parameters:
<OResponse> string

Example: SYST:IDEN USER
// Selects a user-defined identification
SYST:ORES "Test Option"
// Defines the OPT string 'test option'
*OPT?
// Response: 'test option'

Manual operation: See "OPT String" on page 164

:SYSTem:LANGuage <Language>

Sets the remote control command set.

Parameters:
<Language> string

Example: SYSTem:LANGuage "SCPI"
// selects SCPI command set

Manual operation: See "Language" on page 164
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:SYSTem:INFormation:SCPI <InfoString>

Inserts system information in recorded SCPI command lists, for example information
on a missing command.

Parameters:
<InfoString> string

Example: SYST:INF:SCPI "missing command"
enters the information into a recorded SCPI command list.

:SYSTem:SECurity:SANitize[:STATe] <SecPassWord>, <MmemProtState>

Sanitizes the internal memory.

Parameters:
<MmemProtState> 0 | 1 | OFF | ON

*RST: 0

Setting parameters: 
<SecPassWord> string

Example: SYSTem:SECurity:SANitize[:STATe] 1

Manual operation: See "Sanitize" on page 134

:SYSTem:SECurity:SUPolicy <SecPassWord>, <UpdatePolicy>

Configures the automatic signature verification for firmware installation.

Parameters:
<UpdatePolicy> STRict | CONFirm | IGNore

*RST: n.a. (factory preset: CONFirm)

Setting parameters: 
<SecPassWord> string

Manual operation: See "Secure Update Policy" on page 132

:SYSTem:SPECification? <Id>

Retrieves data sheet information for a specific parameter.

Setting parameters: 
<Id> string

Identifies the name of the entry in the data sheet, as quieried
with the command :SYSTem:SPECification:
IDENtification:CATalog? on page 261

Return values: 
<ValList> float

Comma-separated list with the specified and, if available, the
typical value of the parameter, as specified in the data sheet.
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Example: Retrieving instruments specification
Note: The following values are merely an example.
Query the data sheet versions stored in the instrument:
:SYSTem:SPECification:VERSion:CATalog?
"04.03,04.02,04.01,04.00,03.04,03.03,03.02,
03.01,03.00,02.96,02.95,02.94,02.02,02.01,
02.00,01.03,01.02,01.01,01.00"
Query the data sheet version with that the instrument was deliv-
ered:
:SYSTem:SPECification:VERSion:FACTory?
"04.00"
Select a data sheet version:
:SYSTem:SPECification:VERSion?
"04.00"
:SYSTem:SPECification:VERSion "04.01"
Selects one particular data sheet version.
Queries regarding data sheet parameters (IDs) and their values
Rrefer to this particular data sheet
Query the IDs of all parameters listed in the selected data sheet
version:
:SYSTem:SPECification:IDENtification:CATalog?
"ID_RF_FREQ_SETTING_TIME_ALC_ON_MS,
ID_RF_FREQ_SETTING_TIME_MS,..."
Query the data sheet information on a specific parameter,
defined by its ID
:SYSTem:SPECification?
"ID_RF_FREQ_SETTING_TIME_ALC_ON_MS"
Rreturned is the specified and, if available, the typical value of
the parameter

Usage: Query only

:SYSTem:SPECification:VERSion <Version>

Selects a data sheet version from the data sheets saved on the instrument.

Further queries regarding the data sheet parameters (<Id>) and their values refer to
the selected data sheet.

To query the list of data sheet versions, use the command :SYSTem:
SPECification:VERSion:CATalog? on page 262.

Parameters:
<Version> string

Example: See :SYSTem:SPECification? on page 260.

:SYSTem:SPECification:IDENtification:CATalog?

Queries the parameter identifiers (<Id>) available in the data sheet.
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Return values: 
<IdList> string

Comma-separated string of the parameter identifiers (<Id>)

Example: See :SYSTem:SPECification? on page 260.

Usage: Query only

:SYSTem:SPECification:PARameter? <Id>[, <Parameter>]

Retrieves data sheet information for a specific parameter.

Setting parameters: 
<Id> string

Identifies the name of the entry in the data sheet.
Query the data sheet parameters with the command :SYSTem:
SPECification:IDENtification:CATalog?.

<Parameter> float
An additional value the result (ValList) depends on.

Return values: 
<ValList> float

Comma-separated list with the specified and, if available, the
typical value of the parameter, as specified in the data sheet.

Example: Note: The following values are merely an example. Your instru-
ment may not support the same parameters.
SYST:SPEC:PAR? "ID_RF_FREQ_SETTING_TIME_MS",0.1
SYST:SPEC:PAR? "ID_RF_LEVEL_MAX_GENERAL_DBM",
0.1

Usage: Query only

:SYSTem:SPECification:VERSion:CATalog?

Queries all data sheet versions stored in the instrument.

Return values: 
<VersCatalog> string

Example: See :SYSTem:SPECification? on page 260.

Usage: Query only

:SYSTem:SPECification:VERSion:FACTory?

Queries the data sheet version of the factory setting.

Return values: 
<Version> string

Example: See :SYSTem:SPECification? on page 260.
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Usage: Query only

Manual operation: See "Versions" on page 304

:SYSTem:SRData?

Queris the SCPI recording data from the internal file.

This feature enables you to transfer an instrument configuration to other test environ-
ments, as e.g. laboratory virtual instruments.

Return values: 
<FileData> block data

Example: SYSTem:SRData? 
// #3118:SOURce1:ROSCillator:SOURce EXT
// :SOURce1:FREQuency:CW 4000000000
// :SOURce1:FREQuency:OFFSet 1000000
// :SOURce1:AM1:STATe 1
// :OUTPut1:STATe 1

Usage: Query only

:SYSTem:STARtup:COMPlete?

Queries if the startup of the instrument is completed.

Return values: 
<Complete> 0 | 1 | OFF | ON

*RST: 0

Example: SYST:STAR:COMP?
Response: 1
the startup of the instrument is completed.

Usage: Query only

:SYSTem:DATE <Year>, <Month>, <Day>

Queries or sets the date for the instrument-internal calendar.

This is a password-protected function. Unlock the protection level 1 to access it.

Parameters:
<Year> integer

<Month> integer
Range: 1  to  12

<Day> integer
Range: 1  to  31

Example: :SYSTem:DATE?
// 2016,05,01
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Manual operation: See "Date" on page 314

:SYSTem:NTP:HOSTname <NTPName>

Sets the address of the NTP server. You can enter the IP address, or the hostname of
the time server, or even set up an own vendor zone. See the Internet for more informa-
tion on NTP.

Parameters:
<NTPName> string

Manual operation: See "NTP Address" on page 315

:SYSTem:NTP:STATe <UseNtpState>

Activates clock synchronization via NTP.

Parameters:
<UseNtpState> 0 | 1 | OFF | ON

*RST: n.a. (factory preset: 0)

Example: SYSTem:NTP:STATe 1

Manual operation: See "Use Time from NTP Server" on page 315

:SYSTem:TIME <Hour>, <Minute>, <Second>

Queries or sets the time for the instrument-internal clock.

This is a password-protected function. Unlock the protection level 1 to access it.

Parameters:
<Hour> integer

Range: 0  to  23

<Minute> integer
Range: 0  to  59

<Second> integer
Range: 0  to  59

Example: SYSTem:TIME?
// 10,27,14

Manual operation: See "Time" on page 314

:SYSTem:TIME:ZONE <TimeZone>

Sets the timezone. You can query the list of the available timezones with :SYSTem:
TIME:ZONE:CATalog?.

Parameters:
<TimeZone> string
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Manual operation: See "Timezone" on page 314

:SYSTem:TIME:ZONE:CATalog?

Querys the list of available timezones.

Return values: 
<Catalog>

Usage: Query only

Manual operation: See "Timezone" on page 314

:SYSTem:UPTime?

Queries the up time of the operating system.

Return values: 
<UpTime> "<ddd.hh:mm:ss>"

Example: SYSTem:UPTime?
Response: "0.08:11:00"

Usage: Query only

:SYSTem:BIOS:VERSion?

Queries the BIOS version of the instrument.

Return values: 
<Version> string

Example: SYST:BIOS:VERS?
queries the BIOS version.
Response: 123456

Usage: Query only

:SYSTem:VERSion?

Queries the SCPI version the instrument's command set complies with.

Return values: 
<Version> string

Example: SYST:VERS
queries the SCPI version.
Response: "1996"
The instrument complies with the SCPI version from 1996.

Usage: Query only
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:SYSTem:OSYStem?

Queries the operating system of the instrument.

Return values: 
<OperSystem> string

Example: SYSTem:OSYStem?
Response: "Linux"

Usage: Query only

:SYSTem:MMEMory:PATH:USER?

Queries the user directory, that means the directory the R&S AREG100A stores user
files on.

Return values: 
<PathUser> string

Example: SYSTem:MMEMory:PATH:USER?
Response: "'/var/user/"

Usage: Query only

:SYSTem:DFPR?

Queries the device footprint of the instrument. The retrieved information is in machine-
readable form suitable for automatic further processing.

Return values: 
<DeviceFootprint> string

Information on the instrument type, device identification and
details on the installed FW version, hardware and software
options.

Example: :SYSTem:DFPR?
Usage: Query only

:SYSTem:REBoot

Reboots the instrument including the operating system.

Usage: Event

:SYSTem:RESTart

Restarts the instrument without restarting the operating system.

Usage: Event
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:SYSTem:SHUTdown

Shuts down the instrument.

Usage: Event

Manual operation: See "Shut down" on page 319

:SYSTem:WAIT <TimeMs>

Delays the execution of the subsequent remote command by the specified time.

This function is useful, for example to execute an SCPI sequence automatically but
with a defined time delay between some commands.

See Chapter 8.2.4, "How to Assign Actions to the [User] Key", on page 122.

Setting parameters: 
<TimeMs> integer

Wait time in ms
Range: 0  to  10000
*RST: 0

Example: :SYSTem:WAIT 10000
// waits 10s before resetting the instrument
*RST

Usage: Setting only

10.13  TEST

:TEST<hw>:ALL:RESult?................................................................................................267
:TEST<hw>:ALL:STARt.................................................................................................. 267

:TEST<hw>:ALL:RESult?

Queries the result of the performed selftest. Start the selftest with :TEST<hw>:ALL:
STARt.

Return values: 
<Result> 0 | 1 | RUNning | STOPped

*RST: STOPped

Usage: Query only

:TEST<hw>:ALL:STARt

Usage: Event

Starts the selftest. Use the command :TEST<hw>:ALL:RESult? to query the result.
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10.14  SOURce Subsystem

[:SOURce]:ROSCillator:SOURce..................................................................................... 268
[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe].............................................................268
[:SOURce<hw>]:FREQuency[:CW|FIXed].........................................................................269
[:SOURce<hw>]:FREQuency[:CW|FIXed]:RCL................................................................. 269
[:SOURce<hw>]:AREGenerator:OBJect:ALL[:STATe].........................................................269
[:SOURce<hw>]:AREGenerator:OBJect<ch>:ATTenuation................................................. 270
[:SOURce<hw>]:AREGenerator:OBJect<ch>:DOPPler[:SPEed]..........................................270
[:SOURce<hw>]:AREGenerator:OBJect<ch>:DOPPler:FREQuency....................................270
[:SOURce<hw>]:AREGenerator:OBJect<ch>:RANGe?...................................................... 271
[:SOURce<hw>]:AREGenerator:OBJect<ch>:RCS?.......................................................... 271
[:SOURce<hw>]:AREGenerator:OBJect<ch>[:STATe]........................................................ 271
[:SOURce<hw>]:AREGenerator:RADar:ANTenna:CUSTom[:STATe].................................... 272
[:SOURce<hw>]:AREGenerator:RADar:ANTenna:REG:GAIN:TX........................................ 272
[:SOURce<hw>]:AREGenerator:RADar:ANTenna:REG:GAIN:RX........................................272
[:SOURce<hw>]:AREGenerator:RADar:BASE:ATTenuation................................................272
[:SOURce<hw>]:AREGenerator:RADar:EIRP:SENSor....................................................... 273
[:SOURce<hw>]:AREGenerator:RADar:EIRP?..................................................................273
[:SOURce<hw>]:AREGenerator:RADar:LSENsitivity..........................................................274
[:SOURce<hw>]:AREGenerator:RADar:OTA:OFFSet.........................................................274
[:SOURce<hw>]:AREGenerator:RADar:DBYPass[:STATe]................................................. 274
[:SOURce<hw>]:AREGenerator:RADar:POWer:INDicator?................................................ 274
[:SOURce<hw>]:AREGenerator:UNITs:RANGe.................................................................275
[:SOURce<hw>]:AREGenerator:UNITs:DOPPler............................................................... 275
[:SOURce<hw>]:AREGenerator:UNITs:RCS..................................................................... 275
[:SOURce<hw>]:AREGenerator:UNITs:SPEed.................................................................. 276

[:SOURce]:ROSCillator:SOURce <Source>

Selects between internal or external reference frequency.

Parameters:
<Source> INTernal | EXTernal

*RST: n.a. (factory preset: INTernal)

Example: SOURce:ROSCillator:SOURce INTernal
Manual operation: See "Source" on page 72

[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe] <State>

Determines whether the calibrated (off) or a user-defined (on) adjustment value is
used for fine adjustment of the frequency.

Parameters:
<State> 0 | 1 | OFF | ON

0
Fine adjustment with the calibrated frequency value
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1
User-defined adjustment value.
The instrument is no longer in the calibrated state.
The calibration value is, however, not changed. The instrument
resumes the calibrated state if you send
SOURce:ROSCillator:INTernal:ADJust:STATe 0.

*RST: n.a. (factory preset: 0)

Example: SOURce:ROSCillator:INTernal:ADJust:STATe 0

[:SOURce<hw>]:FREQuency[:CW|FIXed] <Frequency>

R&S AREG-B124/-B177: queries the center frequency.

R&S AREG-B181: sets the center frequency of the RF output signal.

Parameters:
<Frequency> float

Range: R&S AREG-B124: 24 GHz, R&S AREG-B177: 77
GHz, R&S AREG-B181: 78 GHz and 79 GHz

Increment: dynamic

[:SOURce<hw>]:FREQuency[:CW|FIXed]:RCL <Rcl>

Set whether the RF frequency value is retained or taken from a loaded instrument con-
figuration, when you recall instrument settings with command *RCL.

Parameters:
<Rcl> INCLude | EXCLude

INCLude
Takes the frequency value of the loaded settings.
EXCLude
Retains the current frequency when an instrument configuration
is loaded.
*RST: INCLude

Example: SOURce1:FREQuency:CW:RCL INCLude
Manual operation: See "Exclude Frequency" on page 95

[:SOURce<hw>]:AREGenerator:OBJect:ALL[:STATe] <GlobalObjStat>

Switches all available radar objects (1 to 4) on or off simultaneously.

Parameters:
<GlobalObjStat> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring radar objects" on page 209.

Manual operation: See "State" on page 66
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[:SOURce<hw>]:AREGenerator:OBJect<ch>:ATTenuation <AregObjAtt>

Sets the attenuation of a specific radar object. Together with the base attenuation that
applies to all radar objects, it forms the total attenuation for the specific object.

Parameters:
<AregObjAtt> float

Range: 0  to  63.5
Increment: 0.5
*RST: 50

Example: See Example "Configuring radar objects" on page 209.

Manual operation: See "Attenuation" on page 66

[:SOURce<hw>]:AREGenerator:OBJect<ch>:DOPPler[:SPEed] <AregObjectDopp>

If [:SOURce<hw>]:AREGenerator:UNITs:DOPPlerSPEed, sets the Doppler
speed of a specific object.

Parameters:
<AregObjectDopp> float

If you do no specify a speed unit, the default unit is used.
Range: -500  to  500
Increment: depends on options
*RST: 0
Default unit: km/h

Example: // to set the Doppler speed to 80 km/h
SOURce:AREGenerator:OBJect4:DOPPler 80
// to set the Doppler speed to 80 mph (miles per hour)
SOURce:AREGenerator:OBJect4:DOPPler 80mph
// to set the Doppler speed to 80 m/s
SOURce:AREGenerator:OBJect4:DOPPler 80mps

Options: R&S AREG-K799: set value applies to all objects
R&S AREG-B60: individual values per object can be set

Manual operation: See "Doppler Speed" on page 67

[:SOURce<hw>]:AREGenerator:OBJect<ch>:DOPPler:FREQuency
<AregObDoppFreq>

If [:SOURce<hw>]:AREGenerator:UNITs:DOPPlerFREQuency, sets the Doppler
frequency of a specific object.

Parameters:
<AregObDoppFreq> float

Range: depends on settings  to  depends on settings
Increment: depends on options
*RST: 0
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Example: See Example "Configuring radar objects" on page 209.

Options: R&S AREG-K799: set value applies to all objects
R&S AREG-B60: individual values per object can be set

Manual operation: See "Doppler Shift" on page 67

[:SOURce<hw>]:AREGenerator:OBJect<ch>:RANGe?

Queries the object's range.

The value is the sum of the fixed delay (depending on the installed option) and the air
gap between DUT and R&S AREG100A.

Return values: 
<AregObjRange> float

Range: depends on settings
Increment: 0.1
*RST: n.a. (no preset)

Example: See Example "Configuring radar objects" on page 209.

Usage: Query only

Manual operation: See "Range" on page 66

[:SOURce<hw>]:AREGenerator:OBJect<ch>:RCS?

Queries the calculated radar cross section of an object.

Return values: 
<AregObjRcs> float

Range: -100  to  100
Increment: 0.1
*RST: 0

Example: See Example "Configuring radar objects" on page 209.

Usage: Query only

Manual operation: See "RCS" on page 67

[:SOURce<hw>]:AREGenerator:OBJect<ch>[:STATe] <AregObjState>

Activates one of the available radar objects (1 to 4).

Parameters:
<AregObjState> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring radar objects" on page 209.

Manual operation: See "State" on page 66
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[:SOURce<hw>]:AREGenerator:RADar:ANTenna:CUSTom[:STATe]
<AregAntCustStat>

If enabled, you can use a custom antenna and define the transmitting and receiving
gain values with the commands:
● [:SOURce<hw>]:AREGenerator:RADar:ANTenna:REG:GAIN:TX

on page 272
● [:SOURce<hw>]:AREGenerator:RADar:ANTenna:REG:GAIN:RX

on page 272.

Parameters:
<AregAntCustStat> 0 | 1 | OFF | ON

0 | OFF
The predefined antenna gain settings for transmitting and receiv-
ing antenna are used.
1 | ON
The customer-specific antenna gain settings for transmitting and
receiving antenna apply.
*RST: n.a. (factory preset: 0)

Example: See Example "Configuring radar objects" on page 209.

Manual operation: See "Use Custom Antenna" on page 71

[:SOURce<hw>]:AREGenerator:RADar:ANTenna:REG:GAIN:TX <AregAntGainTx>
[:SOURce<hw>]:AREGenerator:RADar:ANTenna:REG:GAIN:RX <AregAntGainRx>

Queries the antenna gain of the transmitting/receiving antenna.

If [:SOURce<hw>]:AREGenerator:RADar:ANTenna:CUSTom[:STATe]1, you can
define a customer-specific antenna gain value.

Parameters:
<AregAntGainRx> integer

Range: 0  to  30
Increment: 0.01
*RST: n.a. (factory preset: 10)

Example: See Example "Configuring radar objects" on page 209.

Manual operation: See "AREG Antenna Gain RX" on page 71

[:SOURce<hw>]:AREGenerator:RADar:BASE:ATTenuation <AregBaseAtt>

Defines the attenuation affecting all radar objects. Together with the individual attenua-
tion for a single radar object, it forms the total attenuation for the specific object.
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Parameters:
<AregBaseAtt> integer

Range: -50  to  150
*RST: 0
Default unit: dB

Example: See Example "Configuring radar objects" on page 209.

Manual operation: See "Base Attenuation" on page 68

[:SOURce<hw>]:AREGenerator:RADar:EIRP:SENSor <AregPowSenSelec>

Queries if and which sensor is used to measure the EIRP value.

Parameters:
<AregPowSenSelec> SEN4 | SEN3 | SEN2 | SEN1 | UDEFined

UDEFined
No sensor is selected for EIRP measurement.
However, there can be power sensors connected to one of the
"USB" connectors or the "Sensor" connector of the
R&S AREG100A.
Sent the :SLISt[:LIST]? query to find out if and which power
sensors are connected to the instrument.
SEN4|SEN3|SEN2|SEN1
Indicates that a power sensor is connected to the frontend.
The number SENx indicates the subsequent number in the sen-
sor mapping list of the corresponding sensor. Observe the most
left column in the "NRP Sensor Mapping" dialog.
See :SLISt:ELEMent<ch>:MAPPing on page 281.

*RST: n.a. (no preset. default: UNDefined)

Example: See Example "Measuring EIRP" on page 210.

Manual operation: See "Sensor" on page 73

[:SOURce<hw>]:AREGenerator:RADar:EIRP?

Queries the measured EIRP value of the radar sensor.

For details, see "EIRP calculation" on page 55.

Return values: 
<AregRadarEirp> float

Range: -150  to  150
Increment: 0.001
*RST: 0

Example: See Example "Measuring EIRP" on page 210.

Usage: Query only

Manual operation: See "EIRP" on page 73
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[:SOURce<hw>]:AREGenerator:RADar:LSENsitivity <AregRadarLowSen>

Defines if low sensitivity is used or not.

Parameters:
<AregRadarLowSen> 0 | 1 | OFF | ON

*RST: 1

Example: See Example "Configuring radar objects" on page 209.

Manual operation: See "Low Sensitivity" on page 68

[:SOURce<hw>]:AREGenerator:RADar:OTA:OFFSet <AregOtaOffset>

Defines the distance (air gap) from the R&S AREG100A to the RUT (radar under test).

Parameters:
<AregOtaOffset> float

Range: 0.01  to  10
Increment: 0.01
*RST: 1
Default unit: m

Example: See Example "Configuring radar objects" on page 209.

Manual operation: See "Air Gap from DUT to AREG" on page 71

[:SOURce<hw>]:AREGenerator:RADar:DBYPass[:STATe] <AregRadarDopByp>

Enable to bypass the Doppler stage.

For details, see "Enable Doppler Bypass" on page 72.

Parameters:
<AregRadarDopByp> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring radar objects" on page 209.

Options: R&S AREG-B60

Manual operation: See "Enable Doppler Bypass" on page 72

[:SOURce<hw>]:AREGenerator:RADar:POWer:INDicator?

The radar power indicator is a summary indicator for all radar object powers.

Return values: 
<PowIndicator> OFF | GOOD | WEAK | BAD

OFF
No or very weak RX power is detected.
GOOD
The RX power is in linear range.
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WEAK
The RX power is strong, non-linear effects can occur.
BAD
The RX power is in a range, where the receiver is in saturation.
*RST: OFF

Example: See Example "Configuring radar objects" on page 209.

Usage: Query only

[:SOURce<hw>]:AREGenerator:UNITs:RANGe <AregUnitRange>

Defines the range unit.

Parameters:
<AregUnitRange> M | CM | FT

M
Meter
CM
Centimeter
FT
Feet
*RST: M

Example: :SOURce:AREGenerator:UNITs:RANGe FT
Manual operation: See "Range Unit" on page 69

[:SOURce<hw>]:AREGenerator:UNITs:DOPPler <AregObjDoppUnit>

Defines if the radial velocity is defined as Doppler speed or frequency.

Parameters:
<AregObjDoppUnit> SPEed | FREQuency

*RST: SPEed

Example: See Example "Configuring radar objects" on page 209.

Manual operation: See "Doppler Format" on page 69

[:SOURce<hw>]:AREGenerator:UNITs:RCS <AregUnitRcs>

Defines the unit of the radar cross section.

Parameters:
<AregUnitRcs> DBSM | SM

DBSM
dB relative to one square meter.
SM
m2 (square meters).
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*RST: DBSM

Example: SOURce:AREGenerator:UNITs:RCS SM
Manual operation: See "RCS Unit" on page 69

[:SOURce<hw>]:AREGenerator:UNITs:SPEed <AregUnitSpeed>

Defines the speed unit.

Parameters:
<AregUnitSpeed> KMH | MPH | MPS

KMH
Kilometer per hour
MPH
Miles per Hour
MPS
Meter per Seconds
*RST: KMH

Example: SOURce:AREGenerator:UNITs:SPEed KMH
Manual operation: See "Speed Unit" on page 69

10.15  SENSe, READ, INITiate and SLISt Subsystems

These subsystems contain the commands for configuring the power measurements
with R&S NRP power sensor connected to the R&S AREG100A.

The local state is set with the INIT command. Switching off the local state enhances
the measurement performance. Measurements results can be retrieved in local state
on or off.
Sensor parameters are set with the SENSe commands.

To start the measurement and retrieve the result, use the :READ<ch>[:POWer]?
command.

Suffix Value range Description

SENSe<ch> [1] to 4 Indicates the sensor

Use the :SLISt commands to change the sensor mapping

READ<ch> [1] to 4 Sensor assignment

INIate<hw> [1] to 4 Sensor assignment

ELEMent<ch> [1] to 25 Sensor mapping list
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Programming examples

Example: Detecting and assigning a power sensor
:SLISt:LIST?
// Response: "NRP33SN-V-900007-USB Legacy","NRP-Z211-900001-USB Legacy"
// list of automatically detected sensors

:SLISt:SCAN:STATe 1
// searches for sensors connected in the LAN or via the USBTMC protocol

:SLISt:SCAN:LSENsor 'NRQ6',101624 //sensor name, serial number
:SLISt:SCAN:LSENsor 'NRQ6',11.123.1.123, 101624 //IP address, serial number
// add sensor connected in the LAN to the list

:SLISt:SCAN:USENsor 'NRQ6',101624 //sensor name, serial number
:SLISt:SCAN:USENsor #H15b,101624  //device ID (hexadecimal), serial number
:SLISt:SCAN:USENsor 347,101624    //device ID (decimal), serial number
// add sensor connected at the USB interface to the list

:SLISt:LIST?
// Response: 
// "NRP33SN-V-900007-USB Legacy","NRP-Z211-900001-USB Legacy",
// "NRP33SN-V-900005-USBTMC","NRP33SN-V-900011-LAN"
// list of automatically detected sensors
// the list can contain more entries

:SLISt:ELEMent3:MAPPing SENS1
// maps the third sensor from the list to the first sensor channel

:SLISt:SENSor:MAP "NRPS18S-100654-USB Legacy", SENS3
// maps the sensor directly to channel 3

:SLISt:CLEar[ALL] // remove all sensors from the list
:SLISt:CLEar:LAN  // remove sensors connected in the LAN from the list
:SLISt:CLEar:USB  // remove sensors connected over USB from the list
// remove all sensors from the list

Example: Performing a simple power measurement
Prerequisite: The sensor is connected to the instrument and mapped to the first sensor
channel.
:INITiate1:CONTinuous ON
//Switches the continous power measurement on 

:READ1?
// Triggers the measurement and displays the results
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Example: Performing a power measurement with a fixed filter
Prerequisite: The sensor is connected to the instrument and mapped to the first sensor
channel.
SENSe1:SOURce RF 
//Sensor measures the power of the RF signal

:SENSe1:FILTer:TYPE NSRatio
//Selects fixed noise filter mode

:SENSe1:FILTer:NSRatio 0.02 DB
//Sets the maximum noise component in the result to 0.02 DB

:SENSe1:FILTer:NSRatio:MTIMe 10
//Limits the settling time to 10 seconds.

:SENSe1:APERture:DEFault:STATe 0
// Deactivates the default aperture time of the sensor

:SENSe1:APERture:TIMe 10e-6
// Sets the aperture time to 10 us

:SENSe1:UNIT DBM
//Selects unit dBm for the measured value

:INITiate:CONTinuous ON
//Switches the continous power measurement on 

:READ?
//Triggers the measurement and displays the results

:SLISt[:LIST]?................................................................................................................ 279
:SLISt:SCAN[:STATe]......................................................................................................279
:SLISt:SCAN:LSENsor....................................................................................................279
:SLISt:SCAN:USENsor................................................................................................... 280
:SLISt:CLEar:LAN.......................................................................................................... 280
:SLISt:CLEar:USB..........................................................................................................280
:SLISt:CLEar[:ALL].........................................................................................................281
:SLISt:ELEMent<ch>:MAPPing........................................................................................281
:SLISt:SENSor:MAP.......................................................................................................281
:INITiate<hw>[:POWer]:CONTinuous............................................................................... 281
:READ<ch>[:POWer]?.................................................................................................... 282
:SENSe<ch>:UNIT[:POWer]............................................................................................282
:SENSe<ch>[:POWer]:APERture:DEFault:STATe.............................................................. 283
:SENSe<ch>[:POWer]:APERture:TIMe.............................................................................283
:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect.......................................................283
:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe........................................................284
:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST?.........................................................284
:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO?.................................................................. 284
:SENSe<ch>[:POWer]:FILTer:LENGth[:USER].................................................................. 285
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:SENSe<ch>[:POWer]:FILTer:NSRatio............................................................................. 285
:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe.................................................................. 285
:SENSe<ch>[:POWer]:FILTer:SONCe.............................................................................. 286
:SENSe<ch>[:POWer]:FILTer:TYPE................................................................................. 286
:SENSe<ch>[:POWer]:FREQuency..................................................................................287
:SENSe<ch>[:POWer]:LOGGing:STATe............................................................................287
:SENSe<ch>[:POWer]:OFFSet........................................................................................ 288
:SENSe<ch>[:POWer]:OFFSet:STATe..............................................................................288
:SENSe<ch>[:POWer]:SNUMber?................................................................................... 288
:SENSe<ch>[:POWer]:SOURce.......................................................................................288
:SENSe<ch>[:POWer]:STATus[:DEVice]?......................................................................... 289
:SENSe<ch>[:POWer]:TYPE?......................................................................................... 289
:SENSe<ch>[:POWer]:ZERO.......................................................................................... 289

:SLISt[:LIST]?

Returns a list of all detected sensors in a comma-separated string.

Return values: 
<SensorList> String of comma-separated entries

Each entry contains information on the sensor type, serial num-
ber and interface.
The order of the entries does not correspond to the order the
sensors are displayed in the "NRP Sensor Mapping" dialog.

Example: See Example "Detecting and assigning a power sensor"
on page 277.

Usage: Query only

Manual operation: See " Sensor Mapping List " on page 76

:SLISt:SCAN[:STATe] <State>

Starts the search for R&S NRP power sensors, connected in the LAN or via the
USBTMC protocol.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Detecting and assigning a power sensor"
on page 277.

Manual operation: See " Scan " on page 77

:SLISt:SCAN:LSENsor <IP>

Scans for R&S NRP power sensors connected in the LAN.
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Setting parameters: 
<IP> string

*RST: 0

Example: See Example "Detecting and assigning a power sensor"
on page 277.

Usage: Setting only

Manual operation: See " Add LAN Sensor settings" on page 77

:SLISt:SCAN:USENsor <DeviceID>, <Serial>

Scans for R&S NRP power sensors connected over a USB interface.

Parameters:
<Serial> integer

Range: 0  to  999999

Setting parameters: 
<DeviceID> String or Integer

Range: 0  to  999999
*RST: 0

Example: See Example "Detecting and assigning a power sensor"
on page 277.

Usage: Setting only

Manual operation: See " Add USB Sensor settings " on page 77

:SLISt:CLEar:LAN

Removes all R&S NRP power sensors connected in the LAN from the list.

Example: See Example "Detecting and assigning a power sensor"
on page 277.

Usage: Event

Manual operation: See "Clear" on page 77

:SLISt:CLEar:USB

Removes all R&S NRP power sensors connected over USB from the list.

Example: See Example "Detecting and assigning a power sensor"
on page 277.

Usage: Event

Manual operation: See "Clear" on page 77
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:SLISt:CLEar[:ALL]

Removes all R&S NRP power sensors from the list.

Example: See Example "Detecting and assigning a power sensor"
on page 277.

Usage: Event

Manual operation: See "Clear" on page 77

:SLISt:ELEMent<ch>:MAPPing <Mapping>

Assigns an entry from the :SLISt[:LIST]? to one of the four sensor channels.

Parameters:
<Mapping> SENS1 | SENSor1 | SENS2 | SENSor2 | SENS3 | SENSor3 |

SENS4 | SENSor4 | UNMapped
Sensor channel.
*RST: UNMapped

Example: See Example "Detecting and assigning a power sensor"
on page 277.

Manual operation: See " Sensor Mapping List " on page 76

:SLISt:SENSor:MAP <SensorId>, <Mapping>

Assigns a sensor directly to one of the sensor channels, using the sensor name and
serial number.

To find out the the sensor name and ID, you can get it from the label of the R&S NRP,
or using the command :SLISt:SCAN[:STATe]. This command detects all R&S NRP
power sensors connected in the LAN or via 'USBTMC protocol.

Setting parameters: 
<SensorId> string

<Mapping> enum

Example: See Example "Detecting and assigning a power sensor"
on page 277.

Usage: Setting only

Manual operation: See " Sensor Mapping List " on page 76

:INITiate<hw>[:POWer]:CONTinuous <Continuous>

Switches the local state of the continuous power measurement by R&S NRP power
sensors on and off. Switching off local state enhances the measurement performance
during remote control.
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The remote measurement is triggered with :READ<ch>[:POWer]?). This command
also returns the measurement results. The local state is not affected, measurement
results can be retrieved with local state on or off.

Parameters:
<Continuous> 0 | 1 | OFF | ON

*RST: 0

Example: :INIT1:CONT ON
Switches local state of continuous power measurement on.

Manual operation: See " State " on page 82

:READ<ch>[:POWer]?

Triggers power measurement and displays the results.

Note: This command does not affect the local state, i.e. you can get results with local
state on or off. For long measurement times, we recommend that you use an SRQ for
command synchronization (MAV bit).

Suffix: 
<ch>

.
1 to 3

Return values: 
<Power> float or float,float

The sensor returns the result in the unit set with command :
SENSe<ch>:UNIT[:POWer]
Certain power sensors, such as the R&S NRP-Z81, return two
values, first the value of the average level and - separated by a
comma - the peak value.

Example: :SENS1:UNIT DBM
Selects unit dBm for presentation of measurement result.
:READ1?
Queries the measurement result of the sensor.
-45.6246576745440230
-45.6 dBm were measured at the given frequency.

Example: R&S NRP-Z81
:READ1?
-55.62403263352178,-22.419472478812476
-55.6 dBm is the measured average level, -22. 4 dBm is the
measured peak level at the given frequency.

Usage: Query only

Manual operation: See " Level (Peak) / Level (Average) " on page 82

:SENSe<ch>:UNIT[:POWer] <Power>

Selects the unit (Watt, dBm or dBμV) of measurement result display, queried with :
READ<ch>[:POWer]?.
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Parameters:
<Power> DBM | DBUV | WATT

*RST: DBM

Example: :SENS2:UNIT DBM
Selects dBm as unit for the measured value returned by com-
mand READ.
:READ2?
Response: 7.34
7.34 dBm are measured by sensor 2.

Manual operation: See " Level (Peak) / Level (Average) " on page 82

:SENSe<ch>[:POWer]:APERture:DEFault:STATe <UseDefAp>

Deactivates the default aperture time of the respective sensor.

To specify a user-defined value, use the command :SENSe<ch>[:POWer]:
APERture:TIMe on page 283.

Parameters:
<UseDefAp> 0 | 1 | OFF | ON

*RST: 1

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 278.

Manual operation: See "Default Aperture Time" on page 84

:SENSe<ch>[:POWer]:APERture:TIMe <ApTime>

Defines the aperture time (size of the acquisition interval) for the corresponding sensor.

Parameters:
<ApTime> float

Range: depends on connected power sensor
Increment: 1E-9
*RST: depends on connected power sensor

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 278.

Manual operation: See "Aperture Time" on page 84

:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect <Select>

Several S-parameter tables can be stored in a sensor. The command selects a loaded
data set for S-parameter correction for the corresponding sensor.

Parameters:
<Select> float

*RST: 0
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Manual operation: See " S-Parameter " on page 85

:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe <State>

Activates the use of the S-parameter correction data.

Note: If you use power sensors with attenuator, the instrument automatically activates
the use of S-parameter data.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: :SENSe1:POWer:CORRection:SPDevice:STATe 1
Activates the use of the S-parameters correction data.

Manual operation: See " S-Parameter " on page 85

:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST?

Queries the list of the S-parameter data sets that have been loaded to the power sen-
sor.

Return values: 
<List> string list

*RST: 0

Usage: Query only

Manual operation: See " S-Parameter " on page 85

:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO?

Queries the current filter length in filter mode AUTO (:SENSe<ch>[:POWer]:
FILTer:TYPE)

Return values: 
<Auto> float

Range: 1  to  65536

Example: :SENS1:FILT:TYPE AUTO
Selects auto filter.
:SENS1:FILT:LENG:AUTO?
Queries the automatically set filter length.
Response: 1024

Usage: Query only

Manual operation: See "Filter Length" on page 84
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:SENSe<ch>[:POWer]:FILTer:LENGth[:USER] <User>

Selects the filter length for SENS:POW:FILT:TYPE USER. As the filter length works as
a multiplier for the time window, a constant filter length results in a constant measure-
ment time (see also "About the measuring principle, averaging filter, filter length, and
achieving stable results" on page 78).

The R&S NRP power sensors provide different resolutions for setting the filter length,
depending on the used sensor type:
● Resolution = 1 for R&S NRPxx power sensors
● Resolution = 2n for sensors of the R&S NRP-Zxx family, with n = 1 to 16

Parameters:
<User> float

Range: 1  to  65536
*RST: 1

Example: :SENS1:FILT:TYPE USER
Selects user filter mode.
:SENS1:FILT:LENG 16
Sets a filter length of 16. E.g. using a sensor with 20 ms time
window, the resulting measurement time is 640 ms (2x16x20
ms)

Manual operation: See "Filter Length" on page 84

:SENSe<ch>[:POWer]:FILTer:NSRatio <NSRatio>

Sets an upper limit for the relative noise content in fixed noise filter mode (:
SENSe<ch>[:POWer]:FILTer:TYPE). This value determines the proportion of intrin-
sic noise in the measurement results.

Parameters:
<NSRatio> float

Range: 0.001  to  1
Increment: 0.001
*RST: 0.01

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 278.

Manual operation: See "Noise/Signal Ratio" on page 84

:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe <MTime>

Sets an upper limit for the settling time of the auto-averaging filter in the NSRatio
mode and thus limits the length of the filter. The filter type is set with command :
SENSe<ch>[:POWer]:FILTer:TYPE.
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Parameters:
<MTime> float

Range: 1  to  999.99
Increment: 0.01
*RST: 4

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 278.

Manual operation: See "Timeout" on page 84

:SENSe<ch>[:POWer]:FILTer:SONCe

Starts searching the optimum filter length for the current measurement conditions. You
can check the result with command :SENS1:POW:FILT:LENG:USER? in filter mode
USER (:SENSe<ch>[:POWer]:FILTer:TYPE).

Example: SENS1:FILT:TYPE USER
Selects user filter mode.
:SENS1:FILT:SONC
Activates the search for the optimum filter length.
:SENS1:FILT:LENG?
Returns the found optimum filter length.
Response: 128

Usage: Event

Manual operation: See "Auto Once" on page 84

:SENSe<ch>[:POWer]:FILTer:TYPE <Type>

Selects the filter mode. The filter length is the multiplier for the time window and thus
directly affects the measurement time.

Parameters:
<Type> AUTO | USER | NSRatio

AUTO
Automatically selects the filter length, depending on the mea-
sured value. The higher the power, the shorter the filter length,
and vice versa.
USER
Allows you to set the filter length manually. As the filter-length
takes effect as a multiplier of the measurement time, you can
achieve constant measurement times.
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NSRatio
Selects the filter length (averaging factor) according to the crite-
rion that the intrinsic noise of the sensor (2 standard deviations)
does not exceed the specified noise content. You can define the
noise content with command :SENSe<ch>[:POWer]:FILTer:
NSRatio.
Note: To avoid long settling times when the power is low, you
can limit the averaging factor limited with the "timeout" parame-
ter (:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe).

*RST: AUTO

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 278.

Manual operation: See " Filter" on page 83

:SENSe<ch>[:POWer]:FREQuency <Frequency>

Sets the RF frequency of the signal, if signal source "USER" is selected (:
SENSe<ch>[:POWer]:SOURce).

Parameters:
<Frequency> float

*RST: 1 GHz

Example: :SENS1:SOUR USER
Selects user-defined source.
:SENS1:FREQ 2.44GHz
Sets the RF frequency of the source which is 2.44 GHz.

Manual operation: See " Frequency " on page 83

:SENSe<ch>[:POWer]:LOGGing:STATe <State>

Activates the recording of the power values, measured by a connected R&S NRP
power sensor.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: :SENS:LOGG:STAT ON
Activates recording of the power measurement of the first sen-
sor.

Manual operation: See "Enable Logging" on page 85
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:SENSe<ch>[:POWer]:OFFSet <Offset>

Sets a level offset which is added to the measured level value after activation with
command :SENSe<ch>[:POWer]:OFFSet:STATe. The level offset allows, e.g. to
consider an attenuator in the signal path.

Parameters:
<Offset> float

Range: -100.0  to  100.0
*RST: 0
Default unit: dB

Example: :SENS1:POW:OFFS 10.0
Sets a level offset of 10 dB

Manual operation: See " Level Offset State,Level Offset" on page 83

:SENSe<ch>[:POWer]:OFFSet:STATe <State>

Activates the addition of the level offset to the measured value. The level offset value is
set with command :SENSe<ch>[:POWer]:OFFSet.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: :SENS1:POW:OFFS 0.4dB
Sets a level offset of 0.4 dB
:SENS1:POW:OFFS:STAT ON
A level offset of 0.4 dB is added to the measured value.

Manual operation: See " Level Offset State,Level Offset" on page 83

:SENSe<ch>[:POWer]:SNUMber?

Queries the serial number of the sensor.

Return values: 
<SNumber> string

Example: :SENS1:SNUM?
Queries the serial number.

Usage: Query only

Manual operation: See " Sensor type and serial number " on page 82

:SENSe<ch>[:POWer]:SOURce <Source>

Determines the signal to be measured.
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Note: When measuring the RF signal, the sensor considers the corresponding correc-
tion factor at that frequency, and uses the level setting of the instrument as reference
level.

Parameters:
<Source> A | USER | RF

*RST: A

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 278.

Manual operation: See " Use Frequency Of" on page 83

:SENSe<ch>[:POWer]:STATus[:DEVice]?

Queries if a sensor is connected to the instrument.

Return values: 
<Status> 0 | 1 | OFF | ON

*RST: 0

Example: :SENS1:STAT?
Response: 1
A sensor is connected.

Usage: Query only

Manual operation: See " State " on page 82

:SENSe<ch>[:POWer]:TYPE?

Queries the sensor type. The type is automatically detected.

Return values: 
<Type> string

Example: :SENS1:TYPE?
Queries the type of sensor.
Response: NRP-Z21
The R&S NRP-Z21 sensor is used.

Usage: Query only

Manual operation: See " Sensor type and serial number " on page 82

:SENSe<ch>[:POWer]:ZERO

Performs zeroing of the sensor.

Zeroing is required after warm-up, i.e. after connecting the sensor.

Note: Switch off or disconnect the RF power source from the sensor before zeroing.

We recommend that you zero in regular intervals (at least once a day), if:
● The temperature has varied more than about 5 °C.
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● The sensor has been replaced.
● You want to measure very low power.

Example: :SENS1:ZERO
Executes zeroing.

Usage: Event

Manual operation: See " Zero " on page 82

10.16  STATus Subsystem

This system contains the commands for the status reporting system. See also Chap-
ter A.1.5, "Status Reporting System", on page 333 for detailed information.

*RST on page 213 has no effect on the status registers.

Value ranges

● Queries return the current value of the respective register, which permits a check of
the device status.
Return values: A decimal value in the range 0 to 32767 (=215-1)

● The configuration commands set the respective register thus determining which
status changes of the R&S AREG100A cause the status registers to be changed.
Setting values: A decimal value in the range 0 to 32767 (=215-1)

:STATus:OPERation:CONDition?.....................................................................................290
:STATus:OPERation:ENABle...........................................................................................291
:STATus:OPERation[:EVENt]...........................................................................................291
:STATus:OPERation:NTRansition.................................................................................... 291
:STATus:OPERation:PTRansition.....................................................................................291
:STATus:PRESet............................................................................................................292
:STATus:QUEStionable:CONDition.................................................................................. 292
:STATus:QUEStionable:ENABle.......................................................................................292
:STATus:QUEStionable[:EVENt]...................................................................................... 293
:STATus:QUEStionable:NTRansition................................................................................ 293
:STATus:QUEStionable:PTRansition................................................................................ 293
:STATus:QUEue[:NEXT]?................................................................................................293

:STATus:OPERation:CONDition?

Quieries the content of the CONDition part of the STATus:OPERation register.

This part contains information on the action currently being performed in the instru-
ment. The content is not deleted after being read out because it indicates the current
hardware status.

Return values: 
<Condition> string

Example: :STATus:OPERation:CONDition?

STATus Subsystem
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Usage: Query only

:STATus:OPERation:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:OPERation register. This setting deter-
mines which events of the Status-Event part are forwarded to the sum bit in the status
byte. These events can be used for a service request.

Parameters:
<Enable> string

Example: :STAT:OPER:ENAB 32767
all events are forwarded to the sum bit of the status byte.

:STATus:OPERation[:EVENt] <Event>

Queries the content of the EVENt part of the STATus:OPERation register. This part
contains information on the actions performed in the instrument since the last readout.
The content of the EVENt part is deleted after being read out.

Parameters:
<Event> string

Example: :STAT:OPER:EVEN?
queries the STATus:OPERation:EVENt register.

:STATus:OPERation:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:OPERation register. If a bit is set, a
transition from 1 to 0 in the condition part causes an entry to be made in the EVENt
part of the register. The disappearance of an event in the hardware is thus registered,
for example the end of an adjustment.

Parameters:
<Ntransition> string

Example: :STAT:OPER:NTR 0
a transition from 1 to 0 in the condition part of the Status:Opera-
tion register does not cause an entry to be made in the EVENt
part.

:STATus:OPERation:PTRansition <Ptransition>

Sets the bits of the PTRansition part of the STATus:OPERation register. If a bit is set, a
transition from 0 to 1 in the condition part causes an entry to be made in the EVENt
part of the register. A new event in the hardware is thus registered, for example the
start of an adjustment.

Parameters:
<Ptransition> string
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Example: :STAT:OPER:PTR 32767
all transitions from 0 to 1 in the condition part of the Status:Oper-
ation register cause an entry to be made in the EVENt part.

:STATus:PRESet <Preset>

Resets the status registers. All PTRansition parts are set to FFFFh (32767), i.e. all
transitions from 0 to 1 are detected. All NTRansition parts are set to 0, i.e. a transition
from 1 to 0 in a CONDition bit is not detected. The ENABle parts of STATus:OPERation
and STATus:QUEStionable are set to 0, i.e. all events in these registers are not passed
on.

Parameters:
<Preset> string

Example: STAT:PRES
resets the status registers.

:STATus:QUEStionable:CONDition <Condition>

Queries the content of the CONDition part of the STATus:QUEStionable register. This
part contains information on the action currently being performed in the instrument.
The content is not deleted after being read out since it indicates the current hardware
status.

Parameters:
<Condition> string

Example: :STATus:QUEStionable:CONDition?
queries the Status:Questionable:Condition register.

:STATus:QUEStionable:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:QUEStionable register. The enable part
determines which events of the STATus:EVENt part are enabled for the summary bit in
the status byte. These events can be used for a service request.

If a bit in the ENABle part is 1, and the correesponding EVENt bit is true, a positive
transition occurs in the summary bit. This transition is reportet to the next higher level.

Parameters:
<Enable> string

Example: STAT:QUES:ENAB 1
Problems when performing an adjustment cause an entry to be
made in the sum bit.
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:STATus:QUEStionable[:EVENt] <Event>

Queries the content of the EVENt part of the STATus:QUEStionable register. This
part contains information on the actions performed in the instrument since the last
readout. The content of the EVENt part is deleted after being read out.

Parameters:
<Event> string

Example: STAT:QUES:EVEN?
queries the Status:Questionable:Event register.

:STATus:QUEStionable:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.

Parameters:
<Ntransition> string

Example: STAT:QUES:NTR 0
a transition from 1 to 0 in the condition part of the STA-
Tus:QUEStionable register does not cause an entry to be made
in the EVENt part

:STATus:QUEStionable:PTRansition <PTransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.

Parameters:
<PTransition> string

Example: STAT:QUES:PTR 32767
all transitions from 0 to 1 in the condition part of the STA-
Tus:QUEStionable register cause an entry to be made in the
EVENt part

:STATus:QUEue[:NEXT]?

Queries the oldest entry in the error queue and then deletes it. Positive error numbers
denote device-specific errors, and negative error numbers denote error messages
defined by SCPI. If the error queue is empty, 0 ("No error") is returned.

The command is identical to :SYSTem:ERRor[:NEXT]? on page 247.

Return values: 
<Next> string
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Example: :STATus:QUEue?
queries the oldest entry in the error queue.
Response: 0, 'no error'
no errors have occurred since the error queue was last read out

Usage: Query only
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11  Troubleshooting and Error Messages
The R&S AREG100A distinguishes between various messages such as status mes-
sages, error messages, warnings, or information that are displayed in the "Info" line on
the screen, and also entered in the error/event queue of the status reporting system.

This section describes the types of error messages and warnings. The status reporting
system is described in detail in Chapter A.1.5, "Status Reporting System",
on page 333.

You can also access an info window with detailed information about all messages in a
history list. For details, see Chapter 11.4, "Querying Error Messages", on page 298

11.1  Error Messages

Error messages indicate errors in the instrument. They are displayed in different colors
depending on their importance and display duration. Errors (e.g. no calibration data)
are displayed in red, information (e.g. file not found) and warnings in black. Warnings
indicate less significant errors (e.g. the instrument operates outside specified data).

Some error messages require that the error must be eliminated before correct instru-
ment operation can be ensured. To access the "Info" dialog with a list of current mes-
sages and a detailed description of each message, select "Info".

In the remote control mode, error messages are entered in the error/event queue of the
status reporting system and can be queried with the command SYSTem:ERRor?. If the
error queue is empty, 0 ("No error") is returned.

11.1.1  Volatile Messages

Volatile messages report automatic settings in the instrument (e.g. switching off incom-
patible types of modulation) or on illegal entries that are not accepted by the instrument
(e.g. range violations). They are displayed in the info line on a yellow background.
They are displayed on top of status information or permanent messages.

Volatile messages do not normally demand user actions and disappear automatically
after a brief period of time. They are stored in the history, however.

Remote command:

:SYSTem:ERRor:ALL? or

:SYSTem:ERRor:CODE[:NEXT]?

11.1.2  Permanent Messages

Permanent messages are displayed if an error occurs that impairs further instrument
operation, e.g. a hardware fault. The error signaled by a permanent message must be
eliminated before correct instrument operation can be continued.

Error Messages
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The message is displayed until the error is eliminated. It covers the status display in
the info line. After error elimination, the message automatically disappears and is also
recorded in the history.

Remote command:

:SYSTem:ERRor:STATic?

11.2  SCPI-Error Messages

The SCPI error messages are the same in all SCPI instruments. Detailed information
and an overview of all error messages as defined in SCPI standard can be found in the
corresponding documentation.

SCPI errors have negative codes (numbers). The error text being entered into the
error/event queue or being displayed is printed in bold face on the left together with the
error code. Below the error text, there is an explanation as to the respective error.

11.3  Device-Specific Error Messages

The following table contains all error messages specific for the instrument in alphabeti-
cal order and an explanation of the error situation. The positive error codes mark the
errors specific to the instrument.

The device-specific error messages set bit 3 in the ESR register.

The index provides a list of the error messages sorted according to their error codes.

Error
Code

Error Description Remedy

50 Extern reference out of
range or disconnected

External reference is selected but no external sig-
nal is applied or the signal is out of range.

● Check the selected reference signal
source (internal or external) in the
"Setup > Reference Oscillator" dia-
log.

● Change setting to 'internal' if no
appropriate external source is avail-
able.

80 See Table 11-1   

140 This modulation forces
other modulations off

A modulation has been switched on which cannot
be used at the same time as an already active
modulation. The previous modulation has been
switched off.

 

180 Adjustment failed Adjustment could not be executed Generate the adjustment data and load it
into the device

182 Adjustment data missing Adjustment data is missing. Generate the adjustment data and load it
into the device

Device-Specific Error Messages
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Error
Code

Error Description Remedy

183 Adjustment data invalid Adjustment data is invalid and must be restored. Generate the adjustment data and load it
into the device

200 Cannot access hardware The data transmission to a module was unsuc-
cessful.

The module is not installed, not properly
installed or missing.

201 Hardware revision out of
date

A later version of certain parts of the instrument is
necessary to execute the function selected.

The driver does not support the installed
version of a module.

202 Cannot access the
EEPROM

An error occurs when writing or reading a
EEPROM.

The EEPROM is possibly defect.
Replace it.

203 Invalid EEPROM data Reading a EEPROM is possible, however the data
are inconsistent.

 

204 Driver initialization failed Initialization of a driver fails when booting the
instrument firmware.

The driver is not compatible with the
hardware or software configuration of the
instrument.

241 No current list There is no list selected. To execute the required
operation, a list has to be selected in the related
dialog. If no list is available, a new list must be cre-
ated.

 

242 Unknown list type speci-
fied

The list type selected is not valid for the required
operation.

Check the selected list type.

460 Cannot open the file The selected file cannot be opened. Check the path and file name.

461 Cannot write file The file cannot be written. Check if the file is read-only.

462 Cannot read file The file cannot be read. Check if the file contents are compatible
with the file type.

463 Filename missing The required operation cannot be executed
because the file name is not specified.

Enter file name when creating list.

464 Invalid filename extension The file extension is not valid for the required
operation.

Check the file extension.

465 File contains invalid data The selected file contains data that is not valid for
the file type.

The file extension determines the data that is valid
for this file type. If the file extension is changed,
the lists are no longer recognized and the data is
therefore invalid.

Check the file extension.

Device-Specific Error Messages
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Table 11-1: Device-specific messages: error code 80, info code 90

Error/Info Description Remedy

Frontend 100 MHz PLL not
locked

● Cable IF TX CBL between R&S AREG100A base
unit and frontend module is not connected or

● External reference is selected but no external 10
MHz signal is applied or

● The signal level is out of range

● Check connection of IF TX CBL
● Apply 10 MHz external reference sig-

nal or select "AREG Configuration >
Reference Frequency > Source =
Internal".

Base attenuation range
exceeded

Object attenuation range
exceeded

The configured attenuation cannot be reached by the
internal attenuators in the R&S AREG100A signal
path

Set a higher or lower attenuation.

Frontend RX PLL not locked

Frontend TX PLL not locked

The local oscillator in the frontend module is out of
lock.

Check the cabling between frontend and
R&S AREG100A base unit and reboot the
R&S AREG100A.

If the problem persists, contact customer
support.

See Chapter 11.9, "Contacting Customer
Support", on page 307.

Frontend has been
changed. Please run "Adjust
All".

Alignment data for the currently connected frontend
module is not available.

Select "System Config > Setup > General >
Internal Adjustments" and select "Adjust
All".

Adjustment missing. Please
run "Adjust All".

Alignment data is not available. Select "System Config > Setup > General >
Internal Adjustments" and select "Adjust
All".

Object 2/3/4 laser current
exceeded

The bias current for the internal laser diode of object
2/3/4 is too high.

Contact customer support.

See Chapter 11.9, "Contacting Customer
Support", on page 307.

Doppler path was enabled
due to Doppler speed.

A "Doppler Speed" unequal to zero is only possible in Doppler path for the respective object.

R&S AREG100A activates the objects Doppler path automatically, although the "AREG Config >
Enable Doppler Bypass > On", because a Doppler speed different to zero is selected.

See also "Bypassing Doppler stage" on page 54.

Bypass path was enabled
due to Doppler speed

R&S AREG100A activates the bypass for the object with "Doppler Speed = 0" because "AREG Con-
fig > Enable Doppler Bypass > On".

See also "Bypassing Doppler stage" on page 54.

11.4  Querying Error Messages

The R&S AREG100A monitors the functions performed and automatically detects
errors and irregularities. The instrument displays the messages in the "Info" line and
records them in the background with a detailed description.

Find details to the system messages in Chapter 11, "Troubleshooting and Error Mes-
sages", on page 295.

To display information on static errors and error history

► For some messages, the information line appears briefly on the home screen.

Querying Error Messages
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To open the dialog, in the "Info" line select the "Info" button.

● The "Static Errors" dialog lists the last monitored messages chronologically and
displays additional information on the highlighted message.

● The "Error History" dialog lists the accumulated messages with a short descrip-
tion.
Volatile errors are reported once, at the time they appear. If identical errors
occur subsequently, they are not reported repeatedly.
In the "Info" line, identical errors are displayed repeatedly only if the original
error has already disappeared from the display. If queried by SCPI command,
identical errors are only reported if the original error has already been retrieved
from (and hence not any more present in) the error queue.

Indication and handling of permanent messages
If any critical error occurs, the R&S AREG100A automatically shows the  icon in the
taskbar. Select the icon to obtain information on the error and the number of occurren-
ces.
The icon is assigned to permanent messages. The message and icon are displayed
until the error is eliminated.

Static Errors/Error History
Toggles between "Static" and "History" view of the info dialog.

Remote command: 
:SYSTem:ERRor[:NEXT]? on page 247
Each time a SYST:ERR:NEXT? query is sent, the eldest entry in the error queue is
returned and at the same time cleared in the list.
:SYSTem:ERRor:STATic? on page 248
Queries the list of all errors.

Querying Error Messages
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Clear History
Clears all messages in the "History" view.

Remote command: 
:SYSTem:ERRor:ALL? on page 245
Each time a SYST:ERR:ALL? query is sent, the error queue is returned and at the
same time cleared.
:SYSTem:ERRor:HISTory:CLEar on page 248
Clears the messages in the "History" view.

11.5  Resolving Network Connection Failures

Several issues may cause failures in the network connection to the instrument. This
section lists the most likely reasons and the recommended solutions.

Common reasons for network connection failures

● Network connecting cables and cable connectors of poor quality
● Incompatibility between the network interface of the R&S AREG100A and certain

switches or routers available on the market
● An invalid IP address assigned to the instrument

Possible solutions to network connection failures

1. NOTICE! Connecting to the network can cause network failure. Errors can affect
the entire network.
Consult your network administrator before performing the following tasks:
● Connecting the instrument to the network
● Configuring the network
● Changing IP addresses

2. Try out the following to resolve network connection failures:

● Check the network infrastructure. Exchange connecting cables, if obvious dam-
age is visible.

● If a link failure is detected, connect the instrument to a different device port or
to a different network device.

● Check whether the LAN interface and the required LAN services are enabled.
● If the IP address is set manually (no DHCP) or obtained via the Zeroconf

(APIPA) protocol:
– Check whether the IP address of the instrument is within the network's

address range.
– Check whether the IP address is valid.

Resolving Network Connection Failures
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11.6  Measuring USB cable quality

To check the quality of the USB cable, see the service manual of the R&S AREG100A.

11.7  Requesting Instrument Configuration and Specifica-
tions

The R&S AREG100A is equipped with various hardware and software components. To
get an overview of what your instrument is equipped with, you can request the assem-
blies, hardware and software options, and the firmware version. The components are
structured according to the hardware configuration, software options, including the
license management, and externally used Rohde & Schwarz equipment, like R&S NRP
power sensors.

Software options purchased at a later stage can be activated with a keycode. The acti-
vation code is supplied with the software option. How to install options is described in
chapter 4 of the R&S AREG100A service manual.
The installation of hardware options purchased at a later stage is also described in
chapter 4 of the service manual. Most of the hardware options have to be installed at
an authorized Rohde & Schwarz service center.

11.7.1  Hardware Configuration Settings

Access:

► Select "System Config > Setup > Instrument Assembly > Hardware Config".

Requesting Instrument Configuration and Specifications
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The "Hardware Config" dialog lists all installed assemblies and externally connec-
ted instruments with information on their part and serial numbers, and revision
states. The BIOS version is also listed; firmware updates do not update the BIOS
version.
The dialog is divided in tabs, according to the hardware components of the signal
domains. The "Counter" tab provides information on the operation time and number
of times the instrument was powered on.

The remote commands required to query the hardware configuration are described in
Chapter 10.6, "DIAGnostic Subsystem", on page 219.

Assembly
The tables in the tabs show characteristics of the installed assemblies.

"Assembly" Assembly designation.

"Part Number" Part number of the assembly.

"Serial Number"
Serial number of the assembly.

"Revision" Revision state of the assembly.

"Slot" Indicates whether the assembly is connected to the serial bus or PCI
bus.

Remote command: 
:DIAGnostic<hw>:BGINfo? on page 220

Counter
Displays information on the operation times of the R&S AREG100A.

Requesting Instrument Configuration and Specifications
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Operation Time / h ← Counter
Displays the operation time in hours so far.

Remote command: 
:DIAGnostic:INFO:OTIMe? on page 220

Power On Count ← Counter
Displays the number the instrument has been turned on.

Remote command: 
:DIAGnostic:INFO:POCount? on page 220

Last Factory Calibration ← Counter
Displays the date of the last factory calibration.

Remote command: 
:CALibration:DATA:FACTory:DATE? on page 218

11.7.2  Versions/Options Settings

Access:

► Select "System Config > Setup > Instrument Assembly > Versions / Options".

The "Versions/Options" dialog shows the version of the installed instrument firm-
ware, the hardware and software options, the data sheet and the software compo-
nents of the firmware. The BIOS version is also listed; firmware updates do not
update the BIOS version.

The remote commands required to query the hardware configuration are described in
Chapter 10.6, "DIAGnostic Subsystem", on page 219.

Firmware
Shows the firmware version and the version of the software platform.

Note: Your instrument is delivered with the latest firmware version available.

Requesting Instrument Configuration and Specifications
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You can download firmware updates and the "Release Notes" that describe the modifi-
cations and the firmware update procedure.

Remote command: 
n.a.

Downgrade Info
Shows downgrade information, like factory firmware version and minimum firmware
version to that the instrument can be downgraded.

Remote command: 
n.a.

Show Open Source Acknowledgments
Accesses the list of the used open-source software packages and the corresponding
verbatim license texts.

Hardware Options/Software Options
The tables in the "Hardware" and "Software" tabs list the installed hardware and soft-
ware options.

"Option" Short name of option

"Designation" Name of option

"Expiration Date"
For regular options, "Permanent" is indicated in this column. Some
options are available as trial versions. This column shows their expi-
ration date. After this date, the option is no longer available on the
instrument.

Remote command: 
*OPT? on page 212
*IDN? on page 211

Versions
The "Versions" tab shows the versions of the technical specification of the
R&S AREG100A and of the software components that comprise the firmware.

"Package" Name of the component.

"Version" Current issue of the component.

Remote command: 
:SYSTem:SPECification:VERSion:FACTory? on page 262

11.7.3  How to Query Instrument Configuration

To get information on the components and installed options of the R&S AREG100A,
proceed as described in the following examples.

Requesting Instrument Configuration and Specifications



Troubleshooting and Error MessagesR&S®AREG100A

305User Manual 1178.7417.02 ─ 06

Checking the installed hardware options

To find out the installed options:

1. Select "System Config > Setup > Instrument Assembly > Versions/Options".

2. Select "Hardware Options".

The dialog lists all hardware options that are installed on the R&S AREG100A.

Proceed the same way to get information for instance on the firmware, or the installed
software options in the corresponding tab.

Checking the RF hardware assembly

To find out the installed RF hardware:

1. Select "System Config > Setup > Instrument Assembly > Hardware Config".

2. Select "RF Assembly".

The dialog lists the RF hardware components that are installed on the
R&S AREG100A.

Proceed the same way to get information for instance on general or baseband hard-
ware modules, or on the operating times of the R&S AREG100A in the corresponding
tab.

11.8  Collecting Information for Technical Support

If you encounter problems that you cannot solve yourself, contact your
Rohde & Schwarz support center as listed at http://www.customersupport.rohde-
schwarz.com. Our support center staff is optimally trained to assist you in solving prob-
lems.

The support center finds solutions more quickly and efficiently if you provide them with
information on the instrument and an error description.
● The following dialog boxes in the "Setup > Instrument Assembly" menu provide

useful information:
– Hardware Configuration: hardware assemblies
– Software and Options: the status of all software and hardware options instal-

led on your instrument
● System Messages: displayed in the "Info" line and provide information on any

errors that have occurred
● Support file: a special file (*.tar.gz file) with important support information that

can be created automatically.
The support *.tar.gz file has a user definable name and contains the following
files and information:
– SgErrors.txt: chronological record of errors

Collecting Information for Technical Support
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– SystemRestaurationAREG.savrcltxt: instrument settings at the last cor-
rect shutdown of the instrument

– UndoHistSuppInfo.xml: list of the last user interactions

– DeviceFootprint_<SerialNumber>_<Date>_<Time>.xml: service-rela-
ted information on the instrument's configuration.

– crashlog.txt, coredump: Postmortem debug info

– Several files with information on the last performed adjustment and self-test.

See also the description of error messages Chapter 11.1, "Error Messages",
on page 295.

To collect error information in a support file

1. Connect a USB device to the R&S AREG100A.

2. Select "System Config > Setup > Maintenance > Create R&S Support Information".

3. In the "Create R&S Support Information" dialog, navigate to the /usb directory.
Enter the support filename, for example RSSupport_DeviceInfo.

The error information and further required data is collected automatically.
The support file RSSupport_DeviceInfo.tar.gz is created and stored in the /
usb directory.
Collect the error information and attach it to an email in which you describe the
problem. Send the email to the customer support address for your region as listed
on the Internet (http://www.customersupport.rohde-schwarz.com).

To remove sensitive data

► For information on how to handle or remove the sensitive data from your instru-
ment, refer to the description "Resolving Security Issues when working with
R&S AREG100A".

Collecting Information for Technical Support
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Packing and transporting the instrument

► If the instrument has to be transported or shipped, see Chapter 12, "Transporting",
on page 308.

11.9  Contacting Customer Support

Technical support – where and when you need it

For quick, expert help with any Rohde & Schwarz product, contact our customer sup-
port center. A team of highly qualified engineers provides support and works with you
to find a solution to your query on any aspect of the operation, programming or applica-
tions of Rohde & Schwarz products.

Contact information

Contact our customer support center at www.rohde-schwarz.com/support, or follow this
QR code:

Figure 11-1: QR code to the Rohde & Schwarz support page

Contacting Customer Support

http://www.rohde-schwarz.com/support
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12  Transporting
Lifting and carrying

See:
● "Lifting and carrying the product" on page 15
● Chapter 3.1.1, "Lifting and Carrying", on page 19.

Packing

Use the original packaging material. It consists of antistatic wrap for electrostatic pro-
tection and packing material designed for the product.

If you do not have the original packaging, use similar materials that provide the same
level of protection.

Securing

When moving the R&S AREG100A in a vehicle or using transporting equipment, make
sure that the R&S AREG100A is properly secured. Only use items intended for secur-
ing objects.

Transport altitude

Unless otherwise specified in the data sheet, the maximum transport altitude without
pressure compensation is 4500 m above sea level.
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13  Maintenance, Storage and Disposal
The product does not require regular maintenance. It only requires occasional clean-
ing. It is however advisable to check the nominal data from time to time.

Risk of injury due to laser radiation
A laser (laser class 1M) is installed in the device.
Do not open the device. The device may only be opened by authorized service person-
nel.

13.1  Cleaning

How to clean the product is described in "Cleaning the product" on page 17.

Do not use any liquids for cleaning. Cleaning agents, solvents (thinners, acetone),
acids and bases can damage the front panel labeling, plastic parts and display.

13.2  Storage

Protect the product against dust. Ensure that the environmental conditions, e.g. tem-
perature range and climatic load, meet the values specified in the data sheet.

13.3  Protecting Waveguides and Antennas

We recommend that you protect the waveguides and the antennas if the setup is not in
use as follows:

1. Switch off the base unit.
See "To shut down the product" on page 28.

2. NOTICE! Dust and objects inside the antenna can damage the waveguide.
Cover the antenna to prevent dust or other objects from getting into the waveguide.

13.4  Performing Maintenance Tasks

The R&S AREG100A is accurate due to integrated adjustment procedures. Internal
adjustments are integrated self-calibration routines, which you can execute directly on
the instrument.

Performing Maintenance Tasks
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Self-calibration routines that require additional equipment are performed at an author-
ized Rohde & Schwarz service center. For description, see R&S AREG100A service
manual.

When to start internal adjustments?

We recommend that you run internal adjustments in the following cases:
● Before starting any application, that requires a maximum of level accuracy
● When a long period of time has passed since the last adjustments
● If the ambient temperature of the instrument significantly differs from the one of the

last adjustments
● R&S AREG-B60

If you set up objects with nonzero speeds and you observe strong unexpected
ghost objects with the opposite or zero speed.

How to: See Chapter 13.4.1.2, "How to Use the Internal Adjustments", on page 312.

13.4.1  Internal Adjustments

Internal adjustments are integrated adjustment procedures, which you can execute
directly on the instrument.

Internal adjustments include:
● R&S AREG-B177/-B181

Frontend LO leakage adjustment, that defines the settings where LO leakage
power is at its minimum.
If R&S AREG-B181 is installed, also the optimal settings for both frequency set-
tings 78 GHz and 79 GHz.

● R&S AREG-B60
Doppler alignment, optimizes feedthrough, image and spurious performance for the
doppler generation.

Performing Maintenance Tasks
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13.4.1.1  Internal Adjustments Settings

Access:

► Select "System Config > Setup > General > Internal Adjustments".

In this dialog, you can perform internal calibration routines and get information on
the last performed calibration.
The "Temperature Offset" indicates the deviation of the current temperature of the
instrument, compared to the temperature of the last adjustment.

The remote commands required to define these settings are described in Chapter 10.5,
"CALibration Subsystem", on page 216.

How to: See Chapter 13.4.1.2, "How to Use the Internal Adjustments", on page 312.

Adjust All
Performs all available internal calibration routines of the instrument.

How to: See Chapter 13.4.1.2, "How to Use the Internal Adjustments", on page 312.

Remote command: 
:CALibration:ALL[:MEASure]? on page 216

Last Full Adjustment
Displays the date of the last fully performed adjustment.

Remote command: 
:CALibration<hw>:ALL:DATE? on page 217

Time
Displays the elapsed time since the last full adjustment.

Remote command: 
:CALibration<hw>:ALL:TIME? on page 218
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Temperature Offset
Displays the temperature difference, comparing the temperature of the last adjustment
to the current instrument temperature.

A green checkmark indícates that the offset is within the permitted range. If the temper-
ature deviates more than ±5 K, the instrument indicates a warning icon.

Remote command: 
:CALibration<hw>:ALL:TEMP? on page 217

Information
Displays information to the current adjustment state.

Remote command: 
:CALibration<hw>:ALL:INFormation? on page 217

Continue Adjustment on Error
Continues the calibration even though an error was detected. By default adjustments
are aborted on error.

This function is password-protected. Unlock the protection level 1 to access it.

Remote command: 
:CALibration<hw>:CONTinueonerror on page 218

13.4.1.2  How to Use the Internal Adjustments

Deciding whether to run internal adjustments

1. Select "System Config > Setup > Internal Adjustment".

2. Observe the status and color indication in the section "Since Last Full Adjustment".

Green: Internal adjustments are not required.
Red: Internal adjustments are required. Observe also the indication in the "Informa-
tion" field.

3. We recommend that you run internal adjustments in the following cases:
● Before starting any application, that requires a maximum of level accuracy
● When a long period of time has passed since the last adjustments
● If the ambient temperature of the instrument significantly differs from the one of

the last adjustments
● R&S AREG-B60

If you set up objects with nonzero speeds and you observe strong unexpected
ghost objects with the opposite or zero speed.

4. Proceed as described in "Running internal adjustments" on page 312.

Running internal adjustments

1. NOTICE! Adjustments can be invalid if performed when the instrument is not
warmed-up.

Performing Maintenance Tasks
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Wait until the instrument has reached its operating temperature before you start the
adjustment procedure.
The warm-up time is up to 30 minutes.

2. NOTICE! High power at the frontend waveguide applied during internal adjustment
can destroy connected equipment.
Disconnect the equipment.

3. Select "System Config > Setup > Internal Adjustment > Adjust All".

The adjustment process starts.

4. Do not interrupt the adjustment process.
The extent of the adjustments depends on the installed options.

A progress indicator shows the status of the adjustment process.
If any error occurs, the process aborts and an error message appears in the "Info"
line.

If there is an error:
● Observe the error message.
● Continue the process.

See "Continuing the adjustment process if error appears" on page 313.

Continuing the adjustment process if error appears

Per default, if any error occurs during the adjustment process, the process aborts. An
error message appears in the "Info" line.

If you prefer to finish the adjustments also if there is an error, proceed as follows:

1. Select "System Config > Setup > Security > Protection" an unlock the protection
level 1.
See "Protection Level/Password" on page 131.

2. Select "System Config > Setup > Internal Adjustment > Configuration > Continue
Adjustment on Error > On".

3. Proceed as described in "Running internal adjustments" on page 312.

13.4.2  Date and Time

The R&S AREG100A uses an internal real-time clock to determine the date and time. It
adjusts the time and date to the timezone of your location automatically, by providing a
selection list of continents and cities.

The instrument records the time whenever you create or modify files on your instru-
ment or you use timed licenses. By default, the instrument is set to the UTC timezone,
but you can select the timezone according to your location.

Moreover, the instrument supports NTP protocol for synchronizing all connected instru-
ments and computer systems to minimize time delays in the network.

Performing Maintenance Tasks
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13.4.2.1  Data and Time Settings

Access:

► Select "System Config > Setup > Maintenance > Date / Time".

The "Date / Time" dialog contains the time and data settings of the operating sys-
tem.
This function is password-protected. Unlock the protection level 1 to access it.

The required remote commands are described in Chapter 10.12, "SYSTem Subsys-
tem", on page 243.

Settings:

Date.............................................................................................................................314
Time............................................................................................................................ 314
Timezone.....................................................................................................................314
NTP Address...............................................................................................................315
Use Time from NTP Server.........................................................................................315

Date
Displays the date set in the operating system in the format [dd.mm.yyyy].

Remote command: 
:SYSTem:DATE on page 263

Time
Displays the time set in the operating system in the format [hh.mm.ss].

The time setting corresponds to the selected Use Time from NTP Server.

Remote command: 
:SYSTem:TIME on page 264

Timezone
Selects the timezone.

You can select the timezone according to the major cities on the respective continents.

Performing Maintenance Tasks
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Note: By typing the first letter, you can quickly navigate through the lists to find the
desired destination.

Remote command: 
:SYSTem:TIME:ZONE on page 264
:SYSTem:TIME:ZONE:CATalog? on page 265

NTP Address
Sets the IP address or host name of the NTP server.

NTP is a network time protocol used for synchronizing all participating devices in a
data network.

You can select a high-precision time server to reduce the impact of varying network
delays.

Remote command: 
:SYSTem:NTP:HOSTname on page 264

Use Time from NTP Server
Activates clock synchronization of the network via the NTP protocol.

Remote command: 
:SYSTem:NTP:STATe on page 264

13.4.2.2  How To Set Data and Time

To select the timezone

1. Press the [Setup] key.

2. Select "Maintenance > Date /Time > Timezone".

3. Select continent and city of your location.
Tip: By typing the first letter, you can quickly navigate through the lists to find the
desired destination.

4. Close the dialogs.

The instrument adjusts the time according to the selected location.

To set the date and time

1. Press the [Setup] key.

2. Select "Security > Protection".

3. Enable the "Protection Level 1".
The default password is 123456.

4. Select "Setup > Maintenance > Date / Time".

5. Adjust the settings.

Performing Maintenance Tasks
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6. Close the dialogs.

The instrument adopts the new date and time.

13.4.3  Check Front Panel

Within this dialog, you can verify the functionality of the control keys.

How To: See Chapter 13.4.3.2, "How to Test the Front Panel", on page 316

13.4.3.1  Check Front Panel Settings

Access:

► Select "System Config > Setup > Maintenance > Check Front Panel".

Reflecting the front panel, the "Check Front Panel" dialog contains all functions to
test the operating elements of the instrument.

13.4.3.2  How to Test the Front Panel

See:
● "Testing the key panel" on page 317
● "Testing the touchscreen" on page 317
● "Terminating the test" on page 318
● "Debuging" on page 318
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Testing the key panel

To perform the key panel test, you operate the keys at the front panel, and check the
response of the instrument in the "Check Front Panel" dialog. To perform this test prop-
erly, check each key of the front panel. The test is only completed, when you have veri-
fied all keys.

During the test, the actual functions of the keys are disabled.

1. Press the [Setup] key.

2. Select "Maintenance > Check Front Panel"
The "Check Front Panel" dialog opens.

3. Press a key on the front panel.
Check if the corresponding key in the "Check Front Panel" dialog turns green.

4. Press the same key a second time.
Check that the key in the dialog turns red.
Note: Pressing the same key again has no further effect, except for the [Esc] key.
Pressing this key a third time, terminates the test procedure.

5. Continue with the next key on the front panel and repeat step 3 to  step 5 until all
keys are tested.

The test is completed, when each key is verified successfully, confirmed by a "Test
passed" message.

Testing the touchscreen

1. Press the [Setup] key.

2. Select "Maintenance > Check Touch Panel"
The "Finger Paint" test window opens.

3. Drag with your finger one or more lines, for example diagonally across the screen.
The test traces the movements of your finger on the screen.

The following results are expected:
● If the lines are uninterrupted, the touchscreen works properly.
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● If there are any gaps, the touch-sensitive functionality is damaged.

● To return to the "Check Front Panel" dialog, press [Esc].

Terminating the test

► Press the [Esc] key.

Exits the "Check Front Panel" dialog.

Debuging

► If you detect a malfunction, for example, you press the front panel key the first
time, and the color of the button in the dialog turns red (instead of green), the front
panel key may be stuck.

13.4.4  FPGA/uC Update Settings

Access:

► Select "System Config > Setup > Maintenance > FPGA/µC Update".
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This dialog enables you to check for internal assembly updates and perform
updates.

Settings:

Check For Updates..................................................................................................... 319
Assembly.....................................................................................................................319
Install...........................................................................................................................319
Shut down................................................................................................................... 319

Check For Updates
Check for updates of the FPGA/µC.

Remote command: 
n.a.

Assembly
The table shows the installed assemblies and their states.

"Assembly" Assembly designation.

"State" Indicates the current state of installed assemblies.

Install
Install all available updates for the FPGA/µC.

Remote command: 
n.a.

Shut down
For at least one assembly "State = Done" and no pending assemblies, shuts the instru-
ment down to applies installed updates.

Performing Maintenance Tasks
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Remote command: 
:SYSTem:SHUTdown on page 267

13.5  Disposal

Rohde & Schwarz is committed to making careful, ecologically sound use of natural
resources and minimizing the environmental footprint of our products. Help us by dis-
posing of waste in a way that causes minimum environmental impact.

Electrical and electronic equipment

A product that is labeled as follows cannot be disposed of in normal household waste
after it has come to the end of its service life. Even disposal via the municipal collection
points for waste electrical and electronic equipment is not permitted.

Figure 13-1: Labeling in line with EN 50419

Rohde & Schwarz has developed a disposal concept for the eco-friendly disposal or
recycling of waste material. As a manufacturer, Rohde & Schwarz completely fulfills its
obligation to take back and dispose of electrical and electronic waste. Contact your
local service representative to dispose of the product.

Disposal
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Annex
A  Reference Information for Remote Control

A.1  Additional Basics on Remote Control

This section provides basic information using the remote control.

A.1.1  Messages

The messages transferred on the data lines are divided into the following categories:

● Interface messages
Interface messages are transmitted to the instrument on the data lines, with the
attention line being active (LOW). They are used to communicate between the con-
troller and the instrument. Interface messages can only be sent by instruments that
have GPIB bus functionality. For details see the sections for the required interface.

● Instrument messages
Instrument messages are employed in the same way for all interfaces, if not indica-
ted otherwise in the description. Structure and syntax of the instrument messages
are described in Chapter A.1.3, "SCPI Command Structure", on page 322. A
detailed description of all messages available for the instrument is provided in the
chapter "Remote Control Commands".
There are different types of instrument messages, depending on the direction they
are sent:
– Commands
– Instrument responses

Commands

Commands (program messages) are messages the controller sends to the instrument.
They operate the instrument functions and request information. The commands are
subdivided according to two criteria:
● According to the effect they have on the instrument:

– Setting commands cause instrument settings such as a reset of the instru-
ment or setting the frequency.

– Queries cause data to be provided for remote control, e.g. for identification of
the instrument or polling a parameter value. Queries are formed by directly
appending a question mark to the command header.

● According to their definition in standards:
– Common commands: their function and syntax are precisely defined in stan-

dard IEEE 488.2. They are employed identically on all instruments (if imple-
mented). They refer to functions such as management of the standardized sta-
tus registers, reset and self-test.

Additional Basics on Remote Control
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– Instrument control commands refer to functions depending on the features of
the instrument such as frequency settings. Many of these commands have also
been standardized by the SCPI committee. These commands are marked as
"SCPI confirmed" in the command reference chapters. Commands without this
SCPI label are device-specific; however, their syntax follows SCPI rules as per-
mitted by the standard.

Instrument responses

Instrument responses (response messages and service requests) are messages the
instrument sends to the controller after a query. They can contain measurement
results, instrument settings and information on the instrument status.

A.1.2  LAN Interface Messages

In the LAN connection, the interface messages are called low–level control messages.
These messages can be used to emulate interface messages of the GPIB bus.

Command Long term Effect on the instrument

&ABO Abort Aborts processing of the commands just received.

&DCL Device Clear Aborts processing of the commands just received and
sets the command processing software to a defined initial
state. Does not change the instrument setting.

&GTL Go to Local Transition to the "local" state (manual control). (The
instrument automatically returns to remote state when a
remote command is sent UNLESS &NREN was sent
before.)

&GTR Go to Remote Enables automatic transition from local state to remote
state by a subsequent remote command (after &NREN
was sent).

&GET Group Execute Trigger Triggers a previously active instrument function (e.g. a
sweep). The effect of the command is the same as with
that of a pulse at the external trigger signal input.

&LLO Local Lockout Disables transition from remote control to manual control
by means of the front panel keys.

&NREN Not Remote Enable Disables automatic transition from local state to remote
state by a subsequent remote command. (To re-activate
automatic transition use &GTR.)

&POL Serial Poll Starts a serial poll.

A.1.3  SCPI Command Structure

SCPI commands consist of a header and, in most cases, one or more parameters. The
header and the parameters are separated by a "white space" (ASCII code 0 to 9, 11 to
32 decimal, e.g. blank). The headers may consist of several mnemonics (keywords).
Queries are formed by appending a question mark directly to the header.

Additional Basics on Remote Control
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The commands can be either device-specific or device-independent (common com-
mands). Common and device-specific commands differ in their syntax.

A.1.3.1  Syntax for Common Commands

Common (= device-independent) commands consist of a header preceded by an aster-
isk (*), and possibly one or more parameters.

Table A-1: Examples of common commands

*RST RESET Resets the instrument.

*ESE EVENT STATUS ENABLE Sets the bits of the event status enable registers.

*ESR? EVENT STATUS QUERY Queries the contents of the event status register.

*IDN? IDENTIFICATION QUERY Queries the instrument identification string.

A.1.3.2  Syntax for Device-Specific Commands

Not all commands used in the following examples are necessarily implemented in the
instrument. For demonstration purposes only, assume the existence of the following
commands for this section:
● DISPlay[:WINDow<1...4>]:MAXimize <Boolean>
● FORMat:READings:DATA <type>[,<length>]
● HCOPy:DEVice:COLor <Boolean>
● HCOPy:DEVice:CMAP:COLor:RGB <red>,<green>,<blue>
● HCOPy[:IMMediate]
● HCOPy:ITEM:ALL
● HCOPy:ITEM:LABel <string>
● HCOPy:PAGE:DIMensions:QUADrant[<N>]
● HCOPy:PAGE:ORIentation LANDscape | PORTrait
● HCOPy:PAGE:SCALe <numeric value>
● MMEMory:COPY <file_source>,<file_destination>
● SENSE:BANDwidth|BWIDth[:RESolution] <numeric_value>
● SENSe:FREQuency:STOP <numeric value>
● SENSe:LIST:FREQuency <numeric_value>{,<numeric_value>}

● Long and short form..............................................................................................323
● Numeric Suffixes...................................................................................................324
● Optional Mnemonics............................................................................................. 324

Long and short form

The mnemonics feature a long form and a short form. The short form is marked by
upper case letters, the long form corresponds to the complete word. Either the short
form or the long form can be entered; other abbreviations are not permitted.
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Example: 
HCOPy:DEVice:COLor ON is equivalent to HCOP:DEV:COL ON.

Case-insensitivity
Upper case and lower case notation only serves to distinguish the two forms in the
manual, the instrument itself is case-insensitive.

Numeric Suffixes

If a command can be applied to multiple instances of an object, e.g. specific channels
or sources, the required instances can be specified by a suffix added to the command.
Numeric suffixes are indicated by angular brackets (<1...4>, <n>, <i>) and are replaced
by a single value in the command. Entries without a suffix are interpreted as having the
suffix 1.

Example: 
Definition: HCOPy:PAGE:DIMensions:QUADrant[<N>]
Command: HCOP:PAGE:DIM:QUAD2
This command refers to the quadrant 2.

Different numbering in remote control
For remote control, the suffix may differ from the number of the corresponding selec-
tion used in manual operation. SCPI prescribes that suffix counting starts with 1. Suffix
1 is the default state and used when no specific suffix is specified.
Some standards define a fixed numbering, starting with 0. If the numbering differs in
manual operation and remote control, it is indicated for the corresponding command.

Optional Mnemonics

Some command systems permit certain mnemonics to be inserted into the header or
omitted. These mnemonics are marked by square brackets in the description. The
instrument must recognize the long command to comply with the SCPI standard. Some
commands are considerably shortened by these optional mnemonics.

Example: 
Definition: HCOPy[:IMMediate]
Command: HCOP:IMM is equivalent to HCOP
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Optional mnemonics with numeric suffixes
Do not omit an optional mnemonic if it includes a numeric suffix that is relevant for the
effect of the command.
Example:
Definition:DISPlay[:WINDow<1...4>]:MAXimize <Boolean>
Command: DISP:MAX ON refers to window 1.

In order to refer to a window other than 1, you must include the optional WINDow
parameter with the suffix for the required window.
DISP:WIND2:MAX ON refers to window 2.

A.1.3.3  SCPI Parameters

Many commands are supplemented by a parameter or a list of parameters. The
parameters must be separated from the header by a "white space" (ASCII code 0 to 9,
11 to 32 decimal, e.g. blank).

The parameters required for each command and the allowed range of values are
specified in the command description.

Allowed parameters are:

● Numeric Values.....................................................................................................325
● Special Numeric Values........................................................................................ 326
● Boolean Parameters............................................................................................. 326
● Text Parameters....................................................................................................327
● Character Strings.................................................................................................. 327
● Block Data.............................................................................................................327

Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point and exponent.
Values exceeding the resolution of the instrument are rounded up or down. The man-
tissa may comprise up to 255 characters, the exponent must lie inside the value range
-32000 to 32000. The exponent is introduced by an "E" or "e". Entry of the exponent
alone is not allowed.

Example: 
SENS:FREQ:STOP 1500000 = SENS:FREQ:STOP 1.5E6

Units

For physical quantities, the unit can be entered. If the unit is missing, the basic unit is
used. Allowed unit prefixes are:
● G (giga)
● MA (mega), MOHM, MHZ
● K (kilo)
● M (milli)
● U (micro)
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● N (nano)

Example: 
SENSe:FREQ:STOP 1.5GHz = SENSe:FREQ:STOP 1.5E9

Some settings allow relative values to be stated in percent. According to SCPI, this unit
is represented by the PCT string.

Example: 
HCOP:PAGE:SCAL 90PCT

Special Numeric Values

The following mnemonics are special numeric values. In the response to a query, the
numeric value is provided.

● MIN and MAX: denote the minimum and maximum value.
● DEF: denotes a preset value which has been stored in the EPROM. This value

conforms to the default setting, as it is called by the *RST command.
● UP and DOWN: increases or reduces the numeric value by one step. The step

width can be specified via an allocated step command for each parameter which
can be set via UP and DOWN.

● INF and NINF: INFinity and negative INFinity (NINF) represent the numeric values
9.9E37 or -9.9E37, respectively. INF and NINF are only sent as instrument respon-
ses.

● NAN: Not A Number (NAN) represents the value 9.91E37. NAN is only sent as a
instrument response. This value is not defined. Possible causes are the division of
zero by zero, the subtraction of infinite from infinite and the representation of miss-
ing values.

Example: 
Setting command: SENSe:LIST:FREQ MAXimum
Query: SENS:LIST:FREQ?
Response: 3.5E9

Queries for special numeric values
The numeric values associated to MAXimum/MINimum/DEFault can be queried by
adding the corresponding mnemonic after the quotation mark.
Example: SENSe:LIST:FREQ? MAXimum
Returns the maximum numeric value as a result.

Boolean Parameters

Boolean parameters represent two states. The "ON" state (logically true) is represen-
ted by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by
"OFF" or the numeric value 0. The numeric values are provided as the response for a
query.
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Example: 
Setting command: HCOPy:DEV:COL ON
Query: HCOPy:DEV:COL?
Response: 1

Text Parameters

Text parameters observe the syntactic rules for mnemonics, i.e. they can be entered
using a short or long form. Like any parameter, they have to be separated from the
header by a white space. In the response to a query, the short form of the text is provi-
ded.

Example: 
Setting command: HCOPy:PAGE:ORIentation LANDscape
Query: HCOP:PAGE:ORI?
Response: LAND

Character Strings

Strings must always be entered in quotation marks (' or ").

Example: 
HCOP:ITEM:LABel "Test1"
HCOP:ITEM:LABel 'Test1'

Block Data

Block data is a format which is suitable for the transmission of large amounts of data.
For example, a command using a block data parameter has the following structure:

FORMat:READings:DATA #45168xxxxxxxx
The ASCII character # introduces the data block. The next number indicates how many
of the following digits describe the length of the data block. In the example the 4 follow-
ing digits indicate the length to be 5168 bytes. The data bytes follow. During the trans-
mission of these data bytes all end or other control signs are ignored until all bytes are
transmitted.

#0 specifies a data block of indefinite length. The use of the indefinite format requires a
NL^END message to terminate the data block. This format is useful when the length of
the transmission is not known or if speed or other considerations prevent segmentation
of the data into blocks of definite length.

A.1.3.4  Overview of Syntax Elements

The following tables provide an overview of the syntax elements and special charac-
ters.
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Table A-2: Syntax elements

: The colon separates the mnemonics of a command.

; The semicolon separates two commands of a command line. It does not alter the path.

, The comma separates several parameters of a command.

? The question mark forms a query.

* The asterisk marks a common command.

' '

"

Quotation marks introduce a string and terminate it (both single and double quotation marks are
possible).

# The hash symbol introduces binary, octal, hexadecimal and block data.
● Binary: #B10110
● Octal: #O7612
● Hexa: #HF3A7
● Block: #21312

A "white space" (ASCII-Code 0 to 9, 11 to 32 decimal, e.g. blank) separates the header from the
parameters.

Table A-3: Special characters

| Parameters

A vertical stroke in parameter definitions indicates alternative possibilities in the sense of "or". The
effect of the command differs, depending on which parameter is used.

Example:

Definition:HCOPy:PAGE:ORIentation LANDscape | PORTrait
Command HCOP:PAGE:ORI LAND specifies landscape orientation

Command HCOP:PAGE:ORI PORT specifies portrait orientation

Mnemonics

A selection of mnemonics with an identical effect exists for several commands. These mnemonics are
indicated in the same line; they are separated by a vertical stroke. Only one of these mnemonics
needs to be included in the header of the command. The effect of the command is independent of
which of the mnemonics is used.

Example:

DefinitionSENSE:BANDwidth|BWIDth[:RESolution] <numeric_value>
The two following commands with identical meaning can be created:

SENS:BAND:RES 1
SENS:BWID:RES 1

[ ] Mnemonics in square brackets are optional and may be inserted into the header or omitted.

Example: HCOPy[:IMMediate]
HCOP:IMM is equivalent to HCOP

{ } Parameters in curly brackets are optional and can be inserted once or several times, or omitted.

Example: SENSe:LIST:FREQuency <numeric_value>{,<numeric_value>}
The following are valid commands:

SENS:LIST:FREQ 10
SENS:LIST:FREQ 10,20
SENS:LIST:FREQ 10,20,30,40
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A.1.3.5  Structure of a Command Line

A command line may consist of one or several commands. It is terminated by one of
the following:
● <New Line>
● <New Line> with EOI
● EOI together with the last data byte

Several commands in a command line must be separated by a semicolon ";".

Example: 
MMEM:COPY "Test1","MeasurementXY";:HCOP:ITEM ALL

This command line contains two commands. The first command belongs to the MMEM
system, the second command belongs to the HCOP system. If the next command
belongs to a different command system, the semicolon is followed by a colon.

Example: 
HCOP:ITEM ALL;:HCOP:IMM

This command line contains two commands. Both commands are part of the HCOP
command system, i.e. they have one level in common.
If the successive commands belong to the same system, having one or several levels
in common, the command line can be abbreviated. When abbreviating the command
line, the second command begins with the level below HCOP. The colon after the semi-
colon is omitted. The abbreviated form of the command line reads as follows:
HCOP:ITEM ALL;IMM

Example: 
HCOP:ITEM ALL
HCOP:IMM
A new command line always begins with the complete path.

A.1.3.6  Responses to Queries

A query is defined for each setting command unless explicitly specified otherwise. It is
formed by adding a question mark to the associated setting command. According to
SCPI, the responses to queries are partly subject to stricter rules than in standard
IEEE 488.2.

● The requested parameter is transmitted without a header.
Example: HCOP:PAGE:ORI?, Response: LAND

● Maximum values, minimum values and all other quantities that are requested via a
special text parameter are returned as numeric values.
Example: SENSe:FREQuency:STOP? MAX, Response: 3.5E9

● Numeric values are output without a unit. Physical quantities are referred to the
basic units or to the units set using the Unit command. The response 3.5E9 in
the previous example stands for 3.5 GHz.
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● Truth values (Boolean values) are returned as 0 (for OFF) and 1 (for ON).
Example:
Setting command: HCOPy:DEV:COL ON
Query: HCOPy:DEV:COL?
Response: 1

● Text (character data) is returned in a short form.
Example:
Setting command: HCOPy:PAGE:ORIentation LANDscape
Query: HCOP:PAGE:ORI?
Response: LAND

● Invalid numerical results
In some cases, particularly when a result consists of multiple numeric values, inva-
lid values are returned as 9.91E37 (not a number).

A.1.4  Command Sequence and Synchronization

IEEE 488.2 defines a distinction between overlapped and sequential commands:

● A sequential command always completes executing before the next command
starts. Commands that are processed quickly are defined as sequential com-
mands. They are not implemented in the instrument. However, the execution time
of most of the commands is so short that they act as sequential commands, if they
are sent in separate command lines.

● An overlapping command is still running when the next command starts. Usually,
an overlapping command takes a certain time to process its task, and thus allows
the program to execute other tasks, while it is still running. If overlapping com-
mands have to follow a specific order, for example to avoid incorrect measurement
readings, they must be executed in sequence. This is called synchronization
between the controller and the instrument.

Several setting commands within a command line are not necessarily processed in the
order they are received. Even if they are implemented as sequential commands. To fol-
low a particular sequence, send each command in a separate line.

As a rule, send commands and queries in different program messages.

A.1.4.1  Preventing Overlapping Execution

To prevent an overlapping execution of commands, one of the commands *OPC,
*OPC? or *WAI can be used. All three commands cause a certain action only to be
carried out after the hardware has been set. The controller can be forced to wait for the
corresponding action to occur.
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Table A-4: Synchronization using *OPC, *OPC? and *WAI

Com-
mand

Action Programming the controller

*OPC Sets the Operation Complete bit in the ESR
after all previous commands have been exe-
cuted.

● Setting bit 0 in the ESE
● Setting bit 5 in the SRE
● Waiting for service request (SRQ)

*OPC? Stops command processing until 1 is
returned. This occurs when all pending opera-
tions are completed.

Send *OPC? directly after the command
whose processing must be terminated before
other commands can be executed.

*WAI Stops further command processing until all
commands sent before *WAI have been exe-
cuted.

Send *WAI directly after the command whose
processing must be terminated before other
commands are executed.

Command synchronization using *WAI or *OPC? is a good choice if the overlapped
command takes only little time to process. The two synchronization commands simply
block overlapped execution of the command. Append the synchronization command to
the overlapping command, for example:

SINGle; *OPC?
For time consuming overlapped commands, you can allow the controller or the instru-
ment to do other useful work while waiting for command execution. Use one of the fol-
lowing methods:

*OPC with a service request

1. Set the OPC mask bit (bit no. 0) in the ESE: *ESE 1

2. Set bit no. 5 in the SRE: *SRE 32 to enable ESB service request.

3. Send the overlapped command with *OPC .

4. Wait for a service request.

The service request indicates that the overlapped command has finished.

*OPC? with a service request

1. Set bit no. 4 in the SRE: *SRE 16 to enable MAV service request.

2. Send the overlapped command with *OPC?.

3. Wait for a service request.

The service request indicates that the overlapped command has finished.

Event status register (ESE)

1. Set the OPC mask bit (bit no. 0) in the ESE: *ESE 1

2. Send the overlapped command without *OPC, *OPC? or *WAI.
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3. Poll the operation complete state periodically (with a timer) using the sequence:
*OPC; *ESR?
A return value (LSB) of 1 indicates that the overlapped command has finished.

A.1.4.2  Examples to Command Sequence and Synchronization

See the following examples to command sequences and synchronization. Some exam-
ples given illustrate possible constellations for overlapping tasks.

Example: Commands and queries in one message
The response to a query combined in a program message with commands that affect
the queried value is not predictable.
The following commands always return the specified result:
:FREQ:STAR 1GHZ;SPAN 100 :FREQ:STAR?
Result:
1000000000 (1 GHz)

Whereas the result for the following commands is not specified by SCPI:
:FREQ:STAR 1GHz;STAR?;SPAN 1000000
The result could be the value of STARt before the command was sent since the instru-
ment might defer executing the individual commands until a program message termi-
nator is received. The result could also be 1 GHz if the instrument executes commands
as they are received.

Example: Overlapping command with *OPC
The instrument implements *RST as an overlapped command. Assuming that *RST
takes longer to execute than *OPC, sending the following command sequence results
in initiating a reset and, after some time, setting the OPC bit in the ESR:
*RST; *OPC
Sending the following commands still initiates a reset:
*RST; *OPC; *CLS
However, since the operation is still pending when the instrument executes *CLS, forc-
ing it into the "Operation Complete Command Idle" State (OCIS), *OPC is effectively
skipped. The OPC bit is not set until the instrument executes another *OPC command.

Example: Overlapped command followed by non-conflicting commands
Suppose that the instrument is switched on to provide a real time test signal that
requires some calculation time. At the same time, some settings for the configuration of
a different signal are made which do not interact with the generated signal (for example
the signal may be used later on). The signal generation and the signal configuration
are independent from each other, so there is no need to synchronize the following
overlapped commands:
SOUR:BB:3GPP:STAT ON
SOUR:BB:GSM:FORM FSK2
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Example: Overlapped command followed by conflicting commands
Suppose that the generator is switched on to provide a real time test signal that
requires some calculation time. This signal is to be added to a waveform from the sec-
ond baseband generator. In this case, the application program has to make sure that
the real signal is available in the added signal before further action is started. This
involves an appropriate synchronization technique for the first command (the following
sequence assumes an appropriate routing):
SOUR:BB:3GPP:STAT ON
The instrument waits until command has finished.
SOUR2:BB:GSM:STAT ON
Depending on the selected synchronization techniques, non-conflicting commands can
be executed while waiting until the synchronized overlapped command has finished.

Example: Polling the progress of the zeroing process
Suppose that you start the zeroing for a connected power sensor via the remote con-
trol command SENS1:ZERO. This process blocks the processing of further tasks during
execution. The query for completeness is performed with the *OPC? command. It
returns a 1 in the output buffer when the process is completed.
SENS:ZERO;*OPC?
Instead of waiting via *OPC?, you can perform alternative tasks while the zeroing is
running, as for example updating the GUI or adjusting other instruments. Synchronize
the commands by querying the progress of the zeroing process periodically via the
event status register *ESR?:
*SRE 32
Sets the service request enable. The bit is set when an event in the event status regis-
ter occurs.
*ESE 1
Configures the mask of the event status register to "Operation Complete".
SENS:ZERO;*OPC
Sets the evaluation via the status byte query. It uses *OPC? as the reference.
*CLS
Clears all status registers.
Even if the instrument is busy, you can perform this procedure, since the query is exe-
cuted in a subchannel.

A.1.5  Status Reporting System

The status reporting system stores all information on the current operating state of the
instrument, and on errors which have occurred. This information is stored in the status
registers and in the error queue.

You can query both with the commands of the STATus Subsystem.
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A.1.5.1  Hierarchy of the Status Registers

The Figure A-1 shows the hierarchical structure of information in the status registers
(ascending from left to right).

Figure A-1: Graphical overview of the status registers hierarchy

OPER = Operation Status Summary Bit
RQS/MSS = Service Request Generation
ESB = Standard Event Status Summary Bit
MAV = Message Available in Output Queue
QUES = Questionable Status Summary Bit
2 = Error- /Event-Queue
1, 0 = not used

Note: This legend explains the abbreviations to the Status Byte Register.
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The R&S AREG100A uses the following status registers:
● Status Byte (STB) and Service Request Enable (SRE), see Chapter A.1.5.3,

"Status Byte (STB) and Service Request Enable Register (SRE)", on page 337.
● Standard Event Status, i.e. the Event status Register (ESR) and the Event Status

Enable (ESE), see Chapter A.1.5.4, "Event Status Register (ESR) and Event Sta-
tus Enable Register (ESE)", on page 338.

● Questionable Status and Operation Status, the (SCPI status registers, see
Chapter A.1.5.2, "Structure of a SCPI Status Register", on page 335, Chapter A.
1.5.5, "Questionable Status Register (STATus:QUEStionable)", on page 339 and
Chapter A.1.5.6, "Operation Status Register (STATus:OPERation)", on page 339.

● Output-Queue
The output queue contains the messages the instrument returns to the controller. It
is not part of the status reporting system but determines the value of the MAV bit in
the STB and thus is represented in the overview.

● Error- /Event-Queue
The error-/event-queue contains all errors and events that have occurred in the
past. When reading the queue, the instrument starts with the first occurred error/
event.

All status registers have the same internal structure.

SRE, ESE
The service request enable register SRE can be used as ENABle part of the STB if the
STB is structured according to SCPI. By analogy, the ESE can be used as the ENABle
part of the ESR.

A.1.5.2  Structure of a SCPI Status Register

Each standard SCPI register consists of 5 parts. Each part has a width of 16 bits and
has different functions. The individual bits are independent of each other, i.e. each
hardware status is assigned a bit number which is valid for all five parts. Bit 15 (the
most significant bit) is set to zero for all parts. Thus the contents of the register parts
can be processed by the controller as positive integers.
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Figure A-2: The status-register model

Description of the five status register parts

The five parts of a SCPI register have different properties and functions:

● CONDition
The CONDition part is written into directly by the hardware or the sum bit of the
next lower register. Its contents reflect the current instrument status. This register
part can only be read, but not written into or cleared. Its contents are not affected
by reading.

● PTRansition / NTRansition
The two transition register parts define which state transition of the CONDition
part (none, 0 to 1, 1 to 0 or both) is stored in the EVENt part.
The Positive-TRansition part acts as a transition filter. When a bit of the
CONDition part is changed from 0 to 1, the associated PTR bit decides whether
the EVENt bit is set to 1.

– PTR bit =1: the EVENt bit is set.

– PTR bit =0: the EVENt bit is not set.

This part can be written into and read as required. Its contents are not affected by
reading.
The Negative-TRansition part also acts as a transition filter. When a bit of the
CONDition part is changed from 1 to 0, the associated NTR bit decides whether
the EVENt bit is set to 1.

– NTR bit =1: the EVENt bit is set.

– NTR bit =0: the EVENt bit is not set.

This part can be written into and read as required. Its contents are not affected by
reading.

● EVENt
The EVENt part indicates whether an event has occurred since the last reading, it
is the "memory" of the condition part. It only indicates events passed on by the
transition filters. It is permanently updated by the instrument. This part can only be
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read by the user. Reading the register clears it. This part is often equated with the
entire register.

● ENABle
The ENABle part determines whether the associated EVENt bit contributes to the
sum bit (see below). Each bit of the EVENt part is "ANDed" with the associated
ENABle bit (symbol '&'). The results of all logical operations of this part are passed
on to the sum bit via an "OR" function (symbol '+').
ENABle bit = 0: the associated EVENt bit does not contribute to the sum bit
ENABle bit = 1: if the associated EVENt bit is "1", the sum bit is set to "1" as well.
This part can be written into and read by the user as required. Its contents are not
affected by reading.

Sum bit

The sum bit is obtained from the EVENt and ENABle part for each register. The result
is then entered into a bit of the CONDition part of the higher-order register.

The instrument automatically generates the sum bit for each register. Thus an event
can lead to a service request throughout all levels of the hierarchy.

A.1.5.3  Status Byte (STB) and Service Request Enable Register (SRE)

The STatus Byte (STB) is already defined in IEEE 488.2. It provides a rough over-
view of the instrument status by collecting the pieces of information of the lower regis-
ters. A special feature is that bit 6 acts as the sum bit of the remaining bits of the status
byte.

The STB is read using the command *STB? or a serial poll.

The STatus Byte (STB) is linked to the Service Request Enable (SRE) register.
Each bit of the STB is assigned a bit in the SRE. Bit 6 of the SRE is ignored. If a bit is
set in the SRE and the associated bit in the STB changes from 0 to 1, a service
request (SRQ) is generated. The SRE can be set using the command *SRE and read
using the command *SRE?.

Table A-5: Meaning of the bits used in the status byte

Bit No. Meaning

0...1 Not used

2 Error Queue not empty

The bit is set when an entry is made in the error queue. If this bit is enabled by the SRE, each
entry of the error queue generates a service request. Thus an error can be recognized and
specified in greater detail by polling the error queue. The poll provides an informative error mes-
sage. This procedure is to be recommended since it considerably reduces the problems
involved with remote control.

3 QUEStionable status register summary bit

The bit is set if an EVENt bit is set in the QUEStionable status register and the associated
ENABle bit is set to 1. A set bit indicates a questionable instrument status, which can be speci-
fied in greater detail by querying the STATus:QUEStionable status register.
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Bit No. Meaning

4 MAV bit (message available)

The bit is set if a message is available in the output queue which can be read. This bit can be
used to enable data to be automatically read from the instrument to the controller.

5 ESB bit

Sum bit of the event status register. It is set if one of the bits in the event status register is set
and enabled in the event status enable register. Setting of this bit indicates a serious error which
can be specified in greater detail by polling the event status register.

6 MSS bit (master status summary bit)

The bit is set if the instrument triggers a service request. This is the case if one of the other bits
of this registers is set together with its mask bit in the service request enable register SRE.

7 STATus:OPERation status register summary bit

The bit is set if an EVENt bit is set in the OPERation status register and the associated
ENABle bit is set to 1. A set bit indicates that the instrument is just performing an action. The
type of action can be determined by querying the STATus:OPERation status register.

A.1.5.4  Event Status Register (ESR) and Event Status Enable Register (ESE)

The ESR is defined in IEEE 488.2. It can be compared with the EVENt part of a SCPI
register. The event status register can be read out using command *ESR?.

The ESE corresponds to the ENABle part of a SCPI register. If a bit is set in the ESE
and the associated bit in the ESR changes from 0 to 1, the ESB bit in the STB is set.
The ESE register can be set using the command *ESE and read using the command
*ESE?.

Table A-6: Meaning of the bits used in the event status register

Bit No. Meaning

0 Operation Complete

This bit is set on receipt of the command *OPC exactly when all previous commands have been
executed.

1 Not used

2 Query Error

This bit is set if either the controller wants to read data from the instrument without having sent a
query, or if it does not fetch requested data and sends new instructions to the instrument
instead. The cause is often a query which is faulty and hence cannot be executed.

3 Device-dependent Error

This bit is set if a device-dependent error occurs. An error message with a number between
-300 and -399 or a positive error number, which denotes the error in greater detail, is entered
into the error queue.

4 Execution Error

This bit is set if a received command is syntactically correct but cannot be performed for other
reasons. An error message with a number between -200 and -300, which denotes the error in
greater detail, is entered into the error queue.
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Bit No. Meaning

5 Command Error

This bit is set if a command is received, which is undefined or syntactically incorrect. An error
message with a number between -100 and -200, which denotes the error in greater detail, is
entered into the error queue.

6 User Request

This bit is set when the instrument is switched over to manual control.

7 Power On (supply voltage on)

This bit is set on switching on the instrument.

A.1.5.5  Questionable Status Register (STATus:QUEStionable)

This register contains information on questionable instrument states. Such states may
occur when the instrument is not operated in compliance with its specifications.

To read the register, use the query commands STAT:QUEST:COND? or
STAT:QUEST[:EVEN]?.

Table A-7: Meaning of the bits used in the questionable status register

Bit No. Meaning

0–15 Not used

A.1.5.6  Operation Status Register (STATus:OPERation)

This condition part contains information on the actions currently being performed by
the instrument, while the event part contains information on the actions performed by
the instrument since the last readout of the register.

To read the register, use the query commands STAT:OPER:COND? or
STAT:OPER[:EVEN]?.

Table A-8: Meaning of the bits used in the operation status register

Bit No. Meaning

0 Calibrating

The bit is set during the calibration phase.

1–2 Not used

3 Sweeping

This bit is set during a sweep in automatic or single mode.

4–15 Not used

A.1.5.7  Application of the Status Reporting System

The purpose of the status reporting system is to monitor the status of one or several
devices in a measuring system. To do this and react appropriately, the controller must
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receive and evaluate the information of all devices. The following standard methods
are used:

● Service request (SRQ) initiated by the instrument
● Serial poll of all devices in the bus system, initiated by the controller to find out

who sent an SRQ and why
● Query of a specific instrument status by commands
● Query of the error queue

Service Request

Under certain circumstances, the instrument can send a service request (SRQ) to the
controller. Usually this service request initiates an interrupt at the controller, to which
the control program can react appropriately. An SRQ is always initiated if one or sev-
eral of bits 2, 4 or 5 of the status byte are set and enabled in the SRE. Each of these
bits combines the information of the error queue or the output buffer. To use the possi-
bilities of the service request effectively, all bits should be set to "1" in the enable regis-
ters SRE and ESE.

Example: 
Use command *OPC to generate an SRQ .

*ESE 1 - set bit 0 of ESE (Operation Complete)

*SRE 32 - set bit 5 of SRE (ESB).

After its settings have been completed, the instrument generates an SRQ.

The SRQ is the only possibility for the instrument to become active on its own. Each
controller program should set the instrument such that a service request is initiated in
the case of malfunction. The program should react appropriately to the service request.

Serial Poll

In a serial poll, just as with command *STB, the status byte of an instrument is queried.
However, the query is realized via interface messages and is thus clearly faster.

The serial poll method is defined in IEEE 488.1 and used to be the only standard pos-
sibility for different instruments to poll the status byte. The method also works for
instruments which do not adhere to SCPI or IEEE 488.2.

The serial poll is mainly used to obtain a fast overview of the state of several instru-
ments connected to the controller.

Query of an instrument status

Each part of any status register can be read using queries. There are two types of
commands:

● The common commands *ESR?, *IDN?, *IST?, *STB? query the higher-level
registers.

● The commands of the STATus system query the SCPI registers
(STATus:QUEStionable...)
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The returned value is always a decimal number that represents the bit pattern of the
queried register. This number is evaluated by the controller program.

Queries are usually used after an SRQ in order to obtain more detailed information on
the cause of the SRQ.

Error Queue

Each error state in the instrument leads to an entry in the error queue. The entries of
the error queue are detailed plain text error messages that can be looked up in the
Error Log or queried via remote control using SYSTem:ERRor[:NEXT]?. Each call of
SYSTem:ERRor[:NEXT]? provides one entry from the error queue. If no error mes-
sages are stored there any more, the instrument responds with 0, "No error".

The error queue should be queried after every SRQ in the controller program as the
entries describe the cause of an error more precisely than the status registers. Espe-
cially in the test phase of a controller program the error queue should be queried regu-
larly since faulty commands from the controller to the instrument are recorded there as
well.

A.1.5.8  Reset Values of the Status Reporting System

The following table contains the different commands and events causing the status
reporting system to be reset. None of the commands, except of *RST and
SYSTem:PRESet affect the functional instrument settings. In particular, DCL does not
change the instrument settings.

Table A-9: Resetting the status reporting system

Event Switching on supply
voltage

Power-On-Status-
Clear

DCL,
SDC
(Device
Clear,
Selected
Device
Clear)

*RST or
SYSTem:
PRESet

STATus:
PRESet

*CLS

Effect 0 1

Clear STB, ESR - Yes - - - Yes

Clear SRE, ESE - Yes - - - -

Clear PPE - Yes - - - -

Clear error queue Yes Yes - - - Yes

Clear output buffer Yes Yes Yes 1) 1) 1)

Clear command processing
and input buffer

Yes Yes Yes - - -

1) The first command in a command line that immediately follows a <PROGRAM MESSAGE TERMINA-
TOR> clears the output buffer.
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A.1.6  General Programming Recommendations

Initial instrument status before changing settings

Manual operation is designed for maximum possible operating convenience. In con-
trast, the priority of remote control is the "predictability" of the instrument status. Thus,
when a command attempts to define incompatible settings, the command is ignored
and the instrument status remains unchanged, i.e. other settings are not automatically
adapted. Therefore, control programs should always define an initial instrument status
(e.g. using the *RST command) and then implement the required settings.

Command sequence

As a general rule, send commands and queries in different program messages. Other-
wise, the result of the query may vary depending on which operation is performed first
(see also Preventing Overlapping Execution).

Reacting to malfunctions

The service request is the only possibility for the instrument to become active on its
own. Each controller program should instruct the instrument to initiate a service
request in case of malfunction. The program should react appropriately to the service
request.

Error queues

The error queue should be queried after every service request in the controller pro-
gram as the entries describe the cause of an error more precisely than the status regis-
ters. Especially in the test phase of a controller program the error queue should be
queried regularly since faulty commands from the controller to the instrument are
recorded there as well.
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B  Telnet program examples
The following program example shows a simple TcpClient class that is intended to
explain on how to get started with programming of sockets.

The example sets up a socket communication to R&S AREG100A and opens a simple
user interface, very similar to the telnet, which allows input of commands. To enable
real automation, further development of the program is required.

TcpClient.h

#include <string>
//defines structs for socket handling
#include <netinet/in.h>
using namespace std;
typedef struct sockaddr_in SockAddrStruct;
typedef struct hostent     HostInfoStruct;
class TcpClient
{
  public:
    TcpClient();
    ~TcpClient();
    void connectToServer( string &hostname, int port );
    void disconnect( );
    void transmit( string &txString );
    void receive( string &rxString );
    string getCurrentHostName( ) const;
    int    getCurrentPort( ) const;
  private:
    string           currentHostName;
    int              currentPort;
    int              currentSocketDescr;
    SockAddrStruct   serverAddress;
    HostInfoStruct * currentHostInfo;
    bool             clientIsConnected;
    int              receiveBufferSize;
};

TcpClient.cpp

#include <string>
//defines structs for socket handling
#include <netinet/in.h>
using namespace std;
typedef struct sockaddr_in SockAddrStruct;
typedef struct hostent     HostInfoStruct;
class TcpClient
{
  public:
    TcpClient();



Telnet program examplesR&S®AREG100A

344User Manual 1178.7417.02 ─ 06

    ~TcpClient();
    void connectToServer( string &hostname, int port );
    void disconnect( );
    void transmit( string &txString );
    void receive( string &rxString );
    string getCurrentHostName( ) const;
    int    getCurrentPort( ) const;
  private:
    string           currentHostName;
    int              currentPort;
    int              currentSocketDescr;
    SockAddrStruct   serverAddress;
    HostInfoStruct * currentHostInfo;
    bool             clientIsConnected;
    int              receiveBufferSize;
};

#include <netdb.h>
#include <netinet/in.h>
#include <unistd.h>
#include "TcpClient.h"
TcpClient::TcpClient()
: currentHostName( "" )
, currentPort( 0 )
, currentSocketDescr( 0 )
, serverAddress ( )
, currentHostInfo( NULL )
, clientIsConnected( false )
, receiveBufferSize( 1024 )
{
}
TcpClient::~TcpClient()
{
  currentHostInfo = NULL;
}

void TcpClient::connectToServer( string &hostname, int port )
{
  currentHostInfo = gethostbyname( hostname.c_str( ) );
  if( currentHostInfo == NULL )
  {
    currentHostName   = "";
    currentPort       = 0;
    currentHostInfo   = NULL;
    clientIsConnected = false;
    printf("error connecting host\n" );
  }
  currentHostName = hostname;
  currentPort     = port;
  currentSocketDescr = socket(AF_INET, SOCK_STREAM, 0);
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  if( currentSocketDescr == 0 )
  {
    currentHostName   = "";
    currentPort       = 0;
    currentHostInfo   = NULL;
    clientIsConnected = false;
    printf("can't create socket\n" );
  }
  serverAddress.sin_family = currentHostInfo->h_addrtype;
  serverAddress.sin_port   = htons( currentPort );
  memcpy( (char *) &serverAddress.sin_addr.s_addr, 
  currentHostInfo->h_addr_list[0], currentHostInfo->h_length );
  if( connect( currentSocketDescr, ( struct sockaddr *) &serverAddress, 
  sizeof( serverAddress ) ) < 0 )
  {
   throw string("can't connect server\n" );
  }
  clientIsConnected = true;
}
void TcpClient::disconnect( )
{
  if( clientIsConnected )
  {
    close( currentSocketDescr );
  }
  currentSocketDescr = 0;
  currentHostName    = "";
  currentPort        = 0;
  currentHostInfo    = NULL;
  clientIsConnected  = false;
}
void TcpClient::transmit( string &txString )
{
  if( !clientIsConnected )
  {
  throw string("connection must be established before any data can be sent\n");
  }
  char * transmitBuffer = new char[txString.length() +1];
  memcpy( transmitBuffer, txString.c_str(), txString.length() );
  transmitBuffer[txString.length()] = '\n'; //newline is needed!
  if( send( currentSocketDescr, transmitBuffer, txString.length() + 1, 0 ) < 0 )
  {
    throw string("can't transmit data\n");
  }
  delete [] transmitBuffer;
}
void TcpClient::receive( string &rxString )
{
  if( !clientIsConnected )
  {
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  throw string("connection must be established before any data can be received\n");
  }
  char * receiveBuffer = new char[receiveBufferSize];
  memset( receiveBuffer, 0, receiveBufferSize );
  bool receiving = true;
  while( receiving )
  {
    int receivedByteCount = recv( currentSocketDescr, 
    receiveBuffer, receiveBufferSize, 0 );
    if( receivedByteCount < 0 )
    {
      throw string("error while receiving data\n");
    }
    rxString += string( receiveBuffer );
    receiving = ( receivedByteCount == receiveBufferSize );
  }
  delete [] receiveBuffer;
}
string TcpClient::getCurrentHostName( ) const
{
  return currentHostName;
}
int TcpClient::getCurrentPort( ) const
{
  return currentPort;
}

TelnetClient.cpp

#include <iostream>
#include "TcpClient.h"
void printUsage()
{
  cout<<"usage: EthernetRawCommand <server-ip> [scpi-command]"<<endl;
}
int main( int argc, char *argv[] )
{
  int errorCode         = 0; //no error
  bool useSingleCommand = false;
  string singleCommand  = "";
  string hostname       = "";
  int    port           = 5025;
  string input          = "";
  TcpClient client;
  switch( argc )
  {
    case 3:
      useSingleCommand = true;
      singleCommand    = argv[2];
    case 2:
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      hostname         = argv[1];
      break;
    default:
        printUsage();
        return(-1);
  }
  try
  {
    client.connectToServer( hostname, port );
    bool terminate = false;
    while( !terminate )
    {
      char buffer[1024];
      if( useSingleCommand )
      {
        input =  singleCommand; //send string
      }
      else
      {
        cin.getline( buffer, 1024 );
        input = buffer;
        if( input == "end" )
        {
          terminate = true;
        }
      }
      if( !terminate)
      {
        client.transmit( input ); //send string
        int qPos = input.find( "?", 0 );
        //receive string only when needed
        if( qPos > 0 )
        {
          string rcStr = "";
          client.receive( rcStr );
          cout << rcStr << endl;
        }
      }
      if( useSingleCommand )
      {
        terminate = true;
      }
    }
  }catch( const string errorString )
  {
    cout<<errorString<<endl;
  }
  client.disconnect( );
  return errorCode;
}
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C  Unit Shortcuts
When specifying units or quantities during data entry, the R&S AREG100A provides
the following shortcuts for simplified input.

Shortcut Designation Context Unit

a, A ampere Current A

 atto- Area, surface am2

c, C centi- Distance, length cm

d, D deci- Distance, length dm

  Level, power dB, dBFS, dBm, dBU, dBW

 degree Phase, polar/spherical coordinates deg

e, E exa- Area, surface em2

f, F femto- Area, surface fm2

g, G giga- Area, surface Gm2

  Data rate, sample rate, symbol rate Gbit/s, Gsample/s, Gsymbol/s, Gchip/s

  Frequency GHz

  Impedance, resistance GΩ

h, H hertz Frequency Hz

k, K kilo- Area, surface km2

  Data rate, sample rate, symbol rate kbit/s, ksample/s, ksymbol/s, kchip/s

  Distance, length km

  Frequency kHz

  Impedance, resistance kΩ

  Velocity km/h

m, M milli- Area, surface mm2

  Current mA

  Distance, length mm

  Electromagnetic force, level mV

  Power mW

  Time, period, etc. ms

 mega- Area, surface Mm2

  Data rate, sample rate, symbol rate Mbit/s, Msample/s, Msym/s, Mchip/s

  Frequency MHz

  Impedance, resistance MΩ



Unit ShortcutsR&S®AREG100A

349User Manual 1178.7417.02 ─ 06

Shortcut Designation Context Unit

n, N nano- Area, surface nm2

  Current nA

  Distance, length nm

  Electromagnetic force, level nV

  Power nW

  Time, period, etc. ns

o, O ohm Impedance, resistance Ω

p, P peta- Area, surface pm2

 percent Level, ratio %

 pico- Area, surface pm2

  Current pA

  Electromagnetic force, level pV

  Power pW

  Time, period, etc. ps

r, R radiant Phase, polar/spherical coordinates rad

s, S second Time, period, etc. s

t, T terra- Area, surface Tm2

  Data rate, sample rate, symbol rate Tbit/s, Tsample/s, Tsym/s, Tchip/s

  Frequency THz

  Impedance, resistance TΩ

u, U micro- Current µA

  Distance, length µm

  Electromagnetic force, level µV

  Power µW

  Time, period, etc. µs

v, V volt Level, voltage V

w, W watt Level, power W
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D  Hardware Interfaces
This section covers hardware-related topics, like pin assignment of the IEC 625/IEEE
488 interface.

The remote control interfaces are described in details in Chapter 9, "Network Operation
and Remote Control", on page 147.

For specifications, refer to the data sheet.

D.1  GPIB-Bus Interface

Pin assignment

Figure D-1: Pin assignment of GPIB-bus (IEEE 488) interface

Bus lines

● Data bus with 8 lines D0 to D7:
The transmission is bit-parallel and byte-serial in the ASCII/ISO code. D0 is the
least significant bit, D7 the most significant bit.

● Control bus with five lines:
IFC (Interface Clear): active LOW resets the interfaces of the instruments connec-
ted to the default setting.
ATN (Attention): active LOW signals the transmission of interface messages, inac-
tive HIGH signals the transmission of device messages.
SRQ (Service Request): active LOW enables the connected device to send a ser-
vice request to the controller.
REN (Remote Enable): active LOW permits switchover to remote control.

GPIB-Bus Interface
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EOI (End or Identify): has two functions in connection with ATN:
– ATN=HIGH active LOW marks the end of data transmission.
– ATN=LOW active LOW triggers a parallel poll.

● Handshake bus with three lines:
DAV (Data Valid): active LOW signals a valid data byte on the data bus.
NRFD (Not Ready For Data): active LOW signals that one of the connected devi-
ces is not ready for data transfer.
NDAC (Not Data Accepted): active LOW signals that the instrument connected is
accepting the data on the data bus.

Interface functions

Instruments which can be controlled via GPIB-bus interface can be equipped with dif-
ferent interface functions. Table D-1 lists the interface functions for the
R&S AREG100A.

Table D-1: GPIB-bus interface functions

Control character Interface function

SH1 Handshake source function (source handshake), full capability

AH1 Handshake sink function (acceptor handshake), full capability

L4 Listener function, full capability, de-addressed by MTA.

T6 Talker function, full capability, ability to respond to serial poll, deaddressed
by MLA

SR1 Service request function (Service Request), full capability

PP1 Parallel poll function, full capability

RL1 Remote/Local switch over function, full capability

DC1 Reset function (Device Clear), full capability

DT1 Trigger function (Device Trigger), full capability

GPIB-Bus Interface
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